mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-28 22:57:37 +00:00
community/texstudio to 2.12.18-1
This commit is contained in:
parent
3517b1b4e1
commit
07764ee4fa
2 changed files with 16 additions and 15 deletions
|
@ -5,7 +5,7 @@
|
|||
# - ARM patch, use NO_CRASH_HANDLER=1 for AArch64
|
||||
|
||||
pkgname=texstudio
|
||||
pkgver=2.12.16
|
||||
pkgver=2.12.18
|
||||
pkgrel=1
|
||||
pkgdesc="Integrated writing environment for creating LaTeX documents"
|
||||
arch=('x86_64')
|
||||
|
@ -20,16 +20,16 @@ source=("https://github.com/texstudio-org/texstudio/archive/${pkgver}.tar.gz"
|
|||
fs54269.patch
|
||||
fs56433.patch
|
||||
texstudio-debughelper-arm-fix.patch)
|
||||
sha512sums=('0c17fda78e0cd491d2869ccb1a164ae2348281a39f9883d813ceb2ed6a0287c4cf9e784cafb9c0a12b8839d7afc8897f8f74acffd87a5dfcb50d3b344f33ad28'
|
||||
sha512sums=('826e1e565292e5395a1465215a95ad9c7ad73d88af213de42153fbb410d8a4e4673a83499abd25ad78f901a4e241d4f0ea0cf5a504364ebed86c5a021acd0a4d'
|
||||
'247e85f668b06c8a2def4e7456f0ddc8d35c7990484c1c037f7cf43fdee91419b5df66e968ef1e0c637fe685722bbad9171bdd79fad7a10912ae329aff088b68'
|
||||
'a098c45440077db6c137bbeeb76d266242b80d51c3721aed30987d22b3e381b2a490b685aff4897d203a17256c64a9254360e3ac6f962675ea4b9a575a29a808'
|
||||
'dcb5ce7cd3e83fc221903fa895e6c428c54ada7468e74bb0a3e6bfac01c9e9575e4780d300b67f44064f2d25e10dd1aef531b847cdee71fbfbe7337808a0c8f4')
|
||||
'c8a915846d355593c2ebd0c9ebd5dfa908c456a4a51c4d63f1f685efdf2ff763e68fdaa34ddfe602890f363486ed0b9be55e09112904f60fbd0de40a418947d3')
|
||||
|
||||
prepare() {
|
||||
cd texstudio-${pkgver}/src
|
||||
patch -Np1 < "${srcdir}"/fs54269.patch
|
||||
patch -Np1 < "${srcdir}"/fs56433.patch
|
||||
patch -Np1 < "${srcdir}"/texstudio-debughelper-arm-fix.patch
|
||||
patch -Np2 < "${srcdir}"/texstudio-debughelper-arm-fix.patch
|
||||
}
|
||||
|
||||
build() {
|
||||
|
|
|
@ -1,17 +1,17 @@
|
|||
From 7f41bb239a89d1e66e954577d03b92373ad4da0e Mon Sep 17 00:00:00 2001
|
||||
From b0cf44fde92b66fbaefceb643b6124bc5bf0b087 Mon Sep 17 00:00:00 2001
|
||||
From: hannes <hannes@fedoraproject.org>
|
||||
Date: Sun, 13 Sep 2015 16:40:51 +0200
|
||||
Subject: [PATCH 3/3] debughelper arm fix
|
||||
Date: Sun, 11 Feb 2018 07:39:00 +0100
|
||||
Subject: [PATCH 2/2] armfix
|
||||
|
||||
---
|
||||
debughelper.cpp | 8 ++------
|
||||
1 file changed, 2 insertions(+), 6 deletions(-)
|
||||
src/debughelper.cpp | 6 +-----
|
||||
1 file changed, 1 insertion(+), 5 deletions(-)
|
||||
|
||||
diff --git a/debughelper.cpp b/debughelper.cpp
|
||||
index 4b14ae3..f07c48e 100644
|
||||
--- a/debughelper.cpp
|
||||
+++ b/debughelper.cpp
|
||||
@@ -501,16 +501,12 @@ QString print_backtrace(const QString& message){
|
||||
diff --git a/src/debug/debughelper.cpp b/src/debug/debughelper.cpp
|
||||
index 2918b43..74b94bc 100644
|
||||
--- a/src/debug/debughelper.cpp
|
||||
+++ b/src/debug/debughelper.cpp
|
||||
@@ -517,16 +517,12 @@ QString print_backtrace(const QString &message)
|
||||
#define FRAME_FROM_UCONTEXT(context) (context)->uc_mcontext.gp_regs[31] //not always used
|
||||
#define RETURNTO_FROM_UCONTEXT(context) (context)->uc_mcontext.gp_regs[34]
|
||||
#elif defined(CPU_IS_ARM)
|
||||
|
@ -31,5 +31,6 @@ index 4b14ae3..f07c48e 100644
|
|||
#define PC_FROM_UCONTEXT(context) (context)->_u._mc.sc_ip
|
||||
#define STACK_FROM_UCONTEXT(context) (context)->_u._mc.sc_gr[12] //is that register 12?
|
||||
--
|
||||
2.4.3
|
||||
2.17.1
|
||||
|
||||
|
||||
|
|
Loading…
Reference in a new issue