core/linux-armv5-rc: patch updates

This commit is contained in:
Kevin Mihelich 2015-04-28 03:06:02 +00:00
parent e64a10d6d3
commit 079f6c6b80
6 changed files with 137 additions and 39 deletions

View file

@ -1,7 +1,7 @@
From ef05a3ce8340c7156610b173324ab793b06e0ae2 Mon Sep 17 00:00:00 2001
From a855ffd581def7001f44ae7e7441e51aaa6445e7 Mon Sep 17 00:00:00 2001
From: Michal Ulianko <info@itserve.cz>
Date: Mon, 29 Jul 2013 20:14:38 +0200
Subject: [PATCH 1/2] Added ASoC driver for i.MX233's builtin ADC/DAC codec.
Subject: [PATCH 1/5] Added ASoC driver for i.MX233's builtin ADC/DAC codec.
---
sound/soc/codecs/Kconfig | 4 +
@ -23,10 +23,10 @@ Subject: [PATCH 1/2] Added ASoC driver for i.MX233's builtin ADC/DAC codec.
create mode 100644 sound/soc/mxs/mxs-builtin-pcm.h
diff --git a/sound/soc/codecs/Kconfig b/sound/soc/codecs/Kconfig
index badb6fb..dc1f4ac 100644
index 061c465..577f7fd 100644
--- a/sound/soc/codecs/Kconfig
+++ b/sound/soc/codecs/Kconfig
@@ -127,6 +127,7 @@ config SND_SOC_ALL_CODECS
@@ -170,6 +170,7 @@ config SND_SOC_ALL_CODECS
select SND_SOC_WM9705 if SND_SOC_AC97_BUS
select SND_SOC_WM9712 if SND_SOC_AC97_BUS
select SND_SOC_WM9713 if SND_SOC_AC97_BUS
@ -34,7 +34,7 @@ index badb6fb..dc1f4ac 100644
help
Normally ASoC codec drivers are only built if a machine driver which
uses them is also built since they are only usable with a machine
@@ -515,6 +516,9 @@ config SND_SOC_WM9712
@@ -844,6 +845,9 @@ config SND_SOC_WM9712
config SND_SOC_WM9713
tristate
@ -45,10 +45,10 @@ index badb6fb..dc1f4ac 100644
config SND_SOC_LM4857
tristate
diff --git a/sound/soc/codecs/Makefile b/sound/soc/codecs/Makefile
index 70fd806..9c3b73a 100644
index abe2d7e..9ef8c98 100644
--- a/sound/soc/codecs/Makefile
+++ b/sound/soc/codecs/Makefile
@@ -120,6 +120,7 @@ snd-soc-wm9705-objs := wm9705.o
@@ -175,6 +175,7 @@ snd-soc-wm9705-objs := wm9705.o
snd-soc-wm9712-objs := wm9712.o
snd-soc-wm9713-objs := wm9713.o
snd-soc-wm-hubs-objs := wm_hubs.o
@ -56,7 +56,7 @@ index 70fd806..9c3b73a 100644
# Amp
snd-soc-max9877-objs := max9877.o
@@ -246,6 +247,7 @@ obj-$(CONFIG_SND_SOC_WM9712) += snd-soc-wm9712.o
@@ -357,6 +358,7 @@ obj-$(CONFIG_SND_SOC_WM9712) += snd-soc-wm9712.o
obj-$(CONFIG_SND_SOC_WM9713) += snd-soc-wm9713.o
obj-$(CONFIG_SND_SOC_WM_ADSP) += snd-soc-wm-adsp.o
obj-$(CONFIG_SND_SOC_WM_HUBS) += snd-soc-wm-hubs.o
@ -66,7 +66,7 @@ index 70fd806..9c3b73a 100644
obj-$(CONFIG_SND_SOC_MAX9877) += snd-soc-max9877.o
diff --git a/sound/soc/codecs/mxs-builtin-codec.c b/sound/soc/codecs/mxs-builtin-codec.c
new file mode 100644
index 0000000..e5dcb4e
index 0000000..cd74a8f
--- /dev/null
+++ b/sound/soc/codecs/mxs-builtin-codec.c
@@ -0,0 +1,1128 @@
@ -2030,10 +2030,10 @@ index 0000000..75dee0b
+
+#endif /* __MXS_ADC_CODEC_H */
diff --git a/sound/soc/mxs/Kconfig b/sound/soc/mxs/Kconfig
index 78d321c..9b8dd7d 100644
index 219235c..7612ef8 100644
--- a/sound/soc/mxs/Kconfig
+++ b/sound/soc/mxs/Kconfig
@@ -18,3 +18,13 @@ config SND_SOC_MXS_SGTL5000
@@ -19,3 +19,13 @@ config SND_SOC_MXS_SGTL5000
a sgtl5000 codec.
endif # SND_MXS_SOC
@ -2192,7 +2192,7 @@ index 0000000..7a27c63
+MODULE_LICENSE("GPL");
diff --git a/sound/soc/mxs/mxs-builtin-dai.c b/sound/soc/mxs/mxs-builtin-dai.c
new file mode 100644
index 0000000..cc81f9a
index 0000000..de29256
--- /dev/null
+++ b/sound/soc/mxs/mxs-builtin-dai.c
@@ -0,0 +1,588 @@
@ -2725,7 +2725,7 @@ index 0000000..cc81f9a
+ }
+
+ ret = devm_request_irq(&pdev->dev, mxs_adc->hp_short_irq, mxs_short_irq,
+ IRQF_DISABLED | IRQF_SHARED, "MXS DAC and ADC HP SHORT", mxs_adc);
+ IRQF_SHARED, "MXS DAC and ADC HP SHORT", mxs_adc);
+ if (ret) {
+ printk(KERN_ERR "%s: Unable to request ADC/DAC HP SHORT irq %d\n",
+ __func__, mxs_adc->hp_short_irq);
@ -2891,5 +2891,5 @@ index 0000000..2fba109
+
+#endif
--
1.7.10.4
2.3.5

View file

@ -1,15 +1,15 @@
From a68d3fb3c79b2860a230532c178ed7685db535f7 Mon Sep 17 00:00:00 2001
From 4d384150261938722424fe58b5b2e321f64e58eb Mon Sep 17 00:00:00 2001
From: Robert Nelson <robertcnelson@gmail.com>
Date: Mon, 12 Aug 2013 11:27:22 -0500
Subject: [PATCH 2/2] ARM: dts: imx23-olinuxino: enable mxs-builtin-audio
Subject: [PATCH 2/5] ARM: dts: imx23-olinuxino: enable mxs-builtin-audio
Signed-off-by: Robert Nelson <robertcnelson@gmail.com>
---
arch/arm/boot/dts/imx23-olinuxino.dts | 25 +++++++++++++++++++++++++
arch/arm/boot/dts/imx23-olinuxino.dts | 25 +++++++++++++++++++++++++
1 file changed, 25 insertions(+)
diff --git a/arch/arm/boot/dts/imx23-olinuxino.dts b/arch/arm/boot/dts/imx23-olinuxino.dts
index fc766ae..4a96623 100644
index 7e6eef2..cf5058b 100644
--- a/arch/arm/boot/dts/imx23-olinuxino.dts
+++ b/arch/arm/boot/dts/imx23-olinuxino.dts
@@ -88,6 +88,25 @@
@ -38,7 +38,7 @@ index fc766ae..4a96623 100644
};
};
@@ -122,4 +141,10 @@
@@ -125,4 +144,10 @@
gpios = <&gpio2 1 1>;
};
};
@ -50,5 +50,5 @@ index fc766ae..4a96623 100644
+ };
};
--
1.7.10.4
2.3.5

View file

@ -1,7 +1,7 @@
From 96f0b63db8df533cc619212f41e134cdf112b853 Mon Sep 17 00:00:00 2001
From b29557c7c38f35d7f0cd24b8f51a977d60466996 Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Wed, 18 Jun 2014 21:55:51 -0600
Subject: [PATCH] imx23 I2C fixes
Subject: [PATCH 3/5] imx23 I2C fixes
---
arch/arm/boot/dts/imx23-olinuxino.dts | 35 ++++++++++++++++++++++++++++++
@ -9,7 +9,7 @@ Subject: [PATCH] imx23 I2C fixes
2 files changed, 75 insertions(+), 1 deletion(-)
diff --git a/arch/arm/boot/dts/imx23-olinuxino.dts b/arch/arm/boot/dts/imx23-olinuxino.dts
index 7e6eef2..5caef60 100644
index cf5058b..2ecee35 100644
--- a/arch/arm/boot/dts/imx23-olinuxino.dts
+++ b/arch/arm/boot/dts/imx23-olinuxino.dts
@@ -73,6 +73,25 @@
@ -38,7 +38,7 @@ index 7e6eef2..5caef60 100644
duart: serial@80070000 {
pinctrl-names = "default";
pinctrl-0 = <&duart_pins_a>;
@@ -113,6 +132,22 @@
@@ -132,6 +151,22 @@
startup-delay-us = <300>; /* LAN9215 requires a POR of 200us minimum */
gpio = <&gpio0 17 0>;
};
@ -122,5 +122,5 @@ index bbcfb5a..54b6a83 100644
dma-names = "rx-tx";
status = "disabled";
--
1.9.0
2.3.5

View file

@ -1,11 +1,11 @@
From 2edc71fc799c4fb2661a4b69767f2e28a096954b Mon Sep 17 00:00:00 2001
From e62c10d588514aace9254df1231e12aaec9a161f Mon Sep 17 00:00:00 2001
From: Michal Ulianko <info@itserve.cz>
Date: Tue, 30 Jul 2013 14:28:17 +0200
Subject: [PATCH 2/2] Added DTS with mxs-builtin-* entries for testing the
Subject: [PATCH 4/5] Added DTS with mxs-builtin-* entries for testing the
audio driver.
---
arch/arm/boot/dts/imx23-audio.dts | 153 +++++++++++++++++++++++++++++++++++++
arch/arm/boot/dts/imx23-audio.dts | 153 ++++++++++++++++++++++++++++++++++++++
1 file changed, 153 insertions(+)
create mode 100644 arch/arm/boot/dts/imx23-audio.dts
@ -169,5 +169,5 @@ index 0000000..1555896
+ };
+};
--
1.7.10.4
2.3.5

View file

@ -0,0 +1,93 @@
From fbc9910aa9553955cc3066707cd55f0f496a646b Mon Sep 17 00:00:00 2001
From: Douglas Gilbert <[mailto:dgilbert@interlog.com]>
Date: Mon, 12 Aug 2013 10:36:25 -0500
Subject: [PATCH 5/5] at91: ariag25 updates
v2: dropped at91sam9x5 usart fix, as merged mainline
Signed-off-by: Douglas Gilbert <dgilbert@interlog.com>
Signed-off-by: Robert Nelson <robertcnelson@gmail.com>
---
arch/arm/boot/dts/at91-ariag25.dts | 39 +++++++++++++++++++++++++++++++++++---
1 file changed, 36 insertions(+), 3 deletions(-)
diff --git a/arch/arm/boot/dts/at91-ariag25.dts b/arch/arm/boot/dts/at91-ariag25.dts
index e9ced30..8308515 100644
--- a/arch/arm/boot/dts/at91-ariag25.dts
+++ b/arch/arm/boot/dts/at91-ariag25.dts
@@ -117,7 +117,7 @@
* following can be overwritten by bootloader:
* for example u-boot 'ftd set' command
*/
- local-mac-address = [00 00 00 00 00 00];
+ local-mac-address = [00 04 25 ef 00 00];
status = "okay";
};
@@ -127,13 +127,41 @@
* Change to "okay" if you need additional serial ports
*/
uart0: serial@f8040000 {
- status = "disabled";
+ status = "okay";
};
uart1: serial@f8044000 {
status = "disabled";
};
+ spi0: spi@f0000000 {
+ status = "okay";
+ cs-gpios = <&pioA 14 0>, <0>, <0>, <0>;
+ anything@0 {
+ compatible = "spidev";
+ // spi-max-frequency = <50000000>; // 50 MHz
+ spi-max-frequency = <5000000>; // 5 MHz
+ reg = <0>;
+ };
+ // m25p80@0 {
+ // compatible = "spidev";
+ // spi-max-frequency = <50000000>;
+ // reg = <0>;
+ // };
+
+ mmc-slot@0 {
+ compatible = "mmc-spi-slot";
+ reg = <0>;
+ voltage-ranges = <3300 3300>;
+ // Use one of next 3 lines, comment out other 2
+ gpios = <&pioA 26 0>; /* CD to PA26 */
+ // broken-cd;
+ // non-removable;
+ cd-inverted;
+ spi-max-frequency = <8000000>;
+ };
+ };
+
adc0: adc@f804c000 {
status = "okay";
atmel,adc-channels-used = <0xf>;
@@ -146,7 +174,7 @@
pinctrl@fffff400 {
w1_0 {
pinctrl_w1_0: w1_0-0 {
- atmel,pins = <0 21 0x0 0x1>; /* PA21 PIO, pull-up */
+ atmel,pins = <AT91_PIOA 21 AT91_PERIPH_GPIO AT91_PINCTRL_PULL_UP>;
};
};
};
@@ -154,6 +182,11 @@
rtc@fffffeb0 {
status = "okay";
};
+
+ watchdog@fffffe40 {
+ /* timeout-sec = <14>; */
+ status = "okay";
+ };
};
usb0: ohci@00600000 {
--
2.3.5

View file

@ -21,17 +21,19 @@ source=("http://www.kernel.org/pub/linux/kernel/v4.x/${_srcname}.tar.xz"
"https://www.kernel.org/pub/linux/kernel/v4.x/testing/patch-${_rcver}-rc${_rcrel}.xz"
"git://git.code.sf.net/p/aufs/aufs3-standalone#branch=aufs3.x-rcN"
'0001-Added-ASoC-driver-for-i.MX233-s-builtin-ADC-DAC-code.patch'
'0001-arm-dts-imx23-olinuxino-enable-mxs-builtin-audio.patch'
'0002-Added-DTS-with-mxs-builtin-entries-for-testing-the-a.patch'
'0001-imx23-I2C-fixes.patch'
'0002-ARM-dts-imx23-olinuxino-enable-mxs-builtin-audio.patch'
'0003-imx23-I2C-fixes.patch'
'0004-Added-DTS-with-mxs-builtin-entries-for-testing-the-a.patch'
'0005-at91-ariag25-updates.patch'
'config')
md5sums=('a86916bd12798220da9eb4a1eec3616d'
'7178b5adbaac914f1aa81757295f32c0'
'SKIP'
'114af68d721fdc22548994b847807929'
'3a1e689563354c2f9f2d2764e1baa334'
'a88071c80e1c2b22637894ae148c74b8'
'e64077ce856769fc3af2a15ae95d8310'
'4425a61f4850823509c4c308bf98a85e'
'5d8b0f650d70f7603ce385a11c73a7f9'
'0a604a9981434bddb98045169645c516'
'bd8b8485d4084247565f3a877eeb73e0'
'6c3aee91d74e45dd8ff0787a99949890'
'7c2b83c6e861fdb4208618699dc7506f')
prepare() {
@ -42,9 +44,10 @@ prepare() {
# ALARM patches
git apply ../0001-Added-ASoC-driver-for-i.MX233-s-builtin-ADC-DAC-code.patch
git apply ../0001-arm-dts-imx23-olinuxino-enable-mxs-builtin-audio.patch
git apply ../0002-Added-DTS-with-mxs-builtin-entries-for-testing-the-a.patch
git apply ../0001-imx23-I2C-fixes.patch
git apply ../0002-ARM-dts-imx23-olinuxino-enable-mxs-builtin-audio.patch
git apply ../0003-imx23-I2C-fixes.patch
git apply ../0004-Added-DTS-with-mxs-builtin-entries-for-testing-the-a.patch
git apply ../0005-at91-ariag25-updates.patch
# AUFS patches
#cp -ru "${srcdir}/aufs3-standalone/Documentation" .
@ -171,6 +174,8 @@ _package-headers() {
cp -a arch/$KARCH/include ${pkgdir}/usr/lib/modules/${_kernver}/build/arch/$KARCH/
mkdir -p ${pkgdir}/usr/lib/modules/${_kernver}/build/arch/$KARCH/mach-mvebu
cp -a arch/$KARCH/mach-mvebu/include ${pkgdir}/usr/lib/modules/${_kernver}/build/arch/$KARCH/mach-mvebu/
mkdir -p ${pkgdir}/usr/lib/modules/${_kernver}/build/arch/$KARCH/mach-at91
cp -a arch/$KARCH/mach-at91/include ${pkgdir}/usr/lib/modules/${_kernver}/build/arch/$KARCH/mach-at91/
mkdir -p ${pkgdir}/usr/lib/modules/${_kernver}/build/arch/$KARCH/plat-orion
cp -a arch/$KARCH/plat-orion/include ${pkgdir}/usr/lib/modules/${_kernver}/build/arch/$KARCH/plat-orion/