extra/qt5: patch updates

This commit is contained in:
Kevin Mihelich 2014-09-17 13:29:49 +00:00
parent f065453557
commit 08143a836b
3 changed files with 16 additions and 14 deletions

View file

@ -58,8 +58,8 @@ md5sums=('c4e893678e3d8388ab04d059523d1d78'
'188da8f4c87316e730ebf1c6217bf5a0'
'322b419b16c75d4de0ee7ad0a246caa1'
'a378deccf363bd6079da459c89aff7b9'
'46ff379ce216fc6929dd65e401c86295'
'd9eb94a6cf4f178a7d77d6b8a9280ee2')
'df4b63eb078b81a708a7dc0859cdd693'
'd55ad1f1c90725834b44eada5db4e401')
prepare() {
cd ${_pkgfqn}

View file

@ -18,7 +18,7 @@ diff --git a/Source/WTF/wtf/Platform.h b/Source/WTF/wtf/Platform.h
index 3a9b509..cddc210 100644
--- a/Source/WTF/wtf/Platform.h
+++ b/Source/WTF/wtf/Platform.h
@@ -771,6 +771,11 @@
@@ -803,6 +803,11 @@
#define ENABLE_LLINT 0
#endif

View file

@ -1,6 +1,7 @@
--- qt-everywhere-opensource-src-5.3.1/qtbase/configure.orig 2014-07-19 13:59:34.000000000 +0200
+++ qt-everywhere-opensource-src-5.3.1/qtbase/configure 2014-07-19 13:53:37.000000000 +0200
@@ -4801,16 +4801,6 @@
diff -urN a/qtbase/configure b/qtbase/configure
--- a/qtbase/configure 2014-09-11 04:47:55.000000000 -0600
+++ b/qtbase/configure 2014-09-17 07:19:44.775372102 -0600
@@ -4809,16 +4809,6 @@
fi
elif [ "$CFG_OPENGL" = "es2" ]; then
#OpenGL ES 2.x
@ -17,7 +18,7 @@
compileTest unix/opengles2 "OpenGL ES 2.x" $QMAKE_LIBS_OPENGL_ES2 $QMAKE_CFLAGS_OPENGL_ES2
if [ $? != "0" ]; then
echo "The OpenGL ES 2.0 functionality test failed!"
@@ -5130,14 +5120,6 @@
@@ -5138,14 +5128,6 @@
exit 101
fi
@ -32,9 +33,10 @@
if compileTest qpa/egl "EGL" $QMAKE_CFLAGS_EGL $QMAKE_LIBS_EGL; then
CFG_EGL=yes
if compileTest qpa/egl-x11 "EGL-X11" $QMAKE_CFLAGS_EGL $QMAKE_LIBS_EGL; then
--- qt-everywhere-opensource-src-5.3.1/qtbase/src/gui/Qt5GuiConfigExtras.cmake.in.orig 2014-07-29 19:23:45.000000000 +0200
+++ qt-everywhere-opensource-src-5.3.1/qtbase/src/gui/Qt5GuiConfigExtras.cmake.in 2014-07-29 19:41:12.000000000 +0200
@@ -96,8 +96,8 @@
diff -urN a/qtbase/src/gui/Qt5GuiConfigExtras.cmake.in b/qtbase/src/gui/Qt5GuiConfigExtras.cmake.in
--- a/qtbase/src/gui/Qt5GuiConfigExtras.cmake.in 2014-09-11 04:48:05.000000000 -0600
+++ b/qtbase/src/gui/Qt5GuiConfigExtras.cmake.in 2014-09-17 07:19:44.780372095 -0600
@@ -97,8 +97,8 @@
string(REGEX REPLACE "[^_A-Za-z0-9]" "_" _cmake_lib_name ${_lib})
if (NOT TARGET Qt5::Gui_${_cmake_lib_name} AND NOT _Qt5Gui_${_cmake_lib_name}_LIBRARY_DONE)
find_library(Qt5Gui_${_cmake_lib_name}_LIBRARY ${_lib}
@ -44,7 +46,7 @@
!!IF !mac
NO_DEFAULT_PATH
!!ENDIF
@@ -150,8 +150,15 @@
@@ -155,8 +155,15 @@
unset(Qt5Gui_${_cmake_lib_name}_LIBRARY_DEBUG CACHE)
list(APPEND Qt5Gui_${Name}_LIBRARIES Qt5::Gui_${_cmake_lib_name})
endif()
@ -57,6 +59,6 @@
endif()
endforeach()
+ list(REMOVE_DUPLICATES Qt5Gui_${Name}_LIBRARIES)
if (NOT CMAKE_CROSSCOMPILING)
foreach(_dir ${Qt5Gui_${Name}_INCLUDE_DIRS})
_qt5_Gui_check_file_exists(${_dir})
endmacro()