mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
core/linux-odroid-c1 to 3.10.107-5
This commit is contained in:
parent
53e4fe56e2
commit
0892d0a9d7
6 changed files with 63 additions and 10 deletions
|
@ -0,0 +1,12 @@
|
|||
diff -ruN a/scripts/dtc/dtc-lexer.lex.c_shipped b/scripts/dtc/dtc-lexer.lex.c_shipped
|
||||
--- a/scripts/dtc/dtc-lexer.lex.c_shipped 2021-02-03 08:03:56.000000000 -0700
|
||||
+++ b/scripts/dtc/dtc-lexer.lex.c_shipped 2021-03-25 23:49:08.007267658 -0600
|
||||
@@ -637,7 +637,7 @@
|
||||
#include "srcpos.h"
|
||||
#include "dtc-parser.tab.h"
|
||||
|
||||
-YYLTYPE yylloc;
|
||||
+extern YYLTYPE yylloc;
|
||||
|
||||
/* CAUTION: this will stop working if we ever use yyless() or yyunput() */
|
||||
#define YY_USER_ACTION \
|
15
core/linux-odroid-c1/0004-fix-bad-udelay-for-gcc10.patch
Normal file
15
core/linux-odroid-c1/0004-fix-bad-udelay-for-gcc10.patch
Normal file
|
@ -0,0 +1,15 @@
|
|||
diff -ruN a/arch/arm/mach-meson8b/hdmi_tx_hw/hdmi_tx_hw.c b/arch/arm/mach-meson8b/hdmi_tx_hw/hdmi_tx_hw.c
|
||||
--- a/arch/arm/mach-meson8b/hdmi_tx_hw/hdmi_tx_hw.c 2021-02-03 08:03:56.000000000 -0700
|
||||
+++ b/arch/arm/mach-meson8b/hdmi_tx_hw/hdmi_tx_hw.c 2021-03-26 11:29:07.462226352 -0600
|
||||
@@ -217,8 +217,10 @@
|
||||
//udelay(us);
|
||||
if(delay_flag&0x1)
|
||||
mdelay((us+999)/1000);
|
||||
+ else if (us >= 1000)
|
||||
+ mdelay(us/1000);
|
||||
else
|
||||
- udelay(us);
|
||||
+ udelay(us);
|
||||
} /* delay_us */
|
||||
|
||||
static irqreturn_t intr_handler(int irq, void *dev_instance)
|
|
@ -4,12 +4,12 @@
|
|||
buildarch=4
|
||||
|
||||
pkgbase=linux-odroid-c1
|
||||
_commit=409d98d698652896d804e8d96de0a979aeecf321
|
||||
_commit=5aed95d35d252cafc75ce613a3a0052285662de2
|
||||
_srcname=linux-${_commit}
|
||||
_kernelname=${pkgbase#linux}
|
||||
_desc="ODROID-C1"
|
||||
pkgver=3.10.107
|
||||
pkgrel=4
|
||||
pkgrel=5
|
||||
arch=('armv7h')
|
||||
url="https://github.com/hardkernel/linux"
|
||||
license=('GPL2')
|
||||
|
@ -18,14 +18,18 @@ options=('!strip')
|
|||
source=("https://github.com/hardkernel/linux/archive/${_commit}.tar.gz"
|
||||
"git+https://github.com/mdrjr/c1_bootini.git"
|
||||
'0001-disable-pie.patch'
|
||||
'ARM-fix-put_user-for-gcc-8.patch'
|
||||
'0002-ARM-fix-put_user-for-gcc-8.patch'
|
||||
'0003-fix-redundant-YYLOC-for-gcc10.patch'
|
||||
'0004-fix-bad-udelay-for-gcc10.patch'
|
||||
'config'
|
||||
'amlogic.service')
|
||||
md5sums=('f90b774ae08dbee53c79cee38226edd4'
|
||||
md5sums=('e8d1500aea63182987982f0ed0f32943'
|
||||
'SKIP'
|
||||
'a2329e6dcdc856559fbd8b0847b3b55d'
|
||||
'964321c95e6efde0f702414d661aaf63'
|
||||
'c27274182cbe6e22dcf5b12ad84f4585'
|
||||
'6cde7eeb477853d61dcfa8530bcfdc8f'
|
||||
'ff90474d193873a53801d615debba98b'
|
||||
'035055264d96de7cdd9121b214e47883'
|
||||
'b8956789318f49cec5b8bb0b41654a9b')
|
||||
|
||||
prepare() {
|
||||
|
@ -40,7 +44,9 @@ prepare() {
|
|||
sed -i '2iexit 0' scripts/depmod.sh
|
||||
|
||||
git apply ../0001-disable-pie.patch
|
||||
git apply ../ARM-fix-put_user-for-gcc-8.patch
|
||||
git apply ../0002-ARM-fix-put_user-for-gcc-8.patch
|
||||
git apply ../0003-fix-redundant-YYLOC-for-gcc10.patch
|
||||
git apply ../0004-fix-bad-udelay-for-gcc10.patch
|
||||
}
|
||||
|
||||
build() {
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
#
|
||||
# Automatically generated file; DO NOT EDIT.
|
||||
# Linux/arm 3.10.104-12 Kernel Configuration
|
||||
# Linux/arm 3.10.107-5 Kernel Configuration
|
||||
#
|
||||
CONFIG_ARM=y
|
||||
CONFIG_ARM_HAS_SG_CHAIN=y
|
||||
|
@ -4387,12 +4387,31 @@ CONFIG_SQUASHFS_FRAGMENT_CACHE_SIZE=3
|
|||
# CONFIG_ROMFS_FS is not set
|
||||
# CONFIG_PSTORE is not set
|
||||
# CONFIG_SYSV_FS is not set
|
||||
# CONFIG_UFS_FS is not set
|
||||
CONFIG_UFS_FS=m
|
||||
# CONFIG_UFS_FS_WRITE is not set
|
||||
# CONFIG_UFS_DEBUG is not set
|
||||
CONFIG_F2FS_FS=y
|
||||
CONFIG_F2FS_STAT_FS=y
|
||||
CONFIG_F2FS_FS_XATTR=y
|
||||
CONFIG_F2FS_FS_POSIX_ACL=y
|
||||
# CONFIG_AUFS_FS is not set
|
||||
CONFIG_AUFS_FS=y
|
||||
CONFIG_AUFS_BRANCH_MAX_127=y
|
||||
# CONFIG_AUFS_BRANCH_MAX_511 is not set
|
||||
# CONFIG_AUFS_BRANCH_MAX_1023 is not set
|
||||
# CONFIG_AUFS_BRANCH_MAX_32767 is not set
|
||||
CONFIG_AUFS_SBILIST=y
|
||||
# CONFIG_AUFS_HNOTIFY is not set
|
||||
CONFIG_AUFS_EXPORT=y
|
||||
# CONFIG_AUFS_XATTR is not set
|
||||
# CONFIG_AUFS_FHSM is not set
|
||||
# CONFIG_AUFS_RDU is not set
|
||||
# CONFIG_AUFS_SHWH is not set
|
||||
# CONFIG_AUFS_BR_RAMFS is not set
|
||||
CONFIG_AUFS_BR_FUSE=y
|
||||
CONFIG_AUFS_POLL=y
|
||||
CONFIG_AUFS_BR_HFSPLUS=y
|
||||
CONFIG_AUFS_BDEV_LOOP=y
|
||||
# CONFIG_AUFS_DEBUG is not set
|
||||
CONFIG_NETWORK_FILESYSTEMS=y
|
||||
CONFIG_NFS_FS=y
|
||||
CONFIG_NFS_V2=y
|
||||
|
@ -5071,5 +5090,6 @@ CONFIG_BACKPORT_USB_SIERRA_NET=m
|
|||
CONFIG_BACKPORT_USB_WDM=m
|
||||
CONFIG_RTL8192CU=m
|
||||
CONFIG_RTL8821AU=m
|
||||
CONFIG_RTL8821CU=m
|
||||
CONFIG_RTL8188EU=m
|
||||
CONFIG_RTL8192DU=m
|
||||
|
|
|
@ -2,7 +2,7 @@
|
|||
# arg 2: the old package version
|
||||
|
||||
KERNEL_NAME=-odroid-c1
|
||||
KERNEL_VERSION=3.10.42-1-ARCH
|
||||
KERNEL_VERSION=3.10.107-5-ARCH
|
||||
|
||||
post_install () {
|
||||
# updating module dependencies
|
||||
|
|
Loading…
Reference in a new issue