mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-03-19 00:21:40 +00:00
core/linux-usbarmory to 3.19.2-1
This commit is contained in:
parent
ee49d2dc5a
commit
08a3e0288b
8 changed files with 240 additions and 464 deletions
|
@ -1,51 +0,0 @@
|
|||
From 7ba704a48c49367dda65d1297a4c06a1eb4e8c9c Mon Sep 17 00:00:00 2001
|
||||
From: Willy Tarreau <w@xxxxxx>
|
||||
Date: Sun, 2 Dec 2012 19:59:28 +0100
|
||||
Subject: [PATCH 1/5] ARM: atags: add support for Marvell's u-boot
|
||||
|
||||
Marvell uses a specific atag in its u-boot which includes among other
|
||||
information the MAC addresses for up to 4 network interfaces.
|
||||
|
||||
Signed-off-by: Willy Tarreau <w@xxxxxx>
|
||||
---
|
||||
arch/arm/include/uapi/asm/setup.h | 17 +++++++++++++++++
|
||||
1 file changed, 17 insertions(+)
|
||||
|
||||
diff --git a/arch/arm/include/uapi/asm/setup.h b/arch/arm/include/uapi/asm/setup.h
|
||||
index 979ff40..d1d0c19 100644
|
||||
--- a/arch/arm/include/uapi/asm/setup.h
|
||||
+++ b/arch/arm/include/uapi/asm/setup.h
|
||||
@@ -143,6 +143,18 @@ struct tag_memclk {
|
||||
__u32 fmemclk;
|
||||
};
|
||||
|
||||
+/* Marvell uboot parameters */
|
||||
+#define ATAG_MV_UBOOT 0x41000403
|
||||
+struct tag_mv_uboot {
|
||||
+ __u32 uboot_version;
|
||||
+ __u32 tclk;
|
||||
+ __u32 sysclk;
|
||||
+ __u32 isUsbHost;
|
||||
+ __u8 macAddr[4][6];
|
||||
+ __u16 mtu[4];
|
||||
+ __u32 nand_ecc;
|
||||
+};
|
||||
+
|
||||
struct tag {
|
||||
struct tag_header hdr;
|
||||
union {
|
||||
@@ -165,6 +177,11 @@ struct tag {
|
||||
* DC21285 specific
|
||||
*/
|
||||
struct tag_memclk memclk;
|
||||
+
|
||||
+ /*
|
||||
+ * Marvell specific
|
||||
+ */
|
||||
+ struct tag_mv_uboot mv_uboot;
|
||||
} u;
|
||||
};
|
||||
|
||||
--
|
||||
2.3.0
|
||||
|
229
core/linux-usbarmory/0001-USB-armory-support.patch
Normal file
229
core/linux-usbarmory/0001-USB-armory-support.patch
Normal file
|
@ -0,0 +1,229 @@
|
|||
From 345e2b50bcf13c5dac5c19e71abf0fd37a9d7b68 Mon Sep 17 00:00:00 2001
|
||||
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
Date: Sat, 7 Mar 2015 16:51:15 -0700
|
||||
Subject: [PATCH] USB armory support
|
||||
|
||||
---
|
||||
arch/arm/boot/dts/Makefile | 1 +
|
||||
arch/arm/boot/dts/imx53-usbarmory.dts | 197 ++++++++++++++++++++++++++++++++++
|
||||
2 files changed, 198 insertions(+)
|
||||
create mode 100644 arch/arm/boot/dts/imx53-usbarmory.dts
|
||||
|
||||
diff --git a/arch/arm/boot/dts/Makefile b/arch/arm/boot/dts/Makefile
|
||||
index 91bd5bd..d10ac9f 100644
|
||||
--- a/arch/arm/boot/dts/Makefile
|
||||
+++ b/arch/arm/boot/dts/Makefile
|
||||
@@ -213,6 +213,7 @@ dtb-$(CONFIG_ARCH_MXC) += \
|
||||
imx53-smd.dtb \
|
||||
imx53-tx53-x03x.dtb \
|
||||
imx53-tx53-x13x.dtb \
|
||||
+ imx53-usbarmory.dtb \
|
||||
imx53-voipac-bsb.dtb \
|
||||
imx6dl-aristainetos_4.dtb \
|
||||
imx6dl-aristainetos_7.dtb \
|
||||
diff --git a/arch/arm/boot/dts/imx53-usbarmory.dts b/arch/arm/boot/dts/imx53-usbarmory.dts
|
||||
new file mode 100644
|
||||
index 0000000..ff411be
|
||||
--- /dev/null
|
||||
+++ b/arch/arm/boot/dts/imx53-usbarmory.dts
|
||||
@@ -0,0 +1,197 @@
|
||||
+/*
|
||||
+ * Copyright 2015 Inverse Path, S.r.l.
|
||||
+ *
|
||||
+ * The code contained herein is licensed under the GNU General Public
|
||||
+ * License. You may obtain a copy of the GNU General Public License
|
||||
+ * Version 2 or later at the following locations:
|
||||
+ *
|
||||
+ * http://www.opensource.org/licenses/gpl-license.html
|
||||
+ * http://www.gnu.org/copyleft/gpl.html
|
||||
+ */
|
||||
+
|
||||
+/dts-v1/;
|
||||
+#include "imx53.dtsi"
|
||||
+
|
||||
+/ {
|
||||
+ model = "Inverse Path USB armory";
|
||||
+ compatible = "inversepath,imx53-usbarmory", "fsl,imx53";
|
||||
+};
|
||||
+
|
||||
+/ {
|
||||
+ chosen {
|
||||
+ stdout-path = &uart1;
|
||||
+ };
|
||||
+
|
||||
+ memory {
|
||||
+ reg = <0x70000000 0x20000000>;
|
||||
+ };
|
||||
+
|
||||
+ leds {
|
||||
+ compatible = "gpio-leds";
|
||||
+ pinctrl-names = "default";
|
||||
+ pinctrl-0 = <&led_pin_gpio4_27>;
|
||||
+
|
||||
+ user {
|
||||
+ label = "LED";
|
||||
+ gpios = <&gpio4 27 0>;
|
||||
+ linux,default-trigger = "heartbeat";
|
||||
+ };
|
||||
+ };
|
||||
+
|
||||
+ soc {
|
||||
+ aips@60000000 {
|
||||
+ sahara: crypto@63ff8000 {
|
||||
+ compatible = "fsl,imx53-sahara";
|
||||
+ reg = <0x63ff8000 0x4000>;
|
||||
+ interrupts = <19 20>;
|
||||
+ clocks = <&clks IMX5_CLK_SAHARA_IPG_GATE>,
|
||||
+ <&clks IMX5_CLK_SAHARA_IPG_GATE>;
|
||||
+ clock-names = "ipg", "ahb";
|
||||
+ };
|
||||
+ };
|
||||
+ };
|
||||
+};
|
||||
+
|
||||
+&esdhc1 {
|
||||
+ pinctrl-names = "default";
|
||||
+ pinctrl-0 = <&pinctrl_esdhc1>;
|
||||
+ status = "okay";
|
||||
+};
|
||||
+
|
||||
+&iomuxc {
|
||||
+ pinctrl-names = "default";
|
||||
+ pinctrl-0 = <&pinctrl_hog>;
|
||||
+
|
||||
+ imx53-usbarmory {
|
||||
+ pinctrl_hog: hoggrp {
|
||||
+ fsl,pins = <
|
||||
+ MX53_PAD_GPIO_0__CCM_SSI_EXT1_CLK 0x80000000
|
||||
+ MX53_PAD_GPIO_8__GPIO1_8 0x80000000
|
||||
+ MX53_PAD_PATA_DATA14__GPIO2_14 0x80000000
|
||||
+ MX53_PAD_PATA_DATA15__GPIO2_15 0x80000000
|
||||
+ MX53_PAD_EIM_DA11__GPIO3_11 0x80000000
|
||||
+ MX53_PAD_EIM_DA12__GPIO3_12 0x80000000
|
||||
+ MX53_PAD_PATA_DA_0__GPIO7_6 0x80000000
|
||||
+ MX53_PAD_PATA_DA_2__GPIO7_8 0x80000000
|
||||
+ MX53_PAD_GPIO_16__GPIO7_11 0x80000000
|
||||
+ >;
|
||||
+ };
|
||||
+
|
||||
+ led_pin_gpio4_27: led_gpio4_27@0 {
|
||||
+ fsl,pins = <
|
||||
+ MX53_PAD_DISP0_DAT6__GPIO4_27 0x80000000
|
||||
+ >;
|
||||
+ };
|
||||
+
|
||||
+ pinctrl_esdhc1: esdhc1grp {
|
||||
+ fsl,pins = <
|
||||
+ MX53_PAD_SD1_DATA0__ESDHC1_DAT0 0x1d5
|
||||
+ MX53_PAD_SD1_DATA1__ESDHC1_DAT1 0x1d5
|
||||
+ MX53_PAD_SD1_DATA2__ESDHC1_DAT2 0x1d5
|
||||
+ MX53_PAD_SD1_DATA3__ESDHC1_DAT3 0x1d5
|
||||
+ MX53_PAD_SD1_CMD__ESDHC1_CMD 0x1d5
|
||||
+ MX53_PAD_SD1_CLK__ESDHC1_CLK 0x1d5
|
||||
+ >;
|
||||
+ };
|
||||
+
|
||||
+ pinctrl_i2c1: i2c1grp {
|
||||
+ fsl,pins = <
|
||||
+ MX53_PAD_CSI0_DAT8__I2C1_SDA 0xc0000000
|
||||
+ MX53_PAD_CSI0_DAT9__I2C1_SCL 0xc0000000
|
||||
+ >;
|
||||
+ };
|
||||
+
|
||||
+ pinctrl_uart1: uart1grp {
|
||||
+ fsl,pins = <
|
||||
+ MX53_PAD_CSI0_DAT10__UART1_TXD_MUX 0x1e4
|
||||
+ MX53_PAD_CSI0_DAT11__UART1_RXD_MUX 0x1e4
|
||||
+ >;
|
||||
+ };
|
||||
+ };
|
||||
+};
|
||||
+
|
||||
+&uart1 {
|
||||
+ pinctrl-names = "default";
|
||||
+ pinctrl-0 = <&pinctrl_uart1>;
|
||||
+ status = "okay";
|
||||
+};
|
||||
+
|
||||
+&vpu {
|
||||
+ status = "okay";
|
||||
+};
|
||||
+
|
||||
+&usbotg {
|
||||
+ dr_mode = "peripheral";
|
||||
+ status = "okay";
|
||||
+};
|
||||
+
|
||||
+&i2c1 {
|
||||
+ ltc3589: pmic@34 {
|
||||
+ compatible = "lltc,ltc3589-2";
|
||||
+ reg = <0x34>;
|
||||
+
|
||||
+ regulators {
|
||||
+ sw1_reg: sw1 {
|
||||
+ regulator-min-microvolt = <591930>;
|
||||
+ regulator-max-microvolt = <1224671>;
|
||||
+ lltc,fb-voltage-divider = <100000 158000>;
|
||||
+ regulator-ramp-delay = <7000>;
|
||||
+ regulator-boot-on;
|
||||
+ regulator-always-on;
|
||||
+ };
|
||||
+
|
||||
+ sw2_reg: sw2 {
|
||||
+ regulator-min-microvolt = <704123>;
|
||||
+ regulator-max-microvolt = <1456803>;
|
||||
+ lltc,fb-voltage-divider = <180000 191000>;
|
||||
+ regulator-ramp-delay = <7000>;
|
||||
+ regulator-boot-on;
|
||||
+ regulator-always-on;
|
||||
+ };
|
||||
+
|
||||
+ sw3_reg: sw3 {
|
||||
+ regulator-min-microvolt = <1341250>;
|
||||
+ regulator-max-microvolt = <2775000>;
|
||||
+ lltc,fb-voltage-divider = <270000 100000>;
|
||||
+ regulator-ramp-delay = <7000>;
|
||||
+ regulator-boot-on;
|
||||
+ regulator-always-on;
|
||||
+ };
|
||||
+
|
||||
+ bb_out_reg: bb-out {
|
||||
+ regulator-min-microvolt = <3387341>;
|
||||
+ regulator-max-microvolt = <3387341>;
|
||||
+ lltc,fb-voltage-divider = <511000 158000>;
|
||||
+ regulator-boot-on;
|
||||
+ regulator-always-on;
|
||||
+ };
|
||||
+ ldo1_reg: ldo1 {
|
||||
+ regulator-min-microvolt = <1306329>;
|
||||
+ regulator-max-microvolt = <1306329>;
|
||||
+ lltc,fb-voltage-divider = <100000 158000>;
|
||||
+ regulator-boot-on;
|
||||
+ regulator-always-on;
|
||||
+ };
|
||||
+
|
||||
+ ldo2_reg: ldo2 {
|
||||
+ regulator-min-microvolt = <704123>;
|
||||
+ regulator-max-microvolt = <1456806>;
|
||||
+ lltc,fb-voltage-divider = <180000 191000>;
|
||||
+ regulator-ramp-delay = <7000>;
|
||||
+ regulator-boot-on;
|
||||
+ regulator-always-on;
|
||||
+ };
|
||||
+
|
||||
+ ldo3_reg: ldo3 {
|
||||
+ regulator-min-microvolt = <2800000>;
|
||||
+ regulator-max-microvolt = <2800000>;
|
||||
+ regulator-boot-on;
|
||||
+ };
|
||||
+
|
||||
+ ldo4_reg: ldo4 {
|
||||
+ regulator-min-microvolt = <1200000>;
|
||||
+ regulator-max-microvolt = <3200000>;
|
||||
+ };
|
||||
+ };
|
||||
+ };
|
||||
+};
|
||||
--
|
||||
2.3.4
|
||||
|
|
@ -1,47 +0,0 @@
|
|||
From efad5852f3be8cc444662c3a1ecf22edd38427d4 Mon Sep 17 00:00:00 2001
|
||||
From: Willy Tarreau <w@xxxxxx>
|
||||
Date: Sun, 2 Dec 2012 19:56:58 +0100
|
||||
Subject: [PATCH 2/5] ARM: atags/fdt: retrieve MAC addresses from Marvell boot
|
||||
loader
|
||||
|
||||
The atags are parsed and if a Marvell atag is found, up to 4 MAC
|
||||
addresses are extracted there and assigned to node aliases eth0..3
|
||||
with the name "mac-address".
|
||||
|
||||
This was tested on my Mirabox and the two NICs had their correct
|
||||
address set.
|
||||
|
||||
Signed-off-by: Willy Tarreau <w@xxxxxx>
|
||||
---
|
||||
arch/arm/boot/compressed/atags_to_fdt.c | 8 +++++++-
|
||||
1 file changed, 7 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/arch/arm/boot/compressed/atags_to_fdt.c b/arch/arm/boot/compressed/atags_to_fdt.c
|
||||
index 9448aa0..ac7b6ae 100644
|
||||
--- a/arch/arm/boot/compressed/atags_to_fdt.c
|
||||
+++ b/arch/arm/boot/compressed/atags_to_fdt.c
|
||||
@@ -18,7 +18,7 @@ static int node_offset(void *fdt, const char *node_path)
|
||||
}
|
||||
|
||||
static int setprop(void *fdt, const char *node_path, const char *property,
|
||||
- uint32_t *val_array, int size)
|
||||
+ void *val_array, int size)
|
||||
{
|
||||
int offset = node_offset(fdt, node_path);
|
||||
if (offset < 0)
|
||||
@@ -179,6 +179,12 @@ int atags_to_fdt(void *atag_list, void *fdt, int total_space)
|
||||
initrd_start);
|
||||
setprop_cell(fdt, "/chosen", "linux,initrd-end",
|
||||
initrd_start + initrd_size);
|
||||
+ } else if (atag->hdr.tag == ATAG_MV_UBOOT) {
|
||||
+ /* This ATAG provides up to 4 MAC addresses */
|
||||
+ setprop(fdt, "eth0", "mac-address", atag->u.mv_uboot.macAddr[0], 6);
|
||||
+ setprop(fdt, "eth1", "mac-address", atag->u.mv_uboot.macAddr[1], 6);
|
||||
+ setprop(fdt, "eth2", "mac-address", atag->u.mv_uboot.macAddr[2], 6);
|
||||
+ setprop(fdt, "eth3", "mac-address", atag->u.mv_uboot.macAddr[3], 6);
|
||||
}
|
||||
}
|
||||
|
||||
--
|
||||
2.3.0
|
||||
|
|
@ -1,209 +0,0 @@
|
|||
From 9a1d31f61b309e8a4ebc6a4c85154f20b94af3e2 Mon Sep 17 00:00:00 2001
|
||||
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
Date: Fri, 5 Sep 2014 15:41:19 -0600
|
||||
Subject: [PATCH 3/5] SMILE Plug device tree file
|
||||
|
||||
This adds a dts file for the SMILE Plug, which only differs from the Mirabox
|
||||
dts with the LED definitions.
|
||||
|
||||
Signed-off-by: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
---
|
||||
arch/arm/boot/dts/Makefile | 1 +
|
||||
arch/arm/boot/dts/armada-370-smileplug.dts | 173 +++++++++++++++++++++++++++++
|
||||
2 files changed, 174 insertions(+)
|
||||
create mode 100644 arch/arm/boot/dts/armada-370-smileplug.dts
|
||||
|
||||
diff --git a/arch/arm/boot/dts/Makefile b/arch/arm/boot/dts/Makefile
|
||||
index 91bd5bd..22618d7 100644
|
||||
--- a/arch/arm/boot/dts/Makefile
|
||||
+++ b/arch/arm/boot/dts/Makefile
|
||||
@@ -527,6 +527,7 @@ dtb-$(CONFIG_ARCH_ZYNQ) += \
|
||||
dtb-$(CONFIG_MACH_ARMADA_370) += \
|
||||
armada-370-db.dtb \
|
||||
armada-370-mirabox.dtb \
|
||||
+ armada-370-smileplug.dtb \
|
||||
armada-370-netgear-rn102.dtb \
|
||||
armada-370-netgear-rn104.dtb \
|
||||
armada-370-rd.dtb \
|
||||
diff --git a/arch/arm/boot/dts/armada-370-smileplug.dts b/arch/arm/boot/dts/armada-370-smileplug.dts
|
||||
new file mode 100644
|
||||
index 0000000..d01308a
|
||||
--- /dev/null
|
||||
+++ b/arch/arm/boot/dts/armada-370-smileplug.dts
|
||||
@@ -0,0 +1,173 @@
|
||||
+/*
|
||||
+ * Device Tree file for Marvell SMILE Plug
|
||||
+ *
|
||||
+ * Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
+ * Gregory CLEMENT <gregory.clement@free-electrons.com>
|
||||
+ *
|
||||
+ * This file is licensed under the terms of the GNU General Public
|
||||
+ * License version 2. This program is licensed "as is" without any
|
||||
+ * warranty of any kind, whether express or implied.
|
||||
+ */
|
||||
+
|
||||
+/dts-v1/;
|
||||
+#include <dt-bindings/gpio/gpio.h>
|
||||
+#include "armada-370.dtsi"
|
||||
+
|
||||
+/ {
|
||||
+ model = "Marvell SMILE Plug";
|
||||
+ compatible = "marvell,smileplug", "marvell,armada370", "marvell,armada-370-xp";
|
||||
+
|
||||
+ chosen {
|
||||
+ bootargs = "console=ttyS0,115200 earlyprintk";
|
||||
+ };
|
||||
+
|
||||
+ memory {
|
||||
+ device_type = "memory";
|
||||
+ reg = <0x00000000 0x20000000>; /* 512 MB */
|
||||
+ };
|
||||
+
|
||||
+ soc {
|
||||
+ ranges = <MBUS_ID(0xf0, 0x01) 0 0xd0000000 0x100000
|
||||
+ MBUS_ID(0x01, 0xe0) 0 0xfff00000 0x100000>;
|
||||
+
|
||||
+ pcie-controller {
|
||||
+ status = "okay";
|
||||
+
|
||||
+ /* Internal mini-PCIe connector */
|
||||
+ pcie@1,0 {
|
||||
+ /* Port 0, Lane 0 */
|
||||
+ status = "okay";
|
||||
+ };
|
||||
+
|
||||
+ /* Connected on the PCB to a USB 3.0 XHCI controller */
|
||||
+ pcie@2,0 {
|
||||
+ /* Port 1, Lane 0 */
|
||||
+ status = "okay";
|
||||
+ };
|
||||
+ };
|
||||
+
|
||||
+ internal-regs {
|
||||
+ serial@12000 {
|
||||
+ status = "okay";
|
||||
+ };
|
||||
+ timer@20300 {
|
||||
+ clock-frequency = <600000000>;
|
||||
+ status = "okay";
|
||||
+ };
|
||||
+
|
||||
+ gpio_leds {
|
||||
+ compatible = "gpio-leds";
|
||||
+ pinctrl-names = "default";
|
||||
+ pinctrl-0 = <&smile_led_pins>;
|
||||
+
|
||||
+ red_eyes_led {
|
||||
+ label = "smileplug:red:eyes";
|
||||
+ gpios = <&gpio1 31 0>;
|
||||
+ default-state = "off";
|
||||
+ };
|
||||
+
|
||||
+ green_eyes_led {
|
||||
+ label = "smileplug:green:eyes";
|
||||
+ gpios = <&gpio2 0 0>;
|
||||
+ linux,default-trigger = "default-on";
|
||||
+ };
|
||||
+
|
||||
+ red_smile_led {
|
||||
+ label = "smileplug:red:smile";
|
||||
+ gpios = <&gpio1 15 0>;
|
||||
+ default-state = "off";
|
||||
+ };
|
||||
+
|
||||
+ green_smile_led {
|
||||
+ label = "smileplug:green:smile";
|
||||
+ gpios = <&gpio1 27 0>;
|
||||
+ linux,default-trigger = "default-on";
|
||||
+ };
|
||||
+ };
|
||||
+
|
||||
+ mdio {
|
||||
+ pinctrl-0 = <&mdio_pins>;
|
||||
+ pinctrl-names = "default";
|
||||
+ phy0: ethernet-phy@0 {
|
||||
+ reg = <0>;
|
||||
+ };
|
||||
+
|
||||
+ phy1: ethernet-phy@1 {
|
||||
+ reg = <1>;
|
||||
+ };
|
||||
+ };
|
||||
+ ethernet@70000 {
|
||||
+ pinctrl-0 = <&ge0_rgmii_pins>;
|
||||
+ pinctrl-names = "default";
|
||||
+ status = "okay";
|
||||
+ phy = <&phy0>;
|
||||
+ phy-mode = "rgmii-id";
|
||||
+ };
|
||||
+ ethernet@74000 {
|
||||
+ pinctrl-0 = <&ge1_rgmii_pins>;
|
||||
+ pinctrl-names = "default";
|
||||
+ status = "okay";
|
||||
+ phy = <&phy1>;
|
||||
+ phy-mode = "rgmii-id";
|
||||
+ };
|
||||
+
|
||||
+ mvsdio@d4000 {
|
||||
+ pinctrl-0 = <&sdio_pins3>;
|
||||
+ pinctrl-names = "default";
|
||||
+ status = "okay";
|
||||
+ /*
|
||||
+ * No CD or WP GPIOs: SDIO interface used for
|
||||
+ * Wifi/Bluetooth chip
|
||||
+ */
|
||||
+ broken-cd;
|
||||
+ };
|
||||
+
|
||||
+ usb@50000 {
|
||||
+ status = "okay";
|
||||
+ };
|
||||
+
|
||||
+ usb@51000 {
|
||||
+ status = "okay";
|
||||
+ };
|
||||
+
|
||||
+ i2c@11000 {
|
||||
+ status = "okay";
|
||||
+ clock-frequency = <100000>;
|
||||
+ pca9505: pca9505@25 {
|
||||
+ compatible = "nxp,pca9505";
|
||||
+ gpio-controller;
|
||||
+ #gpio-cells = <2>;
|
||||
+ reg = <0x25>;
|
||||
+ };
|
||||
+ };
|
||||
+
|
||||
+ nand@d0000 {
|
||||
+ status = "okay";
|
||||
+ num-cs = <1>;
|
||||
+ marvell,nand-keep-config;
|
||||
+ marvell,nand-enable-arbiter;
|
||||
+ nand-on-flash-bbt;
|
||||
+
|
||||
+ partition@0 {
|
||||
+ label = "U-Boot";
|
||||
+ reg = <0 0x400000>;
|
||||
+ };
|
||||
+ partition@400000 {
|
||||
+ label = "Linux";
|
||||
+ reg = <0x400000 0x400000>;
|
||||
+ };
|
||||
+ partition@800000 {
|
||||
+ label = "Filesystem";
|
||||
+ reg = <0x800000 0x3f800000>;
|
||||
+ };
|
||||
+ };
|
||||
+ };
|
||||
+ };
|
||||
+};
|
||||
+
|
||||
+&pinctrl {
|
||||
+ smile_led_pins: smile-led-pins {
|
||||
+ marvell,pins = "mpp63", "mpp64", "mpp47", "mpp59";
|
||||
+ marvell,function = "gpio";
|
||||
+ };
|
||||
+};
|
||||
--
|
||||
2.3.0
|
||||
|
|
@ -1,38 +0,0 @@
|
|||
From 29195baa48fe67ae6c0731edc5c64dee9aaf4851 Mon Sep 17 00:00:00 2001
|
||||
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
Date: Fri, 5 Sep 2014 15:43:56 -0600
|
||||
Subject: [PATCH 4/5] fix mvsdio eMMC timing
|
||||
|
||||
These changes from Globalscale change the MMC timing to allow the eMMC versions
|
||||
of the Mirabox and SMILE Plug to work.
|
||||
|
||||
Signed-off-by: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
---
|
||||
drivers/mmc/host/mvsdio.c | 4 +++-
|
||||
1 file changed, 3 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/drivers/mmc/host/mvsdio.c b/drivers/mmc/host/mvsdio.c
|
||||
index 4f8618f..ab95bb7 100644
|
||||
--- a/drivers/mmc/host/mvsdio.c
|
||||
+++ b/drivers/mmc/host/mvsdio.c
|
||||
@@ -97,7 +97,7 @@ static int mvsd_setup_data(struct mvsd_host *host, struct mmc_data *data)
|
||||
tmout_index = fls(tmout - 1) - 12;
|
||||
if (tmout_index < 0)
|
||||
tmout_index = 0;
|
||||
- if (tmout_index > MVSD_HOST_CTRL_TMOUT_MAX)
|
||||
+// if (tmout_index > MVSD_HOST_CTRL_TMOUT_MAX) //by steven, try to setup the timeout to maximum value
|
||||
tmout_index = MVSD_HOST_CTRL_TMOUT_MAX;
|
||||
|
||||
dev_dbg(host->dev, "data %s at 0x%08x: blocks=%d blksz=%d tmout=%u (%d)\n",
|
||||
@@ -619,6 +619,8 @@ static void mvsd_set_ios(struct mmc_host *mmc, struct mmc_ios *ios)
|
||||
u32 m = DIV_ROUND_UP(host->base_clock, ios->clock) - 1;
|
||||
if (m > MVSD_BASE_DIV_MAX)
|
||||
m = MVSD_BASE_DIV_MAX;
|
||||
+ if(ios->clock==50000000 ) //by steven
|
||||
+ m=1;
|
||||
mvsd_write(MVSD_CLK_DIV, m);
|
||||
host->clock = ios->clock;
|
||||
host->ns_per_clk = 1000000000 / (host->base_clock / (m+1));
|
||||
--
|
||||
2.3.0
|
||||
|
|
@ -1,95 +0,0 @@
|
|||
From 5d0fb467e28aeff79590ddcbe69219f4fc2b8fdf Mon Sep 17 00:00:00 2001
|
||||
From: popcornmix <popcornmix@gmail.com>
|
||||
Date: Tue, 18 Feb 2014 01:43:50 -0300
|
||||
Subject: [PATCH 5/5] net/smsc95xx: Allow mac address to be set as a parameter
|
||||
|
||||
---
|
||||
drivers/net/usb/smsc95xx.c | 56 ++++++++++++++++++++++++++++++++++++++++++++++
|
||||
1 file changed, 56 insertions(+)
|
||||
|
||||
diff --git a/drivers/net/usb/smsc95xx.c b/drivers/net/usb/smsc95xx.c
|
||||
index 26423ad..e29a323 100644
|
||||
--- a/drivers/net/usb/smsc95xx.c
|
||||
+++ b/drivers/net/usb/smsc95xx.c
|
||||
@@ -59,6 +59,7 @@
|
||||
#define SUSPEND_SUSPEND3 (0x08)
|
||||
#define SUSPEND_ALLMODES (SUSPEND_SUSPEND0 | SUSPEND_SUSPEND1 | \
|
||||
SUSPEND_SUSPEND2 | SUSPEND_SUSPEND3)
|
||||
+#define MAC_ADDR_LEN (6)
|
||||
|
||||
struct smsc95xx_priv {
|
||||
u32 mac_cr;
|
||||
@@ -74,6 +75,10 @@ static bool turbo_mode = true;
|
||||
module_param(turbo_mode, bool, 0644);
|
||||
MODULE_PARM_DESC(turbo_mode, "Enable multiple frames per Rx transaction");
|
||||
|
||||
+static char *macaddr = ":";
|
||||
+module_param(macaddr, charp, 0);
|
||||
+MODULE_PARM_DESC(macaddr, "MAC address");
|
||||
+
|
||||
static int __must_check __smsc95xx_read_reg(struct usbnet *dev, u32 index,
|
||||
u32 *data, int in_pm)
|
||||
{
|
||||
@@ -763,8 +768,59 @@ static int smsc95xx_ioctl(struct net_device *netdev, struct ifreq *rq, int cmd)
|
||||
return generic_mii_ioctl(&dev->mii, if_mii(rq), cmd, NULL);
|
||||
}
|
||||
|
||||
+/* Check the macaddr module parameter for a MAC address */
|
||||
+static int smsc95xx_is_macaddr_param(struct usbnet *dev, u8 *dev_mac)
|
||||
+{
|
||||
+ int i, j, got_num, num;
|
||||
+ u8 mtbl[MAC_ADDR_LEN];
|
||||
+
|
||||
+ if (macaddr[0] == ':')
|
||||
+ return 0;
|
||||
+
|
||||
+ i = 0;
|
||||
+ j = 0;
|
||||
+ num = 0;
|
||||
+ got_num = 0;
|
||||
+ while (j < MAC_ADDR_LEN) {
|
||||
+ if (macaddr[i] && macaddr[i] != ':') {
|
||||
+ got_num++;
|
||||
+ if ('0' <= macaddr[i] && macaddr[i] <= '9')
|
||||
+ num = num * 16 + macaddr[i] - '0';
|
||||
+ else if ('A' <= macaddr[i] && macaddr[i] <= 'F')
|
||||
+ num = num * 16 + 10 + macaddr[i] - 'A';
|
||||
+ else if ('a' <= macaddr[i] && macaddr[i] <= 'f')
|
||||
+ num = num * 16 + 10 + macaddr[i] - 'a';
|
||||
+ else
|
||||
+ break;
|
||||
+ i++;
|
||||
+ } else if (got_num == 2) {
|
||||
+ mtbl[j++] = (u8) num;
|
||||
+ num = 0;
|
||||
+ got_num = 0;
|
||||
+ i++;
|
||||
+ } else {
|
||||
+ break;
|
||||
+ }
|
||||
+ }
|
||||
+
|
||||
+ if (j == MAC_ADDR_LEN) {
|
||||
+ netif_dbg(dev, ifup, dev->net, "Overriding MAC address with: "
|
||||
+ "%02x:%02x:%02x:%02x:%02x:%02x\n", mtbl[0], mtbl[1], mtbl[2],
|
||||
+ mtbl[3], mtbl[4], mtbl[5]);
|
||||
+ for (i = 0; i < MAC_ADDR_LEN; i++)
|
||||
+ dev_mac[i] = mtbl[i];
|
||||
+ return 1;
|
||||
+ } else {
|
||||
+ return 0;
|
||||
+ }
|
||||
+}
|
||||
+
|
||||
static void smsc95xx_init_mac_address(struct usbnet *dev)
|
||||
{
|
||||
+ /* Check module parameters */
|
||||
+ if (smsc95xx_is_macaddr_param(dev, dev->net->dev_addr))
|
||||
+ return;
|
||||
+
|
||||
/* try reading mac address from EEPROM */
|
||||
if (smsc95xx_read_eeprom(dev, EEPROM_MAC_OFFSET, ETH_ALEN,
|
||||
dev->net->dev_addr) == 0) {
|
||||
--
|
||||
2.3.0
|
||||
|
|
@ -7,8 +7,8 @@ buildarch=4
|
|||
pkgbase=linux-usbarmory
|
||||
_srcname=linux-3.19
|
||||
_kernelname=${pkgbase#linux}
|
||||
_desc="ARMv7 USB armory"
|
||||
pkgver=3.19.1
|
||||
_desc="USB armory"
|
||||
pkgver=3.19.2
|
||||
pkgrel=1
|
||||
rcnrel=armv7-x3
|
||||
arch=('armv7h')
|
||||
|
@ -17,41 +17,30 @@ license=('GPL2')
|
|||
makedepends=('xmlto' 'docbook-xsl' 'kmod' 'inetutils' 'bc' 'git' 'uboot-tools')
|
||||
options=('!strip')
|
||||
source=("http://www.kernel.org/pub/linux/kernel/v3.x/${_srcname}.tar.xz"
|
||||
#"http://www.kernel.org/pub/linux/kernel/v3.x/patch-${pkgver}.xz"
|
||||
"http://www.kernel.org/pub/linux/kernel/v3.x/patch-${pkgver}.xz"
|
||||
"http://rcn-ee.net/deb/sid-armhf/v${pkgver}-${rcnrel}/patch-${pkgver%.0}-${rcnrel}.diff.gz"
|
||||
"git://git.code.sf.net/p/aufs/aufs3-standalone#branch=aufs${pkgver%.*}"
|
||||
#"git://git.code.sf.net/p/aufs/aufs3-standalone#branch=aufs3.x-rcN"
|
||||
'0001-ARM-atags-add-support-for-Marvell-s-u-boot.patch'
|
||||
'0002-ARM-atags-fdt-retrieve-MAC-addresses-from-Marvell-bo.patch'
|
||||
'0003-SMILE-Plug-device-tree-file.patch'
|
||||
'0004-fix-mvsdio-eMMC-timing.patch'
|
||||
'0005-net-smsc95xx-Allow-mac-address-to-be-set-as-a-parame.patch'
|
||||
'0001-USB-armory-support.patch'
|
||||
'config')
|
||||
md5sums=('d3fc8316d4d4d04b65cbc2d70799e763'
|
||||
'0f085618a0d85d406320e8bbba7fbec1'
|
||||
'6f7128647a2fc0912958ac1cbf96a95a'
|
||||
'd06782a0fe457e026abe999bf1b62a6a'
|
||||
'SKIP'
|
||||
'98931609e0e5c0beb3dbaabfb669b872'
|
||||
'b7aa41223a0eff197ab905d9791e4ec4'
|
||||
'd71cd90ee737afc07708fae7e449d651'
|
||||
'950087add736d74afacd54bcfe8908d9'
|
||||
'd6ef79617d7e59e841f4f3d65501a6d8'
|
||||
'54a04c50b97515c057c8889a83a30974'
|
||||
'47604e349d7809f0c71f54de1ecb66df')
|
||||
|
||||
prepare() {
|
||||
cd "${srcdir}/${_srcname}"
|
||||
|
||||
# add upstream patch
|
||||
#git apply --whitespace=nowarn ../patch-${pkgver}
|
||||
git apply --whitespace=nowarn ../patch-${pkgver}
|
||||
|
||||
# RCN patch
|
||||
git apply ../patch-${pkgver%.0}-${rcnrel}.diff
|
||||
|
||||
# ALARM patches
|
||||
git apply ../0001-ARM-atags-add-support-for-Marvell-s-u-boot.patch
|
||||
git apply ../0002-ARM-atags-fdt-retrieve-MAC-addresses-from-Marvell-bo.patch
|
||||
git apply ../0003-SMILE-Plug-device-tree-file.patch
|
||||
git apply ../0004-fix-mvsdio-eMMC-timing.patch
|
||||
git apply ../0005-net-smsc95xx-Allow-mac-address-to-be-set-as-a-parame.patch
|
||||
git apply ../0001-USB-armory-support.patch
|
||||
|
||||
# AUFS patches
|
||||
cp -ru "${srcdir}/aufs3-standalone/Documentation" .
|
||||
|
@ -109,7 +98,6 @@ _package() {
|
|||
optdepends=('crda: to set the correct wireless channels of your country')
|
||||
provides=('kernel26' "linux=${pkgver}" 'aufs_friendly')
|
||||
conflicts=('linux')
|
||||
replaces=('linux-mvebu' 'linux-udoo')
|
||||
install=${pkgname}.install
|
||||
|
||||
cd "${srcdir}/${_srcname}"
|
||||
|
@ -124,7 +112,7 @@ _package() {
|
|||
mkdir -p "${pkgdir}"/{lib/modules,lib/firmware,boot/dtbs}
|
||||
make INSTALL_MOD_PATH="${pkgdir}" modules_install
|
||||
cp arch/$KARCH/boot/zImage "${pkgdir}/boot/zImage"
|
||||
cp arch/$KARCH/boot/dts/*.dtb "${pkgdir}/boot/dtbs"
|
||||
cp arch/$KARCH/boot/dts/imx53-usbarmory.dtb "${pkgdir}/boot/dtbs"
|
||||
|
||||
# set correct depmod command for install
|
||||
sed \
|
||||
|
@ -156,7 +144,6 @@ _package-headers() {
|
|||
pkgdesc="Header files and scripts for building modules for linux kernel - ${_desc}"
|
||||
provides=("linux-headers=${pkgver}")
|
||||
conflicts=('linux-headers')
|
||||
replaces=('linux-mvebu-headers')
|
||||
|
||||
install -dm755 "${pkgdir}/usr/lib/modules/${_kernver}"
|
||||
|
||||
|
|
|
@ -2,7 +2,7 @@
|
|||
# arg 2: the old package version
|
||||
|
||||
KERNEL_NAME=-usbarmory
|
||||
KERNEL_VERSION=3.14.0-1-ARCH
|
||||
KERNEL_VERSION=3.19.2-1-ARCH
|
||||
|
||||
post_install () {
|
||||
# updating module dependencies
|
||||
|
|
Loading…
Reference in a new issue