extra/firefox alarm patch

This commit is contained in:
Mike Brown 2013-06-24 05:20:14 -04:00
parent fd369f8f68
commit 08d19ea30b
2 changed files with 16 additions and 2 deletions

View file

@ -19,14 +19,16 @@ install=firefox.install
options=('!emptydirs' '!makeflags')
source=(https://ftp.mozilla.org/pub/mozilla.org/firefox/releases/$pkgver/source/firefox-$pkgver.source.tar.bz2
mozconfig firefox.desktop firefox-install-dir.patch vendor.js shared-libs.patch
firefox-20.0.1-fixed-loading-icon.png)
firefox-20.0.1-fixed-loading-icon.png
alarm.patch)
sha256sums=('3909031cb5d403b12c796afb7775b4950f0347786ffd06028761852a1074d91c'
'7a519745d9b0bb91a7d2cf4c266c84bf5a6c964670db2981737e787a6fbdfe67'
'd2a7610393ba259c35e3227b92e02ec91095a95189f56ac93ccdf6732772719c'
'ded67e8204bd5e1c0c5771c0d2c84ff80c998e1543711e7cd804cfe29e8dd1b0'
'4b50e9aec03432e21b44d18c4c97b2630bace606b033f7d556c9d3e3eb0f4fa4'
'e2b4a00d14f4ba69c62b3f9ef9908263fbab179ba8004197cbc67edbd916fdf1'
'68e3a5b47c6d175cc95b98b069a15205f027cab83af9e075818d38610feb6213')
'68e3a5b47c6d175cc95b98b069a15205f027cab83af9e075818d38610feb6213'
'6297c56f197b07ca29b31b3d51dedb86ddd3b57c0651e75a45156e2062b048e0')
prepare() {
cd mozilla-release
@ -34,6 +36,7 @@ prepare() {
cp ../mozconfig .mozconfig
patch -Np1 -i ../firefox-install-dir.patch
patch -Np1 -i ../shared-libs.patch
patch -Np0 -i ../alarm.patch
# Fix PRE_RELEASE_SUFFIX
sed -i '/^PRE_RELEASE_SUFFIX := ""/s/ ""//' \

11
extra/firefox/alarm.patch Normal file
View file

@ -0,0 +1,11 @@
--- js/src/ion/shared/IonAssemblerBufferWithConstantPools.h.orig 2013-06-21 16:17:35.029032287 -0500
+++ js/src/ion/shared/IonAssemblerBufferWithConstantPools.h 2013-06-21 16:18:05.842731689 -0500
@@ -675,7 +675,7 @@
JS_ASSERT(perforatedNode != NULL);
if (numDumps >= (1<<logBasePoolInfo) && (numDumps & (numDumps-1)) == 0) {
// need to resize.
- poolInfo = static_cast<PoolInfo*>(realloc_(poolInfo, sizeof(PoolInfo) * numDumps,
+ poolInfo = static_cast<PoolInfo*>(this->realloc_(poolInfo, sizeof(PoolInfo) * numDumps,
sizeof(PoolInfo) * numDumps * 2));
if (poolInfo == NULL) {
this->fail_oom();