core/linux-kirkwood-dt to 3.18.6-1; add Pogoplug V4 support

This commit is contained in:
moonman 2015-02-08 00:03:01 +00:00
parent 517eb3a8bc
commit 08e9110511
2 changed files with 185 additions and 5 deletions

View file

@ -6,7 +6,7 @@ buildarch=2
pkgbase=linux-kirkwood-dt
_kernelname=${pkgbase#linux}
_desc="Marvell Kirkwood DT"
pkgver=3.18.5
pkgver=3.18.6
pkgrel=1
cryptodev_commit=6aa62a2c320b04f55fdfe0ed015c3d9b48997239
bfqver=v7r7
@ -25,14 +25,15 @@ source=("ftp://ftp.kernel.org/pub/linux/kernel/v3.x/linux-${pkgver}.tar.xz"
# "git://git.code.sf.net/p/aufs/aufs3-standalone#branch=aufs3.x-rcN"
"git://git.code.sf.net/p/aufs/aufs3-standalone#branch=aufs${pkgver:0:4}.1+"
"cryptodev.tar.gz::https://github.com/cryptodev-linux/cryptodev-linux/archive/${cryptodev_commit}.tar.gz"
"http://algo.ing.unimo.it/people/paolo/disk_sched/patches/${pkgver:0:4}.0-${bfqver}/0001-block-cgroups-kconfig-build-bits-for-BFQ-${bfqver}-${pkgver:0:4}.patch"
"http://algo.ing.unimo.it/people/paolo/disk_sched/patches/${pkgver:0:4}.0-${bfqver}/0002-block-introduce-the-BFQ-${bfqver}-I-O-sched-for-${pkgver:0:4}.patch"
"http://algo.ing.unimo.it/people/paolo/disk_sched/patches/${pkgver:0:4}.0-${bfqver}/0003-block-bfq-add-Early-Queue-Merge-EQM-to-BFQ-${bfqver}-for-${pkgver:0:4}.0.patch"
"ftp://teambelgium.net/bfq/patches/${pkgver:0:4}.0-${bfqver}/0001-block-cgroups-kconfig-build-bits-for-BFQ-${bfqver}-${pkgver:0:4}.patch"
"ftp://teambelgium.net/bfq/patches/${pkgver:0:4}.0-${bfqver}/0002-block-introduce-the-BFQ-${bfqver}-I-O-sched-for-${pkgver:0:4}.patch"
"ftp://teambelgium.net/bfq/patches/${pkgver:0:4}.0-${bfqver}/0003-block-bfq-add-Early-Queue-Merge-EQM-to-BFQ-${bfqver}-for-${pkgver:0:4}.0.patch"
'goflexhome_dtb.patch'
'pogo_e02_dtb.patch'
'pogoplugv4_dtb.patch'
'mvsdio_TX-DMA_workaround.patch')
md5sums=('b655fcbc4597aa4b0cbabcfc72983259'
md5sums=('997c8492ebfdc9bb9e6ed8d4945539dd'
'5dbb04ebed1afb6d2e1408598cd34ad7'
'e319a8e1a596a39a8951fc6454664b15'
'9b5a265440abf57d2052838f31486a3a'
@ -44,6 +45,7 @@ md5sums=('b655fcbc4597aa4b0cbabcfc72983259'
'8f2743651280f5a022e541f4e95e5546'
'e42c64b6f4b54f382cf3d7e8d82968f1'
'341f8164dad19b6baf05d764a800862a'
'f6d3cdb34455475d0bc70fbf3061023b'
'fd50ede1d3bfdd4b00a3c830ebf2db0d')
prepare() {
@ -74,6 +76,7 @@ msg2 "Add Arch Linux ARM patch for ARMv5te plug computers"
patch -Np1 -i "${srcdir}/archlinuxarm.patch"
patch -Np1 -i "${srcdir}/goflexhome_dtb.patch"
patch -Np1 -i "${srcdir}/pogo_e02_dtb.patch"
patch -Np1 -i "${srcdir}/pogoplugv4_dtb.patch"
msg2 "Add BFQ patches"
patch -Np1 -i "${srcdir}/0001-block-cgroups-kconfig-build-bits-for-BFQ-${bfqver}-${pkgver:0:4}.patch"

View file

@ -0,0 +1,177 @@
--- a/arch/arm/boot/dts/Makefile
+++ b/arch/arm/boot/dts/Makefile
@@ -114,6 +114,7 @@
kirkwood-openrd-client.dtb \
kirkwood-openrd-ultimate.dtb \
kirkwood-pogo_e02.dtb \
+ kirkwood-pogoplugv4.dtb \
kirkwood-rd88f6192.dtb \
kirkwood-rd88f6281-z0.dtb \
kirkwood-rd88f6281-a.dtb \
--- /dev/null
+++ b/arch/arm/boot/dts/kirkwood-pogoplugv4.dts
@@ -0,0 +1,162 @@
+/dts-v1/;
+
+#include "kirkwood.dtsi"
+#include "kirkwood-6281.dtsi"
+
+/ {
+ model = "CloudEngines Pogoplug V4";
+ compatible = "cloudengines,pogoplugv4", "marvell,kirkwood-88f6192", "marvell,kirkwood";
+
+ memory {
+ device_type = "memory";
+ reg = <0x00000000 0x8000000>;
+ };
+
+ chosen {
+ bootargs = "console=ttyS0,115200 earlyprintk root=/dev/mmcblk0p1 rootdelay=10";
+ stdout-path = &uart0;
+ };
+
+ mbus {
+ pcie-controller {
+ status = "okay";
+
+ pcie@1,0 {
+ status = "okay";
+ };
+ };
+ };
+
+ ocp@f1000000 {
+ pinctrl: pin-controller@10000 {
+ pmx_led_green: pmx-led-green {
+ marvell,pins = "mpp22";
+ marvell,function = "gpio";
+ };
+ pmx_led_red: pmx-led-red {
+ marvell,pins = "mpp24";
+ marvell,function = "gpio";
+ };
+ pmx_sdio_cd: pmx-sdio-cd {
+ marvell,pins = "mpp27";
+ marvell,function = "gpio";
+ };
+ pmx_sdio_wp: pmx-sdio-wp {
+ marvell,pins = "mpp28";
+ marvell,function = "gpio";
+ };
+ pmx_button_eject: pmx-button-eject {
+ marvell,pins = "mpp29";
+ marvell,function = "gpio";
+ };
+ };
+
+ spi@10600 {
+ status = "okay";
+
+ m25p05@0 {
+ compatible = "m25p05-nonjedec";
+ reg = <0>;
+ spi-max-frequency = <20000000>;
+ mode = <0>;
+ };
+ };
+
+ serial@12000 {
+ status = "ok";
+ };
+
+ sata@80000 {
+ status = "okay";
+ nr-ports = <1>;
+ };
+
+ i2c0: i2c@11000 {
+ status = "ok";
+ };
+
+ mvsdio@90000 {
+ pinctrl-0 = <&pmx_sdio &pmx_sdio_cd &pmx_sdio_wp>;
+ pinctrl-names = "default";
+ status = "okay";
+ cd-gpios = <&gpio0 27 1>;
+ wp-gpios = <&gpio0 28 1>;
+ };
+ };
+
+ gpio-leds {
+ compatible = "gpio-leds";
+ pinctrl-0 = <&pmx_led_green &pmx_led_red>;
+ pinctrl-names = "default";
+ health {
+ label = "status:green:health";
+ gpios = <&gpio0 22 1>;
+ linux,default-trigger = "default-on";
+ };
+ fault {
+ label = "status:red:fault";
+ gpios = <&gpio0 24 1>;
+ linux,default-trigger = "none";
+ };
+ };
+
+ gpio_keys {
+ compatible = "gpio-keys";
+ #address-cells = <1>;
+ #size-cells = <0>;
+ pinctrl-0 = <&pmx_button_eject>;
+ pinctrl-names = "default";
+
+ button@1 {
+ label = "Eject Button";
+ linux,code = <KEY_EJECTCD>;
+ gpios = <&gpio0 29 1>;
+ };
+ };
+};
+
+&mdio {
+ status = "okay";
+
+ ethphy0: ethernet-phy@0 {
+ device_type = "ethernet-phy";
+ reg = <0>;
+ };
+};
+
+&eth0 {
+ status = "okay";
+ ethernet0-port@0 {
+ phy-handle = <&ethphy0>;
+ };
+};
+
+&nand {
+ status = "okay";
+
+ partition@0 {
+ label = "u-boot";
+ reg = <0x0000000 0x200000>;
+ read-only;
+ };
+
+ partition@200000 {
+ label = "uImage";
+ reg = <0x200000 0x300000>;
+ };
+
+ partition@500000 {
+ label = "uImage2";
+ reg = <0x500000 0x300000>;
+ };
+
+ partition@800000 {
+ label = "failsafe";
+ reg = <0x800000 0x800000>;
+ };
+
+ partition@2500000 {
+ label = "root";
+ reg = <0x1000000 0x7000000>;
+ };
+};