alarm/uboot-pandaboard to 2016.11-1

This commit is contained in:
Kevin Mihelich 2016-11-21 01:14:06 +00:00
parent dc602d309e
commit 08f89e66af
2 changed files with 19 additions and 24 deletions

View file

@ -1,20 +1,20 @@
From cc11d426638760d4a5c7ff2fca3a4e54a423c5d4 Mon Sep 17 00:00:00 2001
From 8c0c87b338851e3085951b5be47f9ffd96dbac71 Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Wed, 16 Mar 2016 20:06:42 -0600
Subject: [PATCH] arch linux arm modifications
---
configs/omap4_panda_defconfig | 5 ++++-
include/configs/ti_omap4_common.h | 7 ++++---
2 files changed, 8 insertions(+), 4 deletions(-)
configs/omap4_panda_defconfig | 6 +++++-
include/configs/ti_omap4_common.h | 5 ++---
2 files changed, 7 insertions(+), 4 deletions(-)
diff --git a/configs/omap4_panda_defconfig b/configs/omap4_panda_defconfig
index b69124e..a803236 100644
index a5fbf9a..6a2da38 100644
--- a/configs/omap4_panda_defconfig
+++ b/configs/omap4_panda_defconfig
@@ -4,6 +4,10 @@ CONFIG_TARGET_OMAP4_PANDA=y
@@ -10,6 +10,10 @@ CONFIG_VERSION_VARIABLE=y
CONFIG_SPL=y
CONFIG_VERSION_VARIABLE=y
CONFIG_SPL_OS_BOOT=y
CONFIG_HUSH_PARSER=y
+CONFIG_AUTOBOOT_KEYED=y
+CONFIG_AUTOBOOT_PROMPT="Press SPACE to abort autoboot in %d seconds\n"
@ -23,7 +23,7 @@ index b69124e..a803236 100644
CONFIG_CMD_BOOTZ=y
# CONFIG_CMD_IMLS is not set
CONFIG_CMD_ASKENV=y
@@ -20,7 +24,6 @@ CONFIG_CMD_MII=y
@@ -26,10 +30,10 @@ CONFIG_CMD_MII=y
CONFIG_CMD_PING=y
CONFIG_CMD_EXT2=y
CONFIG_CMD_EXT4=y
@ -31,20 +31,15 @@ index b69124e..a803236 100644
CONFIG_CMD_FAT=y
CONFIG_CMD_FS_GENERIC=y
CONFIG_SYS_NS16550=y
CONFIG_USB=y
CONFIG_USB_STORAGE=y
CONFIG_OF_LIBFDT=y
+CONFIG_IDENT_STRING=" Arch Linux ARM"
diff --git a/include/configs/ti_omap4_common.h b/include/configs/ti_omap4_common.h
index 8c88ebf..3e8ceaf 100644
index 3d2992f..a1dd6e1 100644
--- a/include/configs/ti_omap4_common.h
+++ b/include/configs/ti_omap4_common.h
@@ -12,6 +12,8 @@
#ifndef __CONFIG_TI_OMAP4_COMMON_H
#define __CONFIG_TI_OMAP4_COMMON_H
+#define CONFIG_IDENT_STRING " Arch Linux ARM"
+
/*
* High Level Configuration Options
*/
@@ -44,7 +46,7 @@
@@ -42,7 +42,7 @@
* the timings to use or use pre-determined timings (based on using the
* dynamic method. Default to the static timing infomation.
*/
@ -53,7 +48,7 @@ index 8c88ebf..3e8ceaf 100644
#ifndef CONFIG_SYS_EMIF_PRECALCULATED_TIMING_REGS
#define CONFIG_SYS_AUTOMATIC_SDRAM_DETECTION
#define CONFIG_SYS_DEFAULT_LPDDR2_TIMINGS
@@ -94,9 +96,8 @@
@@ -91,9 +91,8 @@
#define BOOT_TARGET_DEVICES(func) \
func(MMC, mmc, 0) \
@ -65,5 +60,5 @@ index 8c88ebf..3e8ceaf 100644
func(DHCP, dhcp, na)
--
2.10.0
2.10.2

View file

@ -4,7 +4,7 @@
buildarch=4
pkgname=uboot-pandaboard
pkgver=2016.09
pkgver=2016.11
pkgrel=1
pkgdesc="U-Boot for Pandaboard and Pandaboard ES"
arch=('armv7h')
@ -17,8 +17,8 @@ source=("ftp://ftp.denx.de/pub/u-boot/u-boot-${pkgver/rc/-rc}.tar.bz2"
'0001-arch-linux-arm-modifications.patch'
'boot.txt'
'mkscr')
md5sums=('2e69dda70eb28f8042d2f9fbeb1feaa1'
'81dbf874550beb4ebdf3c50508319668'
md5sums=('ca1f6e019d08aff8d0ca1beb2e66737d'
'97e6355ce22648559fdcf61a99a8a5cf'
'4908cf55626f1109276f14111b11117d'
'021623a04afd29ac3f368977140cfbfd')