mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-02-16 23:57:11 +00:00
core/linux-raspberrypi to 3.10.26
This commit is contained in:
parent
854a9fd89d
commit
0903bd0f33
2 changed files with 55 additions and 6 deletions
|
@ -4,12 +4,12 @@
|
|||
buildarch=18
|
||||
|
||||
pkgbase=linux-raspberrypi
|
||||
_commit=dee3db1c55e9a1c2efce858f44d9810cc2392b18
|
||||
_commit=5df7f220748c30d012f5dd5036c243a10ebe299f
|
||||
_srcname=linux-${_commit}
|
||||
_kernelname=${pkgbase#linux}
|
||||
_desc="Raspberry Pi"
|
||||
pkgver=3.10.25
|
||||
pkgrel=2
|
||||
pkgver=3.10.26
|
||||
pkgrel=1
|
||||
arch=('arm armv6h')
|
||||
url="http://www.kernel.org/"
|
||||
license=('GPL2')
|
||||
|
@ -22,17 +22,28 @@ source=("https://github.com/raspberrypi/linux/archive/${_commit}.tar.gz"
|
|||
'boot-uncompressed.txt'
|
||||
'imagetool-uncompressed.py'
|
||||
"git://git.code.sf.net/p/aufs/aufs3-standalone#branch=aufs${pkgver%.*}"
|
||||
'rasclockPCF2127.patch::http://git.kernel.org/cgit/linux/kernel/git/stable/linux-stable.git/patch/?id=18cb6368f0b0fc6a28bd49ee547b4f655db97fc3')
|
||||
md5sums=('cd52594afe95535dd6bac4f6a7a60b20'
|
||||
'rasclockPCF2127.patch::http://git.kernel.org/cgit/linux/kernel/git/stable/linux-stable.git/patch/?id=18cb6368f0b0fc6a28bd49ee547b4f655db97fc3'
|
||||
'aufs-sources-3.10.26-mmap-aufs3.patch')
|
||||
|
||||
|
||||
md5sums=('5fc82e48381e967da7e417c43a1f8e35'
|
||||
'32fd2a88136c75e11ef0d593acd8aeaa'
|
||||
'9d3c56a4b999c8bfbd4018089a62f662'
|
||||
'9335d1263fd426215db69841a380ea26'
|
||||
'a00e424e2fbb8c5a5f77ba2c4871bed4'
|
||||
'2f82dbe5752af65ff409d737caf11954'
|
||||
'SKIP'
|
||||
'fc75790fbb31312459770c682113c5bc')
|
||||
'fc75790fbb31312459770c682113c5bc'
|
||||
'8af486c1597a93f3523dcd628de9288a')
|
||||
|
||||
prepare() {
|
||||
|
||||
#Remove after this fix is in the tree
|
||||
cd "${srcdir}/aufs3-standalone"
|
||||
patch -p1 -i ../aufs-sources-3.10.26-mmap-aufs3.patch
|
||||
#Evomer
|
||||
|
||||
|
||||
cd "${srcdir}/${_srcname}"
|
||||
|
||||
# Set DEFAULT_CONSOLE_LOGLEVEL to 4 (same value as the 'quiet' kernel param)
|
||||
|
|
38
core/linux-raspberrypi/aufs-sources-3.10.26-mmap-aufs3.patch
Normal file
38
core/linux-raspberrypi/aufs-sources-3.10.26-mmap-aufs3.patch
Normal file
|
@ -0,0 +1,38 @@
|
|||
aufs3-mmap.patch | 17 ++++++-----------
|
||||
1 file changed, 6 insertions(+), 11 deletions(-)
|
||||
|
||||
diff --git a/aufs3-mmap.patch b/aufs3-mmap.patch
|
||||
index 398253b..d9b413c 100644
|
||||
--- a/aufs3-mmap.patch
|
||||
+++ b/aufs3-mmap.patch
|
||||
@@ -215,24 +215,19 @@ index 7905fe7..94cc777 100644
|
||||
if (page->mapping != inode->i_mapping) {
|
||||
unlock_page(page);
|
||||
diff --git a/mm/fremap.c b/mm/fremap.c
|
||||
-index 87da359..92bb6f2 100644
|
||||
+index bbc4d66..7deee2c 100644
|
||||
--- a/mm/fremap.c
|
||||
+++ b/mm/fremap.c
|
||||
-@@ -202,11 +202,12 @@ get_write_lock:
|
||||
- */
|
||||
- if (mapping_cap_account_dirty(mapping)) {
|
||||
- unsigned long addr;
|
||||
-- struct file *file = get_file(vma->vm_file);
|
||||
-+ struct file *file = vma->vm_file;
|
||||
+@@ -211,7 +211,9 @@ get_write_lock:
|
||||
+ /* mmap_region may free vma; grab the info now */
|
||||
+ vm_flags = vma->vm_flags;
|
||||
|
||||
+ vma_get_file(vma);
|
||||
- addr = mmap_region(file, start, size,
|
||||
- vma->vm_flags, pgoff);
|
||||
-- fput(file);
|
||||
+ addr = mmap_region(file, start, size, vm_flags, pgoff);
|
||||
+ vma_fput(vma);
|
||||
+ fput(file);
|
||||
if (IS_ERR_VALUE(addr)) {
|
||||
err = addr;
|
||||
- } else {
|
||||
diff --git a/mm/madvise.c b/mm/madvise.c
|
||||
index 7055883..e6b768d 100644
|
||||
--- a/mm/madvise.c
|
Loading…
Reference in a new issue