mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-03-09 00:17:31 +00:00
extra/thunderbird to 52.1.0-1
This commit is contained in:
parent
e63bc92277
commit
094b70dc96
2 changed files with 56 additions and 3 deletions
|
@ -0,0 +1,48 @@
|
|||
From bbd48a5613c872883616884cfaf41665b0e4ec9b Mon Sep 17 00:00:00 2001
|
||||
From: Ralph Giles <giles@mozilla.com>
|
||||
Date: Fri, 10 Feb 2017 12:58:18 -0800
|
||||
Subject: [PATCH] Bug 1338655 - Don't try to build mp4parse bindings. r=froydnj
|
||||
|
||||
We use the cheddar crate to generate a C header file
|
||||
for our mp4parse_capi wrapper crate. Currently we
|
||||
do this at code check-in time via update-rust.sh.
|
||||
|
||||
Cargo 0.18 and later will try to execute a build.rs
|
||||
file in the crate source tree regardless of whether
|
||||
it's specified in Cargo.toml so patching out that
|
||||
line just results in 'crate cheddar not found'.
|
||||
|
||||
This change restores the old behaviour by substituting
|
||||
a 'build = false' line instead.
|
||||
|
||||
We do have syntex vendored, but we don't currently build
|
||||
it by default, so I prefer this solution to just vendoring
|
||||
cheddar and generating the header at build time. The syntex
|
||||
crate is quite large and adds significantly to our compile
|
||||
time.
|
||||
|
||||
MozReview-Commit-ID: InJRRODWAdP
|
||||
|
||||
--HG--
|
||||
extra : rebase_source : 29378fcbc86015ce6cc22dc66d38a43ddbac204e
|
||||
---
|
||||
media/libstagefright/binding/mp4parse-cargo.patch | 5 +++--
|
||||
media/libstagefright/binding/mp4parse_capi/Cargo.toml | 2 ++
|
||||
2 files changed, 5 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/media/libstagefright/binding/mp4parse_capi/Cargo.toml b/media/libstagefright/binding/mp4parse_capi/Cargo.toml
|
||||
index aee7ee947151a27c..d7e3f55119d3f4b6 100644
|
||||
--- a/media/libstagefright/binding/mp4parse_capi/Cargo.toml
|
||||
+++ b/media/libstagefright/binding/mp4parse_capi/Cargo.toml
|
||||
@@ -18,6 +18,8 @@ exclude = [
|
||||
"*.mp4",
|
||||
]
|
||||
|
||||
+build = false
|
||||
+
|
||||
[dependencies]
|
||||
byteorder = "1.0.0"
|
||||
"mp4parse" = {version = "0.6.0", path = "../mp4parse"}
|
||||
--
|
||||
2.12.2
|
||||
|
|
@ -13,8 +13,8 @@ buildarch=12
|
|||
highmem=1
|
||||
|
||||
pkgname=thunderbird
|
||||
pkgver=52.0.1
|
||||
pkgrel=2
|
||||
pkgver=52.1.0
|
||||
pkgrel=1
|
||||
pkgdesc="Standalone mail and news reader from mozilla.org"
|
||||
arch=(i686 x86_64)
|
||||
license=(MPL GPL LGPL)
|
||||
|
@ -27,9 +27,11 @@ optdepends=('libcanberra: sound support')
|
|||
options=(!emptydirs !makeflags)
|
||||
source=(https://ftp.mozilla.org/pub/mozilla.org/thunderbird/releases/$pkgver/source/thunderbird-$pkgver.source.tar.xz
|
||||
thunderbird.desktop
|
||||
0001-Bug-1338655-Don-t-try-to-build-mp4parse-bindings.-r-.patch
|
||||
thunderbird-install-dir.patch rust-i686.patch fix-wifi-scanner.diff)
|
||||
sha256sums=('a1cede97e836c728d3157b9e043f3724f7aff83f92ba1f3796e9cc7299402cab'
|
||||
sha256sums=('c33ca35b6acd1a0dc0d0f4b1df16745a33144c5d3d3715fe05454a5e9eefd48b'
|
||||
'e44c55501f650a4e80b9c353b81f33e07ca65808db831eff6ca616aded233827'
|
||||
'413cd6d366d78f325d80ebebccfd0afa0d266b40b2e54b66ba2fa03c15f3ea67'
|
||||
'24599eab8862476744fe1619a9a53a5b8cdcab30b3fc5767512f31d3529bd05d'
|
||||
'f61ea706ce6905f568b9bdafd1b044b58f20737426f0aa5019ddb9b64031a269'
|
||||
'9765bca5d63fb5525bbd0520b7ab1d27cabaed697e2fc7791400abc3fa4f13b8')
|
||||
|
@ -59,6 +61,9 @@ prepare() {
|
|||
# Build with the rust targets we actually ship
|
||||
patch -d mozilla -Np1 < ../rust-i686.patch
|
||||
|
||||
# https://bugs.archlinux.org/task/53890
|
||||
patch -d mozilla -Np1 < ../0001-Bug-1338655-Don-t-try-to-build-mp4parse-bindings.-r-.patch
|
||||
|
||||
echo -n "$_google_api_key" >google-api-key
|
||||
echo -n "$_mozilla_api_key" >mozilla-api-key
|
||||
|
||||
|
|
Loading…
Reference in a new issue