core/openssl-cryptodev to 1.1.1.j-1

This commit is contained in:
moonman 2021-03-19 19:46:08 -06:00
parent 7dafd9bce5
commit 095d0d7e91
2 changed files with 20 additions and 15 deletions

View file

@ -9,7 +9,7 @@ buildarch=14
pkgname=openssl-cryptodev
_pkgname=openssl
_ver=1.1.1h
_ver=1.1.1j
# use a pacman compatible version scheme
pkgver=${_ver/[a-z]/.${_ver//[0-9.]/}}
pkgrel=1
@ -17,19 +17,20 @@ pkgdesc='The Open Source toolkit for Secure Sockets Layer and Transport Layer Se
arch=('arm' 'armv7h' 'aarch64')
url='https://www.openssl.org'
license=('custom:BSD')
depends=('perl')
optdepends=('ca-certificates')
depends=('glibc')
makedepends=('perl')
optdepends=('ca-certificates' 'perl')
backup=('etc/ssl/openssl.cnf')
conflicts=('openssl')
provides=("openssl=${pkgver}")
_cryptodevver=1.11
_cryptodevver=1.12
source=("https://www.openssl.org/source/${_pkgname}-${_ver}.tar.gz"
'ca-dir.patch'
"https://github.com/cryptodev-linux/cryptodev-linux/archive/cryptodev-linux-${_cryptodevver}.tar.gz")
sha256sums=('5c9ca8774bd7b03e5784f26ae9e9e6d749c9da2438545077e6b3d755a06595d9'
'0938c8d68110768db4f350a7ec641070686904f2fe7ba630ac94399d7dc8cc5e'
'd71fd8dafc40147586f5bc6acca8fce5088d9c576d1142fe5aeb7b0813186a11')
sha256sums=('aaf2fcb575cdf6491b98ab4829abf78a3dec8402b8b81efc8f23c00d443981bf'
'75aa8c2c638c8a3ebfd9fa146fc61c7ff878fc997dc6aa10d39e4b2415d669b2'
'f51c2254749233b1b1d7ec9445158bd709f124f88e1c650fe2faac83c3a81938')
prepare() {
cd "$srcdir/$_pkgname-$_ver"
@ -74,7 +75,9 @@ check() {
# the test fails due to missing write permissions in /etc/ssl
# revert this patch for make test
patch -p0 -R -i "$srcdir/ca-dir.patch"
make test
patch -p0 -i "$srcdir/ca-dir.patch"
# re-run make to re-generate CA.pl from th patched .in file.
make apps/CA.pl
@ -82,6 +85,8 @@ check() {
package() {
cd "$srcdir/$_pkgname-$_ver"
make DESTDIR=$pkgdir MANDIR=/usr/share/man MANSUFFIX=ssl install_sw install_ssldirs install_man_docs
install -D -m644 LICENSE $pkgdir/usr/share/licenses/$_pkgname/LICENSE
make DESTDIR="$pkgdir" MANDIR=/usr/share/man MANSUFFIX=ssl install_sw install_ssldirs install_man_docs
install -D -m644 LICENSE "$pkgdir/usr/share/licenses/$_pkgname/LICENSE"
}

View file

@ -1,5 +1,5 @@
--- apps/CA.pl.in 2018-09-11 14:48:19.000000000 +0200
+++ apps/CA.pl.in 2018-09-11 16:16:32.125629435 +0200
--- apps/CA.pl.in 2019-09-10 15:13:07.000000000 +0200
+++ apps/CA.pl.in 2019-10-06 09:34:23.960864556 +0200
@@ -33,7 +33,7 @@
my $PKCS12 = "$openssl pkcs12";
@ -9,9 +9,9 @@
my $CAKEY = "cakey.pem";
my $CAREQ = "careq.pem";
my $CACERT = "cacert.pem";
--- apps/openssl.cnf 2018-09-11 14:48:20.000000000 +0200
+++ apps/openssl.cnf 2018-09-11 16:16:32.125629435 +0200
@@ -43,7 +43,7 @@
--- apps/openssl.cnf 2019-09-10 15:13:07.000000000 +0200
+++ apps/openssl.cnf 2019-10-06 09:34:23.960864556 +0200
@@ -42,7 +42,7 @@
####################################################################
[ CA_default ]
@ -20,7 +20,7 @@
certs = $dir/certs # Where the issued certs are kept
crl_dir = $dir/crl # Where the issued crl are kept
database = $dir/index.txt # database index file.
@@ -327,7 +327,7 @@
@@ -325,7 +325,7 @@
[ tsa_config1 ]
# These are used by the TSA reply generation only.