alarm/omxplayer-git fixes

This commit is contained in:
Kevin Mihelich 2014-09-24 14:53:51 +00:00
parent 18b685e3c0
commit 09b0ba5aa6
3 changed files with 56 additions and 13 deletions

View file

@ -1,7 +1,18 @@
diff -urN a/Makefile b/Makefile
--- a/Makefile 2014-08-10 15:20:40.333620698 -0600
+++ b/Makefile 2014-08-10 16:00:28.275387482 -0600
@@ -2,9 +2,9 @@
From cb18af829d01cbd89b2bb8785ee86f29b8659959 Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Wed, 24 Sep 2014 08:47:14 -0600
Subject: [PATCH 1/2] alarm fixes
---
Makefile | 30 ++++++++++--------------------
Makefile.include | 44 ++++----------------------------------------
2 files changed, 14 insertions(+), 60 deletions(-)
diff --git a/Makefile b/Makefile
index 3615ff7..47d196b 100644
--- a/Makefile
+++ b/Makefile
@@ -2,9 +2,9 @@ include Makefile.include
CFLAGS+=-std=c++0x -D__STDC_CONSTANT_MACROS -D__STDC_LIMIT_MACROS -DTARGET_POSIX -DTARGET_LINUX -fPIC -DPIC -D_REENTRANT -D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64 -DHAVE_CMAKE_CONFIG -D__VIDEOCORE4__ -U_FORTIFY_SOURCE -Wall -DHAVE_OMXLIB -DUSE_EXTERNAL_FFMPEG -DHAVE_LIBAVCODEC_AVCODEC_H -DHAVE_LIBAVUTIL_OPT_H -DHAVE_LIBAVUTIL_MEM_H -DHAVE_LIBAVUTIL_AVUTIL_H -DHAVE_LIBAVFORMAT_AVFORMAT_H -DHAVE_LIBAVFILTER_AVFILTER_H -DHAVE_LIBSWRESAMPLE_SWRESAMPLE_H -DOMX -DOMX_SKIP64BIT -ftree-vectorize -DUSE_EXTERNAL_OMX -DTARGET_RASPBERRY_PI -DUSE_EXTERNAL_LIBBCM_HOST
@ -13,7 +24,7 @@ diff -urN a/Makefile b/Makefile
DIST ?= omxplayer-dist
@@ -39,7 +39,7 @@
@@ -39,7 +39,7 @@ SRC=linux/XMemUtils.cpp \
OBJS+=$(filter %.o,$(SRC:.cpp=.o))
@ -22,7 +33,7 @@ diff -urN a/Makefile b/Makefile
%.o: %.cpp
@rm -f $@
@@ -51,7 +51,7 @@
@@ -51,7 +51,7 @@ version:
bash gen_version.sh > version.h
omxplayer.bin: version $(OBJS)
@ -31,7 +42,7 @@ diff -urN a/Makefile b/Makefile
$(STRIP) omxplayer.bin
help.h: README.md Makefile
@@ -74,19 +74,9 @@
@@ -74,19 +74,9 @@ clean:
@rm -rf $(DIST)
@rm -f omxplayer-dist.tar.gz
@ -57,9 +68,10 @@ diff -urN a/Makefile b/Makefile
+ install omxplayer $(DESTDIR)/usr/bin/
+ install omxplayer.bin $(DESTDIR)/usr/bin/
+ install README.md COPYING $(DESTDIR)/usr/share/doc/omxplayer/
diff -urN a/Makefile.include b/Makefile.include
--- a/Makefile.include 2014-08-10 15:20:40.333620698 -0600
+++ b/Makefile.include 2014-08-10 16:03:26.779799178 -0600
diff --git a/Makefile.include b/Makefile.include
index 58e9560..4789f10 100644
--- a/Makefile.include
+++ b/Makefile.include
@@ -1,40 +1,4 @@
-USE_BUILDROOT=0
-FLOAT=hard
@ -105,3 +117,6 @@ diff -urN a/Makefile.include b/Makefile.include
+CFLAGS += -fomit-frame-pointer -mabi=aapcs-linux -mtune=arm1176jzf-s -Wno-psabi -mno-apcs-stack-check -g -mstructure-size-boundary=32 -mno-sched-prolog
+LDFLAGS += -L/opt/vc/lib/
+INCLUDES += -I/opt/vc/include -I/opt/vc/include/interface/vmcs_host/linux -I/opt/vc/include/interface/vcos/pthreads -I/usr/include/freetype2 -I/usr/include/dbus-1.0 -I/usr/lib/dbus-1.0/include
--
2.1.0

View file

@ -0,0 +1,25 @@
From 0cc831816f5b242e0ad139d363685149b6464091 Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Wed, 24 Sep 2014 08:47:43 -0600
Subject: [PATCH 2/2] ffmpeg 2.4 fix
---
DllAvFilter.h | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/DllAvFilter.h b/DllAvFilter.h
index 8149274..313e078 100644
--- a/DllAvFilter.h
+++ b/DllAvFilter.h
@@ -124,7 +124,7 @@ public:
}
virtual int avfilter_graph_parse(AVFilterGraph *graph, const char *filters, AVFilterInOut **inputs, AVFilterInOut **outputs, void *log_ctx)
{
- return ::avfilter_graph_parse(graph, filters, inputs, outputs, log_ctx);
+ return ::avfilter_graph_parse(graph, filters, *inputs, *outputs, log_ctx);
}
virtual int avfilter_graph_config(AVFilterGraph *graphctx, void *log_ctx)
{
--
2.1.0

View file

@ -17,9 +17,11 @@ optdepends=('ttf-freefont')
provides=(omxplayer)
conflicts=('omxplayer' 'omxplayer-bin')
source=('git://github.com/popcornmix/omxplayer.git'
'alarm.patch')
'0001-alarm-fixes.patch'
'0002-ffmpeg-2.4-fix.patch')
md5sums=('SKIP'
'4f21babb3985e7e029a799383938f8ce')
'825bb619d32a3ba9f8aff81fa329d87e'
'c80b6c4578dd6a48b7d5bd0da650843e')
pkgver() {
cd omxplayer
@ -29,7 +31,8 @@ pkgver() {
prepare() {
cd "${srcdir}/omxplayer"
patch -p1 -i ../alarm.patch
git apply ../0001-alarm-fixes.patch
git apply ../0002-ffmpeg-2.4-fix.patch
sed 's|truetype/freefont|TTF|g' -i omxplayer.cpp
}