mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-28 22:57:37 +00:00
extra/firefox: fixes
This commit is contained in:
parent
6df8bfed6c
commit
09c7fa0dc1
3 changed files with 43 additions and 2 deletions
|
@ -9,7 +9,6 @@
|
||||||
|
|
||||||
buildarch=12
|
buildarch=12
|
||||||
highmem=1
|
highmem=1
|
||||||
noautobuild=1
|
|
||||||
|
|
||||||
pkgname=firefox
|
pkgname=firefox
|
||||||
pkgver=66.0
|
pkgver=66.0
|
||||||
|
@ -31,9 +30,13 @@ optdepends=('networkmanager: Location detection via available WiFi networks'
|
||||||
options=(!emptydirs !makeflags)
|
options=(!emptydirs !makeflags)
|
||||||
source=("https://hg.mozilla.org/releases/mozilla-release/archive/FIREFOX_${pkgver//./_}_RELEASE.tar.gz"
|
source=("https://hg.mozilla.org/releases/mozilla-release/archive/FIREFOX_${pkgver//./_}_RELEASE.tar.gz"
|
||||||
0001-bz-1468911.patch
|
0001-bz-1468911.patch
|
||||||
|
arm.patch
|
||||||
|
build-arm-libopus.patch
|
||||||
$pkgname.desktop firefox-symbolic.svg)
|
$pkgname.desktop firefox-symbolic.svg)
|
||||||
sha256sums=('1ccec6bfed18fdeca373ecf856e0e87a6425c8805ca720ff3f7df0e2e426ea90'
|
sha256sums=('fde34091a75b0f54f9e5b8c3392866510a6597f2bd01036d48345934f4ce4859'
|
||||||
'821f858bac2e13ce02b8c20d5387d4ecc8ab2d0e4ebe0a517cbf935da6aeb31b'
|
'821f858bac2e13ce02b8c20d5387d4ecc8ab2d0e4ebe0a517cbf935da6aeb31b'
|
||||||
|
'2c9e39b9b62d5a75e31908cb4d42ff8006ff9406aed2f7deff826fe1466cd31a'
|
||||||
|
'2d4d91f7e35d0860225084e37ec320ca6cae669f6c9c8fe7735cdbd542e3a7c9'
|
||||||
'677e1bde4c6b3cff114345c211805c7c43085038ca0505718a11e96432e9811a'
|
'677e1bde4c6b3cff114345c211805c7c43085038ca0505718a11e96432e9811a'
|
||||||
'9a1a572dc88014882d54ba2d3079a1cf5b28fa03c5976ed2cb763c93dabbd797')
|
'9a1a572dc88014882d54ba2d3079a1cf5b28fa03c5976ed2cb763c93dabbd797')
|
||||||
|
|
||||||
|
@ -116,6 +119,8 @@ END
|
||||||
fi
|
fi
|
||||||
|
|
||||||
LDFLAGS+=" -Wl,--no-keep-memory -Wl,--reduce-memory-overheads"
|
LDFLAGS+=" -Wl,--no-keep-memory -Wl,--reduce-memory-overheads"
|
||||||
|
patch -p1 -i ../arm.patch
|
||||||
|
patch -p1 -i ../build-arm-libopus.patch
|
||||||
}
|
}
|
||||||
|
|
||||||
build() {
|
build() {
|
||||||
|
|
24
extra/firefox/arm.patch
Normal file
24
extra/firefox/arm.patch
Normal file
|
@ -0,0 +1,24 @@
|
||||||
|
https://bugzilla.mozilla.org/show_bug.cgi?id=1526653
|
||||||
|
|
||||||
|
diff --git a/js/src/wasm/WasmSignalHandlers.cpp.orig b/js/src/wasm/WasmSignalHandlers.cpp
|
||||||
|
index d46b1c6..cf4c957 100644
|
||||||
|
--- a/js/src/wasm/WasmSignalHandlers.cpp.orig
|
||||||
|
+++ b/js/src/wasm/WasmSignalHandlers.cpp
|
||||||
|
@@ -228,7 +228,7 @@ using mozilla::DebugOnly;
|
||||||
|
# error "Don't know how to read/write to the thread state via the mcontext_t."
|
||||||
|
#endif
|
||||||
|
|
||||||
|
-#if defined(__linux__) && defined(__arm__)
|
||||||
|
+#if 0 && defined(__linux__) && defined(__arm__)
|
||||||
|
# include <sys/user.h>
|
||||||
|
#endif
|
||||||
|
|
||||||
|
@@ -456,7 +456,7 @@ struct AutoHandlingTrap {
|
||||||
|
}
|
||||||
|
};
|
||||||
|
|
||||||
|
-#if defined(__linux__) && defined(__arm__)
|
||||||
|
+#if 0 && defined(__linux__) && defined(__arm__)
|
||||||
|
|
||||||
|
// Code to handle SIGBUS for unaligned floating point accesses on 32-bit ARM.
|
||||||
|
|
12
extra/firefox/build-arm-libopus.patch
Normal file
12
extra/firefox/build-arm-libopus.patch
Normal file
|
@ -0,0 +1,12 @@
|
||||||
|
diff -up firefox-66.0/media/libopus/silk/arm/arm_silk_map.c.old firefox-66.0/media/libopus/silk/arm/arm_silk_map.c
|
||||||
|
--- firefox-66.0/media/libopus/silk/arm/arm_silk_map.c.old 2019-03-12 21:07:35.356677522 +0100
|
||||||
|
+++ firefox-66.0/media/libopus/silk/arm/arm_silk_map.c 2019-03-12 21:07:42.937693394 +0100
|
||||||
|
@@ -28,7 +28,7 @@ POSSIBILITY OF SUCH DAMAGE.
|
||||||
|
# include "config.h"
|
||||||
|
#endif
|
||||||
|
|
||||||
|
-#include "main_FIX.h"
|
||||||
|
+#include "fixed/main_FIX.h"
|
||||||
|
#include "NSQ.h"
|
||||||
|
#include "SigProc_FIX.h"
|
||||||
|
|
Loading…
Reference in a new issue