Added kernel26-dockstar

This commit is contained in:
Mike Staszel 2010-07-20 06:42:17 -07:00
parent 509f4c22fd
commit 0a1c2ce6e5
6 changed files with 2652 additions and 0 deletions

View file

@ -0,0 +1,43 @@
--- a/arch/arm/Kconfig
+++ b/arch/arm/Kconfig
@@ -1302,6 +1302,17 @@ config CMDLINE
time by entering them here. As a minimum, you should specify the
memory size and the root device (e.g., mem=64M root=/dev/nfs).
+config CMDLINE_FORCE
+ bool "Always use the default kernel command string"
+ depends on CMDLINE != ""
+ help
+ Always use the default kernel command string, even if the boot
+ loader passes other arguments to the kernel.
+ This is useful if you cannot or don't want to change the
+ command-line options your boot loader passes to the kernel.
+
+ If unsure, say N.
+
config XIP_KERNEL
bool "Kernel Execute-In-Place from ROM"
depends on !ZBOOT_ROM
diff --git a/arch/arm/kernel/setup.c b/arch/arm/kernel/setup.c
index 621acad..655aba2 100644
--- a/arch/arm/kernel/setup.c
+++ b/arch/arm/kernel/setup.c
@@ -628,6 +628,7 @@ static int __init parse_tag_revision(const struct tag *tag)
__tagtable(ATAG_REVISION, parse_tag_revision);
+#ifndef CONFIG_CMDLINE_FORCE
static int __init parse_tag_cmdline(const struct tag *tag)
{
strlcpy(default_command_line, tag->u.cmdline.cmdline, COMMAND_LINE_SIZE);
@@ -635,6 +636,7 @@ static int __init parse_tag_cmdline(const struct tag *tag)
}
__tagtable(ATAG_CMDLINE, parse_tag_cmdline);
+#endif /* CONFIG_CMDLINE_FORCE */
/*
* Scan the tag table for this tag, and call its parse function.
--
1.6.4.4

View file

@ -0,0 +1,15 @@
--- a/arch/arm/mach-kirkwood/sheevaplug-setup.c
+++ b/arch/arm/mach-kirkwood/sheevaplug-setup.c
@@ -34,6 +34,10 @@ static struct mtd_partition sheevaplug_nand_parts[] = {
}, {
.name = "root",
.offset = MTDPART_OFS_NXTBLK,
+ .size = SZ_32M
+ }, {
+ .name = "data",
+ .offset = MTDPART_OFS_NXTBLK,
.size = MTDPART_SIZ_FULL
},
};
--
1.6.4.4

View file

@ -0,0 +1,32 @@
--- a/arch/arm/mach-kirkwood/sheevaplug-setup.c
+++ b/arch/arm/mach-kirkwood/sheevaplug-setup.c
@@ -52,9 +52,15 @@ static struct mvsdio_platform_data sheevaplug_mvsdio_data = {
static struct gpio_led sheevaplug_led_pins[] = {
{
- .name = "plug:green:health",
+ .name = "dockstar:green:health",
.default_trigger = "default-on",
- .gpio = 49,
+ .gpio = 46, /* green */
+ .active_low = 1,
+ },
+ {
+ .name = "dockstar:orange:misc",
+ .default_trigger = "none",
+ .gpio = 47, /* orange */
.active_low = 1,
},
};
@@ -74,7 +80,8 @@ static struct platform_device sheevaplug_leds = {
static unsigned int sheevaplug_mpp_config[] __initdata = {
MPP29_GPIO, /* USB Power Enable */
- MPP49_GPIO, /* LED */
+ MPP46_GPIO, /* LED green */
+ MPP47_GPIO, /* LED orange */
0
};
--
1.6.4.4

View file

@ -0,0 +1,22 @@
--- a/arch/arm/mach-kirkwood/Kconfig
+++ b/arch/arm/mach-kirkwood/Kconfig
@@ -27,10 +27,10 @@ config MACH_MV88F6281GTW_GE
Marvell 88F6281 GTW GE Board.
config MACH_SHEEVAPLUG
- bool "Marvell SheevaPlug Reference Board"
+ bool "Seagate DockStar Board"
help
Say 'Y' here if you want your kernel to support the
- Marvell SheevaPlug Reference Board.
+ Seagate DockStar Board.
config MACH_TS219
bool "QNAP TS-110, TS-119, TS-210, TS-219 and TS-219P Turbo NAS"
--- a/arch/arm/mach-kirkwood/sheevaplug-setup.c
+++ b/arch/arm/mach-kirkwood/sheevaplug-setup.c
@@ -143,1 +143,1 @@
-MACHINE_START(SHEEVAPLUG, "Marvell SheevaPlug Reference Board")
+MACHINE_START(SHEEVAPLUG, "Seagate DockStar Board")
--

View file

@ -0,0 +1,57 @@
# Maintainer: Mike Staszel <mikestaszel@gmail.com>
# This PKGBUILD makes a kernel for the DockStar with aholler's LED patches.
pkgname=kernel26-dockstar
pkgver=2.6.34.1
pkgrel=1
pkgdesc="The Linux Kernel and modules with DockStar LEDs"
arch=('arm')
license=('GPL2')
url="http://www.kernel.org"
depends=('coreutils' 'module-init-tools')
makedepends=('uboot-mkimage')
conflicts=('kernel26')
provides=('kernel26')
install=kernel26-dockstar.install
source=(http://www.kernel.org/pub/linux/kernel/v2.6/linux-$pkgver.tar.bz2
config-2.6.33-dockstar
0001-ARM-Add-option-CMDLINE_FORCE-to-force-usage-of-the-i.patch
0002-MTD-partitons-used-by-the-Seagate-FreeAgent-DockStar.patch
0003-LED-definitions-for-the-Seagate-FreeAgent-DockStar.patch
0004-Change-board-name-for-the-SheevaPlug-to-reflect-the-.patch)
md5sums=('b5374deb75373e56ae56a0d362dc58f6'
'382c66de008d1bd1d97089b9ca049b6d'
'99f9eafc0b602483343c3c98f8828f79'
'0ed85186b0b5446c4afbbc45639a7466'
'e81eae381cc2c282d169c879cc4da54b'
'75287077b9a0105156977acb85d57546')
build() {
cd $srcdir/
ln -s linux-$pkgver linux
cp 000* config-2.6.33-dockstar linux/
cd linux/
# Apply Aholler's DockStar hardware patches
patch -p1 -i 0001-ARM-Add-option-CMDLINE_FORCE-to-force-usage-of-the-i.patch
patch -p1 -i 0002-MTD-partitons-used-by-the-Seagate-FreeAgent-DockStar.patch
patch -p1 -i 0003-LED-definitions-for-the-Seagate-FreeAgent-DockStar.patch
patch -p1 -i 0004-Change-board-name-for-the-SheevaPlug-to-reflect-the-.patch
# Prepare for make
mv config-2.6.33-dockstar .config
echo "Press ENTER 4973 times..."
make oldconfig
# Make!
make clean uImage
# Pack up the created uImage
mkdir -p $pkgdir/boot
cp $srcdir/linux/arch/arm/boot/uImage $pkgdir/boot/uImage
# Also, maybe installation should include modules,
# and asking users to move it manually to /boot/uImage,
# just to be sure?
}

File diff suppressed because it is too large Load diff