mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-28 22:57:37 +00:00
core/glibc to 2.19-4
This commit is contained in:
parent
2b3d936271
commit
0a2f7706ac
3 changed files with 50 additions and 25 deletions
|
@ -16,7 +16,7 @@ noautobuild=1
|
|||
|
||||
pkgname=glibc
|
||||
pkgver=2.19
|
||||
pkgrel=3
|
||||
pkgrel=4
|
||||
pkgdesc="GNU C Library"
|
||||
arch=('i686' 'x86_64')
|
||||
url="http://www.gnu.org/software/libc"
|
||||
|
@ -30,14 +30,14 @@ backup=(etc/gai.conf
|
|||
options=('!strip' 'staticlibs' '!distcc')
|
||||
install=glibc.install
|
||||
source=(http://ftp.gnu.org/gnu/libc/${pkgname}-${pkgver}.tar.xz{,.sig}
|
||||
glibc-2.18-xattr-compat-hack.patch
|
||||
glibc-2.19-xattr_header.patch
|
||||
glibc-2.19-fix-sign-in-bsloww1-input.patch
|
||||
local-soname-hack.diff
|
||||
locale.gen.txt
|
||||
locale-gen)
|
||||
md5sums=('e26b8cc666b162f999404b03970f14e4'
|
||||
'SKIP'
|
||||
'7ca96c68a37f2a4ab91792bfa0160a24'
|
||||
'39a4876837789e07746f1d84cd8cb46a'
|
||||
'755a1a9d7844a5e338eddaa9a5d974cd'
|
||||
'905370139382428ef2b97b247c0970bf'
|
||||
'07ac979b6ab5eeb778d55f041529d623'
|
||||
|
@ -46,8 +46,8 @@ md5sums=('e26b8cc666b162f999404b03970f14e4'
|
|||
prepare() {
|
||||
cd ${srcdir}/${pkgname}-${pkgver}
|
||||
|
||||
# hack fix for {linux,sys}/xattr.h incompatibility
|
||||
patch -p1 -i $srcdir/glibc-2.18-xattr-compat-hack.patch
|
||||
# fix for {linux,sys}/xattr.h incompatibility - commit fdbe8eae
|
||||
patch -p1 -i $srcdir/glibc-2.19-xattr_header.patch
|
||||
|
||||
# fix issues in sin/cos slow path calculation - commit ffe768a9
|
||||
patch -p1 -i $srcdir/glibc-2.19-fix-sign-in-bsloww1-input.patch
|
||||
|
@ -110,7 +110,9 @@ check() {
|
|||
LDFLAGS=${LDFLAGS/--as-needed,/}
|
||||
|
||||
cd ${srcdir}/glibc-build
|
||||
#make -k check
|
||||
# only acceptable testsuite error is some small libm ulp failures on i686 with gcc-4.9
|
||||
# TODO: fix upstream and provide patch
|
||||
make -k check || true
|
||||
}
|
||||
|
||||
package() {
|
||||
|
|
|
@ -1,19 +0,0 @@
|
|||
diff -Naur glibc-2.18-orig/misc/sys/xattr.h glibc-2.18/misc/sys/xattr.h
|
||||
--- glibc-2.18-orig/misc/sys/xattr.h 2013-08-11 08:52:55.000000000 +1000
|
||||
+++ glibc-2.18/misc/sys/xattr.h 2014-01-07 15:45:50.533969040 +1000
|
||||
@@ -26,13 +26,8 @@
|
||||
|
||||
/* The following constants should be used for the fifth parameter of
|
||||
`*setxattr'. */
|
||||
-enum
|
||||
-{
|
||||
- XATTR_CREATE = 1, /* set value, fail if attr already exists. */
|
||||
-#define XATTR_CREATE XATTR_CREATE
|
||||
- XATTR_REPLACE = 2 /* set value, fail if attr does not exist. */
|
||||
-#define XATTR_REPLACE XATTR_REPLACE
|
||||
-};
|
||||
+#define XATTR_CREATE 1
|
||||
+#define XATTR_REPLACE 2
|
||||
|
||||
/* Set the attribute NAME of the file pointed to by PATH to VALUE (which
|
||||
is SIZE bytes long). Return 0 on success, -1 for errors. */
|
42
core/glibc/glibc-2.19-xattr_header.patch
Normal file
42
core/glibc/glibc-2.19-xattr_header.patch
Normal file
|
@ -0,0 +1,42 @@
|
|||
From: Serge Hallyn <serge.hallyn@ubuntu.com>
|
||||
Date: Tue, 11 Mar 2014 04:17:07 +0000 (-0500)
|
||||
Subject: misc/sys/xattr.h: guard against linux uapi header inclusion
|
||||
X-Git-Url: https://sourceware.org/git/?p=glibc.git;a=commitdiff_plain;h=fdbe8eae;hp=fede7a5ffa188c22c3789135bd5cf82e487dd3d0
|
||||
|
||||
misc/sys/xattr.h: guard against linux uapi header inclusion
|
||||
|
||||
If the glibc xattr.h header is included after the uapi header,
|
||||
compilation fails due to an enum re-using a #define from the
|
||||
uapi header. Protect against this by guarding the define and
|
||||
enum inclusions against each other.
|
||||
|
||||
(A corresponding kernel patch has been sent here:
|
||||
http://lkml.org/lkml/2014/3/7/331 )
|
||||
|
||||
(See https://lists.debian.org/debian-glibc/2014/03/msg00029.html
|
||||
and https://sourceware.org/glibc/wiki/Synchronizing_Headers
|
||||
for more information.)
|
||||
|
||||
Signed-off-by: Serge Hallyn <serge.hallyn@ubuntu.com>
|
||||
---
|
||||
|
||||
diff --git a/misc/sys/xattr.h b/misc/sys/xattr.h
|
||||
index 929cd87..796df90 100644
|
||||
--- a/misc/sys/xattr.h
|
||||
+++ b/misc/sys/xattr.h
|
||||
@@ -26,6 +26,7 @@ __BEGIN_DECLS
|
||||
|
||||
/* The following constants should be used for the fifth parameter of
|
||||
`*setxattr'. */
|
||||
+#ifndef __USE_KERNEL_XATTR_DEFS
|
||||
enum
|
||||
{
|
||||
XATTR_CREATE = 1, /* set value, fail if attr already exists. */
|
||||
@@ -33,6 +34,7 @@ enum
|
||||
XATTR_REPLACE = 2 /* set value, fail if attr does not exist. */
|
||||
#define XATTR_REPLACE XATTR_REPLACE
|
||||
};
|
||||
+#endif
|
||||
|
||||
/* Set the attribute NAME of the file pointed to by PATH to VALUE (which
|
||||
is SIZE bytes long). Return 0 on success, -1 for errors. */
|
Loading…
Reference in a new issue