lxde packages rebuild for libpng

This commit is contained in:
Kevin Mihelich 2012-03-15 13:05:51 -04:00
parent 41873494e2
commit 0a4161728c
8 changed files with 378 additions and 0 deletions

View file

@ -0,0 +1,33 @@
# $Id: PKGBUILD 52590 2011-07-26 09:08:13Z angvp $
# Maintainer: Angel Velasquez <angvp@archlinux.org>
# Contributor: Geoffroy Carrier <geoffroy.carrier@koon.fr>
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
# - rebuild for libpng - remove when bumped upstream
plugrel=1
pkgname=gpicview
pkgver=0.2.2
pkgrel=1.1
pkgdesc="Picture viewer of the LXDE Desktop"
arch=('i686' 'x86_64')
license=('GPL2')
url="http://lxde.org/"
groups=('lxde')
depends=('gtk2')
makedepends=('pkgconfig' 'intltool')
optdepends=('librsvg: For SVG support')
source=(http://downloads.sourceforge.net/sourceforge/lxde/${pkgname}-${pkgver}.tar.gz)
md5sums=('943da9f4a23541accd5acdd4fb69966f')
build() {
cd "$srcdir/$pkgname-$pkgver"
./configure --sysconfdir=/etc --prefix=/usr
make
}
package() {
cd "$srcdir/$pkgname-$pkgver"
make DESTDIR="$pkgdir" install
}

View file

@ -0,0 +1,39 @@
#$Id: PKGBUILD 60017 2011-12-03 08:38:35Z bpiotrowski $
# Maintainer: Bartłomiej Piotrowski <barthalion@gmail.com>
# Contributor: Angel Velasquez <angvp@archlinux.org>
# Contributor: Geoffroy Carrier <geoffroy.carrier@koon.fr>
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
# - rebuild for libpng - remove when bumped upstream
plugrel=1
pkgname=lxappearance
pkgver=0.5.1
pkgrel=3.1
pkgdesc="GTK+ theme switcher of the LXDE Desktop (manages icons and fonts)"
arch=('i686' 'x86_64')
license=('GPL2')
url="http://lxde.org/"
groups=('lxde')
depends=('gtk2' 'intltool')
makedepends=('pkgconfig')
source=(http://downloads.sourceforge.net/sourceforge/lxde/${pkgname}-${pkgver}.tar.gz
gtk-3.0.patch)
build() {
cd "$srcdir/$pkgname-$pkgver"
patch -Np0 -i ../gtk-3.0.patch
./configure --sysconfdir=/etc --prefix=/usr
make
}
package() {
cd "$srcdir/$pkgname-$pkgver"
make DESTDIR="$pkgdir" install
}
md5sums=('34d157a7fe97ef0b93db8fab3f251e07'
'58fd450329972be03181c98e7287f3ae')

View file

@ -0,0 +1,111 @@
--- src/lxappearance.c 2011-07-29 16:50:19.000000000 +0200
+++ src/lxappearance1.c 2011-07-30 18:51:40.323368701 +0200
@@ -153,21 +153,33 @@
char* file_path = g_build_filename(g_get_home_dir(), ".gtkrc-2.0", NULL);
GString* content = g_string_sized_new(512);
+ GString* content3 = g_string_sized_new(512);
g_string_append(content,
"# DO NOT EDIT! This file will be overwritten by LXAppearance.\n"
"# Any customization should be done in ~/.gtkrc-2.0.mine instead.\n\n");
+ g_string_append(content3, "[Settings]\n"
+ "# DO NOT EDIT! This file will be overwritten by LXAppearance.\n");
+
if(app.widget_theme)
g_string_append_printf(content,
"gtk-theme-name=\"%s\"\n", app.widget_theme);
+ g_string_append_printf(content3,
+ "gtk-theme-name = %s\n", app.widget_theme);
if(app.icon_theme)
g_string_append_printf(content,
- "gtk-icon-theme-name=\"%s\"\n", app.icon_theme);
+ "gtk-icon-theme-name=\"%s\"\n", app.icon_theme);
+ g_string_append_printf(content3,
+ "gtk-icon-theme-name = %s\n", app.icon_theme);
if(app.default_font)
g_string_append_printf(content,
"gtk-font-name=\"%s\"\n", app.default_font);
+ g_string_append_printf(content3,
+ "gtk-font-name = %s\n", app.default_font);
if(app.cursor_theme)
g_string_append_printf(content,
"gtk-cursor-theme-name=\"%s\"\n", app.cursor_theme);
+ g_string_append_printf(content3,
+ "gtk-cursor-theme-name = %s\n", app.cursor_theme);
save_cursor_theme_name();
g_string_append_printf(content,
@@ -196,20 +208,46 @@
app.enable_hinting ? 1 : 0
);
+ g_string_append_printf(content3,
+ "gtk-cursor-theme-size = %d\n"
+ "gtk-toolbar-style = %s\n"
+ "gtk-toolbar-icon-size = %s\n"
+ "gtk-button-images = %d\n"
+ "gtk-menu-images = %d\n"
+ "gtk-enable-event-sounds = %d\n"
+ "gtk-enable-input-feedback-sounds = %d\n"
+ "gtk-xft-antialias = %d\n"
+ "gtk-xft-hinting = %d\n",
+ app.cursor_theme_size,
+ tb_styles[app.toolbar_style],
+ tb_icon_sizes[app.toolbar_icon_size],
+ app.button_images ? 1 : 0,
+ app.menu_images ? 1 : 0,
+ app.enable_event_sound ? 1 : 0,
+ app.enable_input_feedback ? 1 : 0,
+ app.enable_antialising ? 1 : 0,
+ app.enable_hinting ? 1 : 0
+ );
+
if(app.hinting_style)
g_string_append_printf(content,
"gtk-xft-hintstyle=\"%s\"\n", app.hinting_style);
+ g_string_append_printf(content3,
+ "gtk-xft-hintstyle = %s\n", app.hinting_style);
if(app.font_rgba)
g_string_append_printf(content,
"gtk-xft-rgba=\"%s\"\n", app.font_rgba);
+ g_string_append_printf(content3,
+ "gtk-xft-rgba = %s\n", app.font_rgba);
if(app.color_scheme)
{
char* escaped = g_strescape(app.color_scheme, NULL);
g_string_append_printf(content,
- "gtk-color-scheme=\"%s\"\n",
- escaped);
+ "gtk-color-scheme=\"%s\"\n", escaped);
+ g_string_append_printf(content3,
+ "gtk-color-scheme = %s\n", escaped);
g_free(escaped);
}
@@ -218,20 +256,20 @@
g_get_home_dir());
g_file_set_contents(file_path, content->str, content->len, NULL);
+ g_string_free(content, TRUE);
/* Save also for GTK3 */
- g_string_prepend(content, "[Settings] \n");
- char* file_path_gtk3 = g_build_filename(g_get_home_dir(), "gtk-3.0", NULL);
- char* file_path_settings = g_build_filename(g_get_home_dir(), "gtk-3.0", "settings.ini", NULL);
+ char* file_path_gtk3 = g_build_filename(g_get_user_config_dir(), "gtk-3.0", NULL);
+ char* file_path_settings = g_build_filename(g_get_user_config_dir(), "gtk-3.0", "settings.ini", NULL);
if (!g_file_test(file_path_gtk3, G_FILE_TEST_IS_DIR))
{
g_mkdir_with_parents(file_path_gtk3, 0755);
}
- g_file_set_contents(file_path_settings, content->str, content->len, NULL);
+ g_file_set_contents(file_path_settings, content3->str, content3->len, NULL);
- g_string_free(content, TRUE);
+ g_string_free(content3, TRUE);
g_free(file_path);
}

View file

@ -0,0 +1,38 @@
# $Id: PKGBUILD 53456 2011-08-03 20:00:26Z angvp $
# Maintainer: Angel Velasquez <angvp@archlinux.org>
# Maintainer: Juergen Hoetzel <juergen@archlinux.org>
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
# - rebuild for libpng - remove when bumped upstream
plugrel=1
pkgname=lxde-common
pkgver=0.5.5
pkgrel=1.1
pkgdesc="Common files of the LXDE Desktop"
arch=('i686' 'x86_64')
license=('GPL2')
groups=('lxde')
depends=('libx11' 'glib2' 'lxde-icon-theme')
url="http://lxde.org/"
# startlxde is useless without lxsession
makedepends=(automake)
optdepends=(lxsession-lite)
backup=(etc/xdg/lxsession/LXDE/{desktop.conf,autostart})
source=("http://downloads.sourceforge.net/lxde/${pkgname}-${pkgver}.tar.gz")
md5sums=('e51a6b2a815a89fda1f497b509465a97')
build() {
cd "$srcdir/$pkgname-$pkgver"
autoreconf
./configure --sysconfdir=/etc --prefix=/usr
}
package() {
cd "$srcdir/$pkgname-$pkgver"
make DESTDIR="$pkgdir" install
install -Dm644 lxde-logout.desktop \
${pkgdir}/usr/share/applications/lxde-logout.desktop
}

View file

@ -0,0 +1,13 @@
ICON_PATH=usr/share/icons/nuoveXT2
post_install() {
gtk-update-icon-cache -q -t -f ${ICON_PATH}
}
post_upgrade() {
post_install $1
}
post_remove() {
gtk-update-icon-cache -q -t -f ${ICON_PATH}
}

View file

@ -0,0 +1,40 @@
# $Id: PKGBUILD 61193 2011-12-24 11:33:27Z bpiotrowski $
# Maintainer: Bartłomiej Piotrowski <barthalion@gmail.com>
# Contributor: Angel Velasquez <angvp@archlinux.org>
# Contributor: Juergen Hoetzel <juergen@archlinux.org>
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
# - rebuild for libpng - remove when bumped upstream
plugrel=1
pkgname=lxpanel
pkgver=0.5.8
pkgrel=2.1
pkgdesc="Panel of the LXDE Desktop"
arch=('i686' 'x86_64')
license=('GPL2')
url="http://lxde.org/"
groups=('lxde')
depends=('gtk2' 'alsa-lib' 'menu-cache' 'lxmenu-data')
source=(http://downloads.sourceforge.net/lxde/${pkgname}-${pkgver}.tar.gz
battery.patch)
optdepends=(pcmanfm)
build() {
cd "$srcdir/$pkgname-$pkgver"
patch -Np1 -i "$srcdir/battery.patch"
./configure --sysconfdir=/etc --prefix=/usr
make
}
package() {
cd "$srcdir/$pkgname-$pkgver"
make DESTDIR="$pkgdir" install
}
md5sums=('129fae75d1cd3983fd94542c573a70a1'
'5fadb4d5aca09c81138677e91f995d98')
md5sums=('129fae75d1cd3983fd94542c573a70a1'
'5fadb4d5aca09c81138677e91f995d98')

View file

@ -0,0 +1,72 @@
diff --git plugins/batt/batt_sys.c plugins/batt/batt_sys.c
index 54ff678..1eebab5 100644
--- a/src/plugins/batt/batt_sys.c
+++ b/src/plugins/batt/batt_sys.c
@@ -35,15 +35,6 @@
#include <stdlib.h>
#include <string.h>
-battery* battery_new() {
- static int battery_num = 1;
- battery * b = g_new0 ( battery, 1 );
- battery_reset(b);
- b->battery_num = battery_num;
- battery_num++;
- return b;
-}
-
void battery_reset( battery * b) {
b->type_battery = TRUE;
b->capacity_unit = "mAh";
@@ -58,6 +49,15 @@ void battery_reset( battery * b) {
b->state = NULL;
}
+battery* battery_new() {
+ static int battery_num = 1;
+ battery * b = g_new0 ( battery, 1 );
+ battery_reset(b);
+ b->battery_num = battery_num;
+ battery_num++;
+ return b;
+}
+
static gchar* parse_info_file(char *filename)
{
char *buf = NULL;
@@ -194,7 +194,7 @@ void battery_update( battery *b ) {
/* convert energy values (in mWh) to charge values (in mAh) if needed and possible */
if (b->last_capacity_unit != -1 && b->last_capacity == -1) {
- if (b->voltage != -1) {
+ if (b->voltage > 0) {
b->last_capacity = b->last_capacity_unit * 1000 / b->voltage;
} else {
b->last_capacity = b->last_capacity_unit;
@@ -202,7 +202,7 @@ void battery_update( battery *b ) {
}
}
if (b->design_capacity_unit != -1 && b->design_capacity == -1) {
- if (b->voltage != -1) {
+ if (b->voltage > 0) {
b->design_capacity = b->design_capacity_unit * 1000 / b->voltage;
} else {
b->design_capacity = b->design_capacity_unit;
@@ -210,7 +210,7 @@ void battery_update( battery *b ) {
}
}
if (b->remaining_energy != -1 && b->remaining_capacity == -1) {
- if (b->voltage != -1) {
+ if (b->voltage > 0) {
b->remaining_capacity = b->remaining_energy * 1000 / b->voltage;
b->present_rate = b->present_rate * 1000 / b->voltage;
} else {
@@ -220,7 +220,7 @@ void battery_update( battery *b ) {
if (b->last_capacity < MIN_CAPACITY)
b->percentage = 0;
else
- b->percentage = ((float) b->remaining_energy * 100.0) / (float) b->last_capacity_unit;
+ b->percentage = (float) b->remaining_capacity * 100 / b->last_capacity;
if (b->percentage > 100)
b->percentage = 100;

32
community/lxtask/PKGBUILD Normal file
View file

@ -0,0 +1,32 @@
# $Id: PKGBUILD 56901 2011-10-16 07:43:53Z bpiotrowski $
# Maintainer: Angel Velasquez <angvp@archlinux.org>
# Contributor: Geoffroy Carrier <geoffroy.carrier@koon.fr>
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
# - rebuild for libpng - remove when bumped upstream
plugrel=1
pkgname=lxtask
pkgver=0.1.4
pkgrel=3.1
pkgdesc="Task manager of the LXDE Desktop"
arch=('i686' 'x86_64')
license=('GPL2')
url="http://lxde.org/"
groups=('lxde')
depends=('gtk2')
makedepends=('pkgconfig' 'intltool')
source=(http://downloads.sourceforge.net/sourceforge/lxde/${pkgname}-${pkgver}.tar.gz)
md5sums=('c4ab47d03d41a88696d64d3f1e78cf7f')
build() {
cd "$srcdir/$pkgname-$pkgver"
autoreconf
./configure --sysconfdir=/etc --prefix=/usr
make
}
package() {
cd "$srcdir/$pkgname-$pkgver"
make DESTDIR="$pkgdir" install
}