extra/chromium to 22.0.1229.94

This commit is contained in:
Kevin Mihelich 2012-10-13 22:20:53 +00:00
parent 752d7b8834
commit 0a568a615d
2 changed files with 3 additions and 25 deletions

View file

@ -15,8 +15,8 @@
buildarch=4
pkgname=chromium
pkgver=22.0.1229.79
pkgrel=2
pkgver=22.0.1229.94
pkgrel=1
pkgdesc="The open-source project behind Google Chrome, an attempt at creating a safer, faster, and more stable browser"
arch=('i686' 'x86_64')
url="http://www.chromium.org/"
@ -38,9 +38,8 @@ source=(http://commondatastorage.googleapis.com/chromium-browser-official/$pkgna
chromium.default
chromium.sh
chromium-20.0.1132.57-glib-2.16-use-siginfo_t.patch
chromium-22.0.1229.79-only-use-the-different-return-type-under-test.patch
chromium-ppapi-r0.patch)
sha256sums=('06cab1c48092def5bd94e9f4aa764f6ff5728ce35bbcdcc12fddbad3a0f0f738'
sha256sums=('a0af7e681ef43a7a17b32a1f6e1dc16ffa2a5f725f946ddaeea13660eba31caf'
'09bfac44104f4ccda4c228053f689c947b3e97da9a4ab6fa34ce061ee83d0322'
'478340d5760a9bd6c549e19b1b5d1c5b4933ebf5f8cfb2b3e2d70d07443fe232'
'4999fded897af692f4974f0a3e3bbb215193519918a1fa9b31ed51e74a2dccb9'
@ -54,10 +53,6 @@ build() {
# Fix build with glibc 2.16
patch -Np1 -i "$srcdir/chromium-20.0.1132.57-glib-2.16-use-siginfo_t.patch"
# Fix return code when reusing the existing browser
# http://code.google.com/p/chromium/issues/detail?id=146842
patch -Np2 -i "$srcdir/chromium-22.0.1229.79-only-use-the-different-return-type-under-test.patch"
# Fix build without NaCl glibc toolchain (patch from Gentoo)
patch -Np0 -i "$srcdir/chromium-ppapi-r0.patch"

View file

@ -1,17 +0,0 @@
--- trunk/src/chrome/browser/chrome_browser_main.cc 2012/09/07 19:44:53 155456
+++ trunk/src/chrome/browser/chrome_browser_main.cc 2012/09/07 19:45:06 155457
@@ -1081,7 +1081,13 @@
printf("%s\n", base::SysWideToNativeMB(UTF16ToWide(
l10n_util::GetStringUTF16(IDS_USED_EXISTING_BROWSER))).c_str());
#endif
- return chrome::RESULT_CODE_NORMAL_EXIT_PROCESS_NOTIFIED;
+ // Having a differentiated return type for testing allows for tests to
+ // verify proper handling of some switches. When not testing, stick to
+ // the standard Unix convention of returning zero when things went as
+ // expected.
+ if (parsed_command_line().HasSwitch(switches::kTestType))
+ return chrome::RESULT_CODE_NORMAL_EXIT_PROCESS_NOTIFIED;
+ return content::RESULT_CODE_NORMAL_EXIT;
case ProcessSingleton::PROFILE_IN_USE:
return chrome::RESULT_CODE_PROFILE_IN_USE;