core/linux-armv7 to 3.15.0-1

This commit is contained in:
Kevin Mihelich 2014-06-15 15:52:31 +00:00
parent c7ae2da100
commit 0a5f348f57
4 changed files with 361 additions and 317 deletions

View file

@ -1,44 +0,0 @@
commit 45cfc51681287482c8b9843a20d6b4d06555ff62
Author: Stanislaw Gruszka <sgruszka@redhat.com>
Date: Fri Jan 31 13:18:09 2014 +0100
rt2x00: move frequent messages to debug level
On commit 28f2bce9f8bbf704c86f8c684337f82c51592c81 I make change that
print various messages as default. This can cause flood of messages
related to TX status timeout on some environments. I partially fixed
problem on commit bb9c298f3193ac5b80e47b325c690700580b6bcf, but forgot
to move two more messages to debug level.
Signed-off-by: Stanislaw Gruszka <sgruszka@redhat.com>
Acked-by: Gertjan van Wingerde <gwingerde@gmail.com>
Signed-off-by: John W. Linville <linville@tuxdriver.com>
diff --git a/drivers/net/wireless/rt2x00/rt2800usb.c b/drivers/net/wireless/rt2x00/rt2800usb.c
index caddc1b..14a90dd 100644
--- a/drivers/net/wireless/rt2x00/rt2800usb.c
+++ b/drivers/net/wireless/rt2x00/rt2800usb.c
@@ -125,9 +125,9 @@ static inline bool rt2800usb_entry_txstatus_timeout(struct queue_entry *entry)
tout = time_after(jiffies, entry->last_action + msecs_to_jiffies(100));
if (unlikely(tout))
- rt2x00_warn(entry->queue->rt2x00dev,
- "TX status timeout for entry %d in queue %d\n",
- entry->entry_idx, entry->queue->qid);
+ rt2x00_dbg(entry->queue->rt2x00dev,
+ "TX status timeout for entry %d in queue %d\n",
+ entry->entry_idx, entry->queue->qid);
return tout;
}
@@ -566,8 +566,8 @@ static void rt2800usb_txdone(struct rt2x00_dev *rt2x00dev)
queue = rt2x00queue_get_tx_queue(rt2x00dev, qid);
if (unlikely(rt2x00queue_empty(queue))) {
- rt2x00_warn(rt2x00dev, "Got TX status for an empty queue %u, dropping\n",
- qid);
+ rt2x00_dbg(rt2x00dev, "Got TX status for an empty queue %u, dropping\n",
+ qid);
break;
}

View file

@ -1,74 +0,0 @@
From 5d77ba2d26110c678b40fd723866a17d4036de12 Mon Sep 17 00:00:00 2001
From: Lucas De Marchi <lucas.demarchi@intel.com>
Date: Tue, 18 Feb 2014 02:19:26 -0300
Subject: [PATCH 1/6] Bluetooth: allocate static minor for vhci
Commit bfacbb9 (Bluetooth: Use devname:vhci module alias for virtual HCI
driver) added the module alias to hci_vhci module so it's possible to
create the /dev/vhci node. However creating an alias without
specifying the minor doesn't allow us to create the node ahead,
triggerring module auto-load when it's first accessed.
Starting with depmod from kmod 16 we started to warn if there's a
devname alias without specifying the major and minor.
Let's do the same done for uhid, kvm, fuse and others, specifying a
fixed minor. In systems with systemd as the init the following will
happen: on early boot systemd will call "kmod static-nodes" to read
/lib/modules/$(uname -r)/modules.devname and then create the nodes. When
first accessed these "dead" nodes will trigger the module loading.
Signed-off-by: Lucas De Marchi <lucas.demarchi@intel.com>
Acked-by: Greg Kroah-Hartman <gregkh@linuxfoundation.org>
Signed-off-by: Marcel Holtmann <marcel@holtmann.org>
---
Documentation/devices.txt | 1 +
drivers/bluetooth/hci_vhci.c | 3 ++-
include/linux/miscdevice.h | 1 +
3 files changed, 4 insertions(+), 1 deletion(-)
diff --git a/Documentation/devices.txt b/Documentation/devices.txt
index 10378cc..04356f5 100644
--- a/Documentation/devices.txt
+++ b/Documentation/devices.txt
@@ -353,6 +353,7 @@ Your cooperation is appreciated.
133 = /dev/exttrp External device trap
134 = /dev/apm_bios Advanced Power Management BIOS
135 = /dev/rtc Real Time Clock
+ 137 = /dev/vhci Bluetooth virtual HCI driver
139 = /dev/openprom SPARC OpenBoot PROM
140 = /dev/relay8 Berkshire Products Octal relay card
141 = /dev/relay16 Berkshire Products ISO-16 relay card
diff --git a/drivers/bluetooth/hci_vhci.c b/drivers/bluetooth/hci_vhci.c
index 1ef6990..add1c6a 100644
--- a/drivers/bluetooth/hci_vhci.c
+++ b/drivers/bluetooth/hci_vhci.c
@@ -359,7 +359,7 @@ static const struct file_operations vhci_fops = {
static struct miscdevice vhci_miscdev= {
.name = "vhci",
.fops = &vhci_fops,
- .minor = MISC_DYNAMIC_MINOR,
+ .minor = VHCI_MINOR,
};
static int __init vhci_init(void)
@@ -385,3 +385,4 @@ MODULE_DESCRIPTION("Bluetooth virtual HCI driver ver " VERSION);
MODULE_VERSION(VERSION);
MODULE_LICENSE("GPL");
MODULE_ALIAS("devname:vhci");
+MODULE_ALIAS_MISCDEV(VHCI_MINOR);
diff --git a/include/linux/miscdevice.h b/include/linux/miscdevice.h
index 3737f72..7bb6148 100644
--- a/include/linux/miscdevice.h
+++ b/include/linux/miscdevice.h
@@ -23,6 +23,7 @@
#define TEMP_MINOR 131 /* Temperature Sensor */
#define RTC_MINOR 135
#define EFI_RTC_MINOR 136 /* EFI Time services */
+#define VHCI_MINOR 137
#define SUN_OPENPROM_MINOR 139
#define DMAPI_MINOR 140 /* DMAPI */
#define NVRAM_MINOR 144
--
1.9.1

View file

@ -4,45 +4,41 @@
buildarch=4
pkgbase=linux-armv7
_srcname=linux-3.14
_srcname=linux-3.15
_kernelname=${pkgbase#linux}
_desc="ARMv7 multi-platform"
pkgver=3.14.5
pkgver=3.15.0
pkgrel=1
rcnrel=armv7-x8
rcnrel=armv7-x2
arch=('armv7h')
url="http://www.kernel.org/"
license=('GPL2')
makedepends=('xmlto' 'docbook-xsl' 'kmod' 'inetutils' 'bc' 'git' 'uboot-mkimage')
makedepends=('xmlto' 'docbook-xsl' 'kmod' 'inetutils' 'bc' 'git' 'uboot-tools')
options=('!strip')
source=("http://www.kernel.org/pub/linux/kernel/v3.x/${_srcname}.tar.xz"
"http://www.kernel.org/pub/linux/kernel/v3.x/patch-${pkgver}.xz"
#"http://www.kernel.org/pub/linux/kernel/v3.x/patch-${pkgver}.xz"
"http://rcn-ee.net/deb/sid-armhf/v${pkgver}-${rcnrel}/patch-${pkgver%.0}-${rcnrel}.diff.gz"
"git://git.code.sf.net/p/aufs/aufs3-standalone#branch=aufs${pkgver%.*}"
#"git://git.code.sf.net/p/aufs/aufs3-standalone#branch=aufs${pkgver%.*}"
"git://git.code.sf.net/p/aufs/aufs3-standalone#branch=aufs3.x-rcN"
'0001-atags-add-support-for-marvell-uboot.patch'
'0002-atags-retrieve-mac-addresses.patch'
'0003-smileplug-devicetree.patch'
'0004-emmc-timing-fix.patch'
'0005-squelch-rt2800usb-messages.patch'
'0006-Bluetooth-allocate-static-minor-for-vhci.patch'
'config')
md5sums=('b621207b3f6ecbb67db18b13258f8ea8'
'a56bf05cb9033097198f9269bbcff130'
'e5ef8c344800d00cf6b362b5a639853f'
md5sums=('97ca1625bb40368dc41b9a7971549071'
'ada2f334b3246e87bbfd44613eb1eb99'
'SKIP'
'3ad860d0d6daedc82091ea29c9730b95'
'02cce6b8f88c4392f552b14d0bf2e71c'
'0a0c5691aea2503cd0c503cb50244f48'
'911bffe9c261ca5b91dd0a083d99e81f'
'8609ac79ba99320692c50481aabc6ed2'
'1b276abe16d14e133f3f28d9c9e6bd68'
'69f7ad4d81a6165b8595233705774f95')
'3530333f5d95cf11109087b77be06901')
prepare() {
cd "${srcdir}/${_srcname}"
# add upstream patch
patch -p1 -i ../patch-${pkgver}
#patch -p1 -i ../patch-${pkgver}
# RCN patch
git apply ../patch-${pkgver%.0}-${rcnrel}.diff
@ -52,8 +48,6 @@ prepare() {
patch -p1 -i ../0002-atags-retrieve-mac-addresses.patch
patch -p1 -i ../0003-smileplug-devicetree.patch
patch -p1 -i ../0004-emmc-timing-fix.patch
patch -p1 -i ../0005-squelch-rt2800usb-messages.patch
patch -p1 -i ../0006-Bluetooth-allocate-static-minor-for-vhci.patch
# AUFS patches
cp -ru "${srcdir}/aufs3-standalone/Documentation" .

File diff suppressed because it is too large Load diff