mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-01-17 23:34:07 +00:00
extra/irqbalance to 1.5.0-2
This commit is contained in:
parent
e72d90ed75
commit
0a7b72a9fe
2 changed files with 19 additions and 33 deletions
|
@ -1,4 +1,5 @@
|
|||
# Maintainer: Dan McGee <dan@archlinux.org>
|
||||
# Maintainer: David Runge <dave@sleepmap.de>
|
||||
# Contributor: Dan McGee <dan@archlinux.org>
|
||||
# Contributor: Martin Striz <ms@poruba.net>
|
||||
|
||||
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
|
@ -6,38 +7,37 @@
|
|||
|
||||
pkgname=irqbalance
|
||||
pkgver=1.5.0
|
||||
pkgrel=1
|
||||
pkgrel=2
|
||||
pkgdesc="IRQ balancing daemon for SMP systems"
|
||||
arch=('x86_64')
|
||||
url="https://github.com/Irqbalance/irqbalance"
|
||||
license=('GPL')
|
||||
url="https://github.com/irqbalance/irqbalance"
|
||||
license=('GPL2')
|
||||
backup=('etc/irqbalance.env')
|
||||
depends=('glib2' 'libcap-ng' 'systemd-libs')
|
||||
makedepends=('systemd')
|
||||
source=($pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz
|
||||
config.patch)
|
||||
sha1sums=('bb8c786b1aae73679016ae0bbbb7c7dbc488be64'
|
||||
'32e5650f37c64531e69f477959b0c3598acc2825')
|
||||
source=("$pkgname-$pkgver.tar.gz::https://github.com/${pkgname}/${pkgname}/archive/v$pkgver.tar.gz")
|
||||
sha512sums=('343421fd533d7d161fd05a0edfadaddf1da6ced854a19e9f10ea6c12b97b2ef1629aad855214d9700d31d056bb816bf3ec90cdf7c643a1b6e8af1de5befa64f5')
|
||||
|
||||
prepare() {
|
||||
cd "$srcdir/$pkgname-$pkgver"
|
||||
patch -p1 < ../config.patch
|
||||
cd "$pkgname-$pkgver"
|
||||
# fix location of configuration and binary in service
|
||||
sed -e 's|/path/to/|/etc/|g' \
|
||||
-e 's|/usr/sbin|/usr/bin|g' \
|
||||
-i "misc/${pkgname}.service"
|
||||
autoreconf -vfi
|
||||
}
|
||||
|
||||
build() {
|
||||
cd "$srcdir/$pkgname-$pkgver"
|
||||
./autogen.sh
|
||||
cd "$pkgname-$pkgver"
|
||||
./configure --prefix=/usr --sbindir=/usr/bin --with-systemd
|
||||
make
|
||||
}
|
||||
|
||||
package() {
|
||||
cd "$srcdir/$pkgname-$pkgver"
|
||||
cd "$pkgname-$pkgver"
|
||||
make install DESTDIR="$pkgdir"
|
||||
|
||||
install -D -m644 misc/irqbalance.service "$pkgdir"/usr/lib/systemd/system/irqbalance.service
|
||||
install -D -m644 misc/irqbalance.env "$pkgdir"/etc/irqbalance.env
|
||||
|
||||
# Disable udev rule until we clarify it FS#56785
|
||||
# install -D -m644 misc/90-irqbalance.rules "$pkgdir"/usr/lib/udev/rules.d/90-irqbalance.rules
|
||||
install -vDm 644 misc/irqbalance.service \
|
||||
-t "${pkgdir}/usr/lib/systemd/system/"
|
||||
install -vDm 644 misc/irqbalance.env -t "${pkgdir}/etc/"
|
||||
install -vDm 644 {AUTHORS,README.md} -t "${pkgdir}/usr/share/doc/${pkgname}"
|
||||
}
|
||||
|
|
|
@ -1,14 +0,0 @@
|
|||
diff -aur irqbalance-1.5.0/misc/irqbalance.service irqbalance-1.5.0.new/misc/irqbalance.service
|
||||
--- irqbalance-1.5.0/misc/irqbalance.service 2018-10-27 11:36:59.000000000 +0200
|
||||
+++ irqbalance-1.5.0.new/misc/irqbalance.service 2019-02-19 21:49:12.093453013 +0100
|
||||
@@ -5,8 +5,8 @@
|
||||
ConditionVirtualization=!container
|
||||
|
||||
[Service]
|
||||
-EnvironmentFile=/path/to/irqbalance.env
|
||||
-ExecStart=/usr/sbin/irqbalance --foreground $IRQBALANCE_ARGS
|
||||
+EnvironmentFile=/etc/irqbalance.env
|
||||
+ExecStart=/usr/bin/irqbalance --foreground $IRQBALANCE_ARGS
|
||||
CapabilityBoundingSet=
|
||||
NoNewPrivileges=yes
|
||||
ReadOnlyPaths=/
|
Loading…
Reference in a new issue