extra/webkit2gtk to 2.20.0-1

This commit is contained in:
Kevin Mihelich 2018-03-25 00:58:10 +00:00
parent 94127713d5
commit 0a90a08b56
2 changed files with 5 additions and 32 deletions

View file

@ -8,25 +8,23 @@
highmem=1
pkgname=webkit2gtk
pkgver=2.18.6
pkgver=2.20.0
pkgrel=1
pkgdesc="GTK+ Web content engine library"
arch=(x86_64)
url="https://webkitgtk.org/"
license=(custom)
depends=(libxt libxslt enchant geoclue2 gst-plugins-base-libs gst-plugins-bad
libsecret libwebp harfbuzz-icu gtk3 libnotify hyphen)
libsecret libwebp harfbuzz-icu gtk3 libnotify hyphen woff2)
makedepends=(gtk2 gperf gobject-introspection ruby gtk-doc cmake python python2 ninja)
optdepends=('gtk2: Netscape plugin support'
'gst-plugins-base: free media decoding'
'gst-plugins-good: media decoding'
'gst-libav: nonfree media decoding')
source=(https://webkitgtk.org/releases/webkitgtk-${pkgver}.tar.xz{,.asc}
enchant-2.diff
remove_atomics.patch)
sha256sums=('93912cc2f40f12e452be1ca4babdbdaac0ec4f828d441257a6b06c2963bbac3c'
sha256sums=('57f640f720bd9a8a7207f3321cf803a15c2f207b4e7b75ff1be17bc1eeb00a3c'
'SKIP'
'ed8e5fe614ed800da3caccb8162bdd2d8dbd5a69ab90d426b34e124dee5cf1b6'
'410449817b1b181737538be10d96d6d8aec134285f6288e80c96fbfdd5d19519')
validpgpkeys=('D7FCF61CF9A2DEAB31D81BD3F3D322D0EC4582C3')
@ -34,9 +32,6 @@ prepare() {
mkdir build
cd webkitgtk-$pkgver
# enchant 2.2
patch -Np1 -i ../enchant-2.diff
sed -i '1s/python$/&2/' Tools/gtk/generate-gtkdoc
if [[ $CARCH == "arm" || $CARCH == "armv6h" ]]; then
@ -65,10 +60,9 @@ build() {
}
package() {
cd build
DESTDIR="$pkgdir" ninja install
DESTDIR="$pkgdir" ninja -C build install
cd ../webkitgtk-$pkgver
cd webkitgtk-$pkgver
find Source -name 'COPYING*' -or -name 'LICENSE*' -print0 | while IFS= read -d $'\0' -r _f
do
echo "### $_f ###"

View file

@ -1,21 +0,0 @@
diff -u -r webkitgtk-2.18.5/Source/cmake/FindEnchant.cmake webkitgtk-2.18.5-enchant2/Source/cmake/FindEnchant.cmake
--- webkitgtk-2.18.5/Source/cmake/FindEnchant.cmake 2017-08-09 11:13:53.000000000 +0200
+++ webkitgtk-2.18.5-enchant2/Source/cmake/FindEnchant.cmake 2018-01-18 10:06:07.127310881 +0100
@@ -28,7 +28,7 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
find_package(PkgConfig)
-pkg_check_modules(PC_ENCHANT enchant)
+pkg_check_modules(PC_ENCHANT enchant-2)
find_path(ENCHANT_INCLUDE_DIRS
NAMES enchant.h
@@ -37,7 +37,7 @@
)
find_library(ENCHANT_LIBRARIES
- NAMES enchant
+ NAMES enchant-2
PATHS ${PC_ENCHANT_LIBDIR}
${PC_ENCHANT_LIBRARY_DIRS}
)