mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-03-19 00:21:40 +00:00
extra/pyqt5: fix
This commit is contained in:
parent
3e32001db1
commit
0ac71af362
2 changed files with 17 additions and 2 deletions
|
@ -7,6 +7,7 @@
|
||||||
|
|
||||||
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
|
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||||
# - remove qt5-webengine makedepend, not built for ARM
|
# - remove qt5-webengine makedepend, not built for ARM
|
||||||
|
# - hack for OpenGLES
|
||||||
|
|
||||||
pkgbase=pyqt5
|
pkgbase=pyqt5
|
||||||
pkgname=('pyqt5-common' 'python-pyqt5' 'python2-pyqt5')
|
pkgname=('pyqt5-common' 'python-pyqt5' 'python2-pyqt5')
|
||||||
|
@ -20,10 +21,11 @@ makedepends=('python-sip' 'python2-sip' 'python-opengl' 'python2-opengl'
|
||||||
'python2-dbus' 'python-dbus' 'qt5-connectivity'
|
'python2-dbus' 'python-dbus' 'qt5-connectivity'
|
||||||
'qt5-multimedia' 'qt5-tools' 'qt5-serialport' 'qt5-svg'
|
'qt5-multimedia' 'qt5-tools' 'qt5-serialport' 'qt5-svg'
|
||||||
'qt5-webkit' 'qt5-websockets' 'qt5-x11extras')
|
'qt5-webkit' 'qt5-websockets' 'qt5-x11extras')
|
||||||
source=("http://sourceforge.net/projects/pyqt/files/PyQt5/PyQt-$pkgver/PyQt5_gpl-$pkgver.tar.gz" pyqt-qt5.8.patch pyqt5-fix-check-license.patch)
|
source=("http://sourceforge.net/projects/pyqt/files/PyQt5/PyQt-$pkgver/PyQt5_gpl-$pkgver.tar.gz" pyqt-qt5.8.patch pyqt5-fix-check-license.patch opengles-hack.patch)
|
||||||
md5sums=('b3171b67c74aa63a3cd2f386660c898b'
|
md5sums=('b3171b67c74aa63a3cd2f386660c898b'
|
||||||
'524f184f0e63aea952ba77702dff1356'
|
'524f184f0e63aea952ba77702dff1356'
|
||||||
'1f57fb76747c5723dc4747fbbb376145')
|
'1f57fb76747c5723dc4747fbbb376145'
|
||||||
|
'ad09b1c84c26d5e92de192477cb3a2d1')
|
||||||
|
|
||||||
prepare() {
|
prepare() {
|
||||||
pushd PyQt5_gpl-${_pkgver}
|
pushd PyQt5_gpl-${_pkgver}
|
||||||
|
@ -31,6 +33,8 @@ prepare() {
|
||||||
patch -p1 -i ../pyqt-qt5.8.patch
|
patch -p1 -i ../pyqt-qt5.8.patch
|
||||||
# Hack to make the license check pass with Qt 5.8
|
# Hack to make the license check pass with Qt 5.8
|
||||||
patch -p1 -i ../pyqt5-fix-check-license.patch
|
patch -p1 -i ../pyqt5-fix-check-license.patch
|
||||||
|
# Hack for OpenGLES
|
||||||
|
patch -p1 -i ../opengles-hack.patch
|
||||||
popd
|
popd
|
||||||
|
|
||||||
# The additional include path was removed due to this line, I don't really know why they are doing this...
|
# The additional include path was removed due to this line, I don't really know why they are doing this...
|
||||||
|
|
11
extra/pyqt5/opengles-hack.patch
Normal file
11
extra/pyqt5/opengles-hack.patch
Normal file
|
@ -0,0 +1,11 @@
|
||||||
|
diff -urN a/configure.py b/configure.py
|
||||||
|
--- a/configure.py 2017-01-28 20:39:01.562407718 -0700
|
||||||
|
+++ b/configure.py 2017-01-28 22:08:41.670433124 -0700
|
||||||
|
@@ -688,6 +688,7 @@
|
||||||
|
#elif defined(QT_OPENGL_ES_2)
|
||||||
|
out << "PyQt_Desktop_OpenGL\\n";
|
||||||
|
#endif
|
||||||
|
+ out << "PyQt_Desktop_OpenGL\\n";
|
||||||
|
|
||||||
|
#if QT_VERSION < 0x050200
|
||||||
|
// This is the test used in qglobal.h in Qt prior to v5.2. In v5.2 and later
|
Loading…
Reference in a new issue