community/linux-tools to 3.15-1

This commit is contained in:
Jason Plum 2014-07-30 18:17:35 -04:00
parent a1fc3316a0
commit 0ac875314c
2 changed files with 28 additions and 9 deletions

View file

@ -0,0 +1,13 @@
diff --git a/tools/power/acpi/tools/acpidump/acpidump.c b/tools/power/acpi/tools/acpidump/acpidump.c
index a84553a..df453cc 100644
--- a/tools/power/acpi/tools/acpidump/acpidump.c
+++ b/tools/power/acpi/tools/acpidump/acpidump.c
@@ -49,8 +49,6 @@ typedef int s32;
typedef unsigned char u8;
typedef unsigned short u16;
typedef unsigned int u32;
-typedef unsigned long long u64;
-typedef long long s64;
#endif
#include <sys/mman.h>

View file

@ -16,8 +16,8 @@ pkgname=(
'tmon'
'usbip'
)
pkgver=3.14
pkgrel=3
pkgver=3.15
pkgrel=1
license=('GPL2')
arch=('i686' 'x86_64')
url='http://www.kernel.org'
@ -30,33 +30,39 @@ makedepends+=('perl' 'python2' 'libnewt' 'elfutils' 'libunwind')
# cpupower deps
makedepends+=('pciutils')
# usbip deps
makedepends+=('glib2' 'sysfsutils')
makedepends+=('glib2' 'sysfsutils' 'udev')
# tmon deps
makedepends+=('ncurses')
groups=("$pkgbase")
source=("http://ftp.kernel.org/pub/linux/kernel/v3.x/linux-$pkgver.tar.xz"
# "http://ftp.kernel.org/pub/linux/kernel/v3.x/patch-$pkgver.3.xz"
"http://ftp.kernel.org/pub/linux/kernel/v3.x/patch-$pkgver.7.xz"
'cpupower.default'
'cpupower.systemd'
'cpupower.service'
'usbipd.service'
'01-fix-perf-python.patch'
'02-archlinux-paths.patch')
'02-archlinux-paths.patch'
'03-fix-acpidump-compile-error.patch')
# http://www.kernel.org/pub/linux/kernel/v3.x/sha256sums.asc
sha256sums=('61558aa490855f42b6340d1a1596be47454909629327c49a5e4e10268065dffa'
sha256sums=('c3927e87be4040fa8aca1b58663dc0776aaf00485604ff88a623be2f3fb07794'
'25f0767908e736a2388fe36810712ee3faa6c86c5255516496d5942ba1ffb451'
'6d54f1dcd4d9441644a7ef4445f6633158e666fddaa6f06bb6656ab2ff4509d4'
'4fa509949d6863d001075fa3e8671eff2599c046d20c98bb4a70778595cd1c3f'
'fbf6e0ce6eb0ef15703fe212958de6ca46e62188900b5e9f9272ed3cc9cfd54e'
'a89284d0ecb556ca53a66d1c2087b5fd6d0a901ab2769cd3aebb93f4478905dc'
'2e187734d8aec58a3046d79883510d779aa93fb3ab20bd3132c1a607ebe5498f'
'fce128f5e0abfa6916d5cb881456d892d1b163b9639166a4c6c1d53e4dc5086a'
'eb866a589a26b1979ffb2fe08be09417e277a4befac34bdb279a6bb3a27b0570')
'eb866a589a26b1979ffb2fe08be09417e277a4befac34bdb279a6bb3a27b0570'
'c791c9eb95e9db28b5a6530232885def9de941d0cbeb9e8b3b999f0567de3199')
prepare() {
cd linux-$pkgver
#patch -N -p1 -i "$srcdir/patch-$pkgver.3"
#patch -N -p1 -i "$srcdir/patch-$pkgver.7"
patch -N -p1 -i "$srcdir/01-fix-perf-python.patch"
patch -N -p1 -i "$srcdir/02-archlinux-paths.patch"
# the following patch is a fix for compile error in 3.15
# in the 3.16 acpidump code has been reimplemented and patch is not needed.
patch -N -p1 -i "$srcdir/03-fix-acpidump-compile-error.patch"
}
build() {
@ -178,7 +184,7 @@ package_cpupower() {
package_usbip() {
pkgdesc='An USB device sharing system over IP network'
depends=('glib2' 'sysfsutils')
depends=('glib2' 'sysfsutils' 'libsystemd')
pushd linux-$pkgver/drivers/staging/usbip/userspace
make install DESTDIR="$pkgdir"