core/pacman to 5.2.0-2

This commit is contained in:
Kevin Mihelich 2019-10-23 12:52:21 +00:00
parent cddbcb7110
commit 0ae5daf70e
7 changed files with 26 additions and 64 deletions

View file

@ -1,7 +1,7 @@
From f0131b44f6fb8bd54e78ca97a4aefb4538211e75 Mon Sep 17 00:00:00 2001
From 2eb709681537fed1156b2e1dc134e194e7b5c762 Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Sat, 13 Sep 2014 18:58:16 -0600
Subject: [PATCH 1/4] Sychronize filesystem
Subject: [PATCH 1/3] Sychronize filesystem
Since many problems arise from improper flushing of the filesystem,
particularly package installations followed by a reboot very shorly after,
@ -28,5 +28,5 @@ index 4d97921f..531dbbe4 100644
}
--
2.21.0
2.22.0

View file

@ -1,7 +1,7 @@
From c0836b1f802f54c793618823f5d1bb649a13e85d Mon Sep 17 00:00:00 2001
From 544d96b66768a77e838787807235bacb62f31c4b Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Sat, 30 Jan 2016 17:19:03 -0700
Subject: [PATCH 2/4] Revert "close stdin before running install scripts"
Subject: [PATCH 2/3] Revert "close stdin before running install scripts"
This reverts commit e374e6829cea3512f0b4a4069c5a6168f0f8d8a0.
@ -28,5 +28,5 @@ index d33eef2a..e08cb923 100644
close(2);
while(dup2(child2parent_pipefd[HEAD], 1) == -1 && errno == EINTR);
--
2.21.0
2.22.0

View file

@ -1,7 +1,7 @@
From c3daaf594599a1a6942cafc907dbb7e9755fe6d4 Mon Sep 17 00:00:00 2001
From dd5e69dbd55b9649628b5166ad2ebeb664e3d2e0 Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Fri, 11 Mar 2016 20:11:24 -0700
Subject: [PATCH 3/4] Revert "alpm_run_chroot: always connect parent2child
Subject: [PATCH 3/3] Revert "alpm_run_chroot: always connect parent2child
pipe"
This reverts commit 1d6583a58da0904fb7feafd4a666391087955a7b.
@ -56,5 +56,5 @@ index e08cb923..7e788a7e 100644
#define STOP_POLLING(p) do { close(p->fd); p->fd = -1; } while(0)
--
2.21.0
2.22.0

View file

@ -1,27 +0,0 @@
From 2c7bbd7ce02be70a2af21e45a17c2cdca187526f Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Mon, 20 May 2019 18:55:18 -0600
Subject: [PATCH 4/4] Support application/gzip MIME type in extraction
file 5.37 changed the gzip MIME type from application/x-gzip to
application/gzip, so support this when checking to extract source files.
---
scripts/libmakepkg/source/file.sh.in | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/scripts/libmakepkg/source/file.sh.in b/scripts/libmakepkg/source/file.sh.in
index 08b8bef8..8492ba11 100644
--- a/scripts/libmakepkg/source/file.sh.in
+++ b/scripts/libmakepkg/source/file.sh.in
@@ -102,7 +102,7 @@ extract_file() {
case "$file_type" in
*application/x-tar*|*application/zip*|*application/x-zip*|*application/x-cpio*)
cmd="bsdtar" ;;
- *application/x-gzip*)
+ *application/x-gzip*|*application/gzip*)
case "$ext" in
gz|z|Z) cmd="gzip" ;;
*) return;;
--
2.21.0

View file

@ -11,8 +11,8 @@
# - patch to fix application/gzip change in file 5.37
pkgname=pacman
pkgver=5.1.3
pkgrel=1.1
pkgver=5.2.0
pkgrel=2
pkgdesc="A library-based package manager with dependency support"
arch=('x86_64')
url="https://www.archlinux.org/pacman/"
@ -21,9 +21,9 @@ groups=('base' 'base-devel')
depends=('bash' 'glibc' 'libarchive' 'curl'
'gpgme' 'pacman-mirrorlist' 'archlinuxarm-keyring')
makedepends=('asciidoc')
checkdepends=('python2' 'fakechroot')
optdepends=('perl-locale-gettext: translation support in makepkg-template'
'xdelta3: delta support in repo-add')
checkdepends=('python' 'fakechroot')
optdepends=('perl-locale-gettext: translation support in makepkg-template')
provides=('libalpm.so')
backup=(etc/pacman.conf
etc/makepkg.conf)
options=('strip' 'debug')
@ -33,17 +33,15 @@ source=(https://sources.archlinux.org/other/pacman/$pkgname-$pkgver.tar.gz{,.sig
0001-Sychronize-filesystem.patch
0002-Revert-close-stdin-before-running-install-scripts.patch
0003-Revert-alpm_run_chroot-always-connect-parent2child-p.patch
0004-Support-application-gzip-MIME-type-in-extraction.patch
pacman.conf
makepkg.conf)
sha256sums=('10db61a0928d619871340c3f93a677d1541d6c52353c516aec4f8d96e830d4eb'
sha256sums=('4df564447abba9236e0ad3228b781a95f6375a96693b9ae6558dc144b6ecb440'
'SKIP'
'9ac4ded74073b9cba6e977ce44ae51110e4084b49945c999aa4d1e4954517b8d'
'8da873b8ce3b8c4878d29b9ec891aeccbbf8d8d4bf1a239560a006700949296f'
'b9461112d857a897cde4e64a2eee6b5a1dfca29422d14c41a3b248e0d9215561'
'610cea75cc3a0a89fbce3d72a54866d7ebd9d4d692c9c3b6d1d1a15b9ec76a1c'
'd55cd09eda56a0f19dfba8a042056fdf8d8d441d2c218fddaa30c1546a703532'
'edc48d8a6c051d50241fa727e948a06ece8890d9d9da80573f8894a3bf455d36')
'187bef40b14461ef7caba83e8124b6725e0cc9d46fa84353dae3b2afdc013589'
'83597d3092edb2414d3b1a3e2e7337c0edcf102636a5884f3d3f3755fdceb2b0'
'6e6434d123dd57961922627b39d967de384e3902a041e12dfc077081552fec28'
'7210ba34cc95650425b9be1e9f87f77637348b8bd77c8cb68ab293ac08871aee'
'f187a5919f06c6e3d3e67f2d4b9ac14217accaae1ce7e226ff133bcbfde3f03d')
prepare() {
cd "$pkgname-$pkgver"
@ -51,7 +49,6 @@ prepare() {
patch -p1 -i ../0001-Sychronize-filesystem.patch
patch -p1 -i ../0002-Revert-close-stdin-before-running-install-scripts.patch
patch -p1 -i ../0003-Revert-alpm_run_chroot-always-connect-parent2child-p.patch
patch -p1 -i ../0004-Support-application-gzip-MIME-type-in-extraction.patch
}
build() {
@ -106,14 +103,7 @@ package() {
-e "s|@CHOST[@]|$mychost|g" \
-e "s|@CARCHFLAGS[@]|$myflags|g"
sed -i $pkgdir/etc/pacman.conf -e "s|@CARCH[@]|$mycarch|g"
[[ $CARCH == "arm" ]] && sed -i 's/,-z,now//' "$pkgdir/etc/makepkg.conf"
# put bash_completion in the right location
install -dm755 "$pkgdir/usr/share/bash-completion/completions"
mv "$pkgdir/etc/bash_completion.d/pacman" "$pkgdir/usr/share/bash-completion/completions"
rmdir "$pkgdir/etc/bash_completion.d"
for f in makepkg pacman-key; do
ln -s pacman "$pkgdir/usr/share/bash-completion/completions/$f"
done
if [[ $CARCH == "arm" ]]; then
sed -i 's/,-z,now//' "$pkgdir/etc/makepkg.conf"
fi
}

View file

@ -132,16 +132,16 @@ DBGSRCDIR="/usr/src/debug"
COMPRESSGZ=(gzip -c -f -n)
COMPRESSBZ2=(bzip2 -c -f)
COMPRESSXZ=(xz -c -z -)
COMPRESSZST=(zstd -c -z -q -)
COMPRESSLRZ=(lrzip -q)
COMPRESSLZO=(lzop -q)
COMPRESSZ=(compress -c -f)
COMPRESSLZ4=(lz4 -q)
COMPRESSLZ=(lzip -c -f)
#########################################################################
# EXTENSION DEFAULTS
#########################################################################
#
# WARNING: Do NOT modify these variables unless you know what you are
# doing.
#
PKGEXT='.pkg.tar.xz'
SRCEXT='.src.tar.gz'

View file

@ -19,7 +19,6 @@ HoldPkg = pacman glibc
#XferCommand = /usr/bin/curl -L -C - -f -o %o %u
#XferCommand = /usr/bin/wget --passive-ftp -c -O %o %u
#CleanMethod = KeepInstalled
#UseDelta = 0.7
Architecture = @CARCH@
# Pacman won't upgrade packages listed in IgnorePkg and members of IgnoreGroup