aur updates

This commit is contained in:
Kevin Mihelich 2013-10-11 17:15:47 +00:00
parent 07260603bc
commit 0aef3758c5
19 changed files with 156 additions and 226 deletions

View file

@ -2,14 +2,14 @@
# Contributor: Lothar Gesslein <ulmen@cryptomilch.de>
pkgname=aoetools
pkgver=35
pkgver=36
pkgrel=1
pkgdesc="ATA over Ethernet Tools"
arch=('i686' 'x86_64')
url="http://aoetools.sourceforge.net/"
license=('GPL')
source=(http://downloads.sourceforge.net/$pkgname/$pkgname-$pkgver.tar.gz)
sha256sums=('837684fd8c5ccd15ce82d8e01e5e68e59b3045df200d5d68dc09f458baf33c7c')
sha256sums=('fb5e2cd0de7644cc1ec04ee3aeb43211cf7445a0c19e13d6b3ed5a8fbdf215ff')
build() {
cd ${srcdir}/$pkgname-$pkgver

View file

@ -6,17 +6,16 @@
# Contributor: Simon Perry <aur [at] sanxion [dot] net>
pkgname=dropbear
pkgver=2013.58
pkgrel=4
pkgver=2013.59
pkgrel=1
pkgdesc="Lightweight replacement for sshd"
arch=('i686' 'x86_64')
url="http://matt.ucc.asn.au/dropbear/dropbear.html"
install=${pkgname}.install
license=('MIT')
depends=('zlib')
source=(http://matt.ucc.asn.au/$pkgname/releases/$pkgname-$pkgver.tar.bz2
$pkgname.service)
sha256sums=('d866189b1d14e15353aeb4feb616f6132a63ea7c25ca8aa12b63a3a397822e55'
sha256sums=('5e09d773bc4ed4ee904cfa253ab3ac9cd180bf6cdf62475e610bae41dbeb499f'
'1920dc2d9a1dd86b3137ae4348196f9b95142d6eee484ee536bc7dfed7f0def0')
build() {
@ -24,24 +23,20 @@ build() {
sed -i 's|usr/libexec/sftp|usr/lib/ssh/sftp|' options.h
./configure --prefix=/usr --sbindir=/usr/bin
LIBS="-lcrypt" make
./configure --prefix=/usr --bindir=/usr/bin --sbindir=/usr/bin
make
}
package() {
cd ${srcdir}/$pkgname-$pkgver
make prefix=${pkgdir}/usr sbindir=${pkgdir}/usr/bin install
DESTDIR=${pkgdir} make install
#man pages
install -D -m644 dbclient.1 ${pkgdir}/usr/share/man/man1/dbclient.1
install -D -m644 $pkgname.8 ${pkgdir}/usr/share/man/man8/$pkgname.8
install -D -m644 dropbearkey.8 ${pkgdir}/usr/share/man/man8/dropbearkey.8
#configuration files
# Configuration files
install -d ${pkgdir}/etc/$pkgname
install -D -m644 ${srcdir}/$pkgname.service ${pkgdir}/usr/lib/systemd/system/$pkgname.service
#license file
# License file
install -D -m644 LICENSE ${pkgdir}/usr/share/licenses/$pkgname/LICENSE
}

View file

@ -1,10 +0,0 @@
post_upgrade() {
cat << _EOF
* IMPORTANT: Location of the dropbear binary has changed
* from /usr/sbin to /usr/bin
_EOF
}

View file

@ -2,43 +2,32 @@
# Maintainer: Nathan Owe <ndowens.aur at gmail dot com>
pkgname=flexget
_pkgname=FlexGet
pkgver=1.1.83
pkgver=1.1.99
pkgrel=1
pkgdesc="Automate downloading or processing content (torrents, podcasts, etc.)"
arch=(any)
url="http://flexget.com/"
license=('MIT')
depends=('python2'
# documented in FlexGet.egg-info/requires.txt
'python2-beautifulsoup3>=3.2'
'python2-beautifulsoup4>=4.2.1'
'python2-cherrypy'
'python2-dateutil>2.0'
'python2-feedparser>=5.1.3'
'python2-flask'
'python2-html5lib>=0.11'
'python2-jinja'
'python2-jsonschema>=2.0' #AUR#
'python2-progressbar'
'python2-pynzb' #AUR#
'python2-pyrss2gen' #AUR#
'python2-requests>=1.0'
'python2-sqlalchemy-0.7.9' #AUR# # support current 0.8.x someday? FIXME
'python2-tvrage' #AUR#
'python2-yaml'
# undocumented in FlexGet.egg-info/requires.txt
'python2-certifi>=0.0.7' #AUR# # possibly required by python2-requests
#'python2-chardet>=1.0.0' # reason? imdb_lookup.py says installing it might help...
)
optdepends=('python2-guppy: for memusage plugin' #AUR#
'python2-transmissionrpc: Transmission support' #AUR#
)
depends=('python2' 'python2-cherrypy' 'python2-progressbar'
'python2-pynzb' 'python2-pyrss2gen' 'python2-sqlalchemy-0.7.9'
'python2-html5lib' 'python2-beautifulsoup4'
'python2-beautifulsoup3>=3.2' 'python2-yaml' 'python2-feedparser'
'python2-flask' 'python2-requests' 'python2-certifi>=0.0.7'
'python2-chardet>=1.0.0' 'python2-dateutil' 'python2-tvrage'
'python2-jsonschema')
optdepends=('pytransmissionrpc: Transmission support')
makedepends=('python2-distribute')
source=("http://download.flexget.com/${_pkgname}-${pkgver}.tar.gz")
md5sums=('2c90f9207f46b8fc9d1ed21befd441ed')
license=('MIT')
#install=('flexget.install')
source=("http://download.flexget.com/archive/${_pkgname}-${pkgver}.tar.gz")
package() {
cd "${srcdir}/${_pkgname}-${pkgver}"
python2 setup.py install --root="${pkgdir}/" optimize=1
install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
cd "${srcdir}/${_pkgname}-${pkgver}"
python2 setup.py install --root=${pkgdir}/ optimize=1
chmod ugo+r ${pkgdir}/usr/lib/python2.7/site-packages/FlexGet-1.1-py2.7.egg-info/*
install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}
md5sums=('63d86d83b4274dbfe6f597925f938bab')

View file

@ -3,15 +3,16 @@
pkgname=gmrender-resurrect-git
_gitname=gmrender-resurrect
pkgver=20130725
pkgver=260.6d66c7b
pkgrel=1
pkgdesc="Application to stream music from a UPnP server using gstreamer."
arch=('any')
url="https://github.com/hzeller/gmrender-resurrect"
license=('GPL2')
conflicts=('gmediarender')
depends=('gnome-icon-theme' 'gstreamer0.10-ffmpeg' 'gstreamer0.10-base-plugins' 'gstreamer0.10-good-plugins' 'gstreamer0.10-bad-plugins' 'gstreamer0.10-ugly-plugins')
depends=('gnome-icon-theme' 'gst-libav' 'gst-plugins-base' 'gst-plugins-good' 'gst-plugins-bad' 'gst-plugins-ugly')
makedepends=('git' 'autoconf' 'automake' 'libtool' 'libxml2' 'libupnp')
backup=(etc/conf.d/gmediarender)
install='gmrender-resurrect.install'
source=('git+https://github.com/hzeller/gmrender-resurrect.git'
'gmediarender.service'

View file

@ -1,24 +1,37 @@
# Maintainer: Jerome Leclanche <jerome.leclanche+arch@gmail.com>
# Maintainer: Dobroslaw Kijowski [dobo] <dobo90_at_gmail.com>
# Contributor: Jerome Leclanche <jerome.leclanche+arch@gmail.com>
pkgname=lightdm-razor-greeter
pkgver=0.5.2
pkgrel=1
pkgdesc="The Razor-qt LightDM greeter"
url="http://razor-qt.org"
arch=('i686' 'x86_64')
license="GPL2"
depends=('qt4' 'liblightdm-qt4' 'razor-qt')
makedepends=('cmake')
source=("http://razor-qt.org/downloads/razorqt-$pkgver.tar.bz2")
sha256sums=('ac8a890eba7a24a20a2c0ea7a5020c6001853997c1e1b1b927ff4700b0e0e1ad')
pkgrel=2
pkgdesc='The Razor-qt LightDM greeter'
url='http://razor-qt.org'
arch=(i686 x86_64)
license=(GPL2)
depends=(liblightdm-qt4 razor-qt)
makedepends=(cmake)
source=(http://razor-qt.org/downloads/razorqt-${pkgver}.tar.bz2
liblightdm-qt-3.patch)
md5sums=(8b2da8ab69065926bfc998cf1960bffb
cb8c2521110dae53e6211f484fc60992)
prepare() {
patch -p0 < liblightdm-qt-3.patch
}
build() {
cd "$srcdir/razorqt-$pkgver"
cmake ./ -DCMAKE_INSTALL_PREFIX=/usr -DSPLIT_BUILD=On -DMODULE_LIGHTDM=On
make
cd ${srcdir}/razorqt-${pkgver}
mkdir build
cd build
cmake ../ -DCMAKE_INSTALL_PREFIX=/usr -DQT_QMAKE_EXECUTABLE=qmake-qt4 -DLIB_SUFFIX="" \
-DSPLIT_BUILD=ON -DMODULE_LIGHTDM=ON
make
}
package() {
cd "$srcdir/razorqt-$pkgver"
make DESTDIR="${pkgdir}" install
cd ${srcdir}/razorqt-${pkgver}/build
make DESTDIR=${pkgdir} install
}

View file

@ -0,0 +1,16 @@
diff -rupN razorqt-0.5.2/razorqt-lightdm-greeter/CMakeLists.txt razorqt-0.5.2p/razorqt-lightdm-greeter/CMakeLists.txt
--- razorqt-0.5.2/razorqt-lightdm-greeter/CMakeLists.txt 2013-01-12 17:45:52.000000000 +0100
+++ razorqt-0.5.2p/razorqt-lightdm-greeter/CMakeLists.txt 2013-10-11 13:22:28.000000000 +0200
@@ -24,7 +24,11 @@ include ( ${QT_USE_FILE} )
# check for new version
include(FindPkgConfig)
message(STATUS "Checking for lightdm-qt...")
-pkg_check_modules(LIGHTDM_QT liblightdm-qt-2)
+pkg_check_modules(LIGHTDM_QT liblightdm-qt-3)
+if (NOT LIGHTDM_QT_FOUND)
+ message(STATUS "lightdm3 for Qt is not found. Trying to find v2")
+ pkg_check_modules(LIGHTDM_QT liblightdm-qt-2)
+endif()
# or lightdm v1 if the version 2 is not found
if (NOT LIGHTDM_QT_FOUND)
message(STATUS "lightdm2 for Qt is not found. Trying to find v1")

View file

@ -1,9 +1,9 @@
# Contributor: Johannes Dewender arch at JonnyJD dot net
pkgname=lio-utils
pkgver=4.1
pkgrel=9
pkgrel=10
epoch=
pkgdesc="a simple low-level configuration tool set for LIO (Target and iSCSI)"
pkgdesc="deprecated low-level configuration tool set for LIO (Target and iSCSI)"
arch=('i686' 'x86_64')
url="http://linux-iscsi.org/wiki/Lio-utils"
license=('GPL2')

View file

@ -2,37 +2,46 @@
# Contributor: Dincer Celik <dincer@bornovali.com>
pkgname=localepurge
pkgver=0.6.3
pkgrel=3
pkgver=0.7.3
pkgrel=1
pkgdesc="Script to remove disk space wasted for unneeded localizations."
arch=('any')
url="http://packages.debian.org/source/sid/localepurge"
license=('GPL')
backup=('etc/locale.nopurge')
source=("http://ftp.de.debian.org/debian/pool/main/l/localepurge/${pkgname}_${pkgver}.tar.gz"
"http://fgr.bitbucket.org/im/localepurge-arch/${pkgname}.patch"
"http://fgr.bitbucket.org/im/localepurge-arch/${pkgname}.8.patch"
"http://fgr.bitbucket.org/im/localepurge-arch/${pkgname}.config.patch"
"http://fgr.bitbucket.org/im/localepurge-arch/locale.nopurge")
sha256sums=('02f7e4a8b5919221a736abb3a937dffc48ffd275f0968e56612d518e1e69c30b'
'84b8abf57a1af27e5b50fcd5a12701a5980d85a187c5a3b3e3c3e5a79e28886d'
'e899dd39536f854b94fea9f72a38e1f50b255a35f80e1c1e811612603126e80a'
'1cf4c0e9651589502f953ae25654e5b5347de18995055adfb7a6d183a1c4c912'
'b9c28be93fa47d4f0315972159e501d9eef28bbab7ffe6e8e7c4a13c359f35e8')
"http://fgr.bitbucket.org/im/localepurge-arch/${pkgname}.diff"
"http://fgr.bitbucket.org/im/localepurge-arch/${pkgname}.8.diff"
"http://fgr.bitbucket.org/im/localepurge-arch/${pkgname}.config.diff"
"http://fgr.bitbucket.org/im/localepurge-arch/locale.nopurge")
build()
prepare()
{
patch -uN ${srcdir}/${pkgname}/usr/sbin/localepurge < ${srcdir}/localepurge.patch
patch -uN ${srcdir}/${pkgname}/debian/localepurge.8 < ${srcdir}/localepurge.8.patch
patch -uN ${srcdir}/${pkgname}/debian/localepurge.config < ${srcdir}/localepurge.config.patch
install -D -m755 ${srcdir}/${pkgname}/usr/sbin/localepurge ${pkgdir}/usr/bin/localepurge
install -D -m644 ${srcdir}/${pkgname}/debian/localepurge.8 ${pkgdir}/usr/share/man/man8/localepurge.8
install -D -m755 ${srcdir}/${pkgname}/debian/localepurge.config ${pkgdir}/usr/bin/localepurge-config
install -D -m644 locale.nopurge ${pkgdir}/etc/locale.nopurge
if [ ! -e /var/cache/localepurge/localelist ]; then
find /usr/share/locale -maxdepth 1 -type d -name "*" -printf "%f\n" | grep "^[a-z]" | cut -d" " -f1 | sort -u > ${srcdir}/localelist
else
cp /var/cache/localepurge/localelist ${srcdir}/localelist
fi
install -D -m644 ${srcdir}/localelist ${pkgdir}/var/cache/localepurge/localelist
patch -uN ${srcdir}/${pkgname}/usr/sbin/localepurge < ${srcdir}/localepurge.diff
patch -uN ${srcdir}/${pkgname}/debian/localepurge.8 < ${srcdir}/localepurge.8.diff
patch -uN ${srcdir}/${pkgname}/debian/localepurge.config < ${srcdir}/localepurge.config.diff
}
package()
{
install -D -m755 ${srcdir}/${pkgname}/usr/sbin/localepurge ${pkgdir}/usr/bin/localepurge
install -D -m644 ${srcdir}/${pkgname}/debian/localepurge.8 ${pkgdir}/usr/share/man/man8/localepurge.8
install -D -m755 ${srcdir}/${pkgname}/debian/localepurge.config ${pkgdir}/usr/bin/localepurge-config
install -D -m644 locale.nopurge ${pkgdir}/etc/locale.nopurge
if [ ! -e /var/cache/localepurge/localelist ]; then
find /usr/share/locale -maxdepth 1 -type d -name "*" -printf "%f\n" | grep "^[a-z]" | cut -d" " -f1 | sort -u > ${srcdir}/localelist
else
cp /var/cache/localepurge/localelist ${srcdir}/localelist
fi
install -D -m644 ${srcdir}/localelist ${pkgdir}/var/cache/localepurge/localelist
}
sha256sums=('1e5f569c8d5e3d09bf51128f11ebe7c80bccd785b0c028e949df21347ed135f7'
'84b8abf57a1af27e5b50fcd5a12701a5980d85a187c5a3b3e3c3e5a79e28886d'
'82bd40594ef0646465eed6e525368e87694322513c0d3280879fcfc5c40cb6a7'
'dbed1ae1f1514f14c00fdb48d09ac8cd3407dbc3f1a1fed84f1e8735da1f9678'
'b9c28be93fa47d4f0315972159e501d9eef28bbab7ffe6e8e7c4a13c359f35e8')
sha256sums=('1e5f569c8d5e3d09bf51128f11ebe7c80bccd785b0c028e949df21347ed135f7'
'b8704eec22d0e84ada9a524277322f9892c11f3f4b84ec0dd4f50f0ca2dc7474'
'82bd40594ef0646465eed6e525368e87694322513c0d3280879fcfc5c40cb6a7'
'dbed1ae1f1514f14c00fdb48d09ac8cd3407dbc3f1a1fed84f1e8735da1f9678'
'b9c28be93fa47d4f0315972159e501d9eef28bbab7ffe6e8e7c4a13c359f35e8')

View file

@ -1,33 +1,26 @@
# Maintainer: Kyle Keen <keenerd@gmail.com>
# Contributor: Gilrain <pierre.buard+aur gmail com>
pkgname=packer
pkgver=20120302
pkgver=9e61bd1
pkgrel=1
pkgdesc="Bash wrapper for pacman and aur"
url="http://github.com/keenerd/packer"
license="GPL"
license="GPL3"
arch=('any')
makedepends=('git')
depends=('grep' 'sed' 'bash' 'curl' 'pacman' 'jshon')
depends=('grep' 'sed' 'bash' 'curl' 'pacman' 'jshon' 'expac')
optdepends=('sudo: install and update packages as non-root'
'customizepkg: apply customizepkg modifications')
_gitroot='https://github.com/keenerd/packer.git'
_gitname='packer'
source=('git://github.com/keenerd/packer.git')
md5sums=('SKIP')
build() {
cd "$srcdir"
msg "Connecting to github GIT server...."
if [ -d "$srcdir/$_gitname" ] ; then
cd $_gitname && git pull origin
else
git clone "$_gitroot"
cd $_gitname
fi
mkdir -p "$pkgdir/usr/bin/"
mkdir -p "$pkgdir/usr/share/man/man8/"
install -m 755 packer "$pkgdir/usr/bin/packer"
install -m 644 packer.8 "$pkgdir/usr/share/man/man8/packer.8"
pkgver() {
cd "$pkgname"
git describe --always | sed 's|-|.|g'
}
package() {
install -Dm755 "$srcdir/$pkgname/packer" "$pkgdir/usr/bin/packer"
install -Dm644 "$srcdir/$pkgname/packer.8" "$pkgdir/usr/share/man/man8/packer.8"
}

View file

@ -2,38 +2,35 @@
# Maintainer: Steven Allen <steven@stebalien.com>
_pkgname=pithos
pkgname=pithos-git
pkgver=294.759fd22
pkgver(){
cd "$srcdir/$_pkgname"
echo $(git rev-list --count master).$(git rev-parse --short master)
}
epoch=1
pkgname=$_pkgname-git
pkgver=308
pkgrel=1
epoch=1
pkgdesc='Pandora Internet Radio player for GNOME'
arch=('any')
url="http://kevinmehall.net/p/pithos/"
license=('GPL3')
depends=('python2' 'pygtk' 'python2-notify' 'python2-dbus' 'gstreamer0.10-python' 'gstreamer0.10-good-plugins' 'gstreamer0.10-bad-plugins' 'gstreamer0.10-base-plugins' 'python2-xdg' 'hicolor-icon-theme')
makedepends=('git' 'python2-distribute' 'python2-distutils-extra')
makedepends=('git' 'python2-setuptools' 'python2-distutils-extra')
optdepends=('python2-keybinder2: for media keys plugin'
'gstreamer0.10-ugly-plugins: MP3 playback support')
provides=("$_pkgname")
conflicts=("$_pkgname-bzr" "$_pkgname")
install="$pkgname.install"
source=("git://github.com/kevinmehall/pithos.git")
md5sums=('SKIP')
source=("$pkgname.install" "git://github.com/kevinmehall/pithos.git")
build() {
pkgver() {
cd "$srcdir/$_pkgname"
python2 setup.py build
git rev-list HEAD --count
}
package() {
cd "$srcdir/$_pkgname"
python2 setup.py install --prefix=/usr --root="${pkgdir}/"
python2 setup.py install --optimize=1 --prefix=/usr --root="${pkgdir}"
}
md5sums=('c9db50a1fd3d86efe4d6f8a7b044e718'
'SKIP')
# vim:set ts=2 sw=2 et:

View file

@ -1,19 +1,19 @@
# Contributor: Johannes Dewender arch at JonnyJD dot net
pkgname=python2-configshell-fb
_pkgname=configshell-fb
pkgver=1.1.fb8
pkgrel=1
pkgver=1.1.fb9
pkgrel=3
epoch=
pkgdesc="python framework for building simple CLI applications (free branch)"
arch=('any')
url="https://github.com/agrover/configshell-fb"
license=('Apache')
depends=('python2-simpleparse' 'python2-urwid')
depends=('python2-pyparsing' 'python2-urwid')
provides=('python2-configshell')
conflicts=('python2-configshell')
options=()
source=($_pkgname-$pkgver.tar.gz::https://github.com/agrover/$_pkgname/archive/v$pkgver.tar.gz)
md5sums=('1ad1f82df8d3199a28042921bd7516d2')
source=(https://fedorahosted.org/releases/t/a/targetcli-fb/$_pkgname-$pkgver.tar.gz)
md5sums=('48b7c9be66c9e450585598504c2fde45')
build() {
cd "$srcdir/$_pkgname-$pkgver"

View file

@ -1,12 +1,12 @@
# Contributor: Johannes Dewender arch at JonnyJD dot net
pkgname=python2-configshell
pkgver=1.1
pkgrel=5
pkgver=1.2
pkgrel=1
epoch=
pkgdesc="python framework for building simple CLI-based applications"
arch=('any')
url="http://www.risingtidesystems.com/git/?p=configshell.git;a=summary"
license=('AGPL3')
license=('Apache')
depends=('python2-simpleparse' 'python2-urwid' 'epydoc')
provides=()
conflicts=()
@ -18,7 +18,7 @@ _pkgname=configshell
build() {
if [ ! -e "$_pkgname-$pkgver.tgz" ]; then
curl -flC - "http://www.risingtidesystems.com/git/?p=$_pkgname.git;a=snapshot;h=3ba5560219d7ae8545ce825f4ba778b5c2c90893;sf=tgz" -o "$_pkgname-$pkgver.tgz"
curl -flC - "http://www.risingtidesystems.com/git/?p=$_pkgname.git;a=snapshot;h=5fcb00e77153b6a9e188c00a06d88783e7d273f7;sf=tgz" -o "$_pkgname-$pkgver.tgz"
fi
bsdtar -xf "$srcdir/$_pkgname-$pkgver.tgz"
cd "$srcdir/$_pkgname"

View file

@ -1,7 +1,7 @@
# Contributor: Johannes Dewender arch at JonnyJD dot net
pkgname=python2-rtslib
pkgver=2.2
pkgrel=1
pkgrel=2
epoch=
pkgdesc="RisingTide Systems generic SCSI target API in python"
arch=('any')
@ -18,7 +18,7 @@ _pkgname=rtslib
build() {
if [ ! -e "$_pkgname-$pkgver.tgz" ]; then
curl -fLC - "http://www.risingtidesystems.com/git/?p=$_pkgname.git;a=snapshot;h=c4ba14ff21f68e56d6a3a227a0220d1a6b6df958;sf=tgz" -o "$_pkgname-$pkgver.tgz"
curl -fLC - "http://www.risingtidesystems.com/git/?p=$_pkgname.git;a=snapshot;h=909a40c908247135f30b27eb5d69b292aeedd0b4;sf=tgz" -o "$_pkgname-$pkgver.tgz"
fi
bsdtar -xf "$srcdir/$_pkgname-$pkgver.tgz"

View file

@ -2,7 +2,7 @@
pkgname=python2-transmissionrpc
pkgver=0.10
pkgrel=1
pkgrel=2
pkgdesc="Module to communicate with Transmission BT client via JSON-RPC"
arch=(any)
url="https://bitbucket.org/blueluna/transmissionrpc/wiki/Home"

View file

@ -1,6 +1,6 @@
pkgname=sabnzbd
_pkgname=SABnzbd
pkgver=0.7.14
pkgver=0.7.16
pkgrel=1
pkgdesc="A web-interface based binary newsgrabber with NZB file support"
url="http://www.sabnzbd.org"
@ -14,7 +14,7 @@ install="${pkgname}.install"
backup=("etc/conf.d/sabnzbd" "opt/${pkgname}/${pkgname}.ini")
source=("http://downloads.sourceforge.net/sabnzbdplus/${_pkgname}-${pkgver}-src.tar.gz"
"${pkgname}" "${pkgname}.desktop" "addnzb.sh" "nzb-2.png" "sab2_64.png" "x-nzb.xml" "${pkgname}.service" "${pkgname}.confd")
md5sums=('69421a6d05fde2f69bf69f8b7c1c97e4'
md5sums=('13f7ff753e22e81fa6f7efab8c3c7213'
'48d60a1c626503c7fef1bc5374390513'
'f9bd5485072714b11f8c30a28024dc4d'
'69b9bcbcf67ff3e7a4cdd9f26e001341'

View file

@ -1,72 +0,0 @@
#!/bin/bash
. /etc/rc.conf
. /etc/rc.d/functions
. /etc/conf.d/sabnzbd
PID="$(pgrep -f -u "${SABNZBD_USER}" SABnzbd.py)"
case "${1}" in
start)
stat_busy "Starting SABnzbd"
if [ -f /run/daemons/sabnzbd ]; then
echo -n "Sabnzbd is already running as a daemon! If you are certain it is not running, remove /run/daemons/sabnzbd."
stat_fail
else
su - "${SABNZBD_USER}" -c "python2 ${SABNZBD_DIR}/SABnzbd.py ${SABNZBD_ARGS}" -s /bin/sh
if [ "${?}" -gt 0 ]; then
stat_fail
exit 1
else
add_daemon sabnzbd
stat_done
fi
fi
;;
stop)
stat_busy "Stopping SABnzbd"
curl -f "${SABNZBD_PROTOCOL}://${SABNZBD_USPW}${SABNZBD_IP}:${SABNZBD_PORT}/sabnzbd/api?mode=shutdown&apikey=${SABNZBD_KEY}" &> /dev/null
if [ "${?}" -gt 0 ]; then
stat_fail
exit 1
else
rm_daemon sabnzbd
stat_done
fi
;;
force-stop)
stat_busy "Stopping SABnzbd (forced)"
[ -n "${PID}" ]; kill "${PID}" &> /dev/null
if [ "${?}" -gt 0 ]; then
stat_fail
exit 1
else
[ -f /run/daemons/sabnzbd ]; rm -f /run/daemons/sabnzbd &> /dev/null
rm_daemon sabnzbd
stat_done
fi
;;
restart)
"${0}" stop
sleep 1
"${0}" start
;;
force-restart)
"${0}" force-stop
sleep 1
"${0}" start
;;
status)
stat_busy "Checking SABnzbd status";
ck_status sabnzbd
;;
*)
echo "usage: ${0} {start|stop|restart|force-stop|force-restart|status}"
esac
exit 0

View file

@ -1 +0,0 @@
d /run/sabnzbd 0755 sabnzbd sabnzbd -

View file

@ -1,7 +1,7 @@
# Contributor: Johannes Dewender arch at JonnyJD dot net
pkgname=targetcli
pkgver=2.1
pkgrel=1
pkgrel=2
epoch=
pkgdesc="The targetcli administration shell."
arch=('any')
@ -19,7 +19,7 @@ md5sums=()
build() {
if [ ! -e "$pkgname-$pkgver.tgz" ]; then
curl -fLC - "http://www.risingtidesystems.com/git/?p=$pkgname.git;a=snapshot;h=95cdcb7dd669d840d14bd099d68fce4dcdc9cc64;sf=tgz" -o "$pkgname-$pkgver.tgz"
curl -fLC - "http://www.risingtidesystems.com/git/?p=$pkgname.git;a=snapshot;h=a7c313ce9810a0b178e0e8cfaf5ffc22d8868e30;sf=tgz" -o "$pkgname-$pkgver.tgz"
fi
bsdtar -xf "$srcdir/$pkgname-$pkgver.tgz"
cd "$srcdir/$pkgname"