alarm/omxplayer-git to 511.2ee17b2-1

This commit is contained in:
Kevin Mihelich 2017-11-15 01:45:39 +00:00
parent 7a1aacd79b
commit 0af239f45e
2 changed files with 25 additions and 70 deletions

View file

@ -1,31 +1,30 @@
From f8fbb3661bbb1861fab47b73e574378bfeb4c08a Mon Sep 17 00:00:00 2001 From 40bb25f8a0d66fad462d3f12f50873652adf54b9 Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org> From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Wed, 24 Sep 2014 08:47:14 -0600 Date: Wed, 24 Sep 2014 08:47:14 -0600
Subject: [PATCH] alarm fixes Subject: [PATCH] alarm fixes
--- ---
Makefile | 30 ++++++++++-------------------- Makefile | 31 +++++++++----------------------
Makefile.include | 44 ++++---------------------------------------- omxplayer.cpp | 4 ++--
omxplayer.cpp | 4 ++-- 2 files changed, 11 insertions(+), 24 deletions(-)
3 files changed, 16 insertions(+), 62 deletions(-)
diff --git a/Makefile b/Makefile diff --git a/Makefile b/Makefile
index 2857e94..2638e07 100644 index 5f4e414..cb836a5 100644
--- a/Makefile --- a/Makefile
+++ b/Makefile +++ b/Makefile
@@ -2,9 +2,9 @@ include Makefile.include @@ -2,9 +2,9 @@ CFLAGS=-pipe -mfloat-abi=hard -mcpu=arm1176jzf-s -fomit-frame-pointer -mabi=aapc
CFLAGS+=-std=c++0x -D__STDC_CONSTANT_MACROS -D__STDC_LIMIT_MACROS -DTARGET_POSIX -DTARGET_LINUX -fPIC -DPIC -D_REENTRANT -D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64 -DHAVE_CMAKE_CONFIG -D__VIDEOCORE4__ -U_FORTIFY_SOURCE -Wall -DHAVE_OMXLIB -DUSE_EXTERNAL_FFMPEG -DHAVE_LIBAVCODEC_AVCODEC_H -DHAVE_LIBAVUTIL_OPT_H -DHAVE_LIBAVUTIL_MEM_H -DHAVE_LIBAVUTIL_AVUTIL_H -DHAVE_LIBAVFORMAT_AVFORMAT_H -DHAVE_LIBAVFILTER_AVFILTER_H -DHAVE_LIBSWRESAMPLE_SWRESAMPLE_H -DOMX -DOMX_SKIP64BIT -ftree-vectorize -DUSE_EXTERNAL_OMX -DTARGET_RASPBERRY_PI -DUSE_EXTERNAL_LIBBCM_HOST CFLAGS+=-std=c++0x -D__STDC_CONSTANT_MACROS -D__STDC_LIMIT_MACROS -DTARGET_POSIX -DTARGET_LINUX -fPIC -DPIC -D_REENTRANT -D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64 -DHAVE_CMAKE_CONFIG -D__VIDEOCORE4__ -U_FORTIFY_SOURCE -Wall -DHAVE_OMXLIB -DUSE_EXTERNAL_FFMPEG -DHAVE_LIBAVCODEC_AVCODEC_H -DHAVE_LIBAVUTIL_OPT_H -DHAVE_LIBAVUTIL_MEM_H -DHAVE_LIBAVUTIL_AVUTIL_H -DHAVE_LIBAVFORMAT_AVFORMAT_H -DHAVE_LIBAVFILTER_AVFILTER_H -DHAVE_LIBSWRESAMPLE_SWRESAMPLE_H -DOMX -DOMX_SKIP64BIT -ftree-vectorize -DUSE_EXTERNAL_OMX -DTARGET_RASPBERRY_PI -DUSE_EXTERNAL_LIBBCM_HOST
-LDFLAGS+=-L./ -Lffmpeg_compiled/usr/local/lib/ -lc -lWFC -lGLESv2 -lEGL -lbcm_host -lopenmaxil -lfreetype -lz -lasound LDFLAGS=-L$(SDKSTAGE)/opt/vc/lib/
+LDFLAGS+=-L./ -lc -lWFC -lGLESv2 -lEGL -lbcm_host -lopenmaxil -lfreetype -lz -lasound -LDFLAGS+=-L./ -Lffmpeg_compiled/usr/local/lib/ -lc -lbrcmGLESv2 -lbrcmEGL -lbcm_host -lopenmaxil -lfreetype -lz -lasound
+LDFLAGS+=-L./ -lc -lbrcmGLESv2 -lbrcmEGL -lbcm_host -lopenmaxil -lfreetype -lz -lasound
-INCLUDES+=-I./ -Ilinux -Iffmpeg_compiled/usr/local/include/ -I /usr/include/dbus-1.0 -I /usr/lib/arm-linux-gnueabihf/dbus-1.0/include -INCLUDES+=-I./ -Ilinux -Iffmpeg_compiled/usr/local/include/ -I /usr/include/dbus-1.0 -I /usr/lib/arm-linux-gnueabihf/dbus-1.0/include -I/usr/include/freetype2 -isystem$(SDKSTAGE)/opt/vc/include -isystem$(SDKSTAGE)/opt/vc/include/interface/vcos/pthreads
+INCLUDES+=-I./ -Ilinux +INCLUDES+=-I./ -Ilinux -I/usr/include/dbus-1.0 -I/usr/lib/dbus-1.0/include -I/usr/include/freetype2 -I/opt/vc/include
DIST ?= omxplayer-dist DIST ?= omxplayer-dist
STRIP ?= strip
@@ -40,7 +40,7 @@ SRC= linux/XMemUtils.cpp \ @@ -41,7 +41,7 @@ SRC= linux/XMemUtils.cpp \
OBJS+=$(filter %.o,$(SRC:.cpp=.o)) OBJS+=$(filter %.o,$(SRC:.cpp=.o))
@ -34,7 +33,7 @@ index 2857e94..2638e07 100644
%.o: %.cpp %.o: %.cpp
@rm -f $@ @rm -f $@
@@ -52,7 +52,7 @@ version: @@ -53,7 +53,7 @@ version:
bash gen_version.sh > version.h bash gen_version.sh > version.h
omxplayer.bin: version $(OBJS) omxplayer.bin: version $(OBJS)
@ -43,7 +42,7 @@ index 2857e94..2638e07 100644
$(STRIP) omxplayer.bin $(STRIP) omxplayer.bin
help.h: README.md Makefile help.h: README.md Makefile
@@ -75,19 +75,9 @@ clean: @@ -76,25 +76,12 @@ clean:
@rm -rf $(DIST) @rm -rf $(DIST)
@rm -f omxplayer-dist.tar.gz @rm -f omxplayer-dist.tar.gz
@ -63,63 +62,19 @@ index 2857e94..2638e07 100644
- cp omxplayer.1 $(DIST)/usr/share/man/man1 - cp omxplayer.1 $(DIST)/usr/share/man/man1
- cp -P ffmpeg_compiled/usr/local/lib/*.so* $(DIST)/usr/lib/omxplayer/ - cp -P ffmpeg_compiled/usr/local/lib/*.so* $(DIST)/usr/lib/omxplayer/
- cd $(DIST); tar -czf ../$(DIST).tgz * - cd $(DIST); tar -czf ../$(DIST).tgz *
+install: -
install:
- cp -r $(DIST)/* /
+ install -d $(DESTDIR)/usr/bin + install -d $(DESTDIR)/usr/bin
+ install -d $(DESTDIR)/usr/share/doc/omxplayer + install -d $(DESTDIR)/usr/share/doc/omxplayer
+ install omxplayer $(DESTDIR)/usr/bin/ + install omxplayer $(DESTDIR)/usr/bin/
+ install omxplayer.bin $(DESTDIR)/usr/bin/ + install omxplayer.bin $(DESTDIR)/usr/bin/
+ install README.md COPYING $(DESTDIR)/usr/share/doc/omxplayer/ + install README.md COPYING $(DESTDIR)/usr/share/doc/omxplayer/
diff --git a/Makefile.include b/Makefile.include
index 58e9560..4789f10 100644 uninstall:
--- a/Makefile.include rm -rf /usr/bin/omxplayer
+++ b/Makefile.include
@@ -1,40 +1,4 @@
-USE_BUILDROOT=0
-FLOAT=hard
-
-ifeq ($(USE_BUILDROOT), 1)
-BUILDROOT :=/opt/xbmc-bcm/buildroot
-SDKSTAGE :=$(BUILDROOT)/output/staging
-TARGETFS :=$(BUILDROOT)/output/target
-TOOLCHAIN :=$(BUILDROOT)/output/host/usr/
-HOST :=arm-unknown-linux-gnueabi
-SYSROOT :=$(BUILDROOT)/output/host/usr/arm-unknown-linux-gnueabi/sysroot
-else
-BUILDROOT :=/opt/bcm-rootfs
-SDKSTAGE :=/opt/bcm-rootfs
-TARGETFS :=/opt/bcm-rootfs
-TOOLCHAIN :=/home/dc4/tools/arm-bcm2708/gcc-linaro-arm-linux-gnueabihf-raspbian/
-HOST :=arm-linux-gnueabihf
-#SYSROOT :=$(TOOLCHAIN)/arm-bcm2708hardfp-linux-gnueabi/sysroot
-SYSROOT :=/opt/bcm-rootfs
-endif
-
-JOBS=7
-
-CFLAGS := -isystem$(PREFIX)/include
-CXXFLAGS := $(CFLAGS)
-CPPFLAGS := $(CFLAGS)
-LDFLAGS := -L$(BUILDROOT)/lib
-LD := $(TOOLCHAIN)/bin/$(HOST)-ld --sysroot=$(SYSROOT)
-CC := $(TOOLCHAIN)/bin/$(HOST)-gcc --sysroot=$(SYSROOT)
-CXX := $(TOOLCHAIN)/bin/$(HOST)-g++ --sysroot=$(SYSROOT)
-OBJDUMP := $(TOOLCHAIN)/bin/$(HOST)-objdump
-RANLIB := $(TOOLCHAIN)/bin/$(HOST)-ranlib
-STRIP := $(TOOLCHAIN)/bin/$(HOST)-strip
-AR := $(TOOLCHAIN)/bin/$(HOST)-ar
-CXXCP := $(CXX) -E
-PATH := $(PREFIX)/bin:$(BUILDROOT)/output/host/usr/bin:$(PATH)
-
-CFLAGS += -pipe -mfloat-abi=$(FLOAT) -mcpu=arm1176jzf-s -fomit-frame-pointer -mabi=aapcs-linux -mtune=arm1176jzf-s -mfpu=vfp -Wno-psabi -mno-apcs-stack-check -g -mstructure-size-boundary=32 -mno-sched-prolog
-LDFLAGS += -L$(SDKSTAGE)/lib -L$(SDKSTAGE)/usr/lib -L$(SDKSTAGE)/opt/vc/lib/ -Lpcre/build
-#INCLUDES += -isystem$(SDKSTAGE)/usr/include -isystem$(SDKSTAGE)/opt/vc/include -isystem$(SYSROOT)/usr/include -isystem$(SDKSTAGE)/opt/vc/include/interface/vcos/pthreads -isystem$(SDKSTAGE)/usr/include/freetype2
-INCLUDES += -isystem$(SDKSTAGE)/opt/vc/include -isystem$(SYSROOT)/usr/include -isystem$(SDKSTAGE)/opt/vc/include/interface/vcos/pthreads -Ipcre/build -Iboost-trunk -Ifreetype2/include
+STRIP := strip
+CFLAGS += -fomit-frame-pointer -mabi=aapcs-linux -mtune=arm1176jzf-s -Wno-psabi -mno-apcs-stack-check -g -mstructure-size-boundary=32 -mno-sched-prolog
+LDFLAGS += -L/opt/vc/lib/
+INCLUDES += -I/opt/vc/include -I/opt/vc/include/interface/vmcs_host/linux -I/opt/vc/include/interface/vcos/pthreads -I/usr/include/freetype2 -I/usr/include/dbus-1.0 -I/usr/lib/dbus-1.0/include
diff --git a/omxplayer.cpp b/omxplayer.cpp diff --git a/omxplayer.cpp b/omxplayer.cpp
index 428ccb6..6005439 100644 index bde4536..6f5329f 100644
--- a/omxplayer.cpp --- a/omxplayer.cpp
+++ b/omxplayer.cpp +++ b/omxplayer.cpp
@@ -83,8 +83,8 @@ bool m_osd = true; @@ -83,8 +83,8 @@ bool m_osd = true;
@ -134,5 +89,5 @@ index 428ccb6..6005439 100644
bool m_asked_for_font = false; bool m_asked_for_font = false;
bool m_asked_for_italic_font = false; bool m_asked_for_italic_font = false;
-- --
2.10.0 2.14.1

View file

@ -5,7 +5,7 @@
buildarch=20 buildarch=20
pkgname=omxplayer-git pkgname=omxplayer-git
pkgver=507.061425a pkgver=511.2ee17b2
pkgrel=1 pkgrel=1
pkgdesc="omxplayer is a command line media player for the RaspberryPi" pkgdesc="omxplayer is a command line media player for the RaspberryPi"
arch=('armv6h' 'armv7h') arch=('armv6h' 'armv7h')
@ -19,7 +19,7 @@ conflicts=('omxplayer' 'omxplayer-bin')
source=('git://github.com/popcornmix/omxplayer.git' source=('git://github.com/popcornmix/omxplayer.git'
'0001-alarm-fixes.patch') '0001-alarm-fixes.patch')
md5sums=('SKIP' md5sums=('SKIP'
'747cab115c7820ed6107925c63a5383b') 'ec889c9d5e4d361ab9b4248633e429da')
pkgver() { pkgver() {
cd omxplayer cd omxplayer