mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-03-09 00:17:31 +00:00
core/linux-armv5: update imx23-olinuxino.patch
This commit is contained in:
parent
8af39768ea
commit
0afcd25b0d
1 changed files with 30 additions and 30 deletions
|
@ -1,6 +1,6 @@
|
|||
diff -urN a/arch/arm/boot/dts/imx23-audio.dts b/arch/arm/boot/dts/imx23-audio.dts
|
||||
--- a/arch/arm/boot/dts/imx23-audio.dts 1969-12-31 17:00:00.000000000 -0700
|
||||
+++ b/arch/arm/boot/dts/imx23-audio.dts 2014-02-02 11:04:58.873165215 -0700
|
||||
+++ b/arch/arm/boot/dts/imx23-audio.dts 2014-04-03 21:01:23.800864540 -0600
|
||||
@@ -0,0 +1,153 @@
|
||||
+/*
|
||||
+ * Copyright 2012 Freescale Semiconductor, Inc.
|
||||
|
@ -156,8 +156,8 @@ diff -urN a/arch/arm/boot/dts/imx23-audio.dts b/arch/arm/boot/dts/imx23-audio.dt
|
|||
+ };
|
||||
+};
|
||||
diff -urN a/arch/arm/boot/dts/imx23.dtsi b/arch/arm/boot/dts/imx23.dtsi
|
||||
--- a/arch/arm/boot/dts/imx23.dtsi 2014-01-19 19:40:07.000000000 -0700
|
||||
+++ b/arch/arm/boot/dts/imx23.dtsi 2014-02-02 11:04:58.873165215 -0700
|
||||
--- a/arch/arm/boot/dts/imx23.dtsi 2014-03-30 21:40:15.000000000 -0600
|
||||
+++ b/arch/arm/boot/dts/imx23.dtsi 2014-04-03 21:01:23.800864540 -0600
|
||||
@@ -307,6 +307,39 @@
|
||||
fsl,voltage = <MXS_VOLTAGE_HIGH>;
|
||||
fsl,pull-up = <MXS_PULL_ENABLE>;
|
||||
|
@ -198,7 +198,7 @@ diff -urN a/arch/arm/boot/dts/imx23.dtsi b/arch/arm/boot/dts/imx23.dtsi
|
|||
};
|
||||
|
||||
digctl@8001c000 {
|
||||
@@ -378,7 +411,7 @@
|
||||
@@ -380,7 +413,7 @@
|
||||
reg = <0x80038000 0x2000>;
|
||||
status = "disabled";
|
||||
};
|
||||
|
@ -207,7 +207,7 @@ diff -urN a/arch/arm/boot/dts/imx23.dtsi b/arch/arm/boot/dts/imx23.dtsi
|
|||
|
||||
apbx@80040000 {
|
||||
compatible = "simple-bus";
|
||||
@@ -441,8 +474,14 @@
|
||||
@@ -443,8 +476,14 @@
|
||||
status = "disabled";
|
||||
};
|
||||
|
||||
|
@ -224,8 +224,8 @@ diff -urN a/arch/arm/boot/dts/imx23.dtsi b/arch/arm/boot/dts/imx23.dtsi
|
|||
dma-names = "rx-tx";
|
||||
status = "disabled";
|
||||
diff -urN a/arch/arm/boot/dts/imx23-olinuxino.dts b/arch/arm/boot/dts/imx23-olinuxino.dts
|
||||
--- a/arch/arm/boot/dts/imx23-olinuxino.dts 2014-01-19 19:40:07.000000000 -0700
|
||||
+++ b/arch/arm/boot/dts/imx23-olinuxino.dts 2014-02-02 11:04:58.878165195 -0700
|
||||
--- a/arch/arm/boot/dts/imx23-olinuxino.dts 2014-03-30 21:40:15.000000000 -0600
|
||||
+++ b/arch/arm/boot/dts/imx23-olinuxino.dts 2014-04-03 21:01:23.800864540 -0600
|
||||
@@ -29,6 +29,7 @@
|
||||
pinctrl-names = "default";
|
||||
pinctrl-0 = <&mmc0_4bit_pins_a &mmc0_pins_fixup>;
|
||||
|
@ -328,9 +328,9 @@ diff -urN a/arch/arm/boot/dts/imx23-olinuxino.dts b/arch/arm/boot/dts/imx23-olin
|
|||
+ };
|
||||
};
|
||||
diff -urN a/drivers/mmc/host/mxs-mmc.c b/drivers/mmc/host/mxs-mmc.c
|
||||
--- a/drivers/mmc/host/mxs-mmc.c 2014-01-19 19:40:07.000000000 -0700
|
||||
+++ b/drivers/mmc/host/mxs-mmc.c 2014-02-02 11:04:58.878165195 -0700
|
||||
@@ -94,6 +94,9 @@
|
||||
--- a/drivers/mmc/host/mxs-mmc.c 2014-03-30 21:40:15.000000000 -0600
|
||||
+++ b/drivers/mmc/host/mxs-mmc.c 2014-04-03 21:01:23.800864540 -0600
|
||||
@@ -74,6 +74,9 @@
|
||||
|
||||
static int mxs_mmc_get_cd(struct mmc_host *mmc)
|
||||
{
|
||||
|
@ -339,20 +339,20 @@ diff -urN a/drivers/mmc/host/mxs-mmc.c b/drivers/mmc/host/mxs-mmc.c
|
|||
+
|
||||
struct mxs_mmc_host *host = mmc_priv(mmc);
|
||||
struct mxs_ssp *ssp = &host->ssp;
|
||||
|
||||
@@ -663,6 +666,9 @@
|
||||
|
||||
host->cd_inverted = of_property_read_bool(np, "cd-inverted");
|
||||
int present, ret;
|
||||
@@ -634,6 +637,9 @@
|
||||
mmc->caps = MMC_CAP_SD_HIGHSPEED | MMC_CAP_MMC_HIGHSPEED |
|
||||
MMC_CAP_SDIO_IRQ | MMC_CAP_NEEDS_POLL;
|
||||
|
||||
+ if (of_find_property(np, "non-removable", NULL))
|
||||
+ mmc->caps |= MMC_CAP_NONREMOVABLE;
|
||||
+
|
||||
mmc->f_min = 400000;
|
||||
mmc->f_max = 288000000;
|
||||
mmc->ocr_avail = MMC_VDD_32_33 | MMC_VDD_33_34;
|
||||
|
||||
diff -urN a/sound/soc/codecs/Kconfig b/sound/soc/codecs/Kconfig
|
||||
--- a/sound/soc/codecs/Kconfig 2014-01-19 19:40:07.000000000 -0700
|
||||
+++ b/sound/soc/codecs/Kconfig 2014-02-02 11:04:58.878165195 -0700
|
||||
--- a/sound/soc/codecs/Kconfig 2014-03-30 21:40:15.000000000 -0600
|
||||
+++ b/sound/soc/codecs/Kconfig 2014-04-03 21:01:23.805864618 -0600
|
||||
@@ -132,6 +132,7 @@
|
||||
select SND_SOC_WM9705 if SND_SOC_AC97_BUS
|
||||
select SND_SOC_WM9712 if SND_SOC_AC97_BUS
|
||||
|
@ -361,7 +361,7 @@ diff -urN a/sound/soc/codecs/Kconfig b/sound/soc/codecs/Kconfig
|
|||
help
|
||||
Normally ASoC codec drivers are only built if a machine driver which
|
||||
uses them is also built since they are only usable with a machine
|
||||
@@ -534,6 +535,9 @@
|
||||
@@ -536,6 +537,9 @@
|
||||
config SND_SOC_WM9713
|
||||
tristate
|
||||
|
||||
|
@ -372,8 +372,8 @@ diff -urN a/sound/soc/codecs/Kconfig b/sound/soc/codecs/Kconfig
|
|||
config SND_SOC_LM4857
|
||||
tristate
|
||||
diff -urN a/sound/soc/codecs/Makefile b/sound/soc/codecs/Makefile
|
||||
--- a/sound/soc/codecs/Makefile 2014-01-19 19:40:07.000000000 -0700
|
||||
+++ b/sound/soc/codecs/Makefile 2014-02-02 11:04:58.878165195 -0700
|
||||
--- a/sound/soc/codecs/Makefile 2014-03-30 21:40:15.000000000 -0600
|
||||
+++ b/sound/soc/codecs/Makefile 2014-04-03 21:01:23.805864618 -0600
|
||||
@@ -124,6 +124,7 @@
|
||||
snd-soc-wm9712-objs := wm9712.o
|
||||
snd-soc-wm9713-objs := wm9713.o
|
||||
|
@ -392,7 +392,7 @@ diff -urN a/sound/soc/codecs/Makefile b/sound/soc/codecs/Makefile
|
|||
obj-$(CONFIG_SND_SOC_MAX9877) += snd-soc-max9877.o
|
||||
diff -urN a/sound/soc/codecs/mxs-builtin-codec.c b/sound/soc/codecs/mxs-builtin-codec.c
|
||||
--- a/sound/soc/codecs/mxs-builtin-codec.c 1969-12-31 17:00:00.000000000 -0700
|
||||
+++ b/sound/soc/codecs/mxs-builtin-codec.c 2014-02-02 11:04:58.883165175 -0700
|
||||
+++ b/sound/soc/codecs/mxs-builtin-codec.c 2014-04-03 21:01:23.810864750 -0600
|
||||
@@ -0,0 +1,1128 @@
|
||||
+/*
|
||||
+ * mxs-builtin-codec.c -- i.MX233 built-in codec ALSA Soc Audio driver
|
||||
|
@ -1524,7 +1524,7 @@ diff -urN a/sound/soc/codecs/mxs-builtin-codec.c b/sound/soc/codecs/mxs-builtin-
|
|||
+MODULE_LICENSE("GPL");
|
||||
diff -urN a/sound/soc/codecs/mxs-builtin-codec.h b/sound/soc/codecs/mxs-builtin-codec.h
|
||||
--- a/sound/soc/codecs/mxs-builtin-codec.h 1969-12-31 17:00:00.000000000 -0700
|
||||
+++ b/sound/soc/codecs/mxs-builtin-codec.h 2014-02-02 11:04:58.883165175 -0700
|
||||
+++ b/sound/soc/codecs/mxs-builtin-codec.h 2014-04-03 21:01:23.810864750 -0600
|
||||
@@ -0,0 +1,825 @@
|
||||
+#ifndef __MXS_ADC_CODEC_H
|
||||
+
|
||||
|
@ -2352,8 +2352,8 @@ diff -urN a/sound/soc/codecs/mxs-builtin-codec.h b/sound/soc/codecs/mxs-builtin-
|
|||
+
|
||||
+#endif /* __MXS_ADC_CODEC_H */
|
||||
diff -urN a/sound/soc/mxs/Kconfig b/sound/soc/mxs/Kconfig
|
||||
--- a/sound/soc/mxs/Kconfig 2014-01-19 19:40:07.000000000 -0700
|
||||
+++ b/sound/soc/mxs/Kconfig 2014-02-02 11:04:58.883165175 -0700
|
||||
--- a/sound/soc/mxs/Kconfig 2014-03-30 21:40:15.000000000 -0600
|
||||
+++ b/sound/soc/mxs/Kconfig 2014-04-03 21:01:23.810864750 -0600
|
||||
@@ -19,3 +19,13 @@
|
||||
a sgtl5000 codec.
|
||||
|
||||
|
@ -2369,8 +2369,8 @@ diff -urN a/sound/soc/mxs/Kconfig b/sound/soc/mxs/Kconfig
|
|||
+ Say Y or M if you want to add support for codecs attached to
|
||||
+ the MXS SAIF interface.
|
||||
diff -urN a/sound/soc/mxs/Makefile b/sound/soc/mxs/Makefile
|
||||
--- a/sound/soc/mxs/Makefile 2014-01-19 19:40:07.000000000 -0700
|
||||
+++ b/sound/soc/mxs/Makefile 2014-02-02 11:04:58.888165155 -0700
|
||||
--- a/sound/soc/mxs/Makefile 2014-03-30 21:40:15.000000000 -0600
|
||||
+++ b/sound/soc/mxs/Makefile 2014-04-03 21:01:23.810864750 -0600
|
||||
@@ -8,3 +8,12 @@
|
||||
snd-soc-mxs-sgtl5000-objs := mxs-sgtl5000.o
|
||||
|
||||
|
@ -2386,7 +2386,7 @@ diff -urN a/sound/soc/mxs/Makefile b/sound/soc/mxs/Makefile
|
|||
+obj-$(CONFIG_SND_MXS_SOC_BUILTIN) += snd-soc-mxs-builtin-audio.o
|
||||
diff -urN a/sound/soc/mxs/mxs-builtin-audio.c b/sound/soc/mxs/mxs-builtin-audio.c
|
||||
--- a/sound/soc/mxs/mxs-builtin-audio.c 1969-12-31 17:00:00.000000000 -0700
|
||||
+++ b/sound/soc/mxs/mxs-builtin-audio.c 2014-02-02 11:04:58.888165155 -0700
|
||||
+++ b/sound/soc/mxs/mxs-builtin-audio.c 2014-04-03 21:01:23.815864823 -0600
|
||||
@@ -0,0 +1,120 @@
|
||||
+/*
|
||||
+ * mxs-builtin-audio.c -- i.MX233 built-in codec ALSA Soc Audio driver
|
||||
|
@ -2510,7 +2510,7 @@ diff -urN a/sound/soc/mxs/mxs-builtin-audio.c b/sound/soc/mxs/mxs-builtin-audio.
|
|||
+MODULE_LICENSE("GPL");
|
||||
diff -urN a/sound/soc/mxs/mxs-builtin-dai.c b/sound/soc/mxs/mxs-builtin-dai.c
|
||||
--- a/sound/soc/mxs/mxs-builtin-dai.c 1969-12-31 17:00:00.000000000 -0700
|
||||
+++ b/sound/soc/mxs/mxs-builtin-dai.c 2014-02-02 11:04:58.888165155 -0700
|
||||
+++ b/sound/soc/mxs/mxs-builtin-dai.c 2014-04-03 21:01:23.815864823 -0600
|
||||
@@ -0,0 +1,588 @@
|
||||
+/*
|
||||
+ * mxs-builtin-dai.c -- i.MX233 built-in codec ALSA Soc Audio driver
|
||||
|
@ -3102,7 +3102,7 @@ diff -urN a/sound/soc/mxs/mxs-builtin-dai.c b/sound/soc/mxs/mxs-builtin-dai.c
|
|||
+MODULE_LICENSE("GPL");
|
||||
diff -urN a/sound/soc/mxs/mxs-builtin-pcm.c b/sound/soc/mxs/mxs-builtin-pcm.c
|
||||
--- a/sound/soc/mxs/mxs-builtin-pcm.c 1969-12-31 17:00:00.000000000 -0700
|
||||
+++ b/sound/soc/mxs/mxs-builtin-pcm.c 2014-02-02 11:04:58.888165155 -0700
|
||||
+++ b/sound/soc/mxs/mxs-builtin-pcm.c 2014-04-03 21:01:23.815864823 -0600
|
||||
@@ -0,0 +1,69 @@
|
||||
+/*
|
||||
+ * Copyright (C) 2011 Freescale Semiconductor, Inc. All Rights Reserved.
|
||||
|
@ -3175,7 +3175,7 @@ diff -urN a/sound/soc/mxs/mxs-builtin-pcm.c b/sound/soc/mxs/mxs-builtin-pcm.c
|
|||
+MODULE_LICENSE("GPL");
|
||||
diff -urN a/sound/soc/mxs/mxs-builtin-pcm.h b/sound/soc/mxs/mxs-builtin-pcm.h
|
||||
--- a/sound/soc/mxs/mxs-builtin-pcm.h 1969-12-31 17:00:00.000000000 -0700
|
||||
+++ b/sound/soc/mxs/mxs-builtin-pcm.h 2014-02-02 11:04:58.888165155 -0700
|
||||
+++ b/sound/soc/mxs/mxs-builtin-pcm.h 2014-04-03 21:01:23.815864823 -0600
|
||||
@@ -0,0 +1,25 @@
|
||||
+/*
|
||||
+ * Copyright (C) 2011 Freescale Semiconductor, Inc. All Rights Reserved.
|
||||
|
|
Loading…
Reference in a new issue