mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-03-19 00:21:40 +00:00
extra/qt5-webkit to 5.212.0alpha3-6
This commit is contained in:
parent
f81992dfe9
commit
0b1de74f08
2 changed files with 41 additions and 1 deletions
|
@ -12,21 +12,24 @@ highmem=1
|
||||||
pkgname=qt5-webkit
|
pkgname=qt5-webkit
|
||||||
_pkgver=5.212.0-alpha3
|
_pkgver=5.212.0-alpha3
|
||||||
pkgver=${_pkgver/-/}
|
pkgver=${_pkgver/-/}
|
||||||
pkgrel=5
|
pkgrel=6
|
||||||
arch=(x86_64)
|
arch=(x86_64)
|
||||||
url='https://www.qt.io'
|
url='https://www.qt.io'
|
||||||
license=(GPL3 LGPL3 FDL custom)
|
license=(GPL3 LGPL3 FDL custom)
|
||||||
pkgdesc='Classes for a WebKit2 based implementation and a new QML API'
|
pkgdesc='Classes for a WebKit2 based implementation and a new QML API'
|
||||||
source=("https://github.com/qtwebkit/qtwebkit/releases/download/qtwebkit-$_pkgver/qtwebkit-$_pkgver.tar.xz"
|
source=("https://github.com/qtwebkit/qtwebkit/releases/download/qtwebkit-$_pkgver/qtwebkit-$_pkgver.tar.xz"
|
||||||
|
icu65.patch
|
||||||
'atomic.patch')
|
'atomic.patch')
|
||||||
depends=(qt5-location qt5-sensors qt5-webchannel libwebp libxslt libxcomposite gst-plugins-base hyphen woff2)
|
depends=(qt5-location qt5-sensors qt5-webchannel libwebp libxslt libxcomposite gst-plugins-base hyphen woff2)
|
||||||
makedepends=(cmake ruby gperf python2 qt5-doc qt5-tools)
|
makedepends=(cmake ruby gperf python2 qt5-doc qt5-tools)
|
||||||
optdepends=('gst-plugins-good: Webm codec support')
|
optdepends=('gst-plugins-good: Webm codec support')
|
||||||
sha256sums=('357eee582445574472e410ebece632d06fa0ec94358fc4345f2a713922df5e17'
|
sha256sums=('357eee582445574472e410ebece632d06fa0ec94358fc4345f2a713922df5e17'
|
||||||
|
'2c806634ba208696a6cee4de72deefb289dd623378fddf92b09a36e3a99382fd'
|
||||||
'23fbd785daf116c71b3ce87d40860f0a6c56ab1065ee98ec41634626ca961129')
|
'23fbd785daf116c71b3ce87d40860f0a6c56ab1065ee98ec41634626ca961129')
|
||||||
|
|
||||||
prepare() {
|
prepare() {
|
||||||
mkdir -p build
|
mkdir -p build
|
||||||
|
patch -Np1 -d qtwebkit-$_pkgver <icu65.patch
|
||||||
|
|
||||||
if [[ $CARCH == "arm" || $CARCH == "armv6h" ]]; then
|
if [[ $CARCH == "arm" || $CARCH == "armv6h" ]]; then
|
||||||
cd qtwebkit-$_pkgver
|
cd qtwebkit-$_pkgver
|
||||||
|
|
37
extra/qt5-webkit/icu65.patch
Normal file
37
extra/qt5-webkit/icu65.patch
Normal file
|
@ -0,0 +1,37 @@
|
||||||
|
From 2eac3aeb98fca0e6c13aaaff481861c5ef679e68 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Konstantin Tokarev <annulen@yandex.ru>
|
||||||
|
Date: Tue, 8 Oct 2019 01:20:22 +0300
|
||||||
|
Subject: [PATCH] Import QtWebKit commit
|
||||||
|
5e53102492e5ce85bda2657468f1369a0173c2ce
|
||||||
|
|
||||||
|
Change-Id: Id71d7c7f5eafe58f7bd8c46a2a07fd0bad015628
|
||||||
|
Reviewed-by: Konstantin Tokarev <annulen@yandex.ru>
|
||||||
|
|
||||||
|
diff --git a/Source/WebCore/dom/Document.cpp b/Source/WebCore/dom/Document.cpp
|
||||||
|
index 1bca2d0a66f..19355f16601 100644
|
||||||
|
--- a/Source/WebCore/dom/Document.cpp
|
||||||
|
+++ b/Source/WebCore/dom/Document.cpp
|
||||||
|
@@ -4407,12 +4407,12 @@ static bool isValidNameNonASCII(const UChar* characters, unsigned length)
|
||||||
|
unsigned i = 0;
|
||||||
|
|
||||||
|
UChar32 c;
|
||||||
|
- U16_NEXT(characters, i, length, c)
|
||||||
|
+ U16_NEXT(characters, i, length, c);
|
||||||
|
if (!isValidNameStart(c))
|
||||||
|
return false;
|
||||||
|
|
||||||
|
while (i < length) {
|
||||||
|
- U16_NEXT(characters, i, length, c)
|
||||||
|
+ U16_NEXT(characters, i, length, c);
|
||||||
|
if (!isValidNamePart(c))
|
||||||
|
return false;
|
||||||
|
}
|
||||||
|
@@ -4474,7 +4474,7 @@ bool Document::parseQualifiedName(const String& qualifiedName, String& prefix, S
|
||||||
|
|
||||||
|
for (unsigned i = 0; i < length;) {
|
||||||
|
UChar32 c;
|
||||||
|
- U16_NEXT(qualifiedName, i, length, c)
|
||||||
|
+ U16_NEXT(qualifiedName, i, length, c);
|
||||||
|
if (c == ':') {
|
||||||
|
if (sawColon) {
|
||||||
|
ec = NAMESPACE_ERR;
|
Loading…
Reference in a new issue