mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
extra/java8-openjdk-aarch64: add missing patch
This commit is contained in:
parent
2a7faf5ea6
commit
0b9838d6d6
1 changed files with 14 additions and 0 deletions
|
@ -0,0 +1,14 @@
|
|||
diff --git a/src/os_cpu/linux_zero/vm/os_linux_zero.cpp b/src/os_cpu/linux_zero/vm/os_linux_zero.cpp
|
||||
--- jdk8/hotspot/src/os_cpu/linux_zero/vm/os_linux_zero.cpp
|
||||
+++ jdk8/hotspot/src/os_cpu/linux_zero/vm/os_linux_zero.cpp
|
||||
@@ -55,8 +55,8 @@
|
||||
#include "utilities/vmError.hpp"
|
||||
|
||||
address os::current_stack_pointer() {
|
||||
- address dummy = (address) &dummy;
|
||||
- return dummy;
|
||||
+ // return the address of the current function
|
||||
+ return (address)__builtin_frame_address(0);
|
||||
}
|
||||
|
||||
frame os::get_sender_for_C_frame(frame* fr) {
|
Loading…
Reference in a new issue