extra/meson to 0.61.0-3

This commit is contained in:
Kevin Mihelich 2022-01-12 19:41:24 +00:00
parent 0fc5956110
commit 0ba58b3901
3 changed files with 41 additions and 4 deletions

View file

@ -7,7 +7,7 @@
pkgname=meson
pkgver=0.61.0
pkgrel=2
pkgrel=3
pkgdesc='High productivity build system'
url='https://mesonbuild.com/'
arch=('any')
@ -21,20 +21,39 @@ checkdepends=('gcc-objc' 'vala' 'rust' 'gcc-fortran' 'mono' 'boost' 'qt5-base' '
'python-pytest-xdist' 'python2-setuptools' 'ldc' 'rust-bindgen' 'cuda' 'hotdoc')
source=(https://github.com/mesonbuild/meson/releases/download/${pkgver}/meson-${pkgver}.tar.gz{,.asc}
https://github.com/mesonbuild/meson/commit/81fbcd1df48f669b6b23b9dd0752d6d366cc9bf2.patch
https://github.com/mesonbuild/meson/commit/bcfb4d0f46608db46cd8881e2a02ba6c33ff066e.patch
https://github.com/mesonbuild/meson/commit/704e9802c9f424a57c32d9e63ececfece807529a.patch
https://github.com/mesonbuild/meson/commit/63593a55288ee5b89fc9c298dbc300f9c6adaba9.patch
fix-gdbus-codegen.diff
https://github.com/mesonbuild/meson/commit/9952446a2a28ea2b009f4b8b2a14ad50f0878bdd.patch
skip-test.diff
arch-meson)
sha512sums=('ff739f767710c09a1b238f135c81bdb79675d06cec1b091503809cdbd71f0f92fd76bf068650bbec60688b79fbda94e56cb3203c948aa79f16a88f6d9db219d1'
'SKIP'
'7e57c59394b73819e3af9722dc26e68edebec35187ceb39116f15a890fb0277cfe198b0ba84218a7f3333cffb16e217717b94d325224167175c0c1479e0f94a5'
'8c4e9053980bb9cec7d8756a844e13adb44f29615aa279d57f35733925ff3ba7a8451f796e335d63f1fa180a72d42ecbd4ab3782a25497e5ceff551304ae255f'
'8e943cecd9b4a43f690b9bae463f8cdb8dd4a53e6a9c4f9dc93ee0119ffae1d9964604fbc9180c7dda39790542b52ef30b6f76c1321ce493eb24d211895b15fa'
'f7b0d8e77af19cd666c1efcbed8767483efa4d2b58a08d9a01151f77dbcbd8047a6dfd95fa57146d565c0b7f404368efef6fdc096e127c640c66747641ecce3c'
'2fc23d7b1ac8320ffb3742a1299f69700b0ead212446aac9ca7d2c63874f4f2cd90e6739287814c61baaf00d92f9c99c714abac30b5b54e4362ca6476a32ca02'
'00e50d95e34ea15c65dc3976d36388571832bfcc32f1a01357d1eac73825fc5086eedd03238cd5365d81ecddf8d2bde8de4a0e59e54f0661b08879088f841b91'
'cf59e2e2f6067fa512445c81f7e4b417c4fb20c720fbf84e3248bb40ff04a71ad18e20d86d28fc8b1c7ace4c3c2a0b9e9053c4a7870553eed7f0b2e69bd0f49d'
'994d88aaa7d9ad619885674352593826de198ef443c887fe6e9ecdcd84302eb04e0c396263404b4f16e447586f2b61f100643ba627803971070fa7b6baa75f78'
'278f5e4de3aa1170d9b4f9f212985d664f44d90ffec727febeeea1ed570046c6469558a5d123a41bf4c2fdf99dbe7832515b06f1ace423c63e2e95ba6d0ef235')
validpgpkeys=('19E2D6D9B46D8DAA6288F877C24E631BABB1FE70') # Jussi Pakkanen <jpakkane@gmail.com>
prepare() {
cd ${pkgname}-${pkgver}
# https://bugs.archlinux.org/task/73329
# gtk-doc fixes
patch -Np1 -i ../81fbcd1df48f669b6b23b9dd0752d6d366cc9bf2.patch
patch -Np1 -i ../bcfb4d0f46608db46cd8881e2a02ba6c33ff066e.patch
# gdbus-codegen fixes
patch -Np1 -i ../704e9802c9f424a57c32d9e63ececfece807529a.patch
patch -Np1 -i ../63593a55288ee5b89fc9c298dbc300f9c6adaba9.patch
patch -Np1 -i ../fix-gdbus-codegen.diff
# vapigen fixes
patch -Np1 -i ../9952446a2a28ea2b009f4b8b2a14ad50f0878bdd.patch
# Our containers do not allow sanitizers to run
patch -Np1 -i ../skip-test.diff

View file

@ -0,0 +1,18 @@
diff --git i/mesonbuild/modules/gnome.py w/mesonbuild/modules/gnome.py
index e5990f087..835ebfb5a 100644
--- i/mesonbuild/modules/gnome.py
+++ w/mesonbuild/modules/gnome.py
@@ -1477,9 +1477,10 @@ class GnomeModule(ExtensionModule):
build_by_default = kwargs['build_by_default']
# Annotations are a bit ugly in that they are a list of lists of strings...
- if kwargs['annotations']:
- cmd.append('--annotate')
- cmd.extend(kwargs['annotations'])
+ for i, a in enumerate(kwargs['annotations']):
+ if i % 3 == 0:
+ cmd.append('--annotate')
+ cmd.append(a)
targets = []
install_header = kwargs['install_header']

View file

@ -2,7 +2,7 @@
1 file changed, 2 insertions(+)
diff --git c/unittests/linuxliketests.py i/unittests/linuxliketests.py
index 7a0e46e03..67f0c426c 100644
index ade489d83..3ebed302b 100644
--- c/unittests/linuxliketests.py
+++ i/unittests/linuxliketests.py
@@ -343,6 +343,7 @@ class LinuxlikeTests(BasePlatformTests):