extra/qemu to 2.12.0-1

This commit is contained in:
Kevin Mihelich 2018-05-01 18:20:57 +00:00
parent 0771b31378
commit 0bd751f44b
3 changed files with 12 additions and 49 deletions

View file

@ -12,8 +12,8 @@ pkgbase=qemu
pkgname=(qemu qemu-headless qemu-arch-extra qemu-headless-arch-extra
qemu-block-{iscsi,rbd,gluster} qemu-guest-agent)
pkgdesc="A generic and open source machine emulator and virtualizer"
pkgver=2.11.1
pkgrel=2
pkgver=2.12.0
pkgrel=1
arch=(x86_64)
license=(GPL2 LGPL2.1)
url="http://wiki.qemu.org/"
@ -24,14 +24,12 @@ makedepends=(spice-protocol python2 ceph libiscsi glusterfs)
source=(https://download.qemu.org/qemu-$pkgver.tar.xz{,.sig}
qemu-ga.service
65-kvm.rules
remove-problematic-evdev-86-key-from-en-us-keymap.patch
allow_elf64.patch)
sha256sums=('8a5145d1f8bd2eadc6776f3e13c68cd28d01349e30639bdbcb26ac588d668686'
sha256sums=('e69301f361ff65bf5dabd8a19196aeaa5613c1b5ae1678f0823bdf50e7d5c6fc'
'SKIP'
'c39bcde4a09165e64419fd2033b3532378bba84d509d39e2d51694d44c1f8d88'
'a66f0e791b16b03b91049aac61a25950d93e962e1b2ba64a38c6ad7f609b532c'
'3cefabbab32ab21cd3b5a8cc1165c96db0c6c93e7ee8dc9d2ca09be5fb5eccda'
'13a6d9e678bdc9e1f051006cfd0555f5a80582368f54c8a1bb5a78ece3832ac4')
'59751f1ed26ea61b2a37ebee4be6979e584a450b611282138a0893aa9173e2e4')
validpgpkeys=('CEACC9E15534EBABB82D3FA03353C9CEF108B584')
case $CARCH in
@ -48,7 +46,6 @@ prepare() {
cd ${pkgname}-${pkgver}
sed -i 's/vte-2\.90/vte-2.91/g' configure
patch -p1 < ../remove-problematic-evdev-86-key-from-en-us-keymap.patch
patch -p1 < ../allow_elf64.patch
}

View file

@ -1,24 +1,22 @@
commit 3c72765ec760a51f0e879dc792be82c93141e318
commit cb61bc8a42da1a971079767e63df4503b6ab2efb
Author: Anatol Pomozov <anatol.pomozov@gmail.com>
Date: Tue Jun 6 20:07:03 2017 -0700
Date: Mon Jan 29 10:08:53 2018 -0800
Remove restriction that prevents bootimg elf64 images
multiboot: Make elf64 loading functionality compatible with GRUB
It is possible to create a 64 bit elf image that has valid multiboot header.
qemu should be able to boot such images.
Signed-off-by: Anatol Pomozov <anatol.pomozov@gmail.com>
GRUB is a reference multiboot implementation and supports loading elf64
binaries. Make QEMU to work similar was as GRUB.
diff --git a/hw/i386/multiboot.c b/hw/i386/multiboot.c
index 663f35a658..cf1b4f5fb3 100644
index 5bc0a2cddb..0907e42a39 100644
--- a/hw/i386/multiboot.c
+++ b/hw/i386/multiboot.c
@@ -192,11 +192,6 @@ int load_multiboot(FWCfgState *fw_cfg,
@@ -193,11 +193,6 @@ int load_multiboot(FWCfgState *fw_cfg,
int kernel_size;
fclose(f);
- if (((struct elf64_hdr*)header)->e_machine == EM_X86_64) {
- fprintf(stderr, "Cannot load x86-64 image, give a 32bit one.\n");
- error_report("Cannot load x86-64 image, give a 32bit one.");
- exit(1);
- }
-

View file

@ -1,32 +0,0 @@
From 2c25ad161d7714f15b1951c69c50844ea81f4186 Mon Sep 17 00:00:00 2001
From: Adam Williamson <awilliam@redhat.com>
Date: Wed, 20 Dec 2017 15:43:07 -0800
Subject: [PATCH] Remove problematic 'evdev 86' key from en-us keymap
This causes LP#1738283. Gerd will have to come up with a better
fix, but just hacking out the problematic key definition should
work for now.
---
pc-bios/keymaps/en-us | 6 ------
1 file changed, 6 deletions(-)
diff --git a/pc-bios/keymaps/en-us b/pc-bios/keymaps/en-us
index a70e03adc0..e518a9dc35 100644
--- a/pc-bios/keymaps/en-us
+++ b/pc-bios/keymaps/en-us
@@ -343,12 +343,6 @@ KP_Decimal 0x53 numlock
# evdev 85 (0x55): no evdev -> QKeyCode mapping (xkb keysym NoSymbol)
-# evdev 86 (0x56), QKeyCode "less", number 0x56
-less 0x56
-greater 0x56 shift
-bar 0x56 altgr
-brokenbar 0x56 shift altgr
-
# evdev 87 (0x57), QKeyCode "f11", number 0x57
F11 0x57
--
2.15.1