extra/kdebindings-python: update arm patch

This commit is contained in:
Kevin Mihelich 2014-08-21 13:15:05 +00:00
parent fe3d8df64b
commit 0bf43196e6
2 changed files with 10 additions and 12 deletions

View file

@ -17,7 +17,7 @@ groups=('kdebindings')
makedepends=('cmake' 'automoc4' 'boost' 'kdepim-runtime' 'python2-pyqt4' makedepends=('cmake' 'automoc4' 'boost' 'kdepim-runtime' 'python2-pyqt4'
'python-pyqt4' 'qscintilla' 'python2-sip' 'python-sip' 'mesa') 'python-pyqt4' 'qscintilla' 'python2-sip' 'python-sip' 'mesa')
source=("http://download.kde.org/stable/${pkgver}/src/pykde4-${pkgver}.tar.xz" source=("http://download.kde.org/stable/${pkgver}/src/pykde4-${pkgver}.tar.xz"
"pykde4-4.10.0-arm-sip.patch") "pykde4-4.14.0-arm-sip.patch")
sha1sums=('e57d42ca4d6889877e56a24596d892f5b74a316e' sha1sums=('e57d42ca4d6889877e56a24596d892f5b74a316e'
'f0798d25767768006d5f674049e51b2e39f9f4eb') 'f0798d25767768006d5f674049e51b2e39f9f4eb')
@ -25,7 +25,7 @@ prepare() {
mkdir build mkdir build
cd pykde4-${pkgver} cd pykde4-${pkgver}
patch -Np1 -i "${srcdir}/pykde4-4.10.0-arm-sip.patch" patch -Np1 -i "${srcdir}/pykde4-4.14.0-arm-sip.patch"
} }
build() { build() {

View file

@ -1,21 +1,19 @@
diff -urN a/CMakeLists.txt b/CMakeLists.txt diff -urN a/CMakeLists.txt b/CMakeLists.txt
--- a/CMakeLists.txt 2013-01-23 14:49:42.000000000 -0700 --- a/CMakeLists.txt 2014-08-14 14:17:11.000000000 -0600
+++ b/CMakeLists.txt 2013-02-09 11:14:13.362993722 -0700 +++ b/CMakeLists.txt 2014-08-21 07:12:45.079779571 -0600
@@ -101,6 +101,8 @@ @@ -101,12 +101,14 @@
${KDEPIMLIBS_INCLUDE_DIRS}
)
set(SIP_INCLUDES ${CMAKE_BINARY_DIR} ${PYQT4_SIP_DIR} sip)
set(SIP_CONCAT_PARTS 8)
+# Pull in ARM configuration options if needed +# Pull in ARM configuration options if needed
+STRING(REGEX MATCH "PyQt_qreal_double" SIP_ARM_HACK ${PYQT4_SIP_FLAGS} "") +STRING(REGEX MATCH "PyQt_qreal_double" SIP_ARM_HACK ${PYQT4_SIP_FLAGS} "")
set(SIP_INCLUDES ${PYQT4_SIP_DIR} sip)
set(SIP_CONCAT_PARTS 8)
if (WIN32) if (WIN32)
@@ -108,7 +110,7 @@ set(SIP_TAGS ALL WS_WIN ${PYQT4_VERSION_TAG})
else () else ()
set(SIP_TAGS ALL WS_X11 ${PYQT4_VERSION_TAG}) set(SIP_TAGS ALL WS_X11 ${PYQT4_VERSION_TAG})
endif () endif ()
-set(SIP_DISABLE_FEATURES VendorID PyQt_NoPrintRangeBug) -set(SIP_DISABLE_FEATURES VendorID PyQt_NoPrintRangeBug)
+set(SIP_DISABLE_FEATURES VendorID PyQt_NoPrintRangeBug ${SIP_ARM_HACK}) +set(SIP_DISABLE_FEATURES VendorID PyQt_NoPrintRangeBug ${SIP_ARM_HACK})
# Use an extra option when compiling on Python 3. set(SIP_FILES_INSTALL_DIR ${SHARE_INSTALL_PREFIX}/sip)
if (PYTHON_VERSION_MAJOR GREATER 2)