mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-02-16 23:57:11 +00:00
extra/pyqt5: fix patch
This commit is contained in:
parent
768de50c02
commit
0c22e79fbf
2 changed files with 9 additions and 13 deletions
|
@ -21,7 +21,7 @@ makedepends=('python-sip' 'python2-sip' 'python-opengl' 'python2-opengl'
|
|||
source=("http://downloads.sourceforge.net/project/pyqt/PyQt5/PyQt-${pkgver}/PyQt-gpl-${pkgver}.tar.gz"
|
||||
'fix_qreal_check.diff')
|
||||
md5sums=('8ab34b17b7d76ad613ff3af3c59e0c20'
|
||||
'8bd96cc390766ad245295c67f9b3c7bf')
|
||||
'24100c64ed373dfd55a0c050f3989524')
|
||||
|
||||
prepare() {
|
||||
cd PyQt-gpl-${pkgver}
|
||||
|
|
|
@ -1,21 +1,17 @@
|
|||
Description: check if qreal is double based on sizeof
|
||||
Author: Dmitry Shachnev <mitya57@gmail.com>
|
||||
Forwarded: no
|
||||
Last-Update: 2014-01-29
|
||||
|
||||
--- a/configure.py
|
||||
+++ b/configure.py
|
||||
@@ -481,10 +481,8 @@
|
||||
out << "PyQt_Desktop_OpenGL\\n";
|
||||
diff -urN a/configure.py b/configure.py
|
||||
--- a/configure.py 2014-03-14 08:38:18.000000000 -0600
|
||||
+++ b/configure.py 2014-03-28 14:55:32.379777351 -0600
|
||||
@@ -492,11 +492,8 @@
|
||||
#endif
|
||||
|
||||
-// This is the test used in qglobal.h.
|
||||
#if QT_VERSION < 0x050200
|
||||
-// This is the test used in qglobal.h in Qt prior to v5.2. In v5.2 and later
|
||||
-// qreal is always double.
|
||||
-#if defined(QT_NO_FPU) || defined(Q_PROCESSOR_ARM) || defined(Q_OS_WINCE)
|
||||
- out << "PyQt_qreal_double\\n";
|
||||
-#endif
|
||||
+ if (sizeof (qreal) != sizeof (double))
|
||||
+ out << "PyQt_qreal_double\\n";
|
||||
#endif
|
||||
|
||||
return 0;
|
||||
}
|
||||
|
||||
|
|
Loading…
Reference in a new issue