extra/libdrm patch fix

This commit is contained in:
Kevin Mihelich 2012-08-31 18:07:40 +00:00
parent 33405a354c
commit 0c33aab209
2 changed files with 16 additions and 16 deletions

View file

@ -20,7 +20,7 @@ source=(http://dri.freedesktop.org/$pkgname/$pkgname-$pkgver.tar.bz2
no-pthread-stubs.patch
COPYING)
sha256sums=('386b17388980504bca16ede81ceed4c77b12c3488f46ecb7f4d48e48512a733d'
'149457abcb9135a75ded106fb596978a3a903d6bacc167d2c62470e2d106f74f'
'b9844bc8cd706e1d88f048b37e1233fb4388fcb0468e023858af23eddbc6d1f1'
'9631d4f694952e3e6ae5a05534c2e93e994e47d3413677a3a00e45c8cef6db93')
build() {

View file

@ -1,6 +1,6 @@
diff -urN a/configure.ac b/configure.ac
--- a/configure.ac 2012-06-29 12:08:00.000000000 -0600
+++ b/configure.ac 2012-07-02 09:23:15.765231785 -0600
--- a/configure.ac 2012-08-24 08:54:42.000000000 -0600
+++ b/configure.ac 2012-08-31 12:05:03.411667257 -0600
@@ -47,10 +47,6 @@
LT_INIT([disable-static])
@ -13,8 +13,8 @@ diff -urN a/configure.ac b/configure.ac
AC_SUBST(pkgconfigdir)
AC_ARG_ENABLE([udev],
diff -urN a/exynos/Makefile.am b/exynos/Makefile.am
--- a/exynos/Makefile.am 2012-06-05 12:26:51.000000000 -0600
+++ b/exynos/Makefile.am 2012-07-02 09:23:44.094193309 -0600
--- a/exynos/Makefile.am 2012-06-14 15:32:50.000000000 -0600
+++ b/exynos/Makefile.am 2012-08-31 12:05:41.225521950 -0600
@@ -2,13 +2,12 @@
$(WARN_CFLAGS) \
-I$(top_srcdir) \
@ -24,15 +24,15 @@ diff -urN a/exynos/Makefile.am b/exynos/Makefile.am
libdrm_exynos_la_LTLIBRARIES = libdrm_exynos.la
libdrm_exynos_ladir = $(libdir)
libdrm_exynos_la_LDFLAGS = -version-number 1:0:1 -no-undefined
libdrm_exynos_la_LDFLAGS = -version-number 1:0:0 -no-undefined
-libdrm_exynos_la_LIBADD = ../libdrm.la @PTHREADSTUBS_LIBS@
+libdrm_exynos_la_LIBADD = ../libdrm.la
libdrm_exynos_la_SOURCES = exynos_drm.c
diff -urN a/intel/Makefile.am b/intel/Makefile.am
--- a/intel/Makefile.am 2012-03-12 21:20:29.000000000 -0600
+++ b/intel/Makefile.am 2012-07-02 09:23:15.765231785 -0600
--- a/intel/Makefile.am 2012-07-29 07:39:21.000000000 -0600
+++ b/intel/Makefile.am 2012-08-31 12:05:03.427292817 -0600
@@ -26,7 +26,6 @@
$(WARN_CFLAGS) \
-I$(top_srcdir) \
@ -43,15 +43,15 @@ diff -urN a/intel/Makefile.am b/intel/Makefile.am
-I$(top_srcdir)/include/drm
@@ -35,7 +34,6 @@
libdrm_intel_ladir = $(libdir)
libdrm_intel_la_LDFLAGS = -version-number 1:0:1 -no-undefined
libdrm_intel_la_LDFLAGS = -version-number 1:0:0 -no-undefined
libdrm_intel_la_LIBADD = ../libdrm.la \
- @PTHREADSTUBS_LIBS@ \
@PCIACCESS_LIBS@ \
@CLOCK_LIB@
diff -urN a/nouveau/Makefile.am b/nouveau/Makefile.am
--- a/nouveau/Makefile.am 2012-04-21 20:18:55.000000000 -0600
+++ b/nouveau/Makefile.am 2012-07-02 09:23:15.765231785 -0600
--- a/nouveau/Makefile.am 2012-06-14 15:32:50.000000000 -0600
+++ b/nouveau/Makefile.am 2012-08-31 12:05:03.427292817 -0600
@@ -2,14 +2,13 @@
$(WARN_CFLAGS) \
-I$(top_srcdir) \
@ -69,8 +69,8 @@ diff -urN a/nouveau/Makefile.am b/nouveau/Makefile.am
libdrm_nouveau_la_SOURCES = nouveau.c \
pushbuf.c \
diff -urN a/omap/Makefile.am b/omap/Makefile.am
--- a/omap/Makefile.am 2012-03-29 20:56:27.000000000 -0600
+++ b/omap/Makefile.am 2012-07-02 09:23:31.929770653 -0600
--- a/omap/Makefile.am 2012-06-14 15:32:50.000000000 -0600
+++ b/omap/Makefile.am 2012-08-31 12:05:59.233979612 -0600
@@ -2,13 +2,12 @@
$(WARN_CFLAGS) \
-I$(top_srcdir) \
@ -80,15 +80,15 @@ diff -urN a/omap/Makefile.am b/omap/Makefile.am
libdrm_omap_la_LTLIBRARIES = libdrm_omap.la
libdrm_omap_ladir = $(libdir)
libdrm_omap_la_LDFLAGS = -version-number 1:0:1 -no-undefined
libdrm_omap_la_LDFLAGS = -version-number 1:0:0 -no-undefined
-libdrm_omap_la_LIBADD = ../libdrm.la @PTHREADSTUBS_LIBS@
+libdrm_omap_la_LIBADD = ../libdrm.la
libdrm_omap_la_SOURCES = omap_drm.c
diff -urN a/radeon/Makefile.am b/radeon/Makefile.am
--- a/radeon/Makefile.am 2012-02-07 03:45:59.000000000 -0700
+++ b/radeon/Makefile.am 2012-07-02 09:23:15.765231785 -0600
--- a/radeon/Makefile.am 2012-08-24 08:51:13.000000000 -0600
+++ b/radeon/Makefile.am 2012-08-31 12:05:03.435105597 -0600
@@ -26,13 +26,12 @@
$(WARN_CFLAGS) \
-I$(top_srcdir) \