mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-18 22:54:00 +00:00
extra/libphonenumber to 8.12.52-1
This commit is contained in:
parent
cfe1fea7ea
commit
0c6ac6a954
2 changed files with 8 additions and 66 deletions
|
@ -4,8 +4,8 @@
|
||||||
# - re-add makedepend on java
|
# - re-add makedepend on java
|
||||||
|
|
||||||
pkgname=libphonenumber
|
pkgname=libphonenumber
|
||||||
pkgver=8.12.50
|
pkgver=8.12.52
|
||||||
pkgrel=2
|
pkgrel=1
|
||||||
epoch=1
|
epoch=1
|
||||||
pkgdesc="Google's common library for parsing, formatting, and validating international phone numbers"
|
pkgdesc="Google's common library for parsing, formatting, and validating international phone numbers"
|
||||||
url="https://github.com/googlei18n/libphonenumber"
|
url="https://github.com/googlei18n/libphonenumber"
|
||||||
|
@ -14,10 +14,9 @@ license=(Apache)
|
||||||
depends=(icu protobuf boost-libs abseil-cpp)
|
depends=(icu protobuf boost-libs abseil-cpp)
|
||||||
makedepends=(boost cmake gtest git 'java-environment>=9')
|
makedepends=(boost cmake gtest git 'java-environment>=9')
|
||||||
options=(debug)
|
options=(debug)
|
||||||
_commit=e1c6752b358569810fb33bcc9f5c75050e9533fe # tags/v8.12.50^0
|
_commit=011d35d28fe8a7c201efe9164f55ebd0a2d43b0c # tags/v8.12.52^0
|
||||||
source=("git+$url#commit=$_commit" absl.diff)
|
source=("git+$url#commit=$_commit")
|
||||||
sha256sums=('SKIP'
|
sha256sums=('SKIP')
|
||||||
'f6bceb2409ff7cba1e6947e6fdce3fe82b511b04fefcd1f597eceb13af67a8a4')
|
|
||||||
|
|
||||||
pkgver() {
|
pkgver() {
|
||||||
cd $pkgname
|
cd $pkgname
|
||||||
|
@ -26,9 +25,6 @@ pkgver() {
|
||||||
|
|
||||||
prepare() {
|
prepare() {
|
||||||
cd $pkgname
|
cd $pkgname
|
||||||
|
|
||||||
# Use our abseil-cpp
|
|
||||||
git apply -3 ../absl.diff
|
|
||||||
}
|
}
|
||||||
|
|
||||||
build() {
|
build() {
|
||||||
|
@ -36,7 +32,9 @@ build() {
|
||||||
CXXFLAGS+=" -Wno-error=unused-variable" # this is nuts
|
CXXFLAGS+=" -Wno-error=unused-variable" # this is nuts
|
||||||
cmake -S $pkgname/cpp -B build \
|
cmake -S $pkgname/cpp -B build \
|
||||||
-DCMAKE_INSTALL_PREFIX=/usr \
|
-DCMAKE_INSTALL_PREFIX=/usr \
|
||||||
-DCMAKE_INSTALL_LIBDIR=lib
|
-DCMAKE_INSTALL_LIBDIR=lib \
|
||||||
|
-DCMAKE_BUILD_TYPE=None \
|
||||||
|
-DCMAKE_CXX_STANDARD=17
|
||||||
cmake --build build
|
cmake --build build
|
||||||
}
|
}
|
||||||
|
|
||||||
|
|
|
@ -1,56 +0,0 @@
|
||||||
diff --git i/cpp/CMakeLists.txt w/cpp/CMakeLists.txt
|
|
||||||
index 57261a63..83440382 100644
|
|
||||||
--- i/cpp/CMakeLists.txt
|
|
||||||
+++ w/cpp/CMakeLists.txt
|
|
||||||
@@ -18,7 +18,7 @@ cmake_minimum_required (VERSION 3.11)
|
|
||||||
|
|
||||||
# Pick the C++ standard to compile with.
|
|
||||||
# Abseil currently supports C++11, C++14, and C++17.
|
|
||||||
-set(CMAKE_CXX_STANDARD 11)
|
|
||||||
+set(CMAKE_CXX_STANDARD 17)
|
|
||||||
set(CMAKE_CXX_STANDARD_REQUIRED ON)
|
|
||||||
|
|
||||||
project (libphonenumber)
|
|
||||||
@@ -126,6 +126,8 @@ if (${USE_BOOST} STREQUAL "OFF" AND ${USE_STDMUTEX} STREQUAL "OFF")
|
|
||||||
find_package (Threads)
|
|
||||||
endif()
|
|
||||||
|
|
||||||
+find_package (absl REQUIRED)
|
|
||||||
+
|
|
||||||
find_or_build_gtest ()
|
|
||||||
|
|
||||||
if (${USE_RE2} STREQUAL "ON")
|
|
||||||
diff --git i/tools/cpp/CMakeLists.txt w/tools/cpp/CMakeLists.txt
|
|
||||||
index b0941656..58a9b3ba 100644
|
|
||||||
--- i/tools/cpp/CMakeLists.txt
|
|
||||||
+++ w/tools/cpp/CMakeLists.txt
|
|
||||||
@@ -26,29 +26,6 @@ project (generate_geocoding_data)
|
|
||||||
# Helper functions dealing with finding libraries and programs this library
|
|
||||||
# depends on.
|
|
||||||
include (gtest.cmake)
|
|
||||||
-include (FetchContent)
|
|
||||||
-
|
|
||||||
-# Downloading the abseil sources.
|
|
||||||
-FetchContent_Declare(
|
|
||||||
- abseil-cpp
|
|
||||||
- GIT_REPOSITORY https://github.com/abseil/abseil-cpp.git
|
|
||||||
- GIT_TAG origin/master
|
|
||||||
-)
|
|
||||||
-
|
|
||||||
-# Building the abseil binaries
|
|
||||||
-FetchContent_GetProperties(abseil-cpp)
|
|
||||||
-if (NOT abseil-cpp_POPULATED)
|
|
||||||
- FetchContent_Populate(abseil-cpp)
|
|
||||||
-endif ()
|
|
||||||
-
|
|
||||||
-if (NOT abseil-cpp_POPULATED)
|
|
||||||
- message (FATAL_ERROR "Could not build abseil-cpp binaries.")
|
|
||||||
-endif ()
|
|
||||||
-
|
|
||||||
-# Safeguarding against any potential link errors as mentioned in
|
|
||||||
-# https://github.com/abseil/abseil-cpp/issues/225
|
|
||||||
-set(CMAKE_POSITION_INDEPENDENT_CODE TRUE)
|
|
||||||
-add_subdirectory(${abseil-cpp_SOURCE_DIR} ${abseil-cpp_BINARY_DIR})
|
|
||||||
|
|
||||||
find_or_build_gtest ()
|
|
||||||
set (
|
|
Loading…
Reference in a new issue