mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
alarm/kodi-rpi-legacy to 19.4-2
This commit is contained in:
parent
8eecf1f1d2
commit
0c988c72c5
5 changed files with 124 additions and 15 deletions
|
@ -1,10 +1,9 @@
|
|||
From 666fd7f69f684d7dd23b1ee665b0902e29953b76 Mon Sep 17 00:00:00 2001
|
||||
From: graysky <graysky@archlinux.us>
|
||||
Date: Sat, 12 Dec 2020 09:29:51 -0500
|
||||
Subject: [PATCH] mcpu=cortex-xxx application to ffmpeg
|
||||
From 11071b94eff58eeaf69f2b81afe317b72cd22b54 Mon Sep 17 00:00:00 2001
|
||||
From: graysky <therealgraysky@proton.me>
|
||||
Date: Sat, 7 May 2022 06:10:06 -0400
|
||||
Subject: [PATCH 1/2] mcpu=cortex-xxx application to ffmpeg
|
||||
|
||||
Get build system to patch ffmpeg source removing the -march= flag
|
||||
|
||||
---
|
||||
cmake/modules/FindFFMPEG.cmake | 1 +
|
||||
1 file changed, 1 insertion(+)
|
||||
|
@ -22,5 +21,5 @@ index 9ce807c..a18b21c 100644
|
|||
)
|
||||
|
||||
--
|
||||
2.29.2
|
||||
2.36.0
|
||||
|
||||
|
|
|
@ -0,0 +1,24 @@
|
|||
From 9bc4045471dd0f6a23023db6801173b0c624e127 Mon Sep 17 00:00:00 2001
|
||||
From: graysky <therealgraysky@proton.me>
|
||||
Date: Sat, 7 May 2022 06:11:27 -0400
|
||||
Subject: [PATCH 2/2] add dav1d patch to build system
|
||||
|
||||
---
|
||||
cmake/modules/FindFFMPEG.cmake | 1 +
|
||||
1 file changed, 1 insertion(+)
|
||||
|
||||
diff --git a/cmake/modules/FindFFMPEG.cmake b/cmake/modules/FindFFMPEG.cmake
|
||||
index a18b21c..fb7326f 100644
|
||||
--- a/cmake/modules/FindFFMPEG.cmake
|
||||
+++ b/cmake/modules/FindFFMPEG.cmake
|
||||
@@ -280,6 +280,7 @@ if(NOT FFMPEG_FOUND)
|
||||
<SOURCE_DIR> &&
|
||||
patch -p1 < ${CMAKE_SOURCE_DIR}/tools/depends/target/ffmpeg/0001-rpi-Add-hevc-acceleration.patch &&
|
||||
patch -p1 < ${CMAKE_SOURCE_DIR}/tools/depends/target/ffmpeg/0002-use-mcpu-avoiding-march-and-mtune.patch &&
|
||||
+ patch -p1 < ${CMAKE_SOURCE_DIR}/tools/depends/target/ffmpeg/0003-add-dav1d-patch-to-build-system.patch &&
|
||||
echo "########################################## patched ffmpeg ##############################"
|
||||
)
|
||||
|
||||
--
|
||||
2.36.0
|
||||
|
|
@ -1,4 +1,4 @@
|
|||
# Contributor graysky <graysky AT archlinux DOT org>
|
||||
# Contributor graysky <therealgraysky AT proton DOT me>
|
||||
# Contributor: BlackIkeEagle < ike DOT devolder AT gmail DOT com>
|
||||
# Contributor Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
# Contributor BlackIkeEagle < ike DOT devolder AT gmail DOT com >
|
||||
|
@ -15,7 +15,7 @@ pkgname=(
|
|||
'kodi-rpi-legacy-eventclients' 'kodi-rpi-legacy-tools-texturepacker' 'kodi-rpi-legacy-dev'
|
||||
)
|
||||
pkgver=19.4
|
||||
pkgrel=1
|
||||
pkgrel=2
|
||||
_commit=51a36cca9f6dd2bc717e41153fb2d0aa9caf11ca
|
||||
arch=('armv7h')
|
||||
url="https://github.com/graysky2/xbmc/tree/gs-gbm_matrix"
|
||||
|
@ -57,8 +57,10 @@ source=(
|
|||
"http://mirrors.kodi.tv/build-deps/sources/libudfread-$_libudfread_version.tar.gz"
|
||||
"ArchARM-kodi-init-v$_init_version.tar.gz::https://github.com/graysky2/kodi-standalone-service/archive/v$_init_version.tar.gz"
|
||||
kodi.config.txt
|
||||
build-fix-for-dav1d-1.0.0.patch
|
||||
use-mcpu-avoiding-march-and-mtune.patch
|
||||
0001-mcpu-cortex-application-to-ffmpeg.patch
|
||||
0002-add-dav1d-patch-to-build-system.patch
|
||||
)
|
||||
backup=(boot/kodi.config.txt etc/conf.d/kodi-standalone)
|
||||
noextract=(
|
||||
|
@ -86,8 +88,10 @@ sha256sums=('ea57f7d2339bede8086082865afbb47c953f195dbfbaf54c43aeb4b46b8f9f2e'
|
|||
'5ad9f95c53e8f29853c1fefa0a20a301be4045e2c7ae49d1164bc74d94155627'
|
||||
'b94c70baa45e30346224ceecfab031dd183e09303b1f97d6522f9941da9b0067'
|
||||
'2297a8ed19145a6faa84e06440f2693b056326b0f98a99b76f5db1e9ee70d2c2'
|
||||
'16d6c79ff3a3d3653f21d77a36326a0335c8cec49a9c06dbc2de0ed143e50a9f'
|
||||
'76eafede11af936bb554932b2be71ce91d4bf1c07107d847500ebbf3ff7d7245')
|
||||
'bcde6299a805430c3ca1f2807101edc7001e77b1934088db9057f74d9a9dd8f6'
|
||||
'c226f082349e6442b8920e1108005792c42b9461f7cec0e1576ae079520eed13'
|
||||
'afe90ded82e70af8e5680347a72edcbdc1dcae498083a90cc453dce00b665fce'
|
||||
'7f6e8e5c2084ab88d10ab2c55982212a8c6cbcf4101079be343763127f129a22')
|
||||
|
||||
prepare() {
|
||||
[[ -d kodi-build ]] && rm -rf kodi-build
|
||||
|
@ -99,9 +103,13 @@ prepare() {
|
|||
# and make mtume a7 for this package
|
||||
sed 's/mcpu=cortex-a53/mcpu=cortex-a7/' <../use-mcpu-avoiding-march-and-mtune.patch \
|
||||
>tools/depends/target/ffmpeg/0002-use-mcpu-avoiding-march-and-mtune.patch
|
||||
|
||||
cp ../build-fix-for-dav1d-1.0.0.patch \
|
||||
tools/depends/target/ffmpeg/0003-add-dav1d-patch-to-build-system.patch
|
||||
|
||||
# patch kodi build system to apply the patch we just copied over
|
||||
patch -Np1 -i ../0001-mcpu-cortex-application-to-ffmpeg.patch
|
||||
# patch kodi build system to apply the patches we just copied over
|
||||
patch -p1 -i ../0001-mcpu-cortex-application-to-ffmpeg.patch
|
||||
patch -p1 -i ../0002-add-dav1d-patch-to-build-system.patch
|
||||
}
|
||||
|
||||
build() {
|
||||
|
@ -111,8 +119,8 @@ build() {
|
|||
# uses here so unset them and redefine below
|
||||
unset CFLAGS CXXFLAGS
|
||||
|
||||
CFLAGS="-O2 -pipe -fno-plt"
|
||||
CXXFLAGS="${CFLAGS}"
|
||||
CFLAGS="-O2 -pipe -fstack-protector-strong -fno-plt -fexceptions -Wp,-D_FORTIFY_SOURCE=2 -Wformat -Werror=format-security -fstack-clash-protection"
|
||||
CXXFLAGS="${CFLAGS} -Wp,-D_GLIBCXX_ASSERTIONS"
|
||||
|
||||
export CFLAGS+=" -mcpu=cortex-a7 -mtune=cortex-a7 -mfpu=neon-vfpv4 -mfloat-abi=hard"
|
||||
export CXXFLAGS="${CFLAGS}"
|
||||
|
|
78
alarm/kodi-rpi-legacy/build-fix-for-dav1d-1.0.0.patch
Normal file
78
alarm/kodi-rpi-legacy/build-fix-for-dav1d-1.0.0.patch
Normal file
|
@ -0,0 +1,78 @@
|
|||
From 2546e1ed27f92a840a2cf319e3c1833799974cf1 Mon Sep 17 00:00:00 2001
|
||||
From: BlackEagle <ike.devolder@gmail.com>
|
||||
Date: Fri, 29 Apr 2022 14:33:12 +0200
|
||||
Subject: [PATCH] add build fix for dav1d 1.0.0
|
||||
|
||||
Taken from https://github.com/FFmpeg/FFmpeg/commit/e204846ec16c1ab34c7f3a681734cf5190433018
|
||||
|
||||
add FF_DAV1D_VERSION_AT_LEAST
|
||||
|
||||
Extracted from https://github.com/FFmpeg/FFmpeg/commit/7ee17ec7e46afef0e0af20af196292ec75f50b62
|
||||
|
||||
Signed-off-by: BlackEagle <ike.devolder@gmail.com>
|
||||
---
|
||||
libavcodec/libdav1d.c | 24 ++++++++++++++++++++++--
|
||||
1 file changed, 22 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/libavcodec/libdav1d.c b/libavcodec/libdav1d.c
|
||||
index bbb3ec1e6c..08b4af8ac8 100644
|
||||
--- a/libavcodec/libdav1d.c
|
||||
+++ b/libavcodec/libdav1d.c
|
||||
@@ -30,6 +30,9 @@
|
||||
#include "decode.h"
|
||||
#include "internal.h"
|
||||
|
||||
+#define FF_DAV1D_VERSION_AT_LEAST(x,y) \
|
||||
+ (DAV1D_API_VERSION_MAJOR > (x) || DAV1D_API_VERSION_MAJOR == (x) && DAV1D_API_VERSION_MINOR >= (y))
|
||||
+
|
||||
typedef struct Libdav1dContext {
|
||||
AVClass *class;
|
||||
Dav1dContext *c;
|
||||
@@ -140,6 +143,15 @@ static av_cold int libdav1d_init(AVCodecContext *c)
|
||||
if (dav1d->operating_point >= 0)
|
||||
s.operating_point = dav1d->operating_point;
|
||||
|
||||
+#if FF_DAV1D_VERSION_AT_LEAST(6,0)
|
||||
+ if (dav1d->frame_threads || dav1d->tile_threads)
|
||||
+ s.n_threads = FFMAX(dav1d->frame_threads, dav1d->tile_threads);
|
||||
+ else
|
||||
+ s.n_threads = FFMIN(threads, DAV1D_MAX_THREADS);
|
||||
+ s.max_frame_delay = (c->flags & AV_CODEC_FLAG_LOW_DELAY) ? 1 : s.n_threads;
|
||||
+ av_log(c, AV_LOG_DEBUG, "Using %d threads, %d max_frame_delay\n",
|
||||
+ s.n_threads, s.max_frame_delay);
|
||||
+#else
|
||||
s.n_tile_threads = dav1d->tile_threads
|
||||
? dav1d->tile_threads
|
||||
: FFMIN(floor(sqrt(threads)), DAV1D_MAX_TILE_THREADS);
|
||||
@@ -148,6 +160,7 @@ static av_cold int libdav1d_init(AVCodecContext *c)
|
||||
: FFMIN(ceil(threads / s.n_tile_threads), DAV1D_MAX_FRAME_THREADS);
|
||||
av_log(c, AV_LOG_DEBUG, "Using %d frame threads, %d tile threads\n",
|
||||
s.n_frame_threads, s.n_tile_threads);
|
||||
+#endif
|
||||
|
||||
res = dav1d_open(&dav1d->c, &s);
|
||||
if (res < 0)
|
||||
@@ -384,11 +397,18 @@ static av_cold int libdav1d_close(AVCodecContext *c)
|
||||
return 0;
|
||||
}
|
||||
|
||||
+#ifndef DAV1D_MAX_FRAME_THREADS
|
||||
+#define DAV1D_MAX_FRAME_THREADS DAV1D_MAX_THREADS
|
||||
+#endif
|
||||
+#ifndef DAV1D_MAX_TILE_THREADS
|
||||
+#define DAV1D_MAX_TILE_THREADS DAV1D_MAX_THREADS
|
||||
+#endif
|
||||
+
|
||||
#define OFFSET(x) offsetof(Libdav1dContext, x)
|
||||
#define VD AV_OPT_FLAG_VIDEO_PARAM | AV_OPT_FLAG_DECODING_PARAM
|
||||
static const AVOption libdav1d_options[] = {
|
||||
- { "tilethreads", "Tile threads", OFFSET(tile_threads), AV_OPT_TYPE_INT, { .i64 = 0 }, 0, DAV1D_MAX_TILE_THREADS, VD },
|
||||
- { "framethreads", "Frame threads", OFFSET(frame_threads), AV_OPT_TYPE_INT, { .i64 = 0 }, 0, DAV1D_MAX_FRAME_THREADS, VD },
|
||||
+ { "tilethreads", "Tile threads", OFFSET(tile_threads), AV_OPT_TYPE_INT, { .i64 = 0 }, 0, DAV1D_MAX_TILE_THREADS, VD | AV_OPT_FLAG_DEPRECATED },
|
||||
+ { "framethreads", "Frame threads", OFFSET(frame_threads), AV_OPT_TYPE_INT, { .i64 = 0 }, 0, DAV1D_MAX_FRAME_THREADS, VD | AV_OPT_FLAG_DEPRECATED },
|
||||
{ "filmgrain", "Apply Film Grain", OFFSET(apply_grain), AV_OPT_TYPE_BOOL, { .i64 = -1 }, -1, 1, VD },
|
||||
{ "oppoint", "Select an operating point of the scalable bitstream", OFFSET(operating_point), AV_OPT_TYPE_INT, { .i64 = -1 }, -1, 31, VD },
|
||||
{ "alllayers", "Output all spatial layers", OFFSET(all_layers), AV_OPT_TYPE_BOOL, { .i64 = 0 }, 0, 1, VD },
|
||||
--
|
||||
2.36.0
|
||||
|
|
@ -1,5 +1,5 @@
|
|||
From 2e2417894ac5d35bc3d93b86c18f4df299f4d933 Mon Sep 17 00:00:00 2001
|
||||
From: graysky <graysky@archlinux.us>
|
||||
From: graysky <therealgraysky@proton.me>
|
||||
Date: Sat, 12 Dec 2020 09:10:28 -0500
|
||||
Subject: [PATCH] use -mcpu= avoiding -march and -mtune for armv7h
|
||||
|
||||
|
|
Loading…
Reference in a new issue