extra/js60 to 60.7.2-1

This commit is contained in:
Kevin Mihelich 2019-06-20 23:07:27 +00:00
parent 53ea73c2e3
commit 0cb029faf9
2 changed files with 14 additions and 80 deletions

View file

@ -1,31 +1,29 @@
# Maintainer: Jan Alexander Steffens (heftig) <jan.steffens@gmail.com>
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
# - use tarball source
# - remove --enable-linker=gold
pkgname=js60
pkgver=60.7.1
pkgver=60.7.2
pkgrel=1
_ffver=${pkgver%%.*}
pkgdesc="JavaScript interpreter and libraries - Version $_ffver"
pkgdesc="JavaScript interpreter and libraries - Version 60"
arch=(x86_64)
url="https://developer.mozilla.org/en-US/docs/Mozilla/Projects/SpiderMonkey"
license=(MPL)
depends=(gcc-libs readline zlib sh)
makedepends=(python2 zip autoconf2.13 mercurial)
_repo=https://hg.mozilla.org/mozilla-unified
source=("https://hg.mozilla.org/mozilla-unified/archive/FIREFOX_${pkgver//./_}esr_RELEASE.tar.gz"
makedepends=(python2 zip autoconf2.13)
_relver=${pkgver}esr
source=(https://archive.mozilla.org/pub/firefox/releases/$_relver/source/firefox-$_relver.source.tar.xz{,.asc}
bug1415202.patch
mozjs60-fix-soname.patch
mozjs52-include-configure-script.patch)
sha256sums=('de6793d4c7e01e216d3abb04e96b855ea7dd4ac0dadfa9d6bc20e3f310320416'
mozjs60-fix-soname.patch)
sha256sums=('8a918ea70c806524f293336f6f4574bb6e69ca1e98e6e5e0e5c2d6ad2ac26ac2'
'SKIP'
'0b410aa6ebd0236cd3ea524340c2da2235973a42cd0eaa90f7f394cd5bcbab95'
'c792837930defe27355941080e9b80ec1d45003c097e4707860acc13d43bc519'
'd91a89acd88bfc747a255050757a0c17139bf5c3508c2e1c3c6bb2056786a344')
'c792837930defe27355941080e9b80ec1d45003c097e4707860acc13d43bc519')
validpgpkeys=('14F26682D0916CDD81E37B6D61B7B526D98F0353') # Mozilla Software Releases <release@mozilla.com>
prepare() {
cd mozilla-unified-FIREFOX_${pkgver//./_}esr_RELEASE
cd firefox-$pkgver
mkdir obj
# https://bugzilla.mozilla.org/show_bug.cgi?id=1479687
@ -33,7 +31,6 @@ prepare() {
# https://salsa.debian.org/gnome-team/mozjs52/tree/debian/master/debian/patches
patch -Np1 -i ../mozjs60-fix-soname.patch
patch -Np1 -i ../mozjs52-include-configure-script.patch
}
build() {
@ -55,7 +52,7 @@ build() {
--without-system-icu
)
cd mozilla-unified-FIREFOX_${pkgver//./_}esr_RELEASE/obj
cd firefox-$pkgver/obj
export PYTHON=/usr/bin/python2
@ -74,7 +71,7 @@ check() {
basic
)
cd mozilla-unified-FIREFOX_${pkgver//./_}esr_RELEASE/obj
cd firefox-$pkgver/obj
make -C js/src check-jstests check-jit-test \
JSTESTS_EXTRA_ARGS="${jstests_extra_args[*]}" \
JITTEST_EXTRA_ARGS="${jittest_extra_args[*]}" \
@ -82,7 +79,7 @@ check() {
}
package() {
cd mozilla-unified-FIREFOX_${pkgver//./_}esr_RELEASE/obj
cd firefox-$pkgver/obj
make DESTDIR="$pkgdir" install
rm "$pkgdir"/usr/lib/*.ajs
find "$pkgdir"/usr/{lib/pkgconfig,include} -type f -exec chmod -c a-x {} +

View file

@ -1,63 +0,0 @@
From 4a06a1a6a71293decb83aee7adb74bc709493106 Mon Sep 17 00:00:00 2001
From: Philip Chimento <philip.chimento@gmail.com>
Date: Wed, 5 Jul 2017 22:57:09 -0700
Subject: [PATCH] build: Include configure script, be nicer about options
A configure script is not included in the SpiderMonkey tarball by
default. Also, we have to account for JHbuild passing extra unknown
options like --disable-Werror.
https://bugzilla.mozilla.org/show_bug.cgi?id=1379540
---
js/src/configure | 9 +++++++++
python/mozbuild/mozbuild/configure/__init__.py | 2 +-
python/mozbuild/mozbuild/configure/options.py | 6 +++++-
3 files changed, 15 insertions(+), 2 deletions(-)
create mode 100755 js/src/configure
diff --git a/js/src/configure b/js/src/configure
new file mode 100755
index 00000000..f1ef8c49
--- /dev/null
+++ b/js/src/configure
@@ -0,0 +1,9 @@
+#!/bin/sh
+
+SRCDIR=$(dirname $0)
+TOPSRCDIR="$SRCDIR"/../..
+export OLD_CONFIGURE="$SRCDIR"/old-configure
+
+set -- "$@" --enable-project=js
+
+which python2.7 > /dev/null && exec python2.7 "$TOPSRCDIR/configure.py" "$@" || exec python "$TOPSRCDIR/configure.py" "$@"
diff --git a/python/mozbuild/mozbuild/configure/__init__.py b/python/mozbuild/mozbuild/configure/__init__.py
index 0fe640ca..09b460d3 100644
--- a/python/mozbuild/mozbuild/configure/__init__.py
+++ b/python/mozbuild/mozbuild/configure/__init__.py
@@ -356,7 +356,7 @@ def run(self, path=None):
# All options should have been removed (handled) by now.
for arg in self._helper:
without_value = arg.split('=', 1)[0]
- raise InvalidOptionError('Unknown option: %s' % without_value)
+ print('Ignoring', without_value, ': Unknown option')
# Run the execution queue
for func, args in self._execution_queue:
diff --git a/python/mozbuild/mozbuild/configure/options.py b/python/mozbuild/mozbuild/configure/options.py
index 4310c862..15bfe425 100644
--- a/python/mozbuild/mozbuild/configure/options.py
+++ b/python/mozbuild/mozbuild/configure/options.py
@@ -402,7 +402,11 @@ def __init__(self, environ=os.environ, argv=sys.argv):
def add(self, arg, origin='command-line', args=None):
assert origin != 'default'
- prefix, name, values = Option.split_option(arg)
+ try:
+ prefix, name, values = Option.split_option(arg)
+ except InvalidOptionError as e:
+ print('Ignoring', arg, ':', e)
+ return
if args is None:
args = self._extra_args
if args is self._extra_args and name in self._extra_args: