extra/claws-mail to 3.7.9-3

This commit is contained in:
Kevin Mihelich 2011-05-26 08:49:16 -04:00
parent d4795a2425
commit 0cb5e5b651
2 changed files with 27 additions and 4 deletions

View file

@ -1,4 +1,4 @@
# $Id: PKGBUILD 121163 2011-04-29 06:26:08Z andyrtr $
# $Id: PKGBUILD 124918 2011-05-25 08:15:13Z ibiru $
# Maintainer: Andreas Radke <andyrtr@archlinux.org>
# PlugApps: Kevin Mihelich <kevin@plugapps.com>
@ -8,7 +8,7 @@ plugrel=1
pkgname=claws-mail
pkgver=3.7.9
pkgrel=2
pkgrel=3
pkgdesc="A GTK+ based e-mail client."
arch=('i686' 'x86_64')
license=('GPL3')
@ -25,12 +25,17 @@ replaces=('sylpheed-claws')
provides=('claws')
options=(!libtool)
install=claws-mail.install
source=(http://downloads.sourceforge.net/sourceforge/sylpheed-claws/${pkgname}-${pkgver}.tar.bz2)
md5sums=('2f9d2dcabf84e312cfeb56efa799b5b3')
source=(http://downloads.sourceforge.net/sourceforge/sylpheed-claws/${pkgname}-${pkgver}.tar.bz2
claws-notify-crash.patch)
md5sums=('2f9d2dcabf84e312cfeb56efa799b5b3'
'9a2903449f679344b5f5f51c91825b45')
build() {
cd ${srcdir}/${pkgname}-${pkgver}
patch -Np0 -i $srcdir/claws-notify-crash.patch
sed -i 's@^#!.*python.*@#!/usr/bin/python2@' tools/*.py
./configure --prefix=/usr --disable-static \
--enable-enchant \
--enable-gnutls \

View file

@ -0,0 +1,18 @@
Index: src/main.c
===================================================================
RCS file: //claws/src/main.c,v
retrieving revision 1.115.2.237
retrieving revision 1.115.2.238
diff -u -r1.115.2.237 -r1.115.2.238
--- src/main.c 10 Apr 2011 17:19:04 -0000 1.115.2.237
+++ src/main.c 30 Apr 2011 19:27:15 -0000 1.115.2.238
@@ -331,7 +331,7 @@
gtk_widget_show(hack);
}
- xdisplay = gdk_display_get_default();
+ xdisplay = GDK_DISPLAY_XDISPLAY(gdk_display_get_default());
sn_display = sn_display_new(xdisplay,
sn_error_trap_push,
sn_error_trap_pop);