mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-02-16 23:57:11 +00:00
Added gmp_limb_bits patch:
http://svn.php.net/viewvc?view=revision&revision=295402 Enabled debug so php-cli doesn't segfault installing pear
This commit is contained in:
parent
e9c00d6f87
commit
0d0673bf44
1 changed files with 11 additions and 0 deletions
11
extra/php/gmp_limb_bits.patch
Normal file
11
extra/php/gmp_limb_bits.patch
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- ext/gmp/gmp.c.orig 2010-08-15 17:41:04.000000000 -0700
|
||||
+++ ext/gmp/gmp.c 2010-08-15 17:43:30.000000000 -0700
|
||||
@@ -1396,7 +1396,7 @@
|
||||
|
||||
GMPG(rand_initialized) = 1;
|
||||
}
|
||||
- mpz_urandomb(*gmpnum_result, GMPG(rand_state), GMP_ABS (limiter) * __GMP_BITS_PER_MP_LIMB);
|
||||
+ mpz_urandomb(*gmpnum_result, GMPG(rand_state), GMP_ABS (limiter) * GMP_LIMB_BITS);
|
||||
|
||||
ZEND_REGISTER_RESOURCE(return_value, gmpnum_result, le_gmp);
|
||||
}
|
Loading…
Reference in a new issue