core/linux-espressobin to 4.12.5-1

This commit is contained in:
Kevin Mihelich 2017-08-08 00:25:46 +00:00
parent 54a1310b6b
commit 0d57c550e7
14 changed files with 102 additions and 132 deletions

View file

@ -1,7 +1,7 @@
From b5470764c194b8930cf0fb65f48e2f2cea6246c5 Mon Sep 17 00:00:00 2001
From: Marc Zyngier <Marc.Zyngier@arm.com>
Date: Sat, 1 Jul 2017 15:16:34 +0100
Subject: [PATCH 01/12] ARM64: dts: marvell: armada37xx: Fix GIC maintenance
Subject: [PATCH 01/11] ARM64: dts: marvell: armada37xx: Fix GIC maintenance
interrupt
The GIC-500 integrated in the Armada-37xx SoCs is compliant with

View file

@ -1,7 +1,7 @@
From a6e0e494f7213d914963b2aea8e3ff0e9a0e978a Mon Sep 17 00:00:00 2001
From: Marc Zyngier <Marc.Zyngier@arm.com>
Date: Sat, 1 Jul 2017 15:16:35 +0100
Subject: [PATCH 02/12] ARM64: dts: marvell: armada37xx: Enable memory-mapped
Subject: [PATCH 02/11] ARM64: dts: marvell: armada37xx: Enable memory-mapped
GIC CPU interface
The Cortex-A53s that power the Armada-37xx SoCs are equipped with

View file

@ -1,7 +1,7 @@
From b61fe18e003c4a37b91092cf4abaee9592bb5a87 Mon Sep 17 00:00:00 2001
From: Marc Zyngier <Marc.Zyngier@arm.com>
Date: Sat, 1 Jul 2017 15:16:36 +0100
Subject: [PATCH 03/12] ARM64: dts: marvell: armada37xx: Wire PMUv3
Subject: [PATCH 03/11] ARM64: dts: marvell: armada37xx: Wire PMUv3
The Cortex-A53s that power the Armada-37xx SoCs are equipped with
a PMUv3, just like most ARMv8 cores.

View file

@ -1,7 +1,7 @@
From d71549275ca1e2bee8e7914501526b625e9f8a53 Mon Sep 17 00:00:00 2001
From: Marc Zyngier <Marc.Zyngier@arm.com>
Date: Sat, 1 Jul 2017 15:16:37 +0100
Subject: [PATCH 04/12] ARM64: dts: marvell: armada37xx: Enable USB2 on
Subject: [PATCH 04/11] ARM64: dts: marvell: armada37xx: Enable USB2 on
espressobin
The Espressobin SBC has a USB2 interface available on J8. Let's

View file

@ -1,7 +1,7 @@
From aff7d41d285c04f5990247660c860e30029f72b2 Mon Sep 17 00:00:00 2001
From: Konstantin Porotchkin <kostap@marvell.com>
Date: Tue, 23 May 2017 16:11:40 +0300
Subject: [PATCH 05/12] arm64: dts: marvell: Enable second SDHCI controller in
Subject: [PATCH 05/11] arm64: dts: marvell: Enable second SDHCI controller in
Armada 37xx
The Armada 37xx SoCs has 2 SDHCI interfaces. This patch adds the second

View file

@ -0,0 +1,71 @@
From 1d0dd1ab378af298bf4040edb8ee58d340f48518 Mon Sep 17 00:00:00 2001
From: Marcin Wojtas <mw@semihalf.com>
Date: Fri, 21 Jul 2017 01:50:36 +0200
Subject: [PATCH 06/11] ARM64: dts: marvell: armada-37xx: Enable uSD on
ESPRESSObin
The ESPRESSObin board exposes one of the SDHCI interfaces
via J1 uSD slot. This patch enables it.
Tested-by: Miquel Raynal <miquel.raynal@free-electrons.com>
Signed-off-by: Marcin Wojtas <mw@semihalf.com>
Signed-off-by: Zbigniew Bodek <zbodek@gmail.com>
[gregory.clement@free-electrons.com: removed "no-1-8-v"]
Signed-off-by: Gregory CLEMENT <gregory.clement@free-electrons.com>
---
.../boot/dts/marvell/armada-3720-espressobin.dts | 25 ++++++++++++++++++++++
1 file changed, 25 insertions(+)
diff --git a/arch/arm64/boot/dts/marvell/armada-3720-espressobin.dts b/arch/arm64/boot/dts/marvell/armada-3720-espressobin.dts
index b1af3f988b29..2ce52ba74f73 100644
--- a/arch/arm64/boot/dts/marvell/armada-3720-espressobin.dts
+++ b/arch/arm64/boot/dts/marvell/armada-3720-espressobin.dts
@@ -45,6 +45,7 @@
/dts-v1/;
+#include <dt-bindings/gpio/gpio.h>
#include "armada-372x.dtsi"
/ {
@@ -59,6 +60,20 @@
device_type = "memory";
reg = <0x00000000 0x00000000 0x00000000 0x20000000>;
};
+
+ vcc_sd_reg1: regulator {
+ compatible = "regulator-gpio";
+ regulator-name = "vcc_sd1";
+ regulator-min-microvolt = <1800000>;
+ regulator-max-microvolt = <3300000>;
+ regulator-boot-on;
+
+ gpios = <&gpionb 4 GPIO_ACTIVE_HIGH>;
+ gpios-states = <0>;
+ states = <1800000 0x1
+ 3300000 0x0>;
+ enable-active-high;
+ };
};
/* J9 */
@@ -71,6 +86,16 @@
status = "okay";
};
+/* J1 */
+&sdhci1 {
+ wp-inverted;
+ bus-width = <4>;
+ cd-gpios = <&gpionb 3 GPIO_ACTIVE_LOW>;
+ marvell,pad-type = "sd";
+ vqmmc-supply = <&vcc_sd_reg1>;
+ status = "okay";
+};
+
/* Exported on the micro USB connector J5 through an FTDI */
&uart0 {
status = "okay";
--
2.13.3

View file

@ -1,46 +0,0 @@
From c45f110fee171a93323b3cb23f751e6545d01846 Mon Sep 17 00:00:00 2001
From: Sean Nyekjaer <sean@nyekjaer.dk>
Date: Sun, 25 Jun 2017 21:20:05 +0200
Subject: [PATCH 06/12] arm64: dts: marvell: Add microsd card definition for
the ESPRESSObin
This defines and enables the microsd card on the
Marvell ESPRESSObin board.
Signed-off-by: Sean Nyekjaer <sean@nyekjaer.dk>
---
arch/arm64/boot/dts/marvell/armada-3720-espressobin.dts | 11 +++++++++++
1 file changed, 11 insertions(+)
diff --git a/arch/arm64/boot/dts/marvell/armada-3720-espressobin.dts b/arch/arm64/boot/dts/marvell/armada-3720-espressobin.dts
index b1af3f988b29..409385c4195a 100644
--- a/arch/arm64/boot/dts/marvell/armada-3720-espressobin.dts
+++ b/arch/arm64/boot/dts/marvell/armada-3720-espressobin.dts
@@ -45,6 +45,7 @@
/dts-v1/;
+#include <dt-bindings/gpio/gpio.h>
#include "armada-372x.dtsi"
/ {
@@ -76,6 +77,16 @@
status = "okay";
};
+/* microsd slot */
+&sdhci1 {
+ wp-inverted;
+ bus-width = <4>;
+ cd-gpios = <&gpionb 3 GPIO_ACTIVE_LOW>;
+ no-1-8-v;
+ marvell,pad-type = "sd";
+ status = "okay";
+};
+
/* J7 */
&usb3 {
status = "okay";
--
2.13.3

View file

@ -1,7 +1,7 @@
From b6c9745670f6c9d1d1c140678685e2bbc5be2ad8 Mon Sep 17 00:00:00 2001
From 8440f9edeb29c10cc0ec29c55c07d4e5e5b67c5b Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Tue, 4 Jul 2017 19:25:28 -0600
Subject: [PATCH 07/12] arm64: dts: marvell: armada37xx: Add eth0 alias
Subject: [PATCH 07/11] arm64: dts: marvell: armada37xx: Add eth0 alias
Signed-off-by: Kevin Mihelich <kevin@archlinuxarm.org>
---

View file

@ -1,7 +1,7 @@
From 81e63953b87b41ae2aaddb97917ee0cd2e29656e Mon Sep 17 00:00:00 2001
From c1d0aadc4440c07d2e940c83c1b6e5d9d694a3a5 Mon Sep 17 00:00:00 2001
From: Victor Gu <xigu@marvell.com>
Date: Wed, 29 Mar 2017 15:17:03 +0800
Subject: [PATCH 08/12] fix: pci: aardvark: disable LOS state by default
Subject: [PATCH 08/11] fix: pci: aardvark: disable LOS state by default
Some PCIe devices do not support LOS, there will be time out issue
if the RC forces the LOS state.

View file

@ -1,7 +1,7 @@
From dd0a8aec77d2198b9be8997a068fc4ca8f67bdff Mon Sep 17 00:00:00 2001
From 364d845b2fd8c083f32a95377f5b3cd3f0cf2323 Mon Sep 17 00:00:00 2001
From: Victor Gu <xigu@marvell.com>
Date: Mon, 27 Mar 2017 18:28:25 +0800
Subject: [PATCH 09/12] fix: pci: aardvark: use isr1 interrupt in legacy irq
Subject: [PATCH 09/11] fix: pci: aardvark: use isr1 interrupt in legacy irq
mode
The Aardvark has two interrupts sets, first set is bit[23:16] of

View file

@ -1,7 +1,7 @@
From d561d593c0a1352748fc8ae4d04a264d33ca9cbe Mon Sep 17 00:00:00 2001
From dda187271721fbc30329d56fd68034c54e304a44 Mon Sep 17 00:00:00 2001
From: Victor Gu <xigu@marvell.com>
Date: Fri, 24 Mar 2017 20:52:30 +0800
Subject: [PATCH 10/12] pci: aardvard: set host and device to the same MAX
Subject: [PATCH 10/11] pci: aardvard: set host and device to the same MAX
payload size
Since the Aardvard does not implement PCIe root bus, the Linux PCIe

View file

@ -1,7 +1,7 @@
From 54e86a8e68e2ba130e1ed9cbd648901855041e86 Mon Sep 17 00:00:00 2001
From 100881d53b53c3c6691a3f3b4ddfc88d738c753b Mon Sep 17 00:00:00 2001
From: Victor Gu <xigu@marvell.com>
Date: Fri, 24 Mar 2017 20:41:55 +0800
Subject: [PATCH 11/12] fix: pcie: aardvark: correct the default MAX payload
Subject: [PATCH 11/11] fix: pcie: aardvark: correct the default MAX payload
size
The previous PCIe MAX payload field is set to 7 which is undefined

View file

@ -1,52 +0,0 @@
From c68e889e59fff4f6cc56cc4cb3bc63629dff4cf7 Mon Sep 17 00:00:00 2001
From: Sean Nyekjaer <sean@nyekjaer.dk>
Date: Sat, 29 Jul 2017 12:44:11 +0200
Subject: [PATCH 12/12] arm64: dts: marvell: armada-3720-espressobin: Add vqmmc
regulator for SD slot
By adding this regulator, the SD cards are usable at higher speed
protocols such as SDR104.
This patch was tested with an SDHC card compatible with UHS-I.
Signed-off-by: Sean Nyekjaer <sean@nyekjaer.dk>
---
arch/arm64/boot/dts/marvell/armada-3720-espressobin.dts | 15 ++++++++++++++-
1 file changed, 14 insertions(+), 1 deletion(-)
diff --git a/arch/arm64/boot/dts/marvell/armada-3720-espressobin.dts b/arch/arm64/boot/dts/marvell/armada-3720-espressobin.dts
index 409385c4195a..f9756193e78a 100644
--- a/arch/arm64/boot/dts/marvell/armada-3720-espressobin.dts
+++ b/arch/arm64/boot/dts/marvell/armada-3720-espressobin.dts
@@ -60,6 +60,19 @@
device_type = "memory";
reg = <0x00000000 0x00000000 0x00000000 0x20000000>;
};
+
+ vcc_sd_reg1: regulator {
+ compatible = "regulator-gpio";
+ regulator-name= "vcc_sd1";
+ regulator-min-microvolt = <1800000>;
+ regulator-max-microvolt = <3300000>;
+
+ gpios = <&gpionb 4 GPIO_ACTIVE_HIGH>;
+ gpios-states = <0>;
+ states = <1800000 0x1
+ 3300000 0x0>;
+ enable-active-high;
+ };
};
/* J9 */
@@ -82,7 +95,7 @@
wp-inverted;
bus-width = <4>;
cd-gpios = <&gpionb 3 GPIO_ACTIVE_LOW>;
- no-1-8-v;
+ vqmmc-supply = <&vcc_sd_reg1>;
marvell,pad-type = "sd";
status = "okay";
};
--
2.13.3

View file

@ -7,8 +7,8 @@ pkgbase=linux-espressobin
_srcname=linux-4.12
_kernelname=${pkgbase#linux}
_desc="Globalscale ESPRESSOBin"
pkgver=4.12.4
pkgrel=2
pkgver=4.12.5
pkgrel=1
arch=('aarch64')
url="http://www.kernel.org/"
license=('GPL2')
@ -21,29 +21,27 @@ source=("http://www.kernel.org/pub/linux/kernel/v4.x/${_srcname}.tar.xz"
'0003-ARM64-dts-marvell-armada37xx-Wire-PMUv3.patch'
'0004-ARM64-dts-marvell-armada37xx-Enable-USB2-on-espresso.patch'
'0005-arm64-dts-marvell-Enable-second-SDHCI-controller-in-.patch'
'0006-arm64-dts-marvell-Add-microsd-card-definition-for-th.patch'
'0006-ARM64-dts-marvell-armada-37xx-Enable-uSD-on-ESPRESSO.patch'
'0007-arm64-dts-marvell-armada37xx-Add-eth0-alias.patch'
'0008-fix-pci-aardvark-disable-LOS-state-by-default.patch'
'0009-fix-pci-aardvark-use-isr1-interrupt-in-legacy-irq-mo.patch'
'0010-pci-aardvard-set-host-and-device-to-the-same-MAX-pay.patch'
'0011-fix-pcie-aardvark-correct-the-default-MAX-payload-si.patch'
'0012-arm64-dts-marvell-armada-3720-espressobin-Add-vqmmc-.patch'
'config'
'linux.preset')
md5sums=('fc454157e2d024d401a60905d6481c6b'
'8b701bde9ab905f36c9917a6afdfb3e5'
'd9f87445c615eadca01d51c0e1e6a458'
'720058cf4e989060787450a9933ecfb9'
'4922aa23ab91bd69367eb7acf4de4a7f'
'45284a34c89b8be1552ddfab16651db3'
'd6bab1301eaa71fa399fa79c2f4e67af'
'0f5f61d0d33724edbb0478fa537937cf'
'8f985e59ba80ce0011dab959827b2350'
'69fd3a1d44e60de8615c2c393a8427b0'
'9ec5be9e0c46154f376810623821663f'
'339456439ecf6e55ab9e4f3a46c1d037'
'ac1c0c57061e52eb65b1cb2cc6c227d5'
'cffefeed5edf5308b366453f60561b8c'
'0993b69927d19e4f2b52d99670a95d07'
'a5fa5fb4a2c9f81893f64519419d64a0'
'8d6c8a277c5486398aa35b043e4b719d'
'cf2e62ac9c823d5bbbea550e3ec905fa'
'bf107ceb9bf8decef68f8f04c41feef1'
'14edcb80e72bfdd52780d73fa9ee620e'
'0b35c2f91eca2e6b44e856f891fb87f7'
'c6ed17ff51f5fc91a89145232758698f'
'1730d83da11980a67faac86e65011cad'
'a2b48909d123cc289c76b4675ef2d734'
'f9c043188dce7c686ebaad09d693a9eb'
'5dfa7ccc106660a5b45d36dab5352c96'
'c95edc27fef32524f2a02bc8748c635d'
'd8d30aa4a9d4c2b8d4ea53faf46ccf80')
@ -59,13 +57,12 @@ prepare() {
git apply ../0003-ARM64-dts-marvell-armada37xx-Wire-PMUv3.patch
git apply ../0004-ARM64-dts-marvell-armada37xx-Enable-USB2-on-espresso.patch
git apply ../0005-arm64-dts-marvell-Enable-second-SDHCI-controller-in-.patch
git apply ../0006-arm64-dts-marvell-Add-microsd-card-definition-for-th.patch
git apply ../0006-ARM64-dts-marvell-armada-37xx-Enable-uSD-on-ESPRESSO.patch
git apply ../0007-arm64-dts-marvell-armada37xx-Add-eth0-alias.patch
git apply ../0008-fix-pci-aardvark-disable-LOS-state-by-default.patch
git apply ../0009-fix-pci-aardvark-use-isr1-interrupt-in-legacy-irq-mo.patch
git apply ../0010-pci-aardvard-set-host-and-device-to-the-same-MAX-pay.patch
git apply ../0011-fix-pcie-aardvark-correct-the-default-MAX-payload-si.patch
git apply ../0012-arm64-dts-marvell-armada-3720-espressobin-Add-vqmmc-.patch
cat "${srcdir}/config" > ./.config