mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-02-16 23:57:11 +00:00
extra/suitesparse to 5.1.0-1
This commit is contained in:
parent
3a9c5c8c97
commit
0d5906ccd7
2 changed files with 6 additions and 24 deletions
|
@ -5,11 +5,11 @@
|
||||||
# - drop intel-tbb depend, remove TBB=-ltbb SPQR_CONFIG=-DHAVE_TBB
|
# - drop intel-tbb depend, remove TBB=-ltbb SPQR_CONFIG=-DHAVE_TBB
|
||||||
|
|
||||||
pkgname=suitesparse
|
pkgname=suitesparse
|
||||||
pkgver=4.5.6
|
pkgver=5.1.0
|
||||||
pkgrel=1
|
pkgrel=1
|
||||||
pkgdesc="A collection of sparse matrix libraries"
|
pkgdesc="A collection of sparse matrix libraries"
|
||||||
url="http://faculty.cse.tamu.edu/davis/suitesparse.html"
|
url="http://faculty.cse.tamu.edu/davis/suitesparse.html"
|
||||||
arch=('i686' 'x86_64')
|
arch=('x86_64')
|
||||||
conflicts=('umfpack')
|
conflicts=('umfpack')
|
||||||
provides=('umfpack')
|
provides=('umfpack')
|
||||||
replaces=('umfpack')
|
replaces=('umfpack')
|
||||||
|
@ -17,25 +17,18 @@ depends=('metis' 'lapack')
|
||||||
makedepends=('gcc-fortran' 'cmake' 'chrpath')
|
makedepends=('gcc-fortran' 'cmake' 'chrpath')
|
||||||
license=('GPL')
|
license=('GPL')
|
||||||
options=('staticlibs')
|
options=('staticlibs')
|
||||||
source=("http://faculty.cse.tamu.edu/davis/SuiteSparse/SuiteSparse-$pkgver.tar.gz" suitesparse-link-tbb.patch)
|
source=("http://faculty.cse.tamu.edu/davis/SuiteSparse/SuiteSparse-$pkgver.tar.gz")
|
||||||
sha1sums=('06ed5f6f61bfe09f08ce03971a24381a627446b1'
|
sha1sums=('bedf8aa7fdff4247cf1b9029a86cbb76c11627db')
|
||||||
'4f0b3836e8c3c1ec5be01f988f136cee4a2cb936')
|
|
||||||
|
|
||||||
prepare() {
|
|
||||||
# Fix linking with intel-tbb
|
|
||||||
cd SuiteSparse
|
|
||||||
patch -p1 -i ../suitesparse-link-tbb.patch
|
|
||||||
}
|
|
||||||
|
|
||||||
build() {
|
build() {
|
||||||
cd "$srcdir"/SuiteSparse
|
cd SuiteSparse
|
||||||
|
|
||||||
BLAS=-lblas MY_METIS_LIB=/usr/lib/libmetis.so make
|
BLAS=-lblas MY_METIS_LIB=/usr/lib/libmetis.so make
|
||||||
}
|
}
|
||||||
|
|
||||||
|
|
||||||
package() {
|
package() {
|
||||||
cd "${srcdir}"/SuiteSparse
|
cd SuiteSparse
|
||||||
install -dm755 "${pkgdir}"/usr/{include,lib}
|
install -dm755 "${pkgdir}"/usr/{include,lib}
|
||||||
|
|
||||||
BLAS=-lblas MY_METIS_LIB=/usr/lib/libmetis.so \
|
BLAS=-lblas MY_METIS_LIB=/usr/lib/libmetis.so \
|
||||||
|
|
|
@ -1,11 +0,0 @@
|
||||||
--- SuiteSparse/SPQR/Lib/Makefile.orig 2016-09-24 09:36:59.588640845 +0000
|
|
||||||
+++ SuiteSparse/SPQR/Lib/Makefile 2016-09-24 09:37:14.248588339 +0000
|
|
||||||
@@ -13,7 +13,7 @@
|
|
||||||
include ../../SuiteSparse_config/SuiteSparse_config.mk
|
|
||||||
|
|
||||||
# SPQR depends on CHOLMOD, AMD, COLAMD, LAPACK, the BLAS and SuiteSparse_config
|
|
||||||
-LDLIBS += -lamd -lcolamd -lcholmod -lsuitesparseconfig $(LAPACK) $(BLAS)
|
|
||||||
+LDLIBS += -lamd -lcolamd -lcholmod -lsuitesparseconfig $(LAPACK) $(BLAS) $(TBB)
|
|
||||||
|
|
||||||
# compile and install in SuiteSparse/lib
|
|
||||||
library:
|
|
Loading…
Reference in a new issue