mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
extra/mesa to 20.0.7-2
This commit is contained in:
parent
63a4d196a9
commit
0d87d66c6b
6 changed files with 105 additions and 219 deletions
|
@ -1,84 +0,0 @@
|
|||
From c71ea55be7c1dbb58d56df9c6cfa69718fdf5d6a Mon Sep 17 00:00:00 2001
|
||||
From: Ivan Molodetskikh <yalterz@gmail.com>
|
||||
Date: Fri, 27 Sep 2019 00:45:39 +0300
|
||||
Subject: [PATCH 1/2] egl: allow INVALID format for linux_dmabuf
|
||||
|
||||
As per
|
||||
https://gitlab.freedesktop.org/wayland/wayland-protocols/commit/fb9b2a87317c77e26283da5f6c9559d709f6fdcd,
|
||||
the compositor may advertise DRM_FORMAT_MOD_INVALID as a supported
|
||||
modifier. This patch makes mesa recognize this fact and allow
|
||||
linux_dmabuf usage with the INVALID modifier in this case.
|
||||
|
||||
In case the driver doesn't support modifiers, we can still use
|
||||
linux-dmabuf protocol instead of the legacy wl_drm interface to create
|
||||
wl_buffers. This will help compositors to handle these buffers better.
|
||||
|
||||
In this commit, the INVALID modifier is allowed to be added to the list
|
||||
of supported modifiers, and create_wl_buffer will be able to use
|
||||
linux_dmabuf with an INVALID modifier if the compositor advertised it as
|
||||
supported.
|
||||
|
||||
Signed-off-by: Ivan Molodetskikh <yalterz@gmail.com>
|
||||
Tested-by: Marge Bot <https://gitlab.freedesktop.org/mesa/mesa/-/merge_requests/2147>
|
||||
Part-of: <https://gitlab.freedesktop.org/mesa/mesa/-/merge_requests/2147>
|
||||
---
|
||||
src/egl/drivers/dri2/platform_wayland.c | 29 ++++++++++++++++++++-----
|
||||
1 file changed, 24 insertions(+), 5 deletions(-)
|
||||
|
||||
diff --git a/src/egl/drivers/dri2/platform_wayland.c b/src/egl/drivers/dri2/platform_wayland.c
|
||||
index 71bcb04a77b..324ac2357da 100644
|
||||
--- a/src/egl/drivers/dri2/platform_wayland.c
|
||||
+++ b/src/egl/drivers/dri2/platform_wayland.c
|
||||
@@ -522,6 +522,13 @@ get_back_bo(struct dri2_egl_surface *dri2_surf)
|
||||
modifiers = u_vector_tail(&dri2_dpy->wl_modifiers[visual_idx]);
|
||||
num_modifiers = u_vector_length(&dri2_dpy->wl_modifiers[visual_idx]);
|
||||
|
||||
+ if (num_modifiers == 1 && modifiers[0] == DRM_FORMAT_MOD_INVALID) {
|
||||
+ /* For the purposes of this function, an INVALID modifier on its own
|
||||
+ * means the modifiers aren't supported.
|
||||
+ */
|
||||
+ num_modifiers = 0;
|
||||
+ }
|
||||
+
|
||||
/* Substitute dri image format if server does not support original format */
|
||||
if (!BITSET_TEST(dri2_dpy->formats, visual_idx))
|
||||
linear_dri_image_format = dri2_wl_visuals[visual_idx].alt_dri_image_format;
|
||||
@@ -917,7 +924,23 @@ create_wl_buffer(struct dri2_egl_display *dri2_dpy,
|
||||
}
|
||||
}
|
||||
|
||||
- if (dri2_dpy->wl_dmabuf && modifier != DRM_FORMAT_MOD_INVALID) {
|
||||
+ bool supported_modifier = false;
|
||||
+ if (modifier != DRM_FORMAT_MOD_INVALID) {
|
||||
+ supported_modifier = true;
|
||||
+ } else {
|
||||
+ int visual_idx = dri2_wl_visual_idx_from_fourcc(fourcc);
|
||||
+ assert(visual_idx != -1);
|
||||
+
|
||||
+ uint64_t *mod;
|
||||
+ u_vector_foreach(mod, &dri2_dpy->wl_modifiers[visual_idx]) {
|
||||
+ if (*mod == DRM_FORMAT_MOD_INVALID) {
|
||||
+ supported_modifier = true;
|
||||
+ break;
|
||||
+ }
|
||||
+ }
|
||||
+ }
|
||||
+
|
||||
+ if (dri2_dpy->wl_dmabuf && supported_modifier) {
|
||||
struct zwp_linux_buffer_params_v1 *params;
|
||||
int i;
|
||||
|
||||
@@ -1290,10 +1313,6 @@ dmabuf_handle_modifier(void *data, struct zwp_linux_dmabuf_v1 *dmabuf,
|
||||
if (visual_idx == -1)
|
||||
return;
|
||||
|
||||
- if (modifier_hi == (DRM_FORMAT_MOD_INVALID >> 32) &&
|
||||
- modifier_lo == (DRM_FORMAT_MOD_INVALID & 0xffffffff))
|
||||
- return;
|
||||
-
|
||||
BITSET_SET(dri2_dpy->formats, visual_idx);
|
||||
|
||||
mod = u_vector_add(&dri2_dpy->wl_modifiers[visual_idx]);
|
||||
--
|
||||
2.26.2
|
||||
|
|
@ -1,54 +0,0 @@
|
|||
From 4d3f535ebb341ddce05e5b1750fcf17c6c4166c9 Mon Sep 17 00:00:00 2001
|
||||
From: James Xiong <james.xiong@intel.com>
|
||||
Date: Wed, 20 Nov 2019 15:59:00 -0800
|
||||
Subject: [PATCH] iris: handle the failure of converting unsupported yuv
|
||||
formats to isl
|
||||
|
||||
Signed-off-by: James Xiong <james.xiong@intel.com>
|
||||
Reviewed-by: Kenneth Graunke <kenneth@whitecape.org>
|
||||
(cherry picked from commit d8569baaed1a38cf3da9e45375fa2267d9a1eeb0)
|
||||
|
||||
Tested-by: Marge Bot <https://gitlab.freedesktop.org/mesa/mesa/merge_requests/3898>
|
||||
Part-of: <https://gitlab.freedesktop.org/mesa/mesa/merge_requests/3898>
|
||||
Signed-off-by: Laurent Carlier <lordheavym@gmail.com>
|
||||
---
|
||||
src/gallium/drivers/iris/iris_formats.c | 6 +++++-
|
||||
src/gallium/drivers/iris/iris_resource.c | 3 ++-
|
||||
2 files changed, 7 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/src/gallium/drivers/iris/iris_formats.c b/src/gallium/drivers/iris/iris_formats.c
|
||||
index f6344cc7543..a35b663a53c 100644
|
||||
--- a/src/gallium/drivers/iris/iris_formats.c
|
||||
+++ b/src/gallium/drivers/iris/iris_formats.c
|
||||
@@ -338,9 +338,13 @@ iris_format_for_usage(const struct gen_device_info *devinfo,
|
||||
isl_surf_usage_flags_t usage)
|
||||
{
|
||||
enum isl_format format = iris_isl_format_for_pipe_format(pformat);
|
||||
- const struct isl_format_layout *fmtl = isl_format_get_layout(format);
|
||||
struct isl_swizzle swizzle = ISL_SWIZZLE_IDENTITY;
|
||||
|
||||
+ if (format == ISL_FORMAT_UNSUPPORTED)
|
||||
+ return (struct iris_format_info) { .fmt = format, .swizzle = swizzle };
|
||||
+
|
||||
+ const struct isl_format_layout *fmtl = isl_format_get_layout(format);
|
||||
+
|
||||
if (!util_format_is_srgb(pformat)) {
|
||||
if (util_format_is_intensity(pformat)) {
|
||||
swizzle = ISL_SWIZZLE(RED, RED, RED, RED);
|
||||
diff --git a/src/gallium/drivers/iris/iris_resource.c b/src/gallium/drivers/iris/iris_resource.c
|
||||
index bdd715df2c9..7ca6097840a 100644
|
||||
--- a/src/gallium/drivers/iris/iris_resource.c
|
||||
+++ b/src/gallium/drivers/iris/iris_resource.c
|
||||
@@ -85,7 +85,8 @@ modifier_is_supported(const struct gen_device_info *devinfo,
|
||||
|
||||
enum isl_format linear_format = isl_format_srgb_to_linear(rt_format);
|
||||
|
||||
- if (!isl_format_supports_ccs_e(devinfo, linear_format))
|
||||
+ if (linear_format == ISL_FORMAT_UNSUPPORTED ||
|
||||
+ !isl_format_supports_ccs_e(devinfo, linear_format))
|
||||
return false;
|
||||
|
||||
return devinfo->gen >= 9 && devinfo->gen <= 11;
|
||||
--
|
||||
2.25.1
|
||||
|
40
extra/mesa/0001-omx-fix-build-with-gcc-10.patch
Normal file
40
extra/mesa/0001-omx-fix-build-with-gcc-10.patch
Normal file
|
@ -0,0 +1,40 @@
|
|||
From 283e815339a15fa99039c69f1e225269790ae955 Mon Sep 17 00:00:00 2001
|
||||
From: Pierre-Eric Pelloux-Prayer <pierre-eric.pelloux-prayer@amd.com>
|
||||
Date: Thu, 5 Mar 2020 09:37:58 +0100
|
||||
Subject: [PATCH] omx: fix build with gcc 10
|
||||
MIME-Version: 1.0
|
||||
Content-Type: text/plain; charset=UTF-8
|
||||
Content-Transfer-Encoding: 8bit
|
||||
|
||||
bellagio/omx header files reference a global variable without the
|
||||
extern keyworkd.
|
||||
Now that gcc-10 enables the '-fno-common' by default the build fails.
|
||||
Since these are external headers we can't easily fix them, so for
|
||||
now build the omx module with the '-fcommon' flag to keep the
|
||||
previous behavior.
|
||||
|
||||
See https://gitlab.freedesktop.org/mesa/mesa/issues/2385
|
||||
|
||||
Reviewed-by: Michel Dänzer <mdaenzer@redhat.com>
|
||||
Part-of: <https://gitlab.freedesktop.org/mesa/mesa/-/merge_requests/4058>
|
||||
Signed-off-by: Laurent Carlier <lordheavym@gmail.com>
|
||||
---
|
||||
src/gallium/state_trackers/omx/meson.build | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/src/gallium/state_trackers/omx/meson.build b/src/gallium/state_trackers/omx/meson.build
|
||||
index 3aa82090c91..987d3e23c84 100644
|
||||
--- a/src/gallium/state_trackers/omx/meson.build
|
||||
+++ b/src/gallium/state_trackers/omx/meson.build
|
||||
@@ -65,7 +65,7 @@ endif
|
||||
libomx_st = static_library(
|
||||
'omx_st',
|
||||
files_omx,
|
||||
- c_args : [c_vis_args],
|
||||
+ c_args : [c_vis_args, '-fcommon'],
|
||||
include_directories : inc_st_omx,
|
||||
dependencies : dep_st_omx,
|
||||
)
|
||||
--
|
||||
2.26.2
|
||||
|
56
extra/mesa/0001-swr-Fix-build-with-GCC-10.patch
Normal file
56
extra/mesa/0001-swr-Fix-build-with-GCC-10.patch
Normal file
|
@ -0,0 +1,56 @@
|
|||
From 8dacf5f9d1df95c768016a1b92465bbabed37b54 Mon Sep 17 00:00:00 2001
|
||||
From: Vinson Lee <vlee@freedesktop.org>
|
||||
Date: Thu, 30 Jan 2020 20:48:26 -0800
|
||||
Subject: [PATCH] swr: Fix build with GCC 10.
|
||||
MIME-Version: 1.0
|
||||
Content-Type: text/plain; charset=UTF-8
|
||||
Content-Transfer-Encoding: 8bit
|
||||
|
||||
GCC 10 added _mm256_storeu2_m128i.
|
||||
https://gcc.gnu.org/bugzilla/show_bug.cgi?id=91341
|
||||
|
||||
This patch fixes this build error with GCC 10.
|
||||
|
||||
In file included from src/gallium/drivers/swr/rasterizer/codegen/gen_knobs.cpp:39:
|
||||
../src/gallium/drivers/swr/rasterizer/common/os.h:178:20: error: ‘void _mm256_storeu2_m128i(__m128i*, __m128i*, __m256i)’ redeclared inline without ‘gnu_inline’ attribute
|
||||
178 | static INLINE void _mm256_storeu2_m128i(__m128i* hi, __m128i* lo, __m256i a)
|
||||
| ^~~~~~~~~~~~~~~~~~~~
|
||||
In file included from /usr/lib/gcc/x86_64-redhat-linux/10/include/immintrin.h:51,
|
||||
from /usr/lib/gcc/x86_64-redhat-linux/10/include/x86intrin.h:32,
|
||||
from ../src/gallium/drivers/swr/rasterizer/common/os.h:107,
|
||||
from src/gallium/drivers/swr/rasterizer/codegen/gen_knobs.cpp:39:
|
||||
/usr/lib/gcc/x86_64-redhat-linux/10/include/avxintrin.h:1580:1: note: ‘void _mm256_storeu2_m128i(__m128i_u*, __m128i_u*, __m256i)’ previously defined here
|
||||
1580 | _mm256_storeu2_m128i (__m128i_u *__PH, __m128i_u *__PL, __m256i __A)
|
||||
| ^~~~~~~~~~~~~~~~~~~~
|
||||
|
||||
Signed-off-by: Vinson Lee <vlee@freedesktop.org>
|
||||
Tested-by: Marge Bot <https://gitlab.freedesktop.org/mesa/mesa/merge_requests/3650>
|
||||
Part-of: <https://gitlab.freedesktop.org/mesa/mesa/merge_requests/3650>
|
||||
Signed-off-by: Laurent Carlier <lordheavym@gmail.com>
|
||||
---
|
||||
src/gallium/drivers/swr/rasterizer/common/os.h | 4 +++-
|
||||
1 file changed, 3 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/src/gallium/drivers/swr/rasterizer/common/os.h b/src/gallium/drivers/swr/rasterizer/common/os.h
|
||||
index e812da39851..c4ee00bc91d 100644
|
||||
--- a/src/gallium/drivers/swr/rasterizer/common/os.h
|
||||
+++ b/src/gallium/drivers/swr/rasterizer/common/os.h
|
||||
@@ -174,12 +174,14 @@ inline uint64_t __rdtsc()
|
||||
#endif
|
||||
|
||||
#if !defined(__clang__) && !defined(__INTEL_COMPILER)
|
||||
-// Intrinsic not defined in gcc
|
||||
+// Intrinsic not defined in gcc < 10
|
||||
+#if (__GNUC__) && (GCC_VERSION < 100000)
|
||||
static INLINE void _mm256_storeu2_m128i(__m128i* hi, __m128i* lo, __m256i a)
|
||||
{
|
||||
_mm_storeu_si128((__m128i*)lo, _mm256_castsi256_si128(a));
|
||||
_mm_storeu_si128((__m128i*)hi, _mm256_extractf128_si256(a, 0x1));
|
||||
}
|
||||
+#endif
|
||||
|
||||
// gcc prior to 4.9 doesn't have _mm*_undefined_*
|
||||
#if (__GNUC__) && (GCC_VERSION < 409000)
|
||||
--
|
||||
2.26.2
|
||||
|
|
@ -1,71 +0,0 @@
|
|||
From 8aeeb72b5af16e27b152f733da4a7de0ec47f328 Mon Sep 17 00:00:00 2001
|
||||
From: Christopher James Halse Rogers <christopher.halse.rogers@canonical.com>
|
||||
Date: Tue, 24 Mar 2020 14:19:51 +1100
|
||||
Subject: [PATCH 2/2] egl/wayland: Fix zwp_linux_dmabuf usage
|
||||
|
||||
There's no guarantee that the formats advertised by wl_drm and the formats
|
||||
advertised by zwp_linux_dmabuf_v1 are the same.
|
||||
|
||||
get_back_bo() handles this by falling back from createImageWithModifiers() to
|
||||
createImage() when there's a wl_drm format but no corresponding linux_dmabuf
|
||||
format, but create_wl_buffer() unconditionally tries to create a linux_dmabuf
|
||||
buffer unless DRIimage has DRM_FORMAT_MOD_INVALID.
|
||||
|
||||
Fix this by always checking if the DRIimage modifier has been advertised
|
||||
by zwp_linux_dmabuf_v1, and falling back to wl_drm if not.
|
||||
|
||||
If DRM_FORMAT_MOD_INVALID has been advertised then we trust the client
|
||||
has allocated something appropriate and treat any modifier as matching.
|
||||
|
||||
Closes: https://gitlab.freedesktop.org/mesa/mesa/issues/2220
|
||||
Signed-off-by: Christopher James Halse Rogers <christopher.halse.rogers@canonical.com>
|
||||
---
|
||||
src/egl/drivers/dri2/platform_wayland.c | 30 ++++++++++++++++---------
|
||||
1 file changed, 19 insertions(+), 11 deletions(-)
|
||||
|
||||
diff --git a/src/egl/drivers/dri2/platform_wayland.c b/src/egl/drivers/dri2/platform_wayland.c
|
||||
index 324ac2357da..7b7646e6e7f 100644
|
||||
--- a/src/egl/drivers/dri2/platform_wayland.c
|
||||
+++ b/src/egl/drivers/dri2/platform_wayland.c
|
||||
@@ -925,19 +925,27 @@ create_wl_buffer(struct dri2_egl_display *dri2_dpy,
|
||||
}
|
||||
|
||||
bool supported_modifier = false;
|
||||
- if (modifier != DRM_FORMAT_MOD_INVALID) {
|
||||
- supported_modifier = true;
|
||||
- } else {
|
||||
- int visual_idx = dri2_wl_visual_idx_from_fourcc(fourcc);
|
||||
- assert(visual_idx != -1);
|
||||
+ bool mod_invalid_supported = false;
|
||||
+ int visual_idx = dri2_wl_visual_idx_from_fourcc(fourcc);
|
||||
+ assert(visual_idx != -1);
|
||||
|
||||
- uint64_t *mod;
|
||||
- u_vector_foreach(mod, &dri2_dpy->wl_modifiers[visual_idx]) {
|
||||
- if (*mod == DRM_FORMAT_MOD_INVALID) {
|
||||
- supported_modifier = true;
|
||||
- break;
|
||||
- }
|
||||
+ uint64_t *mod;
|
||||
+ u_vector_foreach(mod, &dri2_dpy->wl_modifiers[visual_idx]) {
|
||||
+ if (*mod == DRM_FORMAT_MOD_INVALID) {
|
||||
+ mod_invalid_supported = true;
|
||||
}
|
||||
+ if (*mod == modifier) {
|
||||
+ supported_modifier = true;
|
||||
+ break;
|
||||
+ }
|
||||
+ }
|
||||
+ if (!supported_modifier && mod_invalid_supported) {
|
||||
+ /* If the server has advertised DRM_FORMAT_MOD_INVALID then we trust
|
||||
+ * that the client has allocated the buffer with the right implicit
|
||||
+ * modifier for the format, even though it's allocated a buffer the
|
||||
+ * server hasn't explicitly claimed to support. */
|
||||
+ modifier = DRM_FORMAT_MOD_INVALID;
|
||||
+ supported_modifier = true;
|
||||
}
|
||||
|
||||
if (dri2_dpy->wl_dmabuf && supported_modifier) {
|
||||
--
|
||||
2.26.2
|
||||
|
|
@ -9,7 +9,7 @@
|
|||
pkgbase=mesa
|
||||
pkgname=('vulkan-mesa-layer' 'opencl-mesa' 'vulkan-radeon' 'libva-mesa-driver' 'mesa-vdpau' 'mesa')
|
||||
pkgdesc="An open-source implementation of the OpenGL specification"
|
||||
pkgver=20.0.6
|
||||
pkgver=20.0.7
|
||||
pkgrel=2
|
||||
arch=('x86_64')
|
||||
makedepends=('python-mako' 'libxml2' 'libx11' 'xorgproto' 'libdrm' 'libxshmfence' 'libxxf86vm'
|
||||
|
@ -20,14 +20,14 @@ url="https://www.mesa3d.org/"
|
|||
license=('custom')
|
||||
source=(https://mesa.freedesktop.org/archive/mesa-${pkgver}.tar.xz{,.sig}
|
||||
0001-Rip-out-VC4-forced-NEON.patch
|
||||
0001-egl-allow-INVALID-format-for-linux_dmabuf.patch
|
||||
0002-egl-wayland-Fix-zwp_linux_dmabuf-usage.patch
|
||||
0001-swr-Fix-build-with-GCC-10.patch
|
||||
0001-omx-fix-build-with-gcc-10.patch
|
||||
LICENSE)
|
||||
sha512sums=('a93dc3ed57ed7469b7c60cdbdcf4f29c5da4ec3986171c7b534e009e136ca21fec16207ffab38a6747437a9b1060e2e6c4b74c4e5cdc168b9aba0fc1940b5e90'
|
||||
sha512sums=('00baae50f14bf2b08b5654dffb11cf67499dc1825e1700b137fb5719e767e0e78e789979df2c194f677ea9c5e531f34965d47b9e37c239944c38d0570c7a9685'
|
||||
'SKIP'
|
||||
'ba55fd9816ebd9147be120da1fd4fa0364d19967a11570e6d5dd9d8b4f7971df46ced8b151ee07afaaa98043e131eed14918ec25f8c9b0f7e5c53f452674ee5c'
|
||||
'2371631512cd0f6aeaa9db3a8484da039fe98610123683520d0fe076dbf49860f00f8d44ecb0b0b149cee766946fe800080178c6fca8cff289329bf46ce97858'
|
||||
'd8998785c373743932674eecdfc1f502b5ef58b3f53572a42b177bf5b367d43b4af3867e37bd71c6a23f1b740841aabf2d42c68eb95f1bc33c0e58d9b7e029b8'
|
||||
'296a7502e959ccd2a6f1279878c0562a853ecdd78b5960196fc8f99ed8dd995c6e1106551aef7a53db891295235ca55676788e7cf78e336e2d5ee49e4e463be5'
|
||||
'e1f0fa2a8802184580d9d95777f02a1c35bf71c3ab380d88e5b9268f84c2ac338fa517d20065094b7764490bbbfb290c1c5ad6dec6d27f3dbf737dfa0b6c7263'
|
||||
'f9f0d0ccf166fe6cb684478b6f1e1ab1f2850431c06aa041738563eb1808a004e52cdec823c103c9e180f03ffc083e95974d291353f0220fe52ae6d4897fecc7')
|
||||
validpgpkeys=('8703B6700E7EE06D7A39B8D6EDAE37B02CEB490D' # Emil Velikov <emil.l.velikov@gmail.com>
|
||||
'946D09B5E4C9845E63075FF1D961C596A7203456' # Andres Gomez <tanty@igalia.com>
|
||||
|
@ -39,10 +39,9 @@ validpgpkeys=('8703B6700E7EE06D7A39B8D6EDAE37B02CEB490D' # Emil Velikov <emil.l
|
|||
prepare() {
|
||||
cd mesa-$pkgver
|
||||
|
||||
# https://gitlab.gnome.org/GNOME/mutter/issues/987
|
||||
# https://gitlab.freedesktop.org/mesa/mesa/-/merge_requests/4294
|
||||
patch -Np1 -i ../0001-egl-allow-INVALID-format-for-linux_dmabuf.patch
|
||||
patch -Np1 -i ../0002-egl-wayland-Fix-zwp_linux_dmabuf-usage.patch
|
||||
# fix building with gcc 10
|
||||
patch -Np1 -i ../0001-swr-Fix-build-with-GCC-10.patch
|
||||
patch -Np1 -i ../0001-omx-fix-build-with-gcc-10.patch
|
||||
|
||||
[[ $CARCH == "armv6h" || $CARCH == "armv7h" ]] && patch -p1 -i ../0001-Rip-out-VC4-forced-NEON.patch || true
|
||||
}
|
||||
|
|
Loading…
Reference in a new issue