core/linux-armv7-rc to 4.8.rc3-2

This commit is contained in:
Kevin Mihelich 2016-08-24 03:12:17 +00:00
parent 9301189c2d
commit 0d9562ca34
11 changed files with 138 additions and 38 deletions

View file

@ -1,7 +1,7 @@
From afbbc877305527e93d244824e0a3dca819973d94 Mon Sep 17 00:00:00 2001
From 4113451ffd6105d54c0b0591743f49205f2ad40e Mon Sep 17 00:00:00 2001
From: Willy Tarreau <w@xxxxxx>
Date: Sun, 2 Dec 2012 19:59:28 +0100
Subject: [PATCH 1/8] ARM: atags: add support for Marvell's u-boot
Subject: [PATCH 01/10] ARM: atags: add support for Marvell's u-boot
Marvell uses a specific atag in its u-boot which includes among other
information the MAC addresses for up to 4 network interfaces.
@ -47,5 +47,5 @@ index 979ff40..d1d0c19 100644
};
--
2.9.0
2.9.3

View file

@ -1,8 +1,8 @@
From 14e8a69247c12df417aa4f2d5088f153d164d6a4 Mon Sep 17 00:00:00 2001
From 037cfe3280639b22ad7ad5e11f55fa5d431b4831 Mon Sep 17 00:00:00 2001
From: Willy Tarreau <w@xxxxxx>
Date: Sun, 2 Dec 2012 19:56:58 +0100
Subject: [PATCH 2/8] ARM: atags/fdt: retrieve MAC addresses from Marvell boot
loader
Subject: [PATCH 02/10] ARM: atags/fdt: retrieve MAC addresses from Marvell
boot loader
The atags are parsed and if a Marvell atag is found, up to 4 MAC
addresses are extracted there and assigned to node aliases eth0..3
@ -43,5 +43,5 @@ index 9448aa0..ac7b6ae 100644
}
--
2.9.0
2.9.3

View file

@ -1,7 +1,7 @@
From 0371fbb17b99b7a34cd3620667fb4ec0dc13509f Mon Sep 17 00:00:00 2001
From 8514e0267b935667afb88c8d52c7d2dcbcd41b82 Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Fri, 5 Sep 2014 15:41:19 -0600
Subject: [PATCH 3/8] SMILE Plug device tree file
Subject: [PATCH 03/10] SMILE Plug device tree file
This adds a dts file for the SMILE Plug, which only differs from the Mirabox
dts with the LED definitions.
@ -14,10 +14,10 @@ Signed-off-by: Kevin Mihelich <kevin@archlinuxarm.org>
create mode 100644 arch/arm/boot/dts/armada-370-smileplug.dts
diff --git a/arch/arm/boot/dts/Makefile b/arch/arm/boot/dts/Makefile
index 414b427..939686c 100644
index faacd52..b41e5b0 100644
--- a/arch/arm/boot/dts/Makefile
+++ b/arch/arm/boot/dts/Makefile
@@ -844,6 +844,7 @@ dtb-$(CONFIG_MACH_ARMADA_370) += \
@@ -871,6 +871,7 @@ dtb-$(CONFIG_MACH_ARMADA_370) += \
armada-370-db.dtb \
armada-370-dlink-dns327l.dtb \
armada-370-mirabox.dtb \
@ -205,5 +205,5 @@ index 0000000..d01308a
+ };
+};
--
2.9.0
2.9.3

View file

@ -1,7 +1,7 @@
From 741fabedf4045b35dbebccfa80d89c24fad4f2bf Mon Sep 17 00:00:00 2001
From 9cef6114cdc40b4f16806d5389b84ddbb141f302 Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Fri, 5 Sep 2014 15:43:56 -0600
Subject: [PATCH 4/8] fix mvsdio eMMC timing
Subject: [PATCH 04/10] fix mvsdio eMMC timing
These changes from Globalscale change the MMC timing to allow the eMMC versions
of the Mirabox and SMILE Plug to work.
@ -34,5 +34,5 @@ index 42296e5..e5ce6d2 100644
host->clock = ios->clock;
host->ns_per_clk = 1000000000 / (host->base_clock / (m+1));
--
2.9.0
2.9.3

View file

@ -1,7 +1,8 @@
From 5f270a18f5c0df790ab877d901f904f117d93c5d Mon Sep 17 00:00:00 2001
From 4fde404f38c4833333ce20f446c263dbaef56a09 Mon Sep 17 00:00:00 2001
From: popcornmix <popcornmix@gmail.com>
Date: Tue, 18 Feb 2014 01:43:50 -0300
Subject: [PATCH 5/8] net/smsc95xx: Allow mac address to be set as a parameter
Subject: [PATCH 05/10] net/smsc95xx: Allow mac address to be set as a
parameter
---
drivers/net/usb/smsc95xx.c | 56 ++++++++++++++++++++++++++++++++++++++++++++++
@ -91,5 +92,5 @@ index dc989a8..912be75 100644
/* maybe the boot loader passed the MAC address in devicetree */
--
2.9.0
2.9.3

View file

@ -1,7 +1,7 @@
From d5be5ef162a931a20c5084a1ba8b1ee7d2d4d9f0 Mon Sep 17 00:00:00 2001
From 5012fe79f5b57abc1704819c389298de5201131d Mon Sep 17 00:00:00 2001
From: dobatog <dobatog@gmail.com>
Date: Thu, 26 Feb 2015 12:32:27 +0100
Subject: [PATCH 6/8] ARM: TLV320AIC23 SoC Audio Codec: Fix errors reported
Subject: [PATCH 06/10] ARM: TLV320AIC23 SoC Audio Codec: Fix errors reported
related to input routing signals.
The following patch, based on stable v3.19, corrects the errors that are reported in the boot trace in reference to the Input Signals of the audio codec TLV320AIC23:
@ -45,5 +45,5 @@ index cd8c02b..95e6b11 100644
/* input mux */
{"Capture Source", "Line", "Line Input"},
--
2.9.0
2.9.3

View file

@ -1,7 +1,7 @@
From 87f2ae3fe4ac7b94d44c4cdcb3ea10a75ca7c447 Mon Sep 17 00:00:00 2001
From 4bab5c906887441080ea64af18fc318525322b5f Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Sat, 14 Feb 2015 12:32:27 +0100
Subject: [PATCH 7/8] set default cubietruck led triggers
Subject: [PATCH 07/10] set default cubietruck led triggers
Signed-off-by: Kevin Mihelich <kevin@archlinuxarm.org>
---
@ -29,5 +29,5 @@ index 83f39b0..15e9626 100644
};
--
2.9.0
2.9.3

View file

@ -1,7 +1,7 @@
From e8cf8d92a715bb3432685197e1a5835b6fe9207f Mon Sep 17 00:00:00 2001
From 15e17a63e2723adde14f4b5d6f9cbd7aa8dde870 Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Sat, 7 Feb 2015 12:32:27 +0100
Subject: [PATCH 8/8] USB armory support
Subject: [PATCH 08/10] USB armory support
---
arch/arm/boot/dts/Makefile | 5 +
@ -20,10 +20,10 @@ Subject: [PATCH 8/8] USB armory support
create mode 100644 arch/arm/boot/dts/imx53-usbarmory.dts
diff --git a/arch/arm/boot/dts/Makefile b/arch/arm/boot/dts/Makefile
index 939686c..e5cc351 100644
index b41e5b0..3ce4c32 100644
--- a/arch/arm/boot/dts/Makefile
+++ b/arch/arm/boot/dts/Makefile
@@ -303,6 +303,11 @@ dtb-$(CONFIG_SOC_IMX53) += \
@@ -315,6 +315,11 @@ dtb-$(CONFIG_SOC_IMX53) += \
imx53-smd.dtb \
imx53-tx53-x03x.dtb \
imx53-tx53-x13x.dtb \
@ -677,5 +677,5 @@ index 0000000..33719f7
+ status = "okay";
+};
--
2.9.0
2.9.3

View file

@ -0,0 +1,63 @@
From d0661ab6655fca4a9f0914b9f3339090e4c27cdb Mon Sep 17 00:00:00 2001
From: Vanessa Maegima <vanessa.maegima@nxp.com>
Date: Mon, 1 Aug 2016 09:54:14 -0300
Subject: [PATCH 09/10] ARM: dts: imx6ul-pico-hobbit: Add Wifi support
imx6ul-pico-hobbit has a bcm4339 wifi chip connected to usdhc2 port.
Add support for the WL_REG_ON regulator, so that Wifi can be functional
on this board.
Signed-off-by: Vanessa Maegima <vanessa.maegima@nxp.com>
Tested-by: Fabio Estevam <fabio.estevam@nxp.com>
---
arch/arm/boot/dts/imx6ul-pico-hobbit.dts | 20 ++++++++++++++++++++
1 file changed, 20 insertions(+)
diff --git a/arch/arm/boot/dts/imx6ul-pico-hobbit.dts b/arch/arm/boot/dts/imx6ul-pico-hobbit.dts
index 86f68fa..d3dfa5f 100644
--- a/arch/arm/boot/dts/imx6ul-pico-hobbit.dts
+++ b/arch/arm/boot/dts/imx6ul-pico-hobbit.dts
@@ -100,6 +100,18 @@
gpio = <&gpio1 6 0>;
};
+ reg_brcm: brcm-reg {
+ compatible = "regulator-fixed";
+ enable-active-high;
+ gpio = <&gpio4 8 GPIO_ACTIVE_HIGH>;
+ pinctrl-names = "default";
+ pinctrl-0 = <&pinctrl_brcm_reg>;
+ regulator-name = "brcm_reg";
+ regulator-min-microvolt = <3300000>;
+ regulator-max-microvolt = <3300000>;
+ startup-delay-us = <200000>;
+ };
+
sound {
compatible = "fsl,imx-audio-sgtl5000";
model = "imx6ul-sgtl5000";
@@ -325,12 +337,20 @@
pinctrl-names = "default";
pinctrl-0 = <&pinctrl_usdhc2>;
no-1-8-v;
+ non-removable;
keep-power-in-suspend;
wakeup-source;
+ vmmc-supply = <&reg_brcm>;
status = "okay";
};
&iomuxc {
+ pinctrl_brcm_reg: brcmreggrp {
+ fsl,pins = <
+ MX6UL_PAD_NAND_DATA06__GPIO4_IO08 0x10b0 /* WL_REG_ON */
+ >;
+ };
+
pinctrl_enet2: enet2grp {
fsl,pins = <
MX6UL_PAD_ENET1_TX_DATA1__ENET2_MDIO 0x1b0b0
--
2.9.3

View file

@ -0,0 +1,30 @@
From b60eacd2471725325f89145796149707d8615cbe Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Thu, 11 Aug 2016 00:42:37 -0600
Subject: [PATCH 10/10] exynos4412-odroid: set higher minimum buck2 regulator
voltage
Set a higher minimum voltage to help reboot issue.
http://www.spinics.net/lists/linux-samsung-soc/msg54434.html
Signed-off-by: Kevin Mihelich <kevin@archlinuxarm.org>
---
arch/arm/boot/dts/exynos4412-odroid-common.dtsi | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/arch/arm/boot/dts/exynos4412-odroid-common.dtsi b/arch/arm/boot/dts/exynos4412-odroid-common.dtsi
index 58ad48e7..f7c5571 100644
--- a/arch/arm/boot/dts/exynos4412-odroid-common.dtsi
+++ b/arch/arm/boot/dts/exynos4412-odroid-common.dtsi
@@ -423,7 +423,7 @@
buck2_reg: BUCK2 {
regulator-name = "vdd_arm";
- regulator-min-microvolt = <900000>;
+ regulator-min-microvolt = <1100000>;
regulator-max-microvolt = <1350000>;
regulator-always-on;
regulator-boot-on;
--
2.9.3

View file

@ -13,7 +13,7 @@ _srcname=linux-4.$((${_rcver##*.}-1))
_kernelname=${pkgbase#linux}
_desc="ARMv7 multi-platform (release candidate)"
pkgver=${_rcver}.rc${_rcrel}
pkgrel=1
pkgrel=2
arch=('armv7h')
url="http://www.kernel.org/"
license=('GPL2')
@ -31,6 +31,8 @@ source=("http://www.kernel.org/pub/linux/kernel/v4.x/${_srcname}.tar.xz"
'0006-ARM-TLV320AIC23-SoC-Audio-Codec-Fix-errors-reported-.patch'
'0007-set-default-cubietruck-led-triggers.patch'
'0008-USB-armory-support.patch'
'0009-ARM-dts-imx6ul-pico-hobbit-Add-Wifi-support.patch'
'0010-exynos4412-odroid-set-higher-minimum-buck2-regulator.patch'
'config'
'cmdline'
'kernel.its'
@ -39,14 +41,16 @@ source=("http://www.kernel.org/pub/linux/kernel/v4.x/${_srcname}.tar.xz"
md5sums=('5276563eb1f39a048e4a8a887408c031'
'fa0b8dbf79226c52cf0e97bb316bf769'
'924a282a5a7c02b9b6cc56baceec69b1'
'3c7905e0ab610fb761e98b970e878936'
'365ad95a61dd208b73ca63ec9ae1b5ac'
'47f730f34a1869cac8e23ecb318c2160'
'ae965a26a9dfcfa5738bda5409f8176f'
'789334f7f20d3e324bbadaa3215baf6a'
'69ea845025d4a48a6a2acfcb16bbbc43'
'084263ed8f4ec6b142ba62464beca4cd'
'a726c43d5fee117ca95f123ec89f4a11'
'cdc8a50fddf6a5966b1274674953c0da'
'de30242457fc09e7168d50be9e2f4902'
'fc911a149c3fa8fed1da2880d0361e32'
'd8b9a93424ed627d9d23b78dfb21b5bb'
'9a09d95661b66bec4e14a59e234fa6a7'
'866c4644116e9c5bab0b9e383481e461'
'6a79883ec136a4ffb7056d50b9c1d029'
'9109d8a8ece6116619b93cd5573c9c28'
'4a64303fcd92553c5cb01c9523df8d58'
'03916f015afa5fb6d2fb012a6ef03994'
'36437d9c9c90cd1bffca9769042e6455'
'7d3061393c215d08f44a46ca48b13b7e'
'4f2379ed84258050edb858ee8d281678'
@ -72,6 +76,8 @@ prepare() {
git apply ../0006-ARM-TLV320AIC23-SoC-Audio-Codec-Fix-errors-reported-.patch
git apply ../0007-set-default-cubietruck-led-triggers.patch
git apply ../0008-USB-armory-support.patch
git apply ../0009-ARM-dts-imx6ul-pico-hobbit-Add-Wifi-support.patch
git apply ../0010-exynos4412-odroid-set-higher-minimum-buck2-regulator.patch
cat "${srcdir}/config" > ./.config