extra/boost to 1.58.0-1

This commit is contained in:
Kevin Mihelich 2015-04-28 12:30:37 +00:00
parent c20372e34d
commit 0e3b9d0c06
3 changed files with 4 additions and 71 deletions

View file

@ -1,29 +0,0 @@
From 06ccdfee76fe487a141b95848d1c866890f15d88 Mon Sep 17 00:00:00 2001
From: Evangelos Foutras <evangelos@foutrelis.com>
Date: Thu, 6 Nov 2014 09:19:26 +0200
Subject: [PATCH] Add missing include to signals2/trackable.hpp
boost::weak_ptr started being used in commit a0bf2d1 (Disconnect slots
associated with signals2::trackable immediately) but the matching header
wasn't included.
https://svn.boost.org/trac/boost/ticket/10100#comment:7
---
include/boost/signals2/trackable.hpp | 1 +
1 file changed, 1 insertion(+)
diff --git a/include/boost/signals2/trackable.hpp b/include/boost/signals2/trackable.hpp
index dba001d..64e8489 100644
--- a/include/boost/signals2/trackable.hpp
+++ b/include/boost/signals2/trackable.hpp
@@ -18,6 +18,7 @@
#include <boost/assert.hpp>
#include <boost/shared_ptr.hpp>
+#include <boost/weak_ptr.hpp>
namespace boost {
namespace signals2 {
--
2.1.3

View file

@ -1,24 +0,0 @@
From 02fff0a69e46b4d77844cf7b8c8d3bc2adbc96bb Mon Sep 17 00:00:00 2001
From: Robert Ramey <ramey@rrsd.com>
Date: Tue, 11 Nov 2014 22:13:05 -0800
Subject: [PATCH] fixed shared_ptr_helper include
---
include/boost/serialization/shared_ptr_helper.hpp | 1 +
1 file changed, 1 insertion(+)
diff --git a/include/boost/serialization/shared_ptr_helper.hpp b/include/boost/serialization/shared_ptr_helper.hpp
index f4784ec..64269a9 100644
--- a/include/boost/serialization/shared_ptr_helper.hpp
+++ b/include/boost/serialization/shared_ptr_helper.hpp
@@ -29,6 +29,7 @@
#include <boost/serialization/singleton.hpp>
#include <boost/serialization/extended_type_info.hpp>
#include <boost/serialization/throw_exception.hpp>
+#include <boost/serialization/type_info_implementation.hpp>
#include <boost/archive/archive_exception.hpp>
#include <boost/archive/detail/decl.hpp>
--
2.2.1

View file

@ -13,29 +13,15 @@
pkgbase=boost
pkgname=('boost-libs' 'boost')
pkgver=1.57.0
pkgver=1.58.0
_boostver=${pkgver//./_}
pkgrel=4
pkgrel=1
url='http://www.boost.org/'
arch=('i686' 'x86_64')
license=('custom')
makedepends=('icu>=55.1' 'python' 'python2' 'bzip2' 'zlib')
source=(https://downloads.sourceforge.net/project/${pkgbase}/${pkgbase}/${pkgver}/${pkgbase}_${_boostver}.tar.bz2
0001-fixed-shared_ptr_helper-include.patch
0001-Add-missing-include-to-signals2-trackable.hpp.patch)
sha1sums=('e151557ae47afd1b43dc3fac46f8b04a8fe51c12'
'b58746c795a99150545ebfa5dba7997d771b3dcc'
'35bc8ad7493a641ec708a691036fe5319aec70cd')
prepare() {
cd ${pkgbase}_${_boostver}
# https://svn.boost.org/trac/boost/ticket/10749
patch -Np2 -i ../0001-fixed-shared_ptr_helper-include.patch
# https://github.com/boostorg/signals2/pull/8
patch -Np2 -i ../0001-Add-missing-include-to-signals2-trackable.hpp.patch
}
source=(https://downloads.sourceforge.net/project/${pkgbase}/${pkgbase}/${pkgver}/${pkgbase}_${_boostver}.tar.bz2)
sha1sums=('2fc96c1651ac6fe9859b678b165bd78dc211e881')
build() {
CFLAGS=`echo $CFLAGS | sed -e 's/armv6/armv6k/'` && CXXFLAGS="$CFLAGS"