alarm/kodi-rbp-git to 18.1rc1-1 (#1669)

This commit is contained in:
graysky 2019-02-16 14:18:16 -05:00 committed by Kevin Mihelich
parent 105ea29ae3
commit 0e4a5286b4
2 changed files with 21 additions and 5 deletions

View file

@ -0,0 +1,13 @@
--- a/xbmc/cores/AudioEngine/Sinks/AESinkALSA.cpp 2019-02-11 07:44:48.000000000 -0500
+++ b/xbmc/cores/AudioEngine/Sinks/AESinkALSA.cpp 2019-02-16 11:38:16.251695614 -0500
@@ -1329,6 +1329,10 @@ void CAESinkALSA::EnumerateDevice(AEDevi
if (snd_card_get_name(cardNr, &cardName) == 0)
info.m_displayName = cardName;
+ /* hifiberry digi doesn't correctly report as iec958 device. Needs fixing in kernel driver */
+ if (info.m_displayName == "snd_rpi_hifiberry_digi")
+ info.m_deviceType = AE_DEVTYPE_IEC958;
+
if (info.m_deviceType == AE_DEVTYPE_HDMI && info.m_displayName.size() > 5 &&
info.m_displayName.substr(info.m_displayName.size()-5) == " HDMI")
{

View file

@ -12,10 +12,10 @@ _prefix=/usr
pkgbase=kodi-rbp-git
_suffix=rbp-git
pkgname=("kodi-$_suffix" "kodi-eventclients-$_suffix" "kodi-tools-texturepacker-$_suffix" "kodi-dev-$_suffix")
pkgver=18.0rc5.2.20190115
pkgrel=3
pkgver=18.1rc1.20190211
pkgrel=1
_codename=Leia
_tag="18.0rc5.2-$_codename"
_tag="18.1rc1-$_codename"
_ffmpeg_version="4.0.3-$_codename-RC5"
_libdvdcss_version="1.4.2-$_codename-Beta-5"
_libdvdnav_version="6.0.0-$_codename-Alpha-3"
@ -43,6 +43,7 @@ source=("https://github.com/popcornmix/xbmc/archive/newclock5_$_tag.tar.gz"
'99-kodi.rules'
'polkit.rules'
'00-fix.building.with.mariadb.patch::https://github.com/wsnipex/xbmc/commit/cd20c8eb8a0394db1f028b118c4ca9b91b7e746a.patch'
'01-fix.passthrough.for.hifiberry_digi.patch'
"ffmpeg-$_ffmpeg_version.tar.gz::https://github.com/xbmc/FFmpeg/archive/$_ffmpeg_version.tar.gz"
"libdvdcss-$_libdvdcss_version.tar.gz::https://github.com/xbmc/libdvdcss/archive/$_libdvdcss_version.tar.gz"
"libdvdnav-$_libdvdnav_version.tar.gz::https://github.com/xbmc/libdvdnav/archive/$_libdvdnav_version.tar.gz"
@ -62,12 +63,13 @@ noextract=(
"fstrcmp-$_fstrcmp_version.tar.gz"
"flatbuffers-$_flatbuffers_version.tar.gz"
)
sha256sums=('af37f2bdb84a97e4fb1eac3a2b0bd699d77355319c00f7bd7c785eb089f852ae'
sha256sums=('a8b30401511a6be27e57d04aacfdc77aa551b038ac67071ec186fcce7c23d1ab'
'6eded8b5f52808d5ffa77de546fbf799a255dde2473540e8a8bd46daa6f753d9'
'fe7a1ab2a6e2bf00f756c76545a338d2763003052764d722d492b06b1bc05f5e'
'b31570f95654434b01fd8531612fbb6be77cbc1c519dd60f92feae26eb160f3d'
'9ea592205023ba861603d74b63cdb73126c56372a366dc4cb7beb379073cbb96'
'849daf1d5b081ef6d0e428bbc7d448799fc43a8ac9e79cd7513de0eb5a91b0bb'
'70d8123f1727d4791abba2c809f126ae0c7c42078eb6aaeed1622d4ed9b52694'
'9a971662e44353c120f2ccf87655571998956e699a2dd800ec708b8b928a53c8'
'38816f8373e243bc5950449b4f3b18938c4e1c59348e3411e23f31db4072e40d'
'071e414e61b795f2ff9015b21a85fc009dde967f27780d23092643916538a57a'
@ -84,6 +86,7 @@ prepare() {
mkdir $srcdir/kodi-build
patch -Np1 -i ../00-fix.building.with.mariadb.patch
patch -Np1 -i ../01-fix.passthrough.for.hifiberry_digi.patch
}
build() {
@ -139,7 +142,7 @@ package_kodi-rbp-git() {
'libmicrohttpd' 'libpulse' 'libssh' 'libxrandr' 'lirc' 'raspberrypi-firmware'
'libxslt' 'lzo' 'python2-pillow' 'python2-simplejson' 'smbclient'
'speex' 'taglib' 'tinyxml' 'xorg-xdpyinfo' 'yajl' 'libinput' 'libxkbcommon' 'libbluray-kodi-rbp'
'fbset' 'libnfs'
'fbset' 'libnfs' 'curl'
)
optdepends=(
'afpfs-ng: Apple shares support'