extra/meson to 0.53.0-1

This commit is contained in:
Kevin Mihelich 2020-01-08 00:14:50 +00:00
parent 812523cf23
commit 0e6ab29e65
3 changed files with 56 additions and 20 deletions

View file

@ -0,0 +1,49 @@
From bee44c4c029eeee4c77434fd38208a5c02780b44 Mon Sep 17 00:00:00 2001
From: "Jan Alexander Steffens (heftig)" <jan.steffens@gmail.com>
Date: Tue, 7 Jan 2020 23:48:18 +0100
Subject: [PATCH] Fix CUDA test without devices.
Getting the runtime version fails when no devices are present.
---
.../version_reqs/prog.cu | 21 ++++++++++---------
1 file changed, 11 insertions(+), 10 deletions(-)
diff --git a/test cases/cuda/11 cuda dependency (nvcc)/version_reqs/prog.cu b/test cases/cuda/11 cuda dependency (nvcc)/version_reqs/prog.cu
index 56688303..bc90081e 100644
--- a/test cases/cuda/11 cuda dependency (nvcc)/version_reqs/prog.cu
+++ b/test cases/cuda/11 cuda dependency (nvcc)/version_reqs/prog.cu
@@ -9,20 +9,21 @@ int cuda_devices(void) {
int main(void) {
std::cout << "Compiled against CUDA version: " << CUDART_VERSION << "\n";
+
int runtime_version = 0;
- cudaError_t r = cudaRuntimeGetVersion(&runtime_version);
- if (r != cudaSuccess) {
- std::cout << "Couldn't obtain CUDA runtime version (error " << r << "). Exiting.\n";
- return -1;
+ switch (cudaError_t r = cudaRuntimeGetVersion(&runtime_version)) {
+ case cudaSuccess:
+ std::cout << "CUDA runtime version: " << runtime_version << "\n";
+ break;
+ case cudaErrorNoDevice:
+ std::cout << "No CUDA hardware found. Exiting.\n";
+ return 0;
+ default:
+ std::cout << "Couldn't obtain CUDA runtime version (error " << r << "). Exiting.\n";
+ return -1;
}
- std::cout << "CUDA runtime version: " << runtime_version << "\n";
int n = cuda_devices();
- if (n == 0) {
- std::cout << "No CUDA hardware found. Exiting.\n";
- return 0;
- }
-
std::cout << "Found " << n << " CUDA devices.\n";
return 0;
}
--
2.24.1

View file

@ -6,7 +6,7 @@
# - disable lto in arch-meson
pkgname=meson
pkgver=0.52.1
pkgver=0.53.0
pkgrel=1
pkgdesc='High productivity build system'
url='https://mesonbuild.com/'
@ -19,14 +19,14 @@ checkdepends=('gcc-objc' 'vala' 'rust' 'gcc-fortran' 'mono' 'boost' 'qt5-base' '
'doxygen' 'vulkan-validation-layers' 'openssh' 'mercurial' 'gtk-sharp-2' 'qt5-tools'
'libwmf' 'valgrind' 'cmake' 'netcdf-fortran' 'openmpi' 'cuda' 'nasm' 'gnustep-base'
'libelf' 'python-pytest-xdist')
source=(https://github.com/mesonbuild/meson/releases/download/${pkgver}/meson-${pkgver}.tar.gz{,.asc}
source=(https://github.com/mesonbuild/meson/releases/download/${pkgver}/meson-${pkgver}.tar.gz{,.sig}
skip-test.diff
meson-python-3.8.patch
0001-Fix-CUDA-test-without-devices.patch
arch-meson)
sha512sums=('81e8c5897ba5311ccffc401fd514bd9a67d16caaea1f28a5c5432605766341ecd82b70c05661fbbe0c9a6006ff5ea892950bbaa548e70c3f87350438775ea6fd'
sha512sums=('e375e22eb650d5f8facbffe9773b740b5dcd971a86c5b197bbfa0e82a51f4774345456856e19d6305661e227afbe24db5ca472d5ff9f707b754c1d5361187cd8'
'SKIP'
'fd1694e74cfa628bda81b1056061d75fa288e04d72bda733f3667be43cfb21c60f2e89455e4a101a7f6bef5754fe112dc84e18ec7a0807bc791015c34deea347'
'343d49889942d1cd3f5dc0c573dba226ca9a6c6c5845ff4e74d3c672532ba6fb7cbfeaadb6e053e8793cd7cbfbc936fb753c2dcd95dd236476f07129ac07f67c'
'459559575ac6556cf7f9b340099886442ca222b9cfb584aaad3a2a43c2fe6ce850e7125fb8b7a01782c5f5a57b353adc5683f24aec6717ba78076ad75140fc4e'
'278f5e4de3aa1170d9b4f9f212985d664f44d90ffec727febeeea1ed570046c6469558a5d123a41bf4c2fdf99dbe7832515b06f1ace423c63e2e95ba6d0ef235')
validpgpkeys=('95181F4EED14FDF4E41B518D3BF4693BFEEB9428') # Jussi Pakkanen <jpakkane@gmail.com>
@ -36,8 +36,8 @@ prepare() {
# Our containers do not allow sanitizers to run
patch -Np1 -i ../skip-test.diff
# Fix boost test with python 3.8
patch -Np1 -i ../meson-python-3.8.patch
# Fix CUDA test without devices
patch -Np1 -i ../0001-Fix-CUDA-test-without-devices.patch
}
build() {

View file

@ -1,13 +0,0 @@
diff --git a/test cases/frameworks/1 boost/meson.build b/test cases/frameworks/1 boost/meson.build
index 8f45dc7f..44bc376d 100644
--- a/test cases/frameworks/1 boost/meson.build
+++ b/test cases/frameworks/1 boost/meson.build
@@ -30,7 +30,7 @@ pymod = import('python')
python2 = pymod.find_installation('python2', required: host_machine.system() == 'linux', disabler: true)
python3 = pymod.find_installation('python3', required: host_machine.system() == 'linux', disabler: true)
python2dep = python2.dependency(required: host_machine.system() == 'linux', disabler: true)
-python3dep = python3.dependency(required: host_machine.system() == 'linux', disabler: true)
+python3dep = dependency('python3-embed', required: host_machine.system() == 'linux', disabler: true)
# compile python 2/3 modules only if we found a corresponding python version
if(python2dep.found() and host_machine.system() == 'linux')