core/linux-armv7 to 4.17.6-1

This commit is contained in:
Kevin Mihelich 2018-07-13 00:27:57 +00:00
parent 2fdd43886e
commit 0e90c28d32
15 changed files with 121 additions and 57 deletions

View file

@ -1,7 +1,7 @@
From 8d124d916897d965eafd7e85524d38756fb2d5ce Mon Sep 17 00:00:00 2001 From ba0f7bad7435de617093d47ac4f0895a71dcee00 Mon Sep 17 00:00:00 2001
From: Willy Tarreau <w@xxxxxx> From: Willy Tarreau <w@xxxxxx>
Date: Sun, 2 Dec 2012 19:59:28 +0100 Date: Sun, 2 Dec 2012 19:59:28 +0100
Subject: [PATCH 01/13] ARM: atags: add support for Marvell's u-boot Subject: [PATCH 01/14] ARM: atags: add support for Marvell's u-boot
Marvell uses a specific atag in its u-boot which includes among other Marvell uses a specific atag in its u-boot which includes among other
information the MAC addresses for up to 4 network interfaces. information the MAC addresses for up to 4 network interfaces.
@ -47,5 +47,5 @@ index 6b335a9ff8c8..614150b53643 100644
}; };
-- --
2.17.0 2.18.0

View file

@ -1,7 +1,7 @@
From 6f181867df1ccab0836928cc91a9388239b89086 Mon Sep 17 00:00:00 2001 From 89b2c1805d92a98ccc424ecad060cb08ba8e6211 Mon Sep 17 00:00:00 2001
From: Willy Tarreau <w@xxxxxx> From: Willy Tarreau <w@xxxxxx>
Date: Sun, 2 Dec 2012 19:56:58 +0100 Date: Sun, 2 Dec 2012 19:56:58 +0100
Subject: [PATCH 02/13] ARM: atags/fdt: retrieve MAC addresses from Marvell Subject: [PATCH 02/14] ARM: atags/fdt: retrieve MAC addresses from Marvell
boot loader boot loader
The atags are parsed and if a Marvell atag is found, up to 4 MAC The atags are parsed and if a Marvell atag is found, up to 4 MAC
@ -43,5 +43,5 @@ index 41fa7316c52b..807ed160a4b9 100644
} }
-- --
2.17.0 2.18.0

View file

@ -1,7 +1,7 @@
From a89566aa1896a895360380a6a4e66b997c059e02 Mon Sep 17 00:00:00 2001 From d441e0ca2b03d5cc7e5034efc6b15b56698b353f Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org> From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Fri, 5 Sep 2014 15:41:19 -0600 Date: Fri, 5 Sep 2014 15:41:19 -0600
Subject: [PATCH 03/13] SMILE Plug device tree file Subject: [PATCH 03/14] SMILE Plug device tree file
This adds a dts file for the SMILE Plug, which only differs from the Mirabox This adds a dts file for the SMILE Plug, which only differs from the Mirabox
dts with the LED definitions. dts with the LED definitions.
@ -205,5 +205,5 @@ index 000000000000..d01308ab848b
+ }; + };
+}; +};
-- --
2.17.0 2.18.0

View file

@ -1,7 +1,7 @@
From 80d34ee9819ed5400e37d4a9801f976d1c8281c0 Mon Sep 17 00:00:00 2001 From 23883cf4470afeb33dc9c171978df76f5470f4f0 Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org> From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Fri, 5 Sep 2014 15:43:56 -0600 Date: Fri, 5 Sep 2014 15:43:56 -0600
Subject: [PATCH 04/13] fix mvsdio eMMC timing Subject: [PATCH 04/14] fix mvsdio eMMC timing
These changes from Globalscale change the MMC timing to allow the eMMC versions These changes from Globalscale change the MMC timing to allow the eMMC versions
of the Mirabox and SMILE Plug to work. of the Mirabox and SMILE Plug to work.
@ -34,5 +34,5 @@ index 210247b3d11a..1a1802dc9ef4 100644
host->clock = ios->clock; host->clock = ios->clock;
host->ns_per_clk = 1000000000 / (host->base_clock / (m+1)); host->ns_per_clk = 1000000000 / (host->base_clock / (m+1));
-- --
2.17.0 2.18.0

View file

@ -1,7 +1,7 @@
From 0818bb121a785e899a143871e7b567b4ab1cde91 Mon Sep 17 00:00:00 2001 From b8082b65dc78228d48e693c7bdf9dbe75a2043ff Mon Sep 17 00:00:00 2001
From: popcornmix <popcornmix@gmail.com> From: popcornmix <popcornmix@gmail.com>
Date: Tue, 18 Feb 2014 01:43:50 -0300 Date: Tue, 18 Feb 2014 01:43:50 -0300
Subject: [PATCH 05/13] net/smsc95xx: Allow mac address to be set as a Subject: [PATCH 05/14] net/smsc95xx: Allow mac address to be set as a
parameter parameter
--- ---
@ -92,5 +92,5 @@ index 309b88acd3d0..7bc9feb891a1 100644
/* maybe the boot loader passed the MAC address in devicetree */ /* maybe the boot loader passed the MAC address in devicetree */
-- --
2.17.0 2.18.0

View file

@ -1,7 +1,7 @@
From 0879744ffdf15d57e51a023edac391acf3af80da Mon Sep 17 00:00:00 2001 From 0cf9ae3f97075a40cd14e09c91de0468459c45d3 Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org> From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Sat, 14 Feb 2015 12:32:27 +0100 Date: Sat, 14 Feb 2015 12:32:27 +0100
Subject: [PATCH 06/13] set default cubietruck led triggers Subject: [PATCH 06/14] set default cubietruck led triggers
Signed-off-by: Kevin Mihelich <kevin@archlinuxarm.org> Signed-off-by: Kevin Mihelich <kevin@archlinuxarm.org>
--- ---
@ -29,5 +29,5 @@ index 5649161de1d7..2be64a886555 100644
}; };
-- --
2.17.0 2.18.0

View file

@ -1,7 +1,7 @@
From 655d9afac9327f9ac6884e82146508f1c0a66c01 Mon Sep 17 00:00:00 2001 From 8d59092709da9dc0f852411cb1bad579decd457c Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org> From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Thu, 11 Aug 2016 00:42:37 -0600 Date: Thu, 11 Aug 2016 00:42:37 -0600
Subject: [PATCH 07/13] exynos4412-odroid: set higher minimum buck2 regulator Subject: [PATCH 07/14] exynos4412-odroid: set higher minimum buck2 regulator
voltage voltage
Set a higher minimum voltage to help reboot issue. Set a higher minimum voltage to help reboot issue.
@ -26,5 +26,5 @@ index d7ad07fd48f9..53c31c01713b 100644
regulator-always-on; regulator-always-on;
regulator-boot-on; regulator-boot-on;
-- --
2.17.0 2.18.0

View file

@ -1,7 +1,7 @@
From 288a284da4996b5420bda1635a2240d0615912a3 Mon Sep 17 00:00:00 2001 From c26422909f777d60214288dfdb538fa8cf510c5f Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org> From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Sun, 7 May 2017 13:32:25 -0600 Date: Sun, 7 May 2017 13:32:25 -0600
Subject: [PATCH 08/13] ARM: dove: enable ethernet on D3Plug Subject: [PATCH 08/14] ARM: dove: enable ethernet on D3Plug
Signed-off-by: Kevin Mihelich <kevin@archlinuxarm.org> Signed-off-by: Kevin Mihelich <kevin@archlinuxarm.org>
--- ---
@ -27,5 +27,5 @@ index 826026c28f90..a4c9963e1261 100644
/* Samsung M8G2F eMMC */ /* Samsung M8G2F eMMC */
&sdio0 { &sdio0 {
-- --
2.17.0 2.18.0

View file

@ -1,7 +1,7 @@
From 19a5d3c65f38ed602ab452ab7226d533b4ca66df Mon Sep 17 00:00:00 2001 From ce6183d0a8a9aea1a1d9acc9a85a05d73e741023 Mon Sep 17 00:00:00 2001
From: Peter Chen <peter.chen@nxp.com> From: Peter Chen <peter.chen@nxp.com>
Date: Wed, 21 Jun 2017 14:42:03 +0800 Date: Wed, 21 Jun 2017 14:42:03 +0800
Subject: [PATCH 09/13] power: add power sequence library Subject: [PATCH 09/14] power: add power sequence library
We have an well-known problem that the device needs to do some power We have an well-known problem that the device needs to do some power
sequence before it can be recognized by related host, the typical sequence before it can be recognized by related host, the typical
@ -786,5 +786,5 @@ index 000000000000..c5b278f5f2ae
+ +
+#endif /* __LINUX_PWRSEQ_H */ +#endif /* __LINUX_PWRSEQ_H */
-- --
2.17.0 2.18.0

View file

@ -1,7 +1,7 @@
From 3725bba0f1591b698482f4b144dc311199ef492b Mon Sep 17 00:00:00 2001 From 5b874f0a1f92812bc797c01fa558f0ab4ed338ae Mon Sep 17 00:00:00 2001
From: Peter Chen <peter.chen@nxp.com> From: Peter Chen <peter.chen@nxp.com>
Date: Wed, 21 Jun 2017 14:42:05 +0800 Date: Wed, 21 Jun 2017 14:42:05 +0800
Subject: [PATCH 10/13] usb: core: add power sequence handling for USB devices Subject: [PATCH 10/14] usb: core: add power sequence handling for USB devices
Some hard-wired USB devices need to do power sequence to let the Some hard-wired USB devices need to do power sequence to let the
device work normally, the typical power sequence like: enable USB device work normally, the typical power sequence like: enable USB
@ -39,7 +39,7 @@ index 987fc5ba6321..bd09fc8ff763 100644
---help--- ---help---
Universal Serial Bus (USB) is a specification for a serial bus Universal Serial Bus (USB) is a specification for a serial bus
diff --git a/drivers/usb/core/hub.c b/drivers/usb/core/hub.c diff --git a/drivers/usb/core/hub.c b/drivers/usb/core/hub.c
index aa9968d90a48..14b93b844aaa 100644 index e3bf65e213cd..f6a739bbe754 100644
--- a/drivers/usb/core/hub.c --- a/drivers/usb/core/hub.c
+++ b/drivers/usb/core/hub.c +++ b/drivers/usb/core/hub.c
@@ -28,6 +28,7 @@ @@ -28,6 +28,7 @@
@ -160,5 +160,5 @@ index 4dc769ee9c74..b5d5c4818f90 100644
/** /**
-- --
2.17.0 2.18.0

View file

@ -1,7 +1,7 @@
From bc2e28fa4c09da9f27de359a576ad46f0c108dae Mon Sep 17 00:00:00 2001 From dd0ec5ddeff7c8435888e7250eb47954740e7e5d Mon Sep 17 00:00:00 2001
From: Joshua Clayton <stillcompiling@gmail.com> From: Joshua Clayton <stillcompiling@gmail.com>
Date: Wed, 21 Jun 2017 14:42:06 +0800 Date: Wed, 21 Jun 2017 14:42:06 +0800
Subject: [PATCH 11/13] ARM: dts: imx6qdl: Enable usb node children with <reg> Subject: [PATCH 11/14] ARM: dts: imx6qdl: Enable usb node children with <reg>
Give usb nodes #address and #size attributes, so that a child node Give usb nodes #address and #size attributes, so that a child node
representing a permanently connected device such as an onboard hub may representing a permanently connected device such as an onboard hub may
@ -45,5 +45,5 @@ index c003e62bf290..7ffd2f1f769e 100644
interrupts = <0 42 IRQ_TYPE_LEVEL_HIGH>; interrupts = <0 42 IRQ_TYPE_LEVEL_HIGH>;
clocks = <&clks IMX6QDL_CLK_USBOH3>; clocks = <&clks IMX6QDL_CLK_USBOH3>;
-- --
2.17.0 2.18.0

View file

@ -1,7 +1,7 @@
From b2ad93788d10a09f72eb170cf0f13ddecc540ff4 Mon Sep 17 00:00:00 2001 From 01dea63eabb838525a193c32526791f6880c2b79 Mon Sep 17 00:00:00 2001
From: Peter Chen <peter.chen@nxp.com> From: Peter Chen <peter.chen@nxp.com>
Date: Wed, 21 Jun 2017 14:42:07 +0800 Date: Wed, 21 Jun 2017 14:42:07 +0800
Subject: [PATCH 12/13] ARM: dts: imx6qdl-udoo.dtsi: fix onboard USB HUB Subject: [PATCH 12/14] ARM: dts: imx6qdl-udoo.dtsi: fix onboard USB HUB
property property
The current dts describes USB HUB's property at USB controller's The current dts describes USB HUB's property at USB controller's
@ -76,5 +76,5 @@ index 906387915dc5..d3cc0b666e0d 100644
&usdhc3 { &usdhc3 {
-- --
2.17.0 2.18.0

View file

@ -1,7 +1,7 @@
From 90445c490f11a0afefc9ccbae3ca5893ad0ddb15 Mon Sep 17 00:00:00 2001 From 29a513109fa45d1039d7f52aacb3fc4a188e60d4 Mon Sep 17 00:00:00 2001
From: Joshua Clayton <stillcompiling@gmail.com> From: Joshua Clayton <stillcompiling@gmail.com>
Date: Wed, 21 Jun 2017 14:42:08 +0800 Date: Wed, 21 Jun 2017 14:42:08 +0800
Subject: [PATCH 13/13] ARM: dts: imx6q-evi: Fix onboard hub reset line Subject: [PATCH 13/14] ARM: dts: imx6q-evi: Fix onboard hub reset line
Previously the onboard hub was made to work by treating its Previously the onboard hub was made to work by treating its
reset gpio as a regulator enable. reset gpio as a regulator enable.
@ -70,5 +70,5 @@ index fcd257bc5ac3..d32fa81bba95 100644
>; >;
}; };
-- --
2.17.0 2.18.0

View file

@ -0,0 +1,61 @@
From ac139b06e1b309c605c65cea2d547cbba4ae5370 Mon Sep 17 00:00:00 2001
From: Ethan Tuttle <ethan@ethantuttle.com>
Date: Tue, 19 Jun 2018 21:31:08 -0700
Subject: [PATCH 14/14] ARM: mvebu: declare asm symbols as character arrays in
pmsu.c
With CONFIG_FORTIFY_SOURCE, memcpy uses the declared size of operands to
detect buffer overflows. If src or dest is declared as a char, attempts to
copy more than byte will result in a fortify_panic().
Address this problem in mvebu_setup_boot_addr_wa() by declaring
mvebu_boot_wa_start and mvebu_boot_wa_end as character arrays. Also remove
a couple addressof operators to avoid "arithmetic on pointer to an
incomplete type" compiler error.
See commit 54a7d50b9205 ("x86: mark kprobe templates as character arrays,
not single characters") for a similar fix.
Fixes "detected buffer overflow in memcpy" error during init on some mvebu
systems (armada-370-xp, armada-375):
(fortify_panic) from (mvebu_setup_boot_addr_wa+0xb0/0xb4)
(mvebu_setup_boot_addr_wa) from (mvebu_v7_cpu_pm_init+0x154/0x204)
(mvebu_v7_cpu_pm_init) from (do_one_initcall+0x7c/0x1a8)
(do_one_initcall) from (kernel_init_freeable+0x1bc/0x254)
(kernel_init_freeable) from (kernel_init+0x8/0x114)
(kernel_init) from (ret_from_fork+0x14/0x2c)
Signed-off-by: Ethan Tuttle <ethan@ethantuttle.com>
Tested-by: Ethan Tuttle <ethan@ethantuttle.com>
---
arch/arm/mach-mvebu/pmsu.c | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)
diff --git a/arch/arm/mach-mvebu/pmsu.c b/arch/arm/mach-mvebu/pmsu.c
index 27a78c80e5b1..73d5d72dfc3e 100644
--- a/arch/arm/mach-mvebu/pmsu.c
+++ b/arch/arm/mach-mvebu/pmsu.c
@@ -116,8 +116,8 @@ void mvebu_pmsu_set_cpu_boot_addr(int hw_cpu, void *boot_addr)
PMSU_BOOT_ADDR_REDIRECT_OFFSET(hw_cpu));
}
-extern unsigned char mvebu_boot_wa_start;
-extern unsigned char mvebu_boot_wa_end;
+extern unsigned char mvebu_boot_wa_start[];
+extern unsigned char mvebu_boot_wa_end[];
/*
* This function sets up the boot address workaround needed for SMP
@@ -130,7 +130,7 @@ int mvebu_setup_boot_addr_wa(unsigned int crypto_eng_target,
phys_addr_t resume_addr_reg)
{
void __iomem *sram_virt_base;
- u32 code_len = &mvebu_boot_wa_end - &mvebu_boot_wa_start;
+ u32 code_len = mvebu_boot_wa_end - mvebu_boot_wa_start;
mvebu_mbus_del_window(BOOTROM_BASE, BOOTROM_SIZE);
mvebu_mbus_add_window_by_id(crypto_eng_target, crypto_eng_attribute,
--
2.18.0

View file

@ -7,9 +7,9 @@ pkgbase=linux-armv7
_srcname=linux-4.17 _srcname=linux-4.17
_kernelname=${pkgbase#linux} _kernelname=${pkgbase#linux}
_desc="ARMv7 multi-platform" _desc="ARMv7 multi-platform"
pkgver=4.17.5 pkgver=4.17.6
pkgrel=1 pkgrel=1
rcnrel=armv7-x6 rcnrel=armv7-x7
arch=('armv7h') arch=('armv7h')
url="http://www.kernel.org/" url="http://www.kernel.org/"
license=('GPL2') license=('GPL2')
@ -31,6 +31,7 @@ source=("http://www.kernel.org/pub/linux/kernel/v4.x/${_srcname}.tar.xz"
'0011-ARM-dts-imx6qdl-Enable-usb-node-children-with-reg.patch' '0011-ARM-dts-imx6qdl-Enable-usb-node-children-with-reg.patch'
'0012-ARM-dts-imx6qdl-udoo.dtsi-fix-onboard-USB-HUB-proper.patch' '0012-ARM-dts-imx6qdl-udoo.dtsi-fix-onboard-USB-HUB-proper.patch'
'0013-ARM-dts-imx6q-evi-Fix-onboard-hub-reset-line.patch' '0013-ARM-dts-imx6q-evi-Fix-onboard-hub-reset-line.patch'
'0014-ARM-mvebu-declare-asm-symbols-as-character-arrays-in.patch'
'config' 'config'
'kernel.its' 'kernel.its'
'kernel.keyblock' 'kernel.keyblock'
@ -38,21 +39,22 @@ source=("http://www.kernel.org/pub/linux/kernel/v4.x/${_srcname}.tar.xz"
'linux.preset' 'linux.preset'
'99-linux.hook') '99-linux.hook')
md5sums=('5bb13a03274b66b56c85b26682e407d7' md5sums=('5bb13a03274b66b56c85b26682e407d7'
'eb2b7a35e8d1f04c06227829daf8b392' '61f796237d1b137c5ce707cb308950d4'
'ef2d2906efd01dad90949bb8d8335885' 'bca32c2f4c0a49fe5901f01ef4c8250b'
'659aa5898b6182ba855dff9584d0b77b' '2ab00dfbba67e6411f7d840261079533'
'09112f7298d00fb453b6789286d01334' 'c8484367f1bd02ebf2fc1b9cdf3e2004'
'ada6bd5d1519869a0f60cc3523ea2394' 'fa2402a5d90d651298d1bae0bebf785d'
'7cf7295dd4150ecc78d9a37156946286' '90e45476dfbbff52b921546f68ee4d78'
'ff1771ffab749185fc5a0df1bd78ce4f' '32ddf11e2f4c66c474325037846e67a2'
'6580171cfdb1bca4f9e901be68aeeed0' '9423cfead77b13c537261cef1d8d068f'
'2f3ad2a6d64ae13f6d80046efa067050' 'c16432d5a2cfedb5f8e924b6c23c8ed7'
'b8653cacf717217278c649bd2dea0f20' '8cc861b5ee64aabd71cd4e97f79e6177'
'61f629a249a38aef979cab2be4d7bb7f' 'e83a03c82d1f9f9a3f9c796808c4160b'
'7e20b2245d031eb8443b040dac280a13' 'f14cbc2a326c7735d226a35039f3747d'
'a4d211d0d0920f6f529c22273e1c4708' 'e31b9705491a6bd8aad0442e248019e0'
'8b7f6296bb24f5d6b1d2088cd0fdcb79' 'c414fe8e3ba3c180eaa54c9ebc5636aa'
'52e2a87d059ea401640195b9f9253673' 'c6482625252e4051a144c6f7a9add062'
'480131c4aa1b4675cee89516bbd5c11f'
'91582916c5ab5981ac966f121c699137' '91582916c5ab5981ac966f121c699137'
'4f2379ed84258050edb858ee8d281678' '4f2379ed84258050edb858ee8d281678'
'61c5ff73c136ed07a7aadbf58db3d96a' '61c5ff73c136ed07a7aadbf58db3d96a'
@ -83,6 +85,7 @@ prepare() {
git apply ../0011-ARM-dts-imx6qdl-Enable-usb-node-children-with-reg.patch git apply ../0011-ARM-dts-imx6qdl-Enable-usb-node-children-with-reg.patch
git apply ../0012-ARM-dts-imx6qdl-udoo.dtsi-fix-onboard-USB-HUB-proper.patch git apply ../0012-ARM-dts-imx6qdl-udoo.dtsi-fix-onboard-USB-HUB-proper.patch
git apply ../0013-ARM-dts-imx6q-evi-Fix-onboard-hub-reset-line.patch git apply ../0013-ARM-dts-imx6q-evi-Fix-onboard-hub-reset-line.patch
git apply ../0014-ARM-mvebu-declare-asm-symbols-as-character-arrays-in.patch
cat "${srcdir}/config" > ./.config cat "${srcdir}/config" > ./.config