mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
added community/giac
This commit is contained in:
parent
17f07f88e5
commit
0ed0a2cba4
2 changed files with 63 additions and 0 deletions
46
community/giac/PKGBUILD
Normal file
46
community/giac/PKGBUILD
Normal file
|
@ -0,0 +1,46 @@
|
|||
# Maintainer: Antonio Rojas <arojas@archlinux.org>
|
||||
|
||||
# ALARM: Kevin Mihelich <kevin@archlinxuarm.org>
|
||||
# - delete shipped x86 binary src/mkjs to force rebuild for ARM
|
||||
|
||||
pkgname=giac
|
||||
_pkgver=1.9.0-7
|
||||
pkgver=${_pkgver//-/.}
|
||||
pkgrel=1
|
||||
pkgdesc='A free computer algebra system'
|
||||
arch=(x86_64)
|
||||
url='http://www-fourier.ujf-grenoble.fr/~parisse/giac.html'
|
||||
license=(GPL3)
|
||||
depends=(fltk mpfi gsl pari ntl lapack curl glpk libao gmp-ecm libsamplerate)
|
||||
makedepends=(python libjpeg texlive-core texlive-science hevea nauty)
|
||||
optdepends=('perl: for pgiac')
|
||||
replaces=(libgiac xcas)
|
||||
provides=(libgiac xcas)
|
||||
source=(http://www-fourier.ujf-grenoble.fr/~parisse/debian/dists/stable/main/source/${pkgname}_$_pkgver.tar.gz
|
||||
giac-test-pari-2.11.patch)
|
||||
sha256sums=('72016988b7180e9b630ecabecc60969213e7b61418c2598c91acbaec139fd740'
|
||||
'c5f091986f0a0807fc1ae5a3b7454132816e9bc3ed64411f0a7bdf90a8c8e624')
|
||||
|
||||
prepare() {
|
||||
cd $pkgname-${pkgver%.*}
|
||||
patch -p1 < ../giac-test-pari-2.11.patch # Fix tests with pari 2.11
|
||||
rm -f src/mkjs # force rebuild for ARM
|
||||
}
|
||||
|
||||
build() {
|
||||
cd $pkgname-${pkgver%.*}
|
||||
CXXFLAGS+=" -Wp,-U_GLIBCXX_ASSERTIONS" # Fix crashes
|
||||
./configure --prefix=/usr
|
||||
make
|
||||
}
|
||||
|
||||
check() {
|
||||
cd $pkgname-${pkgver%.*}
|
||||
|
||||
make check
|
||||
}
|
||||
|
||||
package() {
|
||||
cd $pkgbase-${pkgver%.*}
|
||||
make DESTDIR="$pkgdir" install
|
||||
}
|
17
community/giac/giac-test-pari-2.11.patch
Normal file
17
community/giac/giac-test-pari-2.11.patch
Normal file
|
@ -0,0 +1,17 @@
|
|||
Change test output for PARI 2.11
|
||||
|
||||
See https://trac.sagemath.org/ticket/25567
|
||||
and https://xcas.univ-grenoble-alpes.fr/forum/viewtopic.php?f=4&t=2102
|
||||
|
||||
diff -ru a/check/TP11-sol.cas.out1 b/check/TP11-sol.cas.out1
|
||||
--- a/check/TP11-sol.cas.out1 2014-10-21 10:51:48.000000000 +0200
|
||||
+++ b/check/TP11-sol.cas.out1 2018-08-07 17:04:12.528052773 +0200
|
||||
@@ -10,7 +10,7 @@
|
||||
1073741824000000000000000000061203284109000000000000000000000000008409,
|
||||
2^3*3*389*733*156904374622257604823879982847602392900751802349981470895277241,
|
||||
"Done",
|
||||
-matrix[[2,7,1],[3,2,1],[389,2,1],[733,2,1],[156904374622257604823879982847602392900751802349981470895277241,2,matrix[[2,13,1],[3,3,1],[5,2,1],[7,2,1],[56467,2,1],[6553084925887974620811527,2,matrix[[2,5,1],[19,2,1],[71,2,1],[126823,2,1]]]]]],
|
||||
+1,
|
||||
0,
|
||||
[],
|
||||
1,
|
Loading…
Reference in a new issue