mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-02-16 23:57:11 +00:00
extra/claws-mail to 3.8.0-3
This commit is contained in:
parent
20657450c5
commit
0f2c5df73f
3 changed files with 24 additions and 15 deletions
|
@ -8,7 +8,7 @@ plugrel=1
|
|||
|
||||
pkgname=claws-mail
|
||||
pkgver=3.8.0
|
||||
pkgrel=2
|
||||
pkgrel=3
|
||||
pkgdesc="A GTK+ based e-mail client."
|
||||
arch=('i686' 'x86_64')
|
||||
license=('GPL3')
|
||||
|
@ -24,11 +24,14 @@ replaces=('sylpheed-claws')
|
|||
provides=('claws')
|
||||
options=(!libtool)
|
||||
install=claws-mail.install
|
||||
source=(http://downloads.sourceforge.net/sourceforge/sylpheed-claws/${pkgname}-${pkgver}.tar.bz2)
|
||||
md5sums=('df9f1657d7f34959a2205344d952c2e3')
|
||||
source=(http://downloads.sourceforge.net/sourceforge/sylpheed-claws/${pkgname}-${pkgver}.tar.bz2
|
||||
buildfix_gnutls3.diff)
|
||||
md5sums=('df9f1657d7f34959a2205344d952c2e3'
|
||||
'0c0956755ddcec939d916af35310ee3f')
|
||||
|
||||
build() {
|
||||
cd ${srcdir}/${pkgname}-${pkgver}
|
||||
patch -Np0 -i ${srcdir}/buildfix_gnutls3.diff
|
||||
|
||||
sed -i 's@^#!.*python.*@#!/usr/bin/python2@' tools/*.py
|
||||
|
||||
|
|
18
extra/claws-mail/buildfix_gnutls3.diff
Normal file
18
extra/claws-mail/buildfix_gnutls3.diff
Normal file
|
@ -0,0 +1,18 @@
|
|||
Index: src/common/ssl_certificate.c
|
||||
===================================================================
|
||||
RCS file: //claws/src/common/ssl_certificate.c,v
|
||||
retrieving revision 1.4.2.40
|
||||
retrieving revision 1.4.2.41
|
||||
diff -u -r1.4.2.40 -r1.4.2.41
|
||||
--- src/common/ssl_certificate.c 30 Aug 2011 06:18:09 -0000 1.4.2.40
|
||||
+++ src/common/ssl_certificate.c 16 May 2012 05:43:14 -0000 1.4.2.41
|
||||
@@ -686,7 +686,7 @@
|
||||
gnutls_x509_privkey * key,
|
||||
gnutls_x509_crt_t * cert)
|
||||
{
|
||||
- gnutls_pkcs12_bag bag = NULL;
|
||||
+ gnutls_pkcs12_bag_t bag = NULL;
|
||||
int index = 0;
|
||||
int ret;
|
||||
|
||||
|
|
@ -1,12 +0,0 @@
|
|||
--- claws-mail-3.7.10/src/common/ssl.c 2011-12-07 14:55:08.682553870 +0100
|
||||
+++ claws-mail-3.7.10/src/common/ssl.c 2011-12-07 14:55:43.808349602 +0100
|
||||
@@ -270,7 +270,9 @@ gboolean ssl_init_socket_with_method(Soc
|
||||
if (session == NULL || r != 0)
|
||||
return FALSE;
|
||||
|
||||
+#if GNUTLS_VERSION_NUMBER < 0x020c00
|
||||
gnutls_transport_set_lowat (session, 1);
|
||||
+#endif
|
||||
gnutls_set_default_priority(session);
|
||||
gnutls_protocol_set_priority (session, proto_prio);
|
||||
gnutls_cipher_set_priority (session, cipher_prio);
|
Loading…
Reference in a new issue