mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
extra/kdelibs to 4.14.8-1
This commit is contained in:
parent
5ad8e18322
commit
0f3f2faa79
2 changed files with 5 additions and 126 deletions
|
@ -7,9 +7,9 @@
|
|||
# - patch to fix unclickable plasmoid buttons on ARM
|
||||
|
||||
pkgname=kdelibs
|
||||
pkgver=4.14.7
|
||||
_kdeappver=15.04.0
|
||||
pkgrel=3
|
||||
pkgver=4.14.8
|
||||
_kdeappver=15.04.1
|
||||
pkgrel=1
|
||||
pkgdesc="KDE Core Libraries"
|
||||
arch=('i686' 'x86_64')
|
||||
url='https://projects.kde.org/projects/kde/kdelibs'
|
||||
|
@ -21,9 +21,9 @@ depends=('attica-qt4' 'libxss' 'krb5' 'qca' 'libdbusmenu-qt' 'polkit-qt4'
|
|||
makedepends=('cmake' 'automoc4' 'avahi' 'libgl' 'hspell' 'mesa' 'grantlee-qt4')
|
||||
install=${pkgname}.install
|
||||
source=("http://download.kde.org/stable/applications/${_kdeappver}/src/${pkgname}-${pkgver}.tar.xz"
|
||||
'kde-applications-menu.patch' 'archlinux-menu.patch' 'qt4.patch' 'dolphin-places.patch'
|
||||
'kde-applications-menu.patch' 'archlinux-menu.patch' 'qt4.patch'
|
||||
'arm-coronaoffscreen-input-fixes.diff')
|
||||
sha1sums=('6de82328f692717b97ad6833109a564a7b6a0a9a'
|
||||
sha1sums=('98b174dbbbef340bcfc11b819405d8e838cac34c'
|
||||
'86ee8c8660f19de8141ac99cd6943964d97a1ed7'
|
||||
'63a850ab4196b9d06934f2b4a13acd9f7739bc67'
|
||||
'ed1f57ee661e5c7440efcaba7e51d2554709701c'
|
||||
|
@ -40,8 +40,6 @@ prepare() {
|
|||
patch -p1 -i "${srcdir}"/qt4.patch
|
||||
# fix unclickable plasmoid buttons on ARM
|
||||
patch -p1 -i "${srcdir}"/arm-coronaoffscreen-input-fixes.diff
|
||||
# fix disappearing bookmarks in Dolphin https://bugs.kde.org/show_bug.cgi?id=345174
|
||||
patch -p1 -i "$srcdir"/dolphin-places.patch
|
||||
}
|
||||
|
||||
build() {
|
||||
|
|
|
@ -1,119 +0,0 @@
|
|||
From: Emmanuel Pescosta <emmanuelpescosta099@gmail.com>
|
||||
Date: Wed, 29 Apr 2015 14:02:02 +0000
|
||||
Subject: Remove bookmarks syncing from KFilePlacesModel and use user-places.xbel only.
|
||||
X-Git-Url: http://quickgit.kde.org/?p=kdelibs.git&a=commitdiff&h=5c0a31a2f2a46aa44b8c34baae67b6951b2abcaf
|
||||
---
|
||||
Remove bookmarks syncing from KFilePlacesModel and use user-places.xbel only.
|
||||
|
||||
FIXED-IN: 4.14.8
|
||||
BUG: 345174
|
||||
REVIEW: 123568
|
||||
---
|
||||
|
||||
|
||||
--- a/kfile/CMakeLists.txt
|
||||
+++ b/kfile/CMakeLists.txt
|
||||
@@ -22,7 +22,6 @@
|
||||
kfilewidget.cpp
|
||||
kfileplacesitem.cpp
|
||||
kfileplacesmodel.cpp
|
||||
- kfileplacessharedbookmarks.cpp
|
||||
kfileplacesview.cpp
|
||||
kfileplaceeditdialog.cpp
|
||||
kfilepreviewgenerator.cpp
|
||||
|
||||
--- a/kfile/kfileplacesmodel.cpp
|
||||
+++ b/kfile/kfileplacesmodel.cpp
|
||||
@@ -19,7 +19,6 @@
|
||||
*/
|
||||
#include "kfileplacesmodel.h"
|
||||
#include "kfileplacesitem_p.h"
|
||||
-#include "kfileplacessharedbookmarks_p.h"
|
||||
|
||||
#ifdef _WIN32_WCE
|
||||
#include "Windows.h"
|
||||
@@ -61,10 +60,9 @@
|
||||
class KFilePlacesModel::Private
|
||||
{
|
||||
public:
|
||||
- Private(KFilePlacesModel *self) : q(self), bookmarkManager(0), sharedBookmarks(0) {}
|
||||
+ Private(KFilePlacesModel *self) : q(self), bookmarkManager(0) {}
|
||||
~Private()
|
||||
{
|
||||
- delete sharedBookmarks;
|
||||
qDeleteAll(items);
|
||||
}
|
||||
|
||||
@@ -76,7 +74,6 @@
|
||||
|
||||
Solid::Predicate predicate;
|
||||
KBookmarkManager *bookmarkManager;
|
||||
- KFilePlacesSharedBookmarks * sharedBookmarks;
|
||||
|
||||
void reloadAndSignal();
|
||||
QList<KFilePlacesItem *> loadBookmarkList();
|
||||
@@ -93,8 +90,8 @@
|
||||
KFilePlacesModel::KFilePlacesModel(QObject *parent)
|
||||
: QAbstractItemModel(parent), d(new Private(this))
|
||||
{
|
||||
- const QString file = KStandardDirs::locateLocal("data", "kfileplaces/bookmarks.xml");
|
||||
- d->bookmarkManager = KBookmarkManager::managerForFile(file, "kfilePlaces");
|
||||
+ const QString file = KStandardDirs().localxdgdatadir() + "user-places.xbel";
|
||||
+ d->bookmarkManager = KBookmarkManager::managerForExternalFile(file);
|
||||
|
||||
// Let's put some places in there if it's empty. We have a corner case here:
|
||||
// Given you have bookmarked some folders (which have been saved on
|
||||
@@ -145,9 +142,6 @@
|
||||
// user-places.xbel will be filled later). (ereslibre)
|
||||
d->bookmarkManager->saveAs(file);
|
||||
}
|
||||
-
|
||||
- // create after, so if we have own places, they are added afterwards, in case of equal priorities
|
||||
- d->sharedBookmarks = new KFilePlacesSharedBookmarks(d->bookmarkManager);
|
||||
|
||||
QString predicate("[[[[ StorageVolume.ignored == false AND [ StorageVolume.usage == 'FileSystem' OR StorageVolume.usage == 'Encrypted' ]]"
|
||||
" OR "
|
||||
@@ -632,8 +626,6 @@
|
||||
return false;
|
||||
}
|
||||
|
||||
- d->sharedBookmarks->updateSharedBookmarks();
|
||||
-
|
||||
d->reloadAndSignal();
|
||||
|
||||
return true;
|
||||
@@ -660,8 +652,6 @@
|
||||
KFilePlacesItem *item = static_cast<KFilePlacesItem*>(after.internalPointer());
|
||||
d->bookmarkManager->root().moveBookmark(bookmark, item->bookmark());
|
||||
}
|
||||
-
|
||||
- d->sharedBookmarks->updateSharedBookmarks();
|
||||
|
||||
d->reloadAndSignal();
|
||||
}
|
||||
@@ -684,8 +674,6 @@
|
||||
bookmark.setIcon(iconName);
|
||||
bookmark.setMetaDataItem("OnlyInApp", appName);
|
||||
|
||||
- d->sharedBookmarks->updateSharedBookmarks();
|
||||
-
|
||||
d->reloadAndSignal();
|
||||
emit dataChanged(index, index);
|
||||
}
|
||||
@@ -703,7 +691,6 @@
|
||||
if (bookmark.isNull()) return;
|
||||
|
||||
d->bookmarkManager->root().deleteBookmark(bookmark);
|
||||
- d->sharedBookmarks->updateSharedBookmarks();
|
||||
d->reloadAndSignal();
|
||||
}
|
||||
|
||||
@@ -718,8 +705,6 @@
|
||||
if (bookmark.isNull()) return;
|
||||
|
||||
bookmark.setMetaDataItem("IsHidden", (hidden ? "true" : "false"));
|
||||
-
|
||||
- d->sharedBookmarks->updateSharedBookmarks();
|
||||
|
||||
d->reloadAndSignal();
|
||||
emit dataChanged(index, index);
|
Loading…
Reference in a new issue