removed core/udev-oxnas

This commit is contained in:
Kevin Mihelich 2018-03-06 00:18:48 +00:00
parent 096cdc660e
commit 0f6b0c0439
4 changed files with 0 additions and 189 deletions

View file

@ -1,9 +0,0 @@
# do not edit this file, it will be overwritten on update
# this file is going away in the near future
# this might belong in <http://aur.archlinux.org/packages.php?ID=22698>
# see also /usr/src/*/Documentation/laptops/sonypi.txt
KERNEL=="sonypi", MODE="0666"
# this might belong in <https://aur.archlinux.org/packages.php?ID=18393>
KERNEL=="legousbtower*", MODE="0666"

View file

@ -1,78 +0,0 @@
# $Id: PKGBUILD 141113 2011-10-24 09:59:23Z dreisner $
# Maintainer: Tom Gundersen <teg@jklm.no>
# Contributor: Aaron Griffin <aaron@archlinux.org>
# Contributor: Tobias Powalowski <tpowa@archlinux.org>
# Contributor: Thomas Bächler <thomas@archlinux.org>
# ALARM: Jason Plum <max@warheads.net>
# - Make this compatible with non-accept4 kernels.
# - due to newer udev requiring devtmpfs (not available in .31), keeping udev at 175
plugrel=1
_pkgbase='udev'
pkgname='udev-oxnas'
pkgver=182
_pkgver=175
pkgrel=2
arch=(i686 x86_64)
url="http://www.kernel.org/pub/linux/utils/kernel/hotplug/udev.html"
license=('GPL')
options=(!makeflags !libtool)
makedepends=('gobject-introspection' 'gperf')
source=(http://www.kernel.org/pub/linux/utils/kernel/hotplug/$_pkgbase-$_pkgver.tar.bz2
81-arch.rules
pre-accept4-kernel.patch)
md5sums=('2fc9c1efcbde98e3d73ffee7a77aea47'
'3da2bb9891592f9438a07bd641465531'
'8b28d85b2158be1b5a190135c9cc8851')
build() {
cd $srcdir/$_pkgbase-$_pkgver
patch -Np1 -i ${srcdir}/pre-accept4-kernel.patch
./configure --sysconfdir=/etc\
--with-rootlibdir=/lib\
--libexecdir=/lib/udev\
--sbindir=/sbin\
--with-systemdsystemunitdir=/lib/systemd/system\
--disable-rule-generator\
--enable-udev_acl
make
}
package_udev-oxnas() {
pkgdesc="The userspace dev tools for old kernels (udev ${_pkgver})"
depends=('util-linux' 'libusb-compat' 'glib2' 'kmod' 'pciutils')
install=udev.install
backup=(etc/udev/udev.conf)
provides=("udev=${pkgver}")
conflicts=('udev')
cd $srcdir/$_pkgbase-$_pkgver
make DESTDIR=${pkgdir} install
# Install our rule for permissions and symlinks
install -D -m644 $srcdir/81-arch.rules $pkgdir/lib/udev/rules.d/81-arch.rules
# create framebuffer blacklist
mkdir -p $pkgdir/lib/modprobe.d/
for mod in $(find /lib/modules/*/kernel/drivers/video -name '*fb.ko.gz' -exec basename {} .ko.gz \;); do
echo "blacklist $mod"
done | sort -u > $pkgdir/lib/modprobe.d/framebuffer_blacklist.conf
# /dev/loop0 is created for convenience, to autoload the module if necessary
# may be obsoleted by https://lkml.org/lkml/2011/7/30/111
mknod -m 0660 ${pkgdir}/lib/udev/devices/loop0 b 7 0
chgrp disk ${pkgdir}/lib/udev/devices/loop0
# udevd moved, symlink to make life easy for restarting udevd manually
ln -s /lib/udev/udevd ${pkgdir}/sbin/udevd
# Replace dialout/tape/cdrom group in rules with uucp/storage/optical group
for i in $pkgdir/lib/udev/rules.d/*.rules; do
sed -i -e 's#GROUP="dialout"#GROUP="uucp"#g;
s#GROUP="tape"#GROUP="storage"#g;
s#GROUP="cdrom"#GROUP="optical"#g' $i
done
}

View file

@ -1,40 +0,0 @@
diff -urN a/udev/udev-ctrl.c b/udev/udev-ctrl.c
--- a/udev/udev-ctrl.c 2011-10-09 17:10:32.000000000 -0600
+++ b/udev/udev-ctrl.c 2011-10-25 15:11:09.000000000 -0600
@@ -15,6 +15,7 @@
#include <stddef.h>
#include <string.h>
#include <unistd.h>
+#include <fcntl.h>
#include <sys/types.h>
#include <sys/poll.h>
#include <sys/socket.h>
@@ -182,6 +183,7 @@
struct ucred ucred;
socklen_t slen;
const int on = 1;
+ int flgs;
conn = calloc(1, sizeof(struct udev_ctrl_connection));
if (conn == NULL)
@@ -189,13 +191,19 @@
conn->refcount = 1;
conn->uctrl = uctrl;
- conn->sock = accept4(uctrl->sock, NULL, NULL, SOCK_CLOEXEC|SOCK_NONBLOCK);
+// conn->sock = accept4(uctrl->sock, NULL, NULL, SOCK_CLOEXEC|SOCK_NONBLOCK);
+ conn->sock = accept(uctrl->sock, NULL, NULL);
if (conn->sock < 0) {
if (errno != EINTR)
err(uctrl->udev, "unable to receive ctrl connection: %m\n");
goto err;
}
+// Since we don't have accept4
+ flgs = fcntl(conn->sock, F_GETFL, NULL);
+ if(flgs >= 0) fcntl(conn->sock, F_SETFL, flgs | O_NONBLOCK);
+ fcntl(conn->sock, F_SETFD, FD_CLOEXEC);
+
/* check peer credential of connection */
slen = sizeof(ucred);
if (getsockopt(conn->sock, SOL_SOCKET, SO_PEERCRED, &ucred, &slen) < 0) {

View file

@ -1,62 +0,0 @@
# arg 1: the new package version
# arg 2: the old package version
post_upgrade() {
if [ "$(vercmp $2 174)" -lt 0 ]; then
echo "ATTENTION UDEV:"
echo "----------"
if [ "$(vercmp $2 168)" -lt 0 ]; then
echo "Kernel 2.6.32 or newer is now required."
echo " --"
echo "OSS emulation modules are not loaded by default, add to rc.conf if needed."
echo " --"
echo "Arch specific cd symlinks are now no longer created."
echo " --"
echo "cd and net persistent rules will no longer be autogenerated,"
echo "see <https://wiki.archlinux.org/index.php/Udev> for details."
echo " --"
echo "Errors are now logged (possibly to the console) by default."
echo " --"
fi
if [ "$(vercmp $2 171)" -lt 0 ]; then
echo "Arch's custom blacklisting logic has been removed. MOD_AUTOLOAD and"
echo "blacklisting in MODULES no longer works."
echo "See 'man modprobe.conf' for a replacement to blacklisting."
echo "To disable a module mod1 on the kernel command line, use"
echo "mod1.disable=1"
echo "or"
echo "modprobe.blacklist=mod1"
echo " --"
echo "The following modules are no longer unconditionally loaded:"
echo " pcspkr irtty-sir analog lp ppdev ide-generic"
echo "Add them to MODULES in rc.conf if you need them."
echo " --"
fi
if [ "$(vercmp $2 172)" -lt 0 ]; then
echo "Support for non-devtmpfs self-compiled kernels have been moved to udev-compat."
echo " --"
echo "Blacklisting of framebuffer devices has moved from /etc/modprobe.d to"
echo "/lib/modprobe.d. Any customizations shoud be done to the file in /etc, as it"
echo "takes precedence."
echo " --"
echo "kbd and rtc devices are no longer world readable."
echo " --"
echo "rtc is no longer in the audio group and fb devices are no longer in"
echo "the video group, as permissions and ownership of fb devices are controlled"
echo "by X."
echo " --"
fi
echo "We now use upstream rules for assigning devices to the 'disk', 'optical',"
echo "'scanner' and 'video' groups. Beware of any changes."
echo " --"
echo "We no longer create symlinks from /dev/<dev> to /dev/<dev>0."
echo " --"
echo "For security reasons, we no longer add devices to the 'storage' group. Use"
echo "udisks and friends, or add custom rules to /etc/udev.d/rules/, if you want"
echo "this functionality back."
echo " --"
echo "We no longer create the static nodes on install needed for an initrd-less and"
echo "devtmpfs-less boot, this only affects fresh installs."
echo "---------------"
fi
}